Double-Take Cmdlets Summary

Double-Take includes Windows PowerShell cmdlets that you can use to control most Double-Take features. This guide includes all of the Double-Take cmdlets available. However, this guide does not explain how to use Windows PowerShell. You should reference your Windows PowerShell documentation and the many web sites devoted to PowerShell to learn how to use and script with Windows PowerShell.

The following terms and definitions will help you understand Double-Take basics. See the User's Guide for your Double-Take product for complete details on how that product works.

  • Source—The source is the server that has the data you want to protect or migrate. Typically this is a machine on the production network that serves data to clients.

  • Target—The target is the server that maintains the replicated copy of the data that is being protected on the source. Typically this is a backup server that may be local or in a remote data center. For migration jobs, this is the final destination for your data.

  • Workload—A workload is a logical definition of the data that is being protected or migrated on the source. A workload can be a simple set of paths, for example, C:\Data or /usr. It may also be a more complex logical item that maps to multiple paths. For example, protecting a virtual machine means you are protecting multiple, specific virtual machine files, or protecting Microsoft SQL means you are protecting a SQL database and its related files.

  • Workload manager—The workload manager is a web service that creates and configures the Double-Take workload.

  • Job—A job is a logical unit that includes the source, target, and the workload. The job is what you create and monitor in order to protect or migrate your data.

  • Job manager—The job manager is a web service that creates, monitors, and controls the Double-Take job.

  • Connection—The engine connection is the underlying stream that sends the actual replicated data between the source and target servers. Jobs are higher-level objects that use the lower-level connection to protect data.

  • Architecture—Each Double-Take installation has two services, the Management Service and Engine.

    • Management Service—This service is displayed as Double-Take Management Service in the Windows services list and jsvc on Linux. The service hosts the job manager and provides monitoring and control for all job types. For WCF clients, the service listens on port 6325. For non-WCF clients, the service listens on port 6326. This service offers a SOAP-based XML web services interface.

    • Engine—This service is displayed as Double-Take in the Windows service list and DT on Linux. The service transmits the replicated data between the source and target servers. By default this service listens on port 6320. You do not interact directly with this service.

  • Roles—Any Double-Take installation can be a source, target, or both. The existence of a job between two servers and which direction data is being transmitted determines the server’s role.

  • Security—Double-Take enforces security by using local groups on each server where Double-Take is installed. There are two levels of security. Administrator access allows full control of Double-Take on a server, and monitor access allows read-only views of job information. When you connect to the job manager on a server, you will need to provide the credentials of a user who is a member of one of the local groups on that server.

  • Job creation—To create a job, you will first communicate with the source to create a workload. You will then use that workload object and communicate with the target to create the job.

  • Monitoring and controlling jobs—To monitor and control jobs, you will communicate with the job manager on the target of the job.


Add-DtPhysicalRule

This cmdlet adds a physical rule to the specified workload on the specified server. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Add-DtPhysicalRule [-Exclude] <SwitchParameter> [-NonRecursive] <SwitchParameter> [-Path] <String> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Add-DtPhysicalRule [-Rule] <PhysicalRule> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Exclude<SwitchParameter>

Exclude the specified path from mirroring and replication. If you do not specify this option, the path will be included for mirroring and replication.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NonRecursive<SwitchParameter>

Apply the rule to the subdirectories of the specified path. If you do not specify this option, the subdirectories of the specified path will not be included/excluded.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>

Specify the path on the source that contains the data that you want to protect.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Rule<PhysicalRule>

Use the Windows PowerShell New-Object cmdlet to create a physical rule object from DoubleTake.Common.Contract.PhysicalRule.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. A new object is created from Double-Take.Common.Contract.PhysicalRule to store the physical path C:\DirName in the variable DtPhysicalPath. Finally, the physical rule is added to the workload on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtPhysicalPath = New-Object DoubleTake.Common.Contract.PhysicalRule -Property @{Path="C:\DirName"}

Add-DtPhysicalRule -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid -Rule $DtPhysicalPath

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. A physical rule is then created for the path C:\DirName. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

Add-DtPhysicalRule -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid -Path "C:\DirName"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Add-DtUvraPhysicalRule

This cmdlet adds a physical rule to the specified full server to ESX appliance workload on the specified server. For this cmdlet, the -ServiceHost should be your source server, and it should be the object returned from New-DtUvraServer, not New-DtServer.

Syntax

Add-DtUvraPhysicalRule [-Path] <String> [-Recurse] <SwitchParameter> [-Exclude] <SwitchParameter> [-Workload] <Workload> [-ServiceHost] <Server> [<CommonParameters>]

Add-DtUvraPhysicalRule [-Rule] <PhysicalRule> [-Workload] <Workload> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Workload<Workload>

Specify the workload object returned from the Get-DtWorkload cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>

Specify the path on the source that contains the data that you want to protect.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Recurse<SwitchParameter>

Apply the rule to the subdirectories of the specified path. If you do not specify this option, the subdirectories of the specified path will not be included/excluded.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Exclude<SwitchParameter>

Exclude the specified path from mirroring and replication. If you do not specify this option, the path will be included for mirroring and replication.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Rule<PhysicalRule>

Use the Windows PowerShell New-Object cmdlet to create a physical rule object from DoubleTake.Common.Contract.PhysicalRule.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

Three server objects are created for the source, the appliance, and the ESX server hosting the appliance, assigning the server objects to the DtServerObjectAlpha, DtApplianceObject, and DtApplianceHost variables, respectively. Then proxy and host information is retrieved for those server objects, storing the information in DtProxyInfo and DtVmHostInfo, respectively. That information is then used to retrieve the recommended job options. A rule for the path C:\Documents and Settings is added to the recommended job options. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtUvraServer -Name alpha -UserName domain\administrator -Password password -Port 6325

$DtApplianceObject = New-DtUvraServer -Name beta -UserName root -Password password -Port 6325

$DtApplianceHost = New-DtUvraServer -Name gamma -UserName root -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName Lvra

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtRecommendedJobOptions = Get-DtRecommendedJobOptions -ServiceHost $DtApplianceObject -Source $DtServerObjectAlpha -JobType Lvra -Workload $DtWorkload

Add-DtUvraPhysicalRule -ServiceHost $DtApplianceObject -Workload

$DtRecommendedJobOptions.JobOptions.Workload -Path "/home"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtApplianceObject

Disconnect-DtServer -ServiceHost $DtApplianceHost


Checkpoint-DtConnection

This cmdlet creates a snapshot of the source replica data on the target. The snapshot of the source replica data is taken immediately on the target when the snapshot is requested. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Checkpoint-DtConnection [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Checkpoint-DtConnection [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then a snapshot of the replica data on the target is taken. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Checkpoint-DtConnection -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Checkpoint-DtConnectionSourceQueue

This cmdlet creates a coordinated snapshot of the source replica data on the target. This type of snapshot is not taken immediately. It is queued on the source at the time the snapshot is requested. The snapshot request operation will be transmitted in order with any other pending operations. When the snapshot operation is processed on the target, the snapshot will then be taken. This feature allows you to take a snapshot at the source time, rather than the target time. In the case of multiple servers, you can coordinate the snapshot time on the multiple source servers, rather than the varying times of the replica data on the target. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Checkpoint-DtConnectionSourceQueue [-CorrelationId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-CorrelationId<Guid>

Specify a snapshot GUID that will be assigned to the coordinated snapshot.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

Several variables are set including a unique correlation ID for the snapshots that will be taken as well as URI identifiers for the source servers of existing jobs. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The jobs are retrieved from DtServerObjectBeta, and the job information is inserted into unique variables. And array of job IDs is then created. A coordinated snapshot is taken using the specified correlation ID and the jobs stored in the array. Only those jobs will have coordinated snapshots. The connections for the server object are then closed.

$CorId=New-Guid

$Source1Uri = "dtms://112.42.7.63:6325/"

$Source2Uri = "dtms://112.42.7.71:6325/"

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob1 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source1Uri}

$DtJob2 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source2Uri}

$DtJobsArray = New-Object "System.Collections.Generic.List[Guid]"

$DtJobsArray.Clear()

$DtJobsArray.Add($DtJob1.Id)

$DtJobsArray.Add($DtJob2.Id)

Checkpoint-DtConnectionSourceQueue -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJobsArray.ToArray()

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Close-DtWorkload

This cmdlet closes the workload creation process on the specified server and removes all resources associated with the workload creation process. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Close-DtWorkload [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload is then closed on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

Close-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Confirm-DtJobOptions

This cmdlet starts the job validation process, confirming the job options returned from the Get-DtRecommendedJobOptions cmdlet are compatible with the source and target servers you are using. View the details of the validation by using Get-DtVerificationStatus. Do not confuse this process with the verification process that confirms if the data between the source and target are synchronized. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Confirm-DtJobOptions [-JobId] <Guid> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Confirm-DtJobOptions [-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Confirm-DtJobOptions [-CreateOptions] <CreateOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>

Specify the type of job from the following list.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>

Specify the JobOptions returned from the Get-DtRecommendedJobOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>

Specify the server object returned from the New-DtServer cmdlet. Specify multiple server objects in an array using the format @($server1, $server2).

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>

Specify the create options available in DoubleTake.Jobs.Contract.CreateOptions. Use the Windows PowerShell New-Object cmdlet to create this object.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job options used by the job are confirmed, and the validation result is stored in DtValidation. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtValidation = Confirm-DtJobOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJob.Options

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Disconnect-DtServer

This cmdlet closes all WCF (Windows Communication Foundation) connections that have been opened during use of the server object. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Disconnect-DtServer [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The connections for the server object are then closed.

$DtServerObjectAlpha = New-DtServer -Name alpha -UserName domain\administrator -Password password

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Edit-DtJob

This cmdlet allows you to edit an existing job that is stopped or running, using a JobOptions object that has been modified with your edited job settings. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Edit-DtJob [-JobId] <Guid> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Edit-DtJob [-JobInfo] <JobInfo> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobOptions<JobOptions>

Specify the JobOptions returned from the Get-DtRecommendedJobOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. A job option is changed. In this case, the total time before failover is triggered is set to 10 minutes. Finally, the job options are used to edit the specified job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtJobForAlpha.Options.CoreMonitorOptions.TotalTimeAllowed="00:10:00"

Edit-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJobForAlpha.Options

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtAccessLevel

This cmdlet returns the Double-Take security access level for the credentials stored in the specified server object. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtAccessLevel [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take security access level for that server is returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtAccessLevel -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtActivationStatus

This cmdlet returns the Double-Take license key validation information for the specified server. If you do not provide the code parameters, the license keys currently in use will be returned. Specifying the codes will return what the license status would be if the keys were applied using Set-DtActivationCode. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtActivationStatus [-Code] <String[]> [-AdditionalCode] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Code<String[]>

Specify the 24-character, alpha-numeric license key which applies the appropriate Double-Take license to your Double-Take server. Specify multiple keys in an array using the format @(code1, code2).

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-AdditionalCode<String[]>

Specify any additional licenese keys, such as activation keys. Specify multiple keys in an array using the format @(code1, code2).

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the validation information for the Double-Take license key assigned to the server is returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtActivationStatus -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtAllFailoverReports

This cmdlet returns all of the failover reports associated with the specified job. For this cmdlet, the -ServiceHost should be your target server for the failover.

Syntax

Get-DtAllFailoverReports [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

All reports are retrieved for a job from the target server. The reports are ordered from latest to oldest.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob = Get-DtJob -ServiceHost $DtServerObjectBeta

$DtReports = Get-DtAllFailoverReports -ServiceHost $DtServerObjectBeta -JobId $DtJob.Id

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtBandwidthLimit

This cmdlet returns the bandwidth limiting configuration for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtBandwidthLimit [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtBandwidthLimit [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The bandwidth limiting configuration is then returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtBandwidthLimit -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtConnectionIds

This cmdlet returns the connection ID associated with the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtConnectionIds [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The connection ID for the job is then stored in DtConIdForAlpha. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtConIdForAlpha = Get-DtConnectionIds -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtDiagnostics

This cmdlet collects configuration data for use when reporting problems to technical support. Because the diagnostics are gathering several pieces of information, potentially across the network to the machine where you are running the cmdlet, it may take several minutes to complete the information gathering and sending the resulting zip file to the cmdlet machine. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtDiagnostics [-OutputDirectory] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-OutputDirectory<String>

Specify the full location and file name with a .zip extension, on the machine where you are running the Get-DtDiagnostics cmdlet, to store the resulting zip file containing the diagnostics information.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then diagnostics are collected for the server and stored at the root of the C: drive in the file called AlphaDiagnostics.zip. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtDiagnostics -ServiceHost $DtServerObjectAlpha "C:\AlphaDiagnostics.zip"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtDnsOptions

This cmdlet returns DNS options available between the specified source and target servers. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtDnsOptions [-Source] <Server> [-JobType] <String> [-Workload] <Workload> [-DnsCredentials] <PSCredential> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>

This value is the type of job.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Workload<Workload>

Specify the workload object returned from the Get-DtWorkload cmdlet.

Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DnsCredentials<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password. See Hiding your password in a PowerShell script for basic details on using this cmdlet. See your Windows PowerShell documentation for detailed instructions.

Required? | true
Position? | 5
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a full sever job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. User credentials are stored in a variable called $DtCredential. The script will prompt you to supply the username and password and the credentials will be encrypted. The DNS options for the two servers are then retrieved. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha-WorkloadTypeName FullServerFailover

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtCredentialEncrypted = Get-Credential

Get-DtDnsOptions -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FullServerFailover -Workload $DtWorkload -DnsCredentials $DtCredentialEncrypted

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtEmailNotificationOptions

This cmdlet returns the current e-mail notification settings for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtEmailNotificationOptions [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the current e-mail notification settings for that server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtEmailNotificationOptions -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtEventLogEntry

This cmdlet returns a list of Double-Take event log entries for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtEventLogEntry [-LastIndex] <Int32> [-ChunkSize] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-LastIndex<Int32>

Specify an index entry. The next index entry after the number you specify will be the starting point for the log entries returned. For example, if you specify 144 then the first log entry retrieved will be index 145.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ChunkSize<Int32>

Specify the number of entries that will be returned at one time. The default number of entries is 1024.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take event entries are displayed, in groups of 25. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtEventLogEntry -ServiceHost $DtServerObjectAlpha -ChunkSize 25

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtHvSystemState

Syntax

Get-DtHvSystemState [-Credential] <PSCredential> [-BiosGuid] <Guid> [-GuestDnsName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtHvSystemState [-Domain] <String> [-Password] <String> [-UserName] <String> [-BiosGuid] <Guid> [-GuestDnsName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BiosGuid<Guid>
Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Domain<String>
Required? | false
Position? | 6
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-GuestDnsName<String>
Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>
Required? | true
Position? | 5
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>
Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.


Get-DtImages

This cmdlet returns DR image information for the specified server. For this cmdlet, the -ServiceHost should be your repository server.

Syntax

Get-DtImages [-ImageIds] <List`1> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ImageIds<List`1>

Specify an image GUID or a comma-separated list of GUIDs. If you have an existing job, you can find the image GUID in JobOptions.ImageProtectionOptions returned from the Get-DtJob cmdlet. If you do not have an existing job, you will need to use this cmdlet to gather all of the image GUIDs available on a repository server and then specify an image GUID or list of image GUIDs from the previous Get-DtImages call.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The available image information for the server is returned.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

Get-DtImages -ServiceHost $DtServerObjectBeta


Get-DtJob

Returns job information and status for the specified job on the specified server. To change the options of an existing job, use Edit-DtJob. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtJob [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet. Specify multiple GUID objects in an array using the format @($JobGuid1, $JobGuid2).

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. The recommended job options for the servers and the workload type are then stored in the variable DtJobOptions. A new files and folders job is created using the servers and the job options. The job ID is stored in the variable DtFnFJobGuid. Finally, the job information for the job is stored in the variable DtJobInfo. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtJobOptions = Get-DtRecommendedJobOptions -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -Workload $DtWorkload

$DtFnFJobGuid = New-DtJob -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -JobOptions $DtJobOptions.JobOptions

$DtJobInfo = Get-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtFnFJobGuid

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta

------------------EXAMPLE 2------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. All job information for all of the jobs on the server beta are stored in the variable DtJobInfo. This type of usage is common when the jobs were created in the past or if you did not store or do not know a job's ID. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobInfo = Get-DtJob -ServiceHost $DtServerObjectBeta

Disconnect-DtServer -ServiceHost $DtServerObjectBeta

------------------EXAMPLE 3------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. This usage is common for servers that have more than one job, but you only want job information for one specific job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtJobActionStatus

This cmdlet returns the status of a job action that has been queued for job. The first syntax returns the status of all of the actions queued for the specified job. The second syntax returns the status for the job action object specified. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtJobActionStatus [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtJobActionStatus [-Action] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Action<ActivityToken>

Specify a Double-Take job action object.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. Finally, the status of the job action is returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtJobActionStatus -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtLatestFailoverReport

This cmdlet returns the latest failover report associated with the specified job. For this cmdlet, the -ServiceHost should be your target server for the failover.

Syntax

Get-DtLatestFailoverReport [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A report is retrieved for a job from the target server. The returned report is the latest for the machine.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob = Get-DtJob -ServiceHost $DtServerObjectBeta

$DtReport = Get-DtLatestFailoverReport -ServiceHost $DtServerObjectBeta -JobId $DtJob.Id

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtLogicalItem

This cmdlet returns the logical items associated with the specified workload. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Get-DtLogicalItem [-RefItem] <LogicalItem> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RefItem<LogicalItem>

Specify an object returned from a previous Get-DtLogicalItem call.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a full sever job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The logical items associated with the workload type and the server are then stored in the variable DtLogicalItems. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha-WorkloadTypeName FullServerFailover

$DtLogicalItems = Get-DtLogicalItem -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGUID

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtLogMessage

This cmdlet returns messages from the Double-Take log file and the Double-Take Management Service log file. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtLogMessage [-Source] <String> [-LastSequenceNumber] <Int32> [-LastTimestamp] <DateTimeOffset> [-ChunkSize] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<String>

Specify source of the log message. If no source is specified, both Double-Take Management Service messages and Double-Take service messages will be returned. To have only Double-Take Management Service messages displayed, specify MS for the string value. To have only Double-Take service messages displayed, specify EN for the string value.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LastSequenceNumber<Int32>

Specify a sequence number to be the starting point to retrieve the log messages.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LastTimestamp<DateTimeOffset>

Specify a date and time stamp to be the starting point to retrieve the log messages. Specify the date in mm/dd/yyyy format. Specify the time in hh:mm:ss format with AM or PM. You can specify a time zone offset, for example, -04:00. If you do not specify a time zone offset, the time zone of the machine you are running from will be used. If you do not specify a time, 12:00:00 AM will be used.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ChunkSize<Int32>

Specify the number of entries that will be returned at one time. The default number of entries is 1024.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take Management Service log messages after 5:19pm on November 24, 2015 are displayed in groups of 25. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtLogMessage -ServiceHost $DtServerObjectAlpha -source MS -LastTimeStamp "11/24/2015 05:19:00 PM" -ChunkSize 25

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtOnlineActivationRequest

This cmdlet returns server information, unique to a specific, single server that is required to activate a Double-Take license. The server must already have an activation code on the server in order to get the server information. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtOnlineActivationRequest [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The server information for the online activation process is returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtOnlineActivationRequest -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtOption

This cmdlet returns the value of the specific job or server option from the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtOption [-Name] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Name<String[]>

Specify the name of the job or server option. Specify multiple strings in an array using the format @(string1, string2).

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the value of the server option called MirrorChunkSize is returned from the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtOption -ServiceHost $DtServerObjectAlpha -Name MirrorChunkSize

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtPathBlocking

This cmdlet returns the paths that are blocked on the specified target server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtPathBlocking [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the paths that are blocked on the server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtPathBlocking -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtPhysicalItem

This cmdlet returns file system information for the specified server. A physical item can be used to specify a specific file, folder, or volume to return file system information for. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtPhysicalItem [-Ref] <PhysicalItem> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Ref<PhysicalItem>

Specify an object returned from a previous Get-DtPhysicalItem call.

Required? | false
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the volumes on the server are stored in the variable DtVolumes. Finally, the files and folders at the root of the first volume in DtVolumes is stored in the variable DtVolume1Root. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtVolumes = Get-DtPhysicalItem -ServiceHost $DtServerObjectAlpha

$DtVolume1Root = Get-DtPhysicalItem -ServiceHost $DtServerObjectAlpha -Ref $DtVolumes[0]

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtProductInfo

This cmdlet returns Double-Take product information for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtProductInfo [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take product information for the server is returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtProductInfo -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtQualificationResults

This cmdlet returns the qualification results for the specified job type. You may want to use these results for job options when editing a job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtQualificationResults [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtQualificationResults [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The qualification results for the job are then returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtQualificationResults -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtRecommendedFailbackOptions

This cmdlet returns the recommended failback options for the specified job on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtRecommendedFailbackOptions [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedFailbackOptions [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then the recommended failback options for the specified job and server are returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtRecommendedFailbackOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtRecommendedFailoverOptions

This cmdlet returns the recommended failover options for the specified job on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtRecommendedFailoverOptions [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedFailoverOptions [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then the recommended failover options for the specified job and server are returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtRecommendedFailoverOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtRecommendedJobOptions

This cmdlet returns the recommended job options for the specified job type. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtRecommendedJobOptions [-Source] <Server> [-JobType] <String> [-Workload] <Workload> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>

Specify the type of job from the following list.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Workload<Workload>

Specify the workload object returned from the Get-DtWorkload cmdlet.

Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>

Specify the server object returned from the New-DtServer cmdlet. Specify multiple server objects in an array using the format @($server1, $server2).

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. The recommended job options for the servers and the workload type are then stored in the variable DtJobOptions. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtJobOptions = Get-DtRecommendedJobOptions -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -Workload $DtWorkload

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtRecommendedPathTransform

This cmdlet returns the recommended mapping between the location of the data on the source and the location of the replica data on the target for the specific type of workload. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Get-DtRecommendedPathTransform [-BasePath] <String> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BasePath<String>

Specify the location on the target where the replica of the source data will be stored. By default, the replica source data will be stored in the same directory structure on the target, in a one-to-one configuration.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a full sever job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The recommended mapping of the data on the source and the replica data on the target is then returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha-WorkloadTypeName FullServerFailover

Get-DtRecommendedPathTransform -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtRecommendedRestoreOptions

Returns the recommended restoration options for the specified job on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtRecommendedRestoreOptions [-JobId] <Guid> [-RestoreTarget] <Server> [-RequestCanClearRestoreRequired] <SwitchParameter> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtRecommendedRestoreOptions [-JobInfo] <JobInfo> [-RestoreTarget] <Server> [-RequestCanClearRestoreRequired] <SwitchParameter> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RestoreTarget<Server>

Specify the server you wan to restore to. If you do not specify a server, the original source server will be used.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-RequestCanClearRestoreRequired<SwitchParameter>

Sets RecommendedRestoreOptions.CanClearRestoreRequired on the RecommendedRestoreOptions object based on whether it is supported by the current job state. You still need to set ClearRestoreRequired on RestoreOptions to clear the restore required state of a job.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then the recommended restore options for the specified job and server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtRecommendedRestoreOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -RestoreTarget $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta

------------------EXAMPLE 2------------------

If you want to clear the restore required flag, save your recommended restore options to a variable and then set ClearRestoreRequired to true.

$DtRecommendedRestoreOptions = Get-DtRecommendedRestoreOptions -ServiceHost

$DtServerObjectBeta -JobId $DtJobForAlpha.Id -RestoreTarget $DtServerObjectAlpha -RequestCanClearRestoreRequired

$DtRestoreOptions = $DtRecommendedRestoreOptions.RestoreOptions

$DtRestoreOptions.ClearRestoreRequired = $true


Get-DtRepairJobOptionsStatus

This cmdlet returns the details and status of the repair performed by the Repair-DtJobOptions cmdlet. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtRepairJobOptionsStatus [-Token] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>

Specify the repair action object returned from the Repair-DtJobOptions cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job options used by the job are confirmed, and the validation result is stored in DtValidation. The details of the validation are stored in the variable DtStatus. Those items that can automatically be fixed are corrected. If the job options were modified in order to fix an issues, the updated job options are now contained in the variable $DtRepair. The details and status of the repair are stored in the variable DtRepairStatus. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtValidation = Confirm-DtJobOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJob.Options

$DtStatus = Get-DtVerificationStatus -ServiceHost $DtServerObjectBeta -Token $DtValidation

$DtRepair = Repair-DtJobOptions -ServiceHost $DtTarget -JobId $DtJob.Id -JobOptions $DtJob.Options -Step $DtStatus.Steps

$DtRepairStatus = Get-DtRepairJobOptionsStatus -ServiceHost $DtServerObjectBeta -Token $DtRepair

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtScriptCredentials

This cmdlet returns the credentials that Double-Take is currently using to run scripts on the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtScriptCredentials [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Return Types

System.Management.Automation.PSCredential

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the credentials that Double-Take is using to run scripts on this server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtScriptCredentials -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtServerInfo

This cmdlet returns server configuration information for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Get-DtServerInfo [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then server configuration information for the server is returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtServerInfo -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtSnapshot

This cmdlet returns the available Double-Take snapshots for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtSnapshot [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtSnapshot [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The snapshots available for the job are returned. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtSnapshot -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtSourceQueueSnapshot

This cmdlet returns the coordinated snapshot for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtSourceQueueSnapshot [-CorrelationId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-CorrelationId<Guid>

Specify the correlation ID used to create the coordinated snapshots.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

Several variables are set including a unique correlation ID for the snapshots that will be taken as well as URI identifiers for the source servers of existing jobs. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The jobs are retrieved from DtServerObjectBeta, and the job information is inserted into unique variables. And array of job IDs is then created. A coordinated snapshot is taken using the specified correlation ID and the jobs stored in the array. Only those jobs will have coordinated snapshots. Then the coordinated snapshot for the specified correlation ID and job ID is returned. The connections for the server object are then closed.

$CorId=New-Guid

$Source1Uri = "dtms://112.42.7.63:6325/"

$Source2Uri = "dtms://112.42.7.71:6325/"

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob1 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source1Uri}

$DtJob2 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source2Uri}

$DtJobsArray = New-Object "System.Collections.Generic.List[Guid]"

$DtJobsArray.Clear()

$DtJobsArray.Add($DtJob1.Id)

$DtJobsArray.Add($DtJob2.Id)

Checkpoint-DtConnectionSourceQueue -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJobsArray.ToArray()

Get-DtSourceQueueSnapshot -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJob1.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtSourceQueueSnapshots

This cmdlet returns all coordinated snapshot for one correlation ID. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtSourceQueueSnapshots [-CorrelationId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-CorrelationId<Guid>

Specify the correlation ID used to create the coordinated snapshots.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

Several variables are set including a unique correlation ID for the snapshots that will be taken as well as URI identifiers for the source servers of existing jobs. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The jobs are retrieved from DtServerObjectBeta, and the job information is inserted into unique variables. And array of job IDs is then created. A coordinated snapshot is taken using the specified correlation ID and the jobs stored in the array. Only those jobs will have coordinated snapshots. Then the coordinated snapshots for the specified correlation ID are returned. The connections for the server object are then closed.

$CorId=New-Guid

$Source1Uri = "dtms://112.42.7.63:6325/"

$Source2Uri = "dtms://112.42.7.71:6325/"

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob1 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source1Uri}

$DtJob2 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source2Uri}

$DtJobsArray = New-Object "System.Collections.Generic.List[Guid]"

$DtJobsArray.Clear()

$DtJobsArray.Add($DtJob1.Id)

$DtJobsArray.Add($DtJob2.Id)

Checkpoint-DtConnectionSourceQueue -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJobsArray.ToArray()

Get-DtSourceQueueSnapshots -ServiceHost $DtServerObjectBeta -CorrelationId $CorId

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtUvraRecommendedFailoverOptions

This cmdlet returns the recommended failover options for the specified full server to ESX appliance job on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtUvraRecommendedFailoverOptions [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtUvraRecommendedFailoverOptions [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the root and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the appliance beta using port 6325 and the root and password credentials. It assigns the server object to the variable called DtApplianceObject. The job (s) are retrieved from DtApplianceObject, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then the recommended failover options for the specified full server to ESX appliance job and server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName root -Password password

$DtApplianceObject = New-DtUvraServer -Name beta -UserName root -Password password -Port 6325

$DtJobForAlpha = Get-DtJob -ServiceHost $DtApplianceObject | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtUvraRecommendedFailoverOptions -ServiceHost $DtApplianceObject -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtApplianceObject

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtUvraRecommendedRemoveOptions

This cmdlet returns the recommended removal options when deleting the specified full server to ESX appliance job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtUvraRecommendedRemoveOptions [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Get-DtUvraRecommendedRemoveOptions [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the root and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the appliance beta using port 6325 and the root and password credentials. It assigns the server object to the variable called DtApplianceObject. The job (s) are retrieved from DtApplianceObject, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Then the recommended remove options for the specified full server to ESX appliance job and server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName root -Password password

$DtApplianceObject = New-DtUvraServer -Name beta -UserName root -Password password -Port 6325

$DtJobForAlpha = Get-DtJob -ServiceHost $DtApplianceObject | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Get-DtUvraRecommendedRemoveOptions -ServiceHost $DtApplianceObject -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtApplianceObject

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtVerificationStatus

This cmdlet returns the details and status of the validation performed by the Confirm-DtJobOptions cmdlet. Do not confuse this process with the verification process that confirms if the data between the source and target are synchronized. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Get-DtVerificationStatus [-Token] <ActivityToken> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>

Specify the confirm action object returned from the Confirm-DtJobOption cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job options used by the job are confirmed, and the validation result is stored in DtValidation. The details of the validation are stored in the variable DtStatus. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtValidation = Confirm-DtJobOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJob.Options

$DtStatus = Get-DtVerificationStatus -ServiceHost $DtServerObjectBeta -Token $DtValidation

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Get-DtWorkload

This cmdlet returns an object that represents the workload definition, including the workload type name, any physical rules, and any logical rules. This object is used in job cmdlets. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Get-DtWorkload [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a full sever job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha-WorkloadTypeName FullServerFailover

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtWorkloadPhysicalItem

This cmdlet returns the physical items available for the specified workload on the specified server. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Get-DtWorkloadPhysicalItem [-RefItem] <PhysicalItem> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RefItem<PhysicalItem>

Specify an object returned from a previous Get-DtWorkloadPhysicalItem call.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. Finally, the physical items available for the workload on the server are returned. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

Get-DtWorkloadPhysicalItem -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Get-DtWorkloadType

This cmdlet returns the types of workloads that are supported on the specified server. The supported workload types are based on the Double-Take activation code(s) on the server, the applications on the server, the server configuration (like standalone or cluster), and so on. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Get-DtWorkloadType [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then it returns the workload types that are supported on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtWorkloadType -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Install-DoubleTake

This cmdlet installs Double-Take on the specified server. One syntax allows you to install Double-Take immediately, and the other syntax allows you to schedule the installation.

Syntax

Install-DoubleTake [-ActivationCode] <String[]> [-DiskQueueFolder] <String> [-DiskQueueLimit] <Nullable`1> [-DotNetPackagePath] <String> [-InstallationFolder] <String> [-MaxMemoryUsage] <Nullable`1> [-MinFreeDiskSpace] <Nullable`1> [-PackageBaseFolder] <String> [-SimultaneousFilePushLimit] <Nullable`1> [-TempFolder] <String> [-X64PackageFolder] <String> [-X86PackageFolder] <String> [-LinuxPackageFolder] <String> [-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Install-DoubleTake [-ActivationCode] <String[]> [-DiskQueueFolder] <String> [-DiskQueueLimit] <Nullable`1> [-DotNetPackagePath] <String> [-InstallationFolder] <String> [-MaxMemoryUsage] <Nullable`1> [-MinFreeDiskSpace] <Nullable`1> [-NoReboot] <SwitchParameter> [-PackageBaseFolder] <String> [-Schedule] <DateTime> [-SimultaneousFilePushLimit] <Nullable`1> [-TempFolder] <String> [-X64PackageFolder] <String> [-X86PackageFolder] <String> [-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Parameters
-ActivationCode<String[]>

Specify your 24-character, alpha-numeric license key which applies the appropriate Double-Take license to your Double-Take server. Specify multiple keys in an array using the format @(code1, code2). You can also specify the keyword None and provide a license key later.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DiskQueueFolder<String>

Specify the location where you want to store the Double-Take disk queue on each server. The default is \Program Files\Vision Solutions\Double-Take.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DiskQueueLimit<Nullable`1>

Specify a fixed amount of disk space, in MB, in the specified DiskQueueFolder that can be used for Double-Take disk queuing. When the disk space limit is reached, Double-Take will automatically begin the auto-disconnect process. By default, an unlimited amount of disk queuing will be allowed.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-DotNetPackagePath<String>

If your servers are running Windows 2008 or earlier and do not have Microsoft .NET version 3.5.1, specify the location of the setup file (on the local machine) that will be used to install it. The setup file is available on the Double-Take CD in the \NetFx\v3.5SP1\Full directory or from the Microsoft web site.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InstallationFolder<String>

Specify the location where you want to install Double-Take on the server. The default is \Program Files\Vision Solutions\Double-Take.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MaxMemoryUsage<Nullable`1>

Specify the maximum amount of memory, in MB, that can be used for Double-Take processing. The default will depend on your operating system and hardware.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MinFreeDiskSpace<Nullable`1>

This is the minimum amount of disk space in the specified DiskQueueFolder that must be available at all times. This amount should be less than the amount of physical disk space minus the disk size specified for DiskQueueLimit. The default is 50 MB.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NoReboot<SwitchParameter>

Specify if you do not want the server to reboot after the installation, even if a reboot is required.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-PackageBaseFolder<String>

Specifies the locations of the setup files (on the local machine or a UNC path) that will be used to install on both 32-bit and 64-bit servers. By default, these are in the i386\ and \x64 subdirectories where you installed Double-Take.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Schedule<DateTime>

Specify a date and time to complete the installation. Specify the date in mm/dd/yyyy format. Specify the time in hh:mm:ss format with AM or PM. You can specify a time zone offset, for example, -04:00. If you do not specify a time zone offset, the time zone of the machine you are running from will be used. If you do not specify a time, 12:00:00 AM will be used.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SimultaneousFilePushLimit<Nullable`1>

Specify the number of files that can simultaneously be pushed to the machine you are installing on. The default is 5.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-TempFolder<String>

Specify a temporary location (on the server where you are installing Double-Take) where the installation files will be copied and run. The default is \Temp. You need approximately 130 MB of space in the specified location.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-X64PackageFolder<String>

Specify the location of the setup file (on the local machine or a UNC path) that will be used to install on 64-bit Windows servers. By default, this is in the \x64 subdirectory where you installed Double-Take.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-X86PackageFolder<String>

Specify the location of the setup file (on the local machine or a UNC path) that will be used to install on 32-bit Windows servers. By default, this is in the \i386 subdirectory where you installed Double-Take.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-LinuxPackageFolder<String>

Specify the location of the .rpm or .deb installation files (on the local machine or a UNC path) that will be used to install on Linux servers.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-RemoteServer<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-AsJob<SwitchParameter>

Specify if you want the installation to occur asynchronously in the background, returning the PowerShell command immediately. You can get the status of each installation using the Windows PowerShell Get-Job command. Without this parameter, each push installation specified will be executed synchronously and the current activity of the current installation will be displayed.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then Double-Take is installed to the server using the activation code 1234567890abcdefghij1234, using the setup.exe installation file stored locally at C:\Program Files\Vision Solutions\Double-Take\x64. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Install-DoubleTake -RemoteServer $DtServerObjectAlpha -ActivationCode 1234567890abcdefghij1234 -x64PackageFolder "C:\Program Files\Vision Solutions\Double-Take\x64"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then Double-Take is installed to the server using the activation code 1234567890abcdefghij1234, using the .rpm or .deb installation files stored locally at C:\Program Files\Vision Solutions\Double-Take\Linux. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Install-DoubleTake -RemoteServer $DtServerObjectAlpha -ActivationCode 1234567890abcdefghij1234 -LinuxPackageFolder "C:\Program Files\Vision Solutions\Double-Take\Linux"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 3------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then Double-Take is installed to the server using the activation code 1234567890abcdefghij1234, using the .rpm or .deb installation files stored on a deployed Double-Take Linux appliance at \\DTAppliance\installers. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Install-DoubleTake -RemoteServer $DtServerObjectAlpha -ActivationCode 1234567890abcdefghij1234 -LinuxPackageFolder "\\DTAppliance\installers"

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Install-DtVmwareCertificate

This cmdlet installs the specified certificate. For this cmdlet, the -ServiceHost needs to be the target server.

Syntax

Install-DtVmwareCertificate [-Certificate] <X509Certificate2> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Certificate<X509Certificate2>

Specify the certificate to install.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The server $DTServerObjectBeta is tested to see if the current policy or any valid certificates will allow a connection to the specified VMware server. In this example, assume the return is false. The VMware certificate policy on the server $DTServerObjectBeta is then set to allow all certificates to be installed. The certificate from the Test-DtVmwareCertificatePolicy false return is then installed on the server $DTServerObjectBeta. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$TestResult = Test-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6

Set-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6 -Policy AllowAll

Install-DtVmwareCertificate -ServiceHost $DtServerObjectBeta -Certificate $TestResult[1]

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Invoke-DtAddShares

This cmdlet takes the drive share configuration that was gathered during Double-Take mirroring and replication and applies it to the target server. This process is independent of the failover process. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Invoke-DtAddShares [-JobXmlPath] <String> [-SharePathFilter] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobXmlPath<String>

Specify the path and file name to the Double-Take .xml configuration file for the job that contains the protected shares. By default, this location is \Program Files\Vision Solutions\Double-Take\Service\Data. The file name will be JobGuid.xml where Guid is the unique identifier assigned to the job. You can find this ID by using Get-DtJob.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SharePathFilter<String>

Creates shares from the specified path and any subdirectories of this path.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. All job information for all of the jobs on the server beta are stored in the variable DtJobInfo. This type of usage is common when the jobs were created in the past or if you did not store or do not know a job's ID. In this example, assume there is only one job on the server. Job id from the stored job information is stored in the variable JobId. The path to the location of the job file is stored in the variable PathToJobFile. The extension of the job file is stored in the variable JobFileExtension. The variables are appended, together with the word Job, to create the variable JobFile. For example, the JobFile variable might end up being C:\Program Files\Vision Solutions\Double-Take\Service\Data\Job87667a0d-4516-4182-ab8f-13f6fd15dd92.xml. Shares are then added on the server DtServerObjectBeta using the job configuration file stored in JobFile. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobInfo = Get-DtJob -ServiceHost $DtServerObjectBeta

$JobId = $DtJobInfo.Id

$PathToJobFile = "C:\Program Files\Vision Solutions\Double-Take\Service\Data\"

$JobFileExtension = ".xml"

$JobFile = $PathToJobFile + "Job" + $JobId + $JobFileExtension

Invoke-DtAddShares –ServiceHost $DtServerObjectBeta –JobXmlPath $JobFile

Disconnect-DtServer –ServiceHost $DtServerObjectBeta


Invoke-DtQueueTask

This cmdlet queues tasks inline with replication data. Keep the following in mind when using this cmdlet.

For this cmdlet, the -ServiceHost should be your target server.

Any combination of one or more execution points can be used with the same Invoke-DtQueueTask cmdlet.

All script processing messages, including errors, can be viewed in the Double-Take log and the Windows Event log.

If your source is in a restore required state (after a failover), any task placed on the queue will be executed immediately. Use caution when submitting tasks while in this state so that the target does not get inadvertently updated.

If a task is submitted after replication is stopped, the task will be executed immediately.

A task may be discarded if all jobs to a target are manually stopped, if replication is stopped to a target, or if an auto-disconnect occurs.

If you disable task command processing while tasks are in queue, those tasks will not be executed.

The user submitting the task command must be a member of the Double-Take Admin security group on both the source and target and the Double-Take service must have proper privileges to access the files or run the commands specified in the task.

Syntax

Invoke-DtQueueTask [-JobId] <Guid> [-OnQueue] <TaskParameters> [-OnTransmit] <TaskParameters> [-OnReceive] <TaskParameters> [-OnExecute] <TaskParameters> [-InteractWithDesktop] <SwitchParameter> [-Timeout] <TimeSpan> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Invoke-DtQueueTask [-JobInfo] <JobInfo> [-OnQueue] <TaskParameters> [-OnTransmit] <TaskParameters> [-OnReceive] <TaskParameters> [-OnExecute] <TaskParameters> [-InteractWithDesktop] <SwitchParameter> [-Timeout] <TimeSpan> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-OnQueue<TaskParameters>

Execute the specified task on the source machine as soon as the source receives and queues the task. During heavy replication, there may be a delay while the task is queued inline with the replication operations. Define the task parameters by using New-DtTaskParameters.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnTransmit<TaskParameters>

Execute the specified task on the source machine just before the source transmits the task to the target. Define the task parameters by using New-DtTaskParameters.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnReceive<TaskParameters>

Execute the specified task on the target machine as soon as the target receives and queues the task. Define the task parameters by using New-DtTaskParameters.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OnExecute<TaskParameters>

Execute the specified task on the target when the target processes the task from the queue. Since the task is not executed until it is processed, if the target is paused, the task will be held in queue. Define the task parameters by using New-DtTaskParameters.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InteractWithDesktop<SwitchParameter>

Tasks interact with the desktop and, therefore, display on screen and run in the foreground. If you do not use this option, tasks do not interact with the desktop and will be run in the background.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Timeout<TimeSpan>

Specify the length of time, in timespan format, to wait for tasks to complete. For example, 0.01:30:00 would wait for one hour and thirty minutes. If you set the timespan to zero (0.00:00:00), there is no timeout delay and the next operation is immediately processed. If you do not specify a timeout parameter, the timeout will default to forever.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The script called ScriptName, located in C:\PathDir, along with two arguments, is stored in the variable DtScript. The script to launch PowerShell and run the script called Script.ps1, located in C:\PathDir, along with two arguments and the ExecutionPolicy parameter, is stored in the variable DtPsScript. Finally, the script stored in DtScript is executed when the target receives and queues the task and the script stored in DtPsScript is executed when the target processes the task from the queue. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtScript = New-DtTaskParameters -ScriptPath "C:\PathDir\ScriptName" -Arguments "arg1 arg2"

$DtPsScript = New-DtTaskParameters -ScriptPath "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -Arguments "-File ""C:\PathDir\Script.ps1"" ""-Arg1 argument1_info -Arg2 argument2_info"" -ExecutionPolicy RemoteSigned"

Invoke-DtQueueTask -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -OnReceive $DtScript -OnExecute $DtPsScript

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Invoke-DtRemoveShares

This cmdlet takes the drive share configuration that was gathered during Double-Take mirroring and replication and removes it from the target server. This process is independent of the failback process. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Invoke-DtRemoveShares [-JobXmlPath] <String> [-SharePathFilter] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobXmlPath<String>

Specify the path and file name to the Double-Take .xml configuration file for the job that contains the protected shares. By default, this location is \Program Files\Vision Solutions\Double-Take\Service\Data. The file name will be JobGuid.xml where Guid is the unique identifier assigned to the job. You can find this ID by using Get-DtJob.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SharePathFilter<String>

Removes shares from the specified path and any subdirectories of this path.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. All job information for all of the jobs on the server beta are stored in the variable DtJobInfo. This type of usage is common when the jobs were created in the past or if you did not store or do not know a job's ID. In this example, assume there is only one job on the server. Job id from the stored job information is stored in the variable JobId. The path to the location of the job file is stored in the variable PathToJobFile. The extension of the job file is stored in the variable JobFileExtension. The variables are appended, together with the word Job, to create the variable JobFile. For example, the JobFile variable might end up being C:\Program Files\Vision Solutions\Double-Take\Service\Data\Job87667a0d-4516-4182-ab8f-13f6fd15dd92.xml. Shares are then removed on the server DtServerObjectBeta using the job configuration file stored in JobFile. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobInfo = Get-DtJob -ServiceHost $DtServerObjectBeta

$JobId = DtJobInfo.Id

$PathToJobFile = "C:\Program Files\Vision Solutions\Double-Take\Service\Data\"

$JobFileExtension = ".xml"

$JobFile = $PathToJobFile + "Job" + $JobId + JobFileExtension

Invoke-DtRemoveShares –ServiceHost $DtServerObjectBeta –JobXmlPath $JobFile

Disconnect-DtServer – ServiceHost $DtServerObjectBeta


Merge-DtConsoleServerData

This cmdlet applies the server information from a server data file generated from the Save-DtConsoleServerData cmdlet. The server information from the file will be applied to the user profile of the user that is currently logged into the machine. If you have multiple administrators sharing the same Double-Take Console installation, each administrator will need to be logged in to apply console server data to their user profile. You must close the Double-Take Console to apply the server data file.

Syntax

Merge-DtConsoleServerData [-ImportFilePath] <String> [-Replace] <SwitchParameter> [<CommonParameters>]

Parameters
-ImportFilePath<String>

Specify the path and file name of the .xml console data file that was generated from the Save-DtConsoleServerData cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Replace<SwitchParameter>

Remove the servers from the console that are not present in the import file.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

The Double-Take Console server data from the file DtAdmin1_ServerData.xml is applied to the user profile for the user that is currently logged in.

Merge-DtConsoleServerData -ImportFilePath "C:\DtAdmin1_ServerData.xml"


New-DtFilesAndFoldersJob

This cmdlet creates a files and folders job on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

New-DtFilesAndFoldersJob [-Source] <Server> [-Path] <String> [-TargetPath] <String> [-Name] <String> [-JobOptions] <JobOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Path<String>

Specify the path on the source that contains the data that you want to protect.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-TargetPath<String>

Specify the path on the target where you want to store the replica data from the source. By default, a one-to-one mapping will be used on the target, which means the replica source data will be stored in the same directory structure on the target.

Required? | false
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Name<String>

Specify the name of the job.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>

Specify the JobOptions returned from the Get-DtRecommendedJobOptions cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. The recommended job options for the servers and the workload type are then stored in the variable DtJobOptions. A new files and folders job is created using the servers and the job options. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtJobOptions = Get-DtRecommendedJobOptions -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -Workload $DtWorkload

New-DtFilesAndFoldersJob -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -Path "C:\Data" -TargetPath "C:\Alpha\C" -Name "Alpha to Beta" -JobOptions $DtJobOptions.JobOptions

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


New-DtJob

This cmdlet creates the specified job type on the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

New-DtJob [-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

New-DtJob [-CreateOptions] <CreateOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>

Specify the type of job from the following list.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>

Specify the JobOptions returned from the Get-DtRecommendedJobOptions cmdlet.

Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>

Specify the server object returned from the New-DtServer cmdlet. Specify multiple server objects in an array using the format @($server1, $server2).

Required? | false
Position? | 5
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>

Specify the create options available in DoubleTake.Jobs.Contract.CreateOptions. Use the Windows PowerShell New-Object cmdlet to create this object.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload definition for the workload type and the server is then stored in the DtWorkload variable. The recommended job options for the servers and the workload type are then stored in the variable DtJobOptions. A new files and folders job is created using the servers and the job options. The job ID is stored in the variable DtFnFJobGuid. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtWorkload = Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtJobOptions = Get-DtRecommendedJobOptions -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -Workload $DtWorkload

$DtFnFJobGuid = New-DtJob -ServiceHost $DtServerObjectBeta -Source $DtServerObjectAlpha -JobType FilesAndFolders -JobOptions $DtJobOptions.JobOptions

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


New-DtServer

This cmdlet creates a server object with specific credentials associated with it. This may be any type of server in your organization, for example a Double-Take server, a DNS server, an application server, and so on. This object is used to communicate with the Double-Take Management Service. You should close the connections to this server object when you are finished using it by using Disconnect-DtServer.

Syntax

New-DtServer [-UserName] <String> [-Password] <String> [-Name] <String> [-Role] <String> [<CommonParameters>]

New-DtServer [-Credential] <PSCredential> [-Name] <String> [-Role] <String> [<CommonParameters>]

Parameters
-Name<String>

Specify the name or IP address of the server, cluster, or cluster node.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>

Specify a user name. If you are using a domain, specify domain\user name.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>

Specify the password associated with the user you have entered. This password will be visible in plain text.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Role<String>

Specify one of the following roles for the server object you are creating. These servers are used when you specify the -OtherServers parameter in other cmdlets.

TargetVimServer - This is the ESX server or vCenter that will host the replica virtual machine after failover. If you are using vCenter, specify your vCenter. Only specify an ESX host if you are using ESX standalone.

ReverseVimServer - This is the ESX server or vCenter server that will host the replica virtual after reverse and failover. If you are using vCenter, specify your vCenter. Only specify an ESX host if you are using ESX standalone.

ReverseHelperRole - This is the target where data will be replicated after a reverse.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

User credentials are stored in a variable called $DtCredential. The script will prompt you to supply the username and password and the credentials will be encrypted. Then the stored credentials are used to create a new server object for the server alpha. It assigns the server object to the variable called DtServerObject. The connections for the server object are then closed.

$DtCredentialEncrypted = Get-Credential

$DtServerObjectAlpha = New-DtServer -Name alpha -Credential $DtCredential

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


New-DtTaskParameters

Creates a parameter set to be used with the Invoke-DtQueueTask cmdlet.

Syntax

New-DtTaskParameters [-ScriptPath] <String> [-Arguments] <String> [<CommonParameters>]

Parameters
-ScriptPath<String>

Specify the full path and script name.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Arguments<String>

Specify any arguments that need to be passed to the script.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

The script called ScriptName, located in C:\PathDir, along with two arguments, is stored in the variable DtScript.

$DtScript = New-DtTaskParameters -ScriptPath "C:\PathDir\ScriptName" -Arguments "arg1 arg2"

------------------EXAMPLE 2------------------

The script to launch PowerShell and run the script called Script.ps1, located in C:\PathDir, along with two arguments and the ExecutionPolicy parameter, is stored in the variable DtPsScript.

$DtPsScript = New-DtTaskParameters -ScriptPath "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -Arguments "-File ""C:\PathDir\Script.ps1"" ""-Arg1 argument1_info -Arg2 argument2_info"" -ExecutionPolicy RemoteSigned"


New-DtUri

This cmdlet creates a URI (uniform resource identifier) that is used to specify job credentials.

Syntax

New-DtUri [-Literal] <String> [<CommonParameters>]

New-DtUri [-NetworkId] <String> [-Credential] <PSCredential> [-Port] <Nullable`1> [-Scheme] <String> [-Query] <String> [-Fragment] <String> [<CommonParameters>]

Parameters
-Literal<String>

Specify the entire URI string.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-NetworkId<String>

Specify the name or IP address of the server.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Port<Nullable`1>

Specify the communications port.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Scheme<String>

Specify the scheme name.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Query<String>

Specify any additional identification information.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Fragment<String>

Specify any identifying information that provides direction to a secondary resource.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A URI is created for http://server:6320.

New-DtUri -Literal "http://server:6320"

------------------EXAMPLE 2------------------

A URI is created for foo://username:password@domain.com:6320/location/index?type=volume&amp;directory=C#location.

New-DtUri -Literal "foo://username:password@domain.com:6320/location/index?type=volume&directory=C#location"


New-DtUvraServer

This cmdlet creates a server object with specific credentials associated with it. This cmdlet is specific to the full server to ESX appliance job type. The server object may be one of the following types of servers: Double-Take server, virtual recovery appliance, or VMware host. The object is used to communicate with the Double-Take Management Service.

Syntax

New-DtUvraServer [-UserName] <String> [-Password] <String> [-Port] <Int32> [-Name] <String> [-Role] <String> [<CommonParameters>]

New-DtUvraServer [-Credential] <PSCredential> [-Port] <Int32> [-Name] <String> [-Role] <String> [<CommonParameters>]

Parameters
-Port<Int32>

Specify the port for the XML web service protocol. By default, that is 443. Use 6325 for Double-Take servers and appliances, unless you changed the default Double-Take port. Do not specify a port for VMware hosts.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Name<String>

Specify the name or IP address of the server, cluster, or cluster node.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-UserName<String>

Specify a user name. If you are using a domain, specify domain\user name.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>

Specify the password associated with the user you have entered. This password will be visible in plain text.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Role<String>

Specify one of the following roles for the server object you are creating. These servers are used when you specify the -OtherServers parameter in other cmdlets.

TargetVimServer - This is the ESX server or vCenter that will host the replica virtual machine after failover. If you are using vCenter, specify your vCenter. Only specify an ESX host if you are using ESX standalone.

ReverseVimServer - This is the ESX server or vCenter server that will host the replica virtual after reverse and failover. If you are using vCenter, specify your vCenter. Only specify an ESX host if you are using ESX standalone.

ReverseHelperRole - This is the target where data will be replicated after a reverse.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using port 6325 and the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObject. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtUvraServer -Name alpha -UserName domain\administrator -Password password -Port 6325

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

User credentials are stored in a variable called $DtCredential. The script will prompt you to supply the username and password and the credentials will be encrypted. Then the stored credentials are used to create a new server object for the server alpha using port 6325. It assigns the server object to the variable called DtServerObject. The connections for the server object are then closed.

$DtCredentialEncrypted = Get-Credential

$DtServerObjectAlpha = New-DtUvraServer -Name alpha -Credential $DtCredential -Port 6325

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


New-DtWorkload

This cmdlet creates a Double-Take workload on the specified server. For this cmdlet, the -ServiceHost should be your source server.

Syntax

New-DtWorkload [-WorkloadTypeName] <String> [-ImageId] <Guid> [-SnapshotId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

New-DtWorkload [-Workload] <Workload> [-ImageId] <Guid> [-SnapshotId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-WorkloadTypeName<String>

Specify a supported workload type from the Get-DtWorkloadType cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Workload<Workload>

Specify a supported workload type from the Get-DtWorkloadType cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ImageId<Guid>

Specify the image GUID returned from the Get-DtImages cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-SnapshotId<Guid>

Specify the snapshot GUID returned from the Get-DtSnapshot cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Remove-DtJob

This cmdlet deletes the specified job from the specified server. A running job will be stopped before it is deleted. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Remove-DtJob [-JobId] <Guid> [-DeleteOptions] <DeleteOptions> [-ServiceHost] <Server> [<CommonParameters>]

Remove-DtJob [-JobInfo] <JobInfo> [-DeleteOptions] <DeleteOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-DeleteOptions<DeleteOptions>

Specify the delete options available in DoubleTake.Jobs.Contract.DeleteOptions. Use the Windows PowerShell New-Object cmdlet to create this object.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The delete options are stored in DtDeleteOptions, then the specific delete option DiscardTargetQueue is set to true. Finally the job is removed using the delete options. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtDeleteOptions = New-Object DoubleTake.Jobs.Contract.DeleteOptions

$DtDeleteOptions.DiscardTargetQueue = $true

Remove-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -DeleteOptions $DtDeleteOptions

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Remove-DtPhysicalRule

This cmdlet removes a physical rule from the specified workload on the specified server. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Remove-DtPhysicalRule [-Rule] <PhysicalRule> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Rule<PhysicalRule>

Use the Windows PowerShell New-Object cmdlet to create a physical rule object from DoubleTake.Common.Contract.PhysicalRule.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. A new object is created from Double-Take.Common.Contract.PhysicalRule to store the physical path C:\DirName in the variable DtPhysicalPath. Finally, the physical rule is removed from the workload on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtPhysicalPath = New-Object DoubleTake.Common.Contract.PhysicalRule -Property @{Path="C:\DirName"}

Remove-DtPhysicalRule -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid -Rule $DtPhysicalPath

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The workload information for the workload is then stored in DtWorkloadInfo. The physical rule within DtWorkloadInfo called C:\DirNameToRemove is then stored in DtRemoveRule. Finally, the physical rule DtRemoveRule is removed from the workload on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtWorkloadInfo=Get-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid

$DtRemoveRule = $DtWorkloadInfo.PhysicalRules | Where-Object {$_.Path -eq "C:\DirNameToRemove"}

Remove-DtPhysicalRule -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid -Rule $DtRemoveRule

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Remove-DtSnapshot

This cmdlet removes a Double-Take snapshot from the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Remove-DtSnapshot [-Snapshot] <SnapshotEntry> [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Remove-DtSnapshot [-SnapshotId] <Guid> [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Snapshot<SnapshotEntry>

Specify the snapshot entry object returned from the Get-DtSnapshot cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-SnapshotId<Guid>

Specify the snapshot GUID returned from the Get-DtSnapshot cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The snapshots available for the job are stored in DtSnaps and then the first snapshot is stored in FirstSnap. That first snapshot is then deleted. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtSnaps = Get-DtSnapshot -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

$FirstSnap=$DtSnaps | Select-Object -First 1

Remove-DtSnapshot -ServiceHost $DtServerObjectBeta -SnapshotId $FirstSnap.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Remove-DtSourceQueueSnapshot

This cmdlet deletes a coordinated snapshot from the specified jobs. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Remove-DtSourceQueueSnapshot [-CorrelationId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-CorrelationId<Guid>

Specify the correlation ID of the coordinated snapshots you want to remove.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

Several variables are set including a unique correlation ID for the snapshots that will be taken as well as URI identifiers for the source servers of existing jobs. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The jobs are retrieved from DtServerObjectBeta, and the job information is inserted into unique variables. An array of job IDs is then created. A coordinated snapshot is taken using the specified correlation ID and the jobs stored in the array. Only those jobs will have coordinated snapshots. A second array of job IDs is then created, with just one item in the array. The coordinated snapshot for the job in the second array is then deleted. Other snapshots having the same correlation ID but not in the specified array will not be deleted. The connections for the server object are then closed.

$CorId=New-Guid

$Source1Uri = "dtms://112.42.7.63:6325/"

$Source2Uri = "dtms://112.42.7.71:6325/"

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJob1 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source1Uri}

$DtJob2 = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object { $_.SourceHostUri -eq $Source2Uri}

$DtJobsArray = New-Object "System.Collections.Generic.List[Guid]"

$DtJobsArray.Clear()

$DtJobsArray.Add($DtJob1.Id)

$DtJobsArray.Add($DtJob2.Id)

Checkpoint-DtConnectionSourceQueue -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJobsArray.ToArray()

$DtJobsArray2 = New-Object "System.Collections.Generic.List[Guid]"

$DtJobsArray.Clear()

$DtJobsArray2.Add($DtJob2.Id)

Remove-DtSourceQueueSnapshot -ServiceHost $DtServerObjectBeta -CorrelationId $CorId -JobIds $DtJobsArray2.ToArray()

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Repair-DtJobOptions

This cmdlet attempts to fix job option errors and warnings. For those errors and warnings that Double-Take cannot correct automatically, you will need to modify the job options manually, modify the source or target configuration, or perhaps select a different target. Use the first syntax for existing jobs and the second syntax for new jobs. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Repair-DtJobOptions [-JobId] <Guid> [-JobOptions] <JobOptions> [-Step] <VerificationStep[]> [-ServiceHost] <Server> [<CommonParameters>]

Repair-DtJobOptions [-CreateOptions] <CreateOptions> [-Step] <VerificationStep[]> [-ServiceHost] <Server> [<CommonParameters>]

Repair-DtJobOptions [-Source] <Server> [-JobType] <String> [-JobOptions] <JobOptions> [-Step] <VerificationStep[]> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-CreateOptions<CreateOptions>

Specify the create options available in DoubleTake.Jobs.Contract.CreateOptions. Use the Windows PowerShell New-Object cmdlet to create this object.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Source<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobType<String>

Specify the type of job from the following list.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobOptions<JobOptions>

Specify the JobOptions returned from the Get-DtRecommendedJobOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Step<VerificationStep[]>

Specify the verification steps returned by the Get-DtVerificationStatus cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-OtherServers<Server[]>

Specify the server object returned from the New-DtServer cmdlet. Specify multiple server objects in an array using the format @($server1, $server2).

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job options used by the job are confirmed, and the validation result is stored in DtValidation. The details of the validation are stored in the variable DtStatus. Those items that can automatically be fixed are corrected. If the job options were modified in order to fix an issues, the updated job options are now contained in the variable $DtRepair. The updated job options are then applied to the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtValidation = Confirm-DtJobOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJob.Options

$DtStatus = Get-DtVerificationStatus -ServiceHost $DtServerObjectBeta -Token $DtValidation

$DtRepair = Repair-DtJobOptions -ServiceHost $DtTarget -JobId $DtJob.Id -JobOptions $DtJob.Options -Step $DtStatus.Steps

Edit-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtRepair.Options

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Request-DtOnlineActivation

This cmdlet activates the Double-Take license over the Internet using the server information returned by the Get-DtOnlineActivationRequest cmdlet. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Request-DtOnlineActivation [-Code] <String> [-ServerName] <String> [-ServerInformation] <String> [-ServiceHost] <Server> [-EmailAddress] <String> [<CommonParameters>]

Parameters
-Code<String>

Specify the 24-character, alpha-numeric license key which applies the appropriate Double-Take license to your Double-Take server. Specify multiple codes in an array using the format @(code1, code2). You can also use the code that is returned by the Get-DtOnlineActivationRequest cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServerName<String>

Specify the name of the server or use the server name returned by the Get-DtOnlineActivationRequest cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServerInformation<String>

Specify the server information returned by the Get-DtOnlineActivationRequest cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-EmailAddress<String>

Specify a valid email address.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The server information for the online activation process is returned. The license is activated online. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtOnlineActivationRequest -ServiceHost $DtServerObjectAlpha

Request-DtOnlineActivation -Code 1234-5678-9012-3456-7890-1234 -ServerName $DtServerObjectAlpha -ServerInformation thnvkg9anmtjr5y27qgzhrmvqqbhyr5f7152pecq

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The server information for the online activation process is returned. The output from the Get-DtOnlineActivationRequest cmdlet is piped directly to Request-DtOnlineActivation, which activates the license online, and then that output (from Request-DtOnlineActivation) is piped directory to Set-DtActivationCode to set the activation key on the server.The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtOnlineActivationRequest -ServiceHost $DtServerObjectAlpha | Request-DtOnlineActivation | Set-DtActivationCode

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Request-DtOnlineDeactivation

This cmdlet deactivates the Double-Take license over the Internet for the specified server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Request-DtOnlineDeactivation [-ServiceHost] <Server> [-EmailAddress] <String> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-EmailAddress<String>

Specify a valid email address.

Required? | false
Position? | 2
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The license for that server is deactivated. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Request-DtOnlineDectivation -ServerName $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Restart-DtReplicationService

This cmdlet stops and restarts the Double-Take service on the specified server. This cmdlet does not impact the Double-Take Management Service. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Restart-DtReplicationService [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take service on the server is stopped and restarted. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Restart-DtReplicationService -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Resume-DtJob

This cmdlet resumes a paused job. All jobs from the same source to the same IP address on the target will be resumed. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Resume-DtJob [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Resume-DtJob [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job is then resumed. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Resume-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Resume-DtMirror

This cmdlet resumes a paused mirror. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Resume-DtMirror [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Resume-DtMirror [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The mirror for the job is then resumed. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Resume-DtMirror -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Resume-DtTarget

This cmdlet resumes Double-Take processing on the target. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Resume-DtTarget [-ServiceHost] <Server> [-All] <SwitchParameter> [<CommonParameters>]

Resume-DtTarget [-ServiceHost] <Server> [-JobId] <Guid> [-ConnectionId] <Guid> [<CommonParameters>]

Resume-DtTarget [-ServiceHost] <Server> [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-All<SwitchParameter>

Execute the cmdlet on all jobs that are present.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. Double-Take processing on that server is then resumed. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

Resume-DtTarget -ServiceHost $DtServerObjectBeta -All

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Save-DtConsoleServerData

This cmdlet saves the server information from the Double-Take Console for the user that is currently logged into the machine. If you have multiple administrators sharing the same Double-Take Console installation, each administrator will need to be logged in to save their console server data.

Syntax

Save-DtConsoleServerData [-FilePath] <String> [<CommonParameters>]

Parameters
-FilePath<String>

Specify the path and file name with an .xml fie extension to store the server data from the Double-Take Console.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

The Double-Take Console server data for the user currently logged in will be saved at the root of the C: drive to the file DtAdmin1_ServerData.xml.

Save-DtConsoleServerData -FilePath "C:\DtAdmin1_ServerData.xml"


Save-DtJobDiagnostics

Saves a diagnostics file (also known as DTInfo) to the \Service\Data directory of your Double-Take installation on the specified server. This cmdlet is not applicable to Exchange jobs, SQL jobs, full server to ESX appliance jobs, or agentless Hyper-V jobs. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Save-DtJobDiagnostics [-JobId] <Guid[]> [-ServiceHost] <Server> [<CommonParameters>]

Save-DtJobDiagnostics [-JobInfo] <JobInfo[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid[]>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo[]>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet and used in this cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The diagnostics files is then saved on the server. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Save-DtJobDiagnostics -Servicehost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Set-DtActivationCode

This cmdlet sets the Double-Take activation code on the specified server. It also returns the Double-Take activation code validation information from the Get-DtActivationStatus cmdlet. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Set-DtActivationCode [-Code] <String[]> [-AdditionalCode] <String[]> [-ActivationKey] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Code<String[]>

Specify the 24-character, alpha-numeric license key which applies the appropriate Double-Take license to your Double-Take server. Specify multiple keys in an array using the format @(code1, code2).

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-AdditionalCode<String[]>

Specify any additional license keys. Specify multiple keys in an array using the format @(code1, code2).

Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ActivationKey<String>

Specify the 24-character, alpha-numeric activation key which activates your Double-Take license.

Required? | false
Position? | named
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the activation code 1234567890abcdefghij1234 is applied to the server. The server returns the activation code information. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Set-DtActivationCode -ServiceHost $DtServerObjectAlpha -Code 1234567890abcdefghij1234

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The server information for the online activation process is returned. The output from the Get-DtOnlineActivationRequest cmdlet is piped directly to Request-DtOnlineActivation, which activates the license online, and then that output (from Request-DtOnlineActivation) is piped directory to Set-DtActivationCode to set the activation key on the server.The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Get-DtOnlineActivationRequest -ServiceHost $DtServerObjectAlpha | Request-DtOnlineActivation | Set-DtActivationCode

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtBandwidthLimit

This cmdlet sets bandwidth limiting for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Set-DtBandwidthLimit [-JobId] <Guid> [-BandwidthLimit] <BandwidthLimit> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtBandwidthLimit [-JobInfo] <JobInfo> [-BandwidthLimit] <BandwidthLimit> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-BandwidthLimit<BandwidthLimit>

Specify the bandwidth limit configuration from Get-BandwidthLimit.

Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The bandwidth limiting configuration is then stored in DtFixedBandwidth. The Mode is then changed to fixed and the Limit is set to 100,000 bytes/second. Finally, the bandwidth settings are applied to the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtFixedBandwidth = Get-DtBandwidthLimit -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

$DtFixedBandwidth.Mode = "Fixed"

$DtFixedBandwidth.Limit = 100000

Set-DtBandwidthLimit -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -BandwidthLimit $DtFixedBandwidth

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Set-DtEmailNotificationOptions

This cmdlet sets the Double-Take e-mail notification configuration for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Set-DtEmailNotificationOptions [-Options] <EmailNotificationOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Options<EmailNotificationOptions>

Specify the object returned from the Get-DtEmailNotificationOptions cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the default Double-Take e-mail notification options are stored in the variable DtEmailOptions. Two of the options are then changed. The Enabled option is set to true which turns on the e-mail notification feature. The SMTP server is also configured for mail.company.com. Finally those changes for the email notification options are set on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtEmailOptions = Get-DtEmailNotificationOptions -ServiceHost $DtServerObject

$DtEmailOptions.Enabled = $true

$DtEmailOptions.SmtpServer = "mail.company.com"

Set-DtEmailNotificationOptions -ServiceHost $DtServerObjectAlpha -Options $DtEmailOptions

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtJobCredentials

Updates the credentials for the source, appliance, and VMware host servers used in the specified job.

Syntax

Set-DtJobCredentials [-JobId] <Guid> [-Source] <PSCredential> [-Target] <PSCredential> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtJobCredentials [-JobInfo] <JobInfo> [-Source] <PSCredential> [-Target] <PSCredential> [-OtherServers] <Server[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Source<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Target<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-OtherServers<Server[]>

Specify the server object returned from the New-DtServer or New-DtUvraServer cmdlet. Specify the server object in an array using the format @($server).

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

You will be prompted for credentials for the domain\administrator account and they will be stored in DtCredentials. Then a server object is created for the servers alpha and beta using the stored credentials. The objects are stored in DtServerObjectAlpha and DtServerObjectBeta, respectively. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Finally, the credentials are updated for the job using the stored credentials. The connections for the server object are then closed.

$DtCredentials = Get-Credential domain\administrator

$DtServerObjectAlpha = New-DtServer -Name alpha -Credential $DtCredentials

$DtServerObjectBeta = New-DtServer -Name beta -Credential $DtCredentials

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Set-DtJobCredentials -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -Source $DtCredentials -Target $DtCredentials

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Set-DtLogicalItemSelection

This cmdlet adds or removes a logical items for the specified workload for the specified server. Adding or removing logical items will add or remove physical rules depending on the workload type. For this cmdlet, the -ServiceHost should be your source server.

Syntax

Set-DtLogicalItemSelection [-LogicalPath] <String> [-Unselect] <SwitchParameter> [-WorkloadId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-LogicalPath<String>

Specify the path of an item returned from Get-DtLogicalItem.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Unselect<SwitchParameter>

Specify this option if you want to remove the logical item.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-WorkloadId<Guid>

Specify the workload GUID returned from the New-DtWorkload cmdlet using the workload type name parameter.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. The script then creates a workload on the server for a files and folders job, returning a global unique ID for the workload, and assigns that ID to the variable DtWorkloadGuid. The logical items associated with the workload type and the server are then stored in the variable DtLogicalItems. Finally, the first logical item in DtLogicalItems is added to the workload. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtWorkloadGuid = New-DtWorkload -ServiceHost $DtServerObjectAlpha -WorkloadTypeName FilesAndFolders

$DtLogicalItems = Get-DtLogicalItem -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGUID

Set-DtLogicalItemSelection -ServiceHost $DtServerObjectAlpha -WorkloadId $DtWorkloadGuid -LogicalPath $DtLogicalItem[0].Path

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtOption

This cmdlet sets the value of the Double-Take server or job option for the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Set-DtOption [-Setting] <Hashtable> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption [-Name] <String> [-IntValue] <Int64> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption [-Name] <String> [-StringValue] <String> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtOption [-Name] <String> [-MultiStringValue] <String[]> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Setting<Hashtable>

Specify a hash table using the format @{option1=value1; option2=value2}.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-Name<String>

Specify the name of the job or server option.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-IntValue<Int64>

Specify an integer value for the server or job option.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-StringValue<String>

Specify a single string (text) value for the server or job option

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-MultiStringValue<String[]>

Specify multiple string (text) values for the server or job option in an array using the format @(string1, string2).

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the server settings MaxChecksumBlocks and MirrorChunkSize are set to 64 and 131072, respectively, on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Set-DtOption -ServiceHost $DtServerObjectAlpha -Setting @{MaxChecksumBlocks=64; MirrorChunkSize=131072}

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then it sets the MirrorChunkSize server setting to 64. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Set-DtOption -Servicehost $DtServerObjectAlpha -Name MirrorChunkSize -IntValue 64

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtPathBlocking

This cmdlet blocks writing to the replica source data located on the target, keeping the data from being changed outside of Double-Take processing. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Set-DtPathBlocking [-SourceAddress] <String> [-Mode] <PathBlockingMode> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-SourceAddress<String>

Specify the IP address of the source, including the port, for example, 123.123.123.123:6320.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Mode<PathBlockingMode>

Specify Blocked or Unblocked.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then it sets the target paths associated with the replica data from the specified source IP address to blocked. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Set-DtPathBlocking -ServiceHost $DtServerObjectAlpha -SourceAddress "112.42.74.29:6320" -Mode Blocked

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtScriptCredentials

This cmdlet sets the credentials for Double-Take to use when running scripts on the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Set-DtScriptCredentials [-Credential] <PSCredential> [-ServiceHost] <Server> [<CommonParameters>]

Set-DtScriptCredentials [-UserName] <String> [-Password] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>

Specify a user name. If you are using a domain, specify domain\user name.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>

Specify the password associated with the user you have entered. This password will be visible in plain text.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then you will be prompted for credentials for the domain\administrator account and those credentials will be stored in the variable DtCredentials. Finally, the credentials used for Double-Take scripts on the server will be set to the stored credentials. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtCredentials = Get-Credential domain\administrator

Set-DtScriptCredentials -ServiceHost $DtServerObjectAlpha -Credential $DtCredentials

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Set-DtServerCredential

This cmdlet changes the credentials associated with the server object that has already been created using the New-DtServer cmdlet.

Syntax

Set-DtServerCredential [-Input] <Server> [-Credential] <PSCredential> [<CommonParameters>]

Parameters
-Input<Server>

Specify the name or IP address of the server, cluster, or cluster node, or specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

User credentials are stored in a variable called $DtCredential. The script will prompt you to supply the username and password and the credentials will be encrypted. Then the stored credentials are used to update the current credentials on the server alpha.

$DtCredentialEncrypted = Get-Credential

Set-DtServerCredential -Input alpha -Credential $DtCredential


Set-DtVmwareCertificatePolicy

This cmdlet sets the VMWare certificate policy. For this cmdlet, the -ServiceHost needs to be the target server.

Syntax

Set-DtVmwareCertificatePolicy [-VmwareServer] <String> [-Policy] <Nullable`1> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-VmwareServer<String>

Specify the name of the VMware server (ESX host or vCenter) where the target server is located. If not specified, policy is applied to all VMware servers.

Required? | false
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Policy<Nullable`1>

Specify the VMware security certificate policy you want to apply.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The server $DTServerObjectBeta is tested to see if the current policy or any valid certificates will allow a connection to the specified VMware server. In this example, assume the return is false. The VMware certificate policy on the server $DTServerObjectBeta is then set to allow all certificates to be installed. The certificate from the Test-DtVmwareCertificatePolicy false return is then installed on the server $DTServerObjectBeta.The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$TestResult = Test-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6

Set-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6 -Policy AllowAll

Install-DtVmwareCertificate -ServiceHost $DtServerObjectBeta -Certificate $TestResult[1]

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtJob

This cmdlet starts the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtJob [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJob [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job is then started. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Start-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtJobFailback

This cmdlet starts failback for the specified job using the specified failback options. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtJobFailback [-JobId] <Guid> [-FailbackOptions] <FailbackOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobFailback [-JobInfo] <JobInfo> [-FailbackOptions] <FailbackOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-FailbackOptions<FailbackOptions>

Specify the failback options returned from the Get-DtRecommendedFailbackOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The failback options are stored in DtFailbackOptions. Failback is then started using the failback options. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtFailbackOptions = Get-DtRecommendedFailbackOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Start-DtJobFailback -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -FailbackOptions $DtFailbackOptions

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtJobFailover

This cmdlet starts failover for the specified job using the specified failover options. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtJobFailover [-JobId] <Guid> [-FailoverOptions] <FailoverOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobFailover [-JobInfo] <JobInfo> [-FailoverOptions] <FailoverOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-FailoverOptions<FailoverOptions>

Specify the failover options returned from the Get-DtRecommendedFailoverOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The failover options are stored in DtFailoverOptions, and then the PerformTestFailover option is set to true. Failover is then started using the failover options. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtFailoverOptions = Get-DtRecommendedFailoverOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

$DtFailoverOptions.FailoverOptions.PerformTestFailover = $true

Start-DtJobFailover -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -FailoverOptions $DtFailoverOptions.FailoverOptions

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtJobRestore

This cmdlet starts the restoration process for the specified job using the specified restoration options. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtJobRestore [-JobId] <Guid> [-RestoreOptions] <RestoreOptions> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobRestore [-JobInfo] <JobInfo> [-RestoreOptions] <RestoreOptions> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-RestoreOptions<RestoreOptions>

Specify the restoration options returned from the Get-DtRecommendedRestoreOptions cmdlet.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The restoration options are stored in DtRestoreOptions, and then the ProcessOrphans option is set to true. Restoration is then started using the restoration options. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtRestoreOptions = Get-DtRecommendedRestoreOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -RestoreTarget $DtServerObjectAlpha

$DtRestoreOptions.RestoreOptions.RestoreParameters.ProcessOrphans = $true

Start-DtJobRestore -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -RestoreOptions $DtRestoreOptions

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtJobReverse

This cmdlet starts the reverse process for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtJobReverse [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtJobReverse [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job is then reversed. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Start-DtJobReverse -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtMirror

This cmdlet starts mirroring on the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtMirror [-JobId] <Guid> [-MirrorParameters] <MirrorParameters> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtMirror [-JobInfo] <JobInfo> [-MirrorParameters] <MirrorParameters> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-MirrorParameters<MirrorParameters>

Specify the mirror options available in DoubleTake.Core.Contract.Connection.MirrorParameters. Use the Windows PowerShell New-Object cmdlet to create this object.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The mirror options are stored in DtMirrorChecksum. The ComparisonCriteria value is changed to checksum and the Options are set to Synchronize and CalculateDifferences. Then the mirror is started for the job using the stored mirroring options. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtMirrorChecksum = New-Object DoubleTake.Core.Contract.Connection.MirrorParameters

$DtMirrorChecksum.ComparisonCriteria = "Checksum"

$DtMirrorChecksum.Options = "Synchronize,CalculateDifferences"

Start-DtMirror -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -MirrorParameters $DtMirrorChecksum

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtOrphansProcessing

This cmdlet starts orphan files processing on the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtOrphansProcessing [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtOrphansProcessing [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Orphan file processing is then started for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Start-DtOrphansProcessing -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtReplication

This cmdlet starts replication on the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtReplication [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtReplication [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Replication is then started for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Start-DtReplication -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Start-DtVerify

This cmdlet starts the Double-Take verification process to check that the replica source data on the target is identical to the actual data on the source. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Start-DtVerify [-JobId] <Guid> [-Synchronize] <SwitchParameter> [-Newer] <SwitchParameter> [-Checksum] <SwitchParameter> [-ProcessOrphans] <SwitchParameter> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Start-DtVerify [-JobInfo] <JobInfo> [-Synchronize] <SwitchParameter> [-Newer] <SwitchParameter> [-Checksum] <SwitchParameter> [-ProcessOrphans] <SwitchParameter> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Synchronize<SwitchParameter>

Mirrors to the target any protected files that are different on the source. Without this option, the verification process will only verify the data and generate a verification log file, but it does not remirror any files that are different on the source and target.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Newer<SwitchParameter>

If you are mirroring files to the target during the verification process with the synchronize option, this option will only mirror files that are newer on the source than on the target. If you are using a database application, do not use this option unless you know for certain that you need it. With database applications, it is critical that all files, not just some of the file that might be newer, get mirrored.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Checksum<SwitchParameter>

If you are mirroring files to the target during the verification process with the synchronize option, this option will have the verification process perform a block checksum comparison to determine which blocks are different.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ProcessOrphans<SwitchParameter>

If you are mirroring files to the target during the verification process with the synchronize option, this option will delete orphaned files on the target.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Verification is then started for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Start-DtVerify -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -Synchronize -Newer -Checksum -ProcessOrphans

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Stop-DtJob

This cmdlet stops the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Stop-DtJob [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtJob [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job is then stopped. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Stop-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Stop-DtMirror

This cmdlet stops mirroring on the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Stop-DtMirror [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtMirror [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The mirror is then stopped for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Stop-DtMirror -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Stop-DtReplication

This cmdlet stops replication on the specified job. For this cmdlet, the -ServiceHost should be your target server

Syntax

Stop-DtReplication [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Stop-DtReplication [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Replication is then stopped for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Stop-DtReplication -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Stop-DtReplicationService

This cmdlet stops the Double-Take service on the specified server. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Stop-DtReplicationService [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the Double-Take service is stopped on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Stop-DtReplicationService -ServiceHost $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Suspend-DtJob

This cmdlet paused a job. All jobs from the same source to the same IP address on the target will be paused. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Suspend-DtJob [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Suspend-DtJob [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job is then suspended. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Suspend-DtJob -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Suspend-DtMirror

This cmdlet pauses mirroring. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Suspend-DtMirror [-JobId] <Guid> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Suspend-DtMirror [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The mirror for the job is then paused. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Suspend-DtMirror -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Suspend-DtTarget

This cmdlet pauses Double-Take processing on the target. Incoming Double-Take data from the source will be queued on the target. All active jobs to the target will complete the operations already in progress. Any new operations will be queued on the target until the target is resumed. The data will not be committed until the target is resumed. Pausing the target only pauses Double-Take processing, not the entire server. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Suspend-DtTarget [-ServiceHost] <Server> [-All] <SwitchParameter> [<CommonParameters>]

Suspend-DtTarget [-ServiceHost] <Server> [-JobId] <Guid> [-ConnectionId] <Guid> [<CommonParameters>]

Suspend-DtTarget [-ServiceHost] <Server> [-JobInfo] <JobInfo> [-ConnectionId] <Guid> [<CommonParameters>]

Parameters
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-All<SwitchParameter>

Execute the cmdlet on all jobs that are present.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet and used in this cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Double-Take processing for the job is then paused. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Suspend-DtTarget -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Test-DtActiveDirectoryCredentials

This cmdlet tests if the specified credentials have privileges to update Active Directory on the specified server's domain. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Test-DtActiveDirectoryCredentials [-Credential] <PSCredential> [-ComputerDomain] <String> [-ComputerName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Test-DtActiveDirectoryCredentials [-UserName] <String> [-Password] <String> [-ComputerDomain] <String> [-ComputerName] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-ComputerDomain<String>

Specify a domain name.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ComputerName<String>

Specify a computer name.

Required? | true
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>

Specify a user name. If you are using a domain, specify domain\user name.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>

Specify the password associated with the user you have entered. This password will be visible in plain text.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then you will be prompted for credentials for the domain\administrator account and those credentials will be stored in the variable DtCredentials. Finally, the stored credentials will be tested to see if they can update Active Directory on the server's domain. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtCredentials = Get-Credential domain\administrator

Test-DtActiveDirectoryCredentials -ServiceHost $DtServerObjectAlpha -Credential $DtCredentials

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Test-DtEmailNotification

Tests the e-mail options configured with Set-DtEmailNotificationOptions by attempting to send an e-mail to the specified recipient. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Test-DtEmailNotification [-Options] <EmailNotificationOptions> [-To] <String> [-Body] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Options<EmailNotificationOptions>

Specify the object returned from the Get-DtEmailNotificationOptions cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-To<String>

Specify the e-mail address that the test Double-Take e-mail message should be sent to. Multiple addresses can be separated by a comma.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Body<String>

Specify the text of the test Double-Take email message.

Required? | true
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the default Double-Take e-mail notification options are stored in the variable DtEmailOptions. Two of the options are then changed. The Enabled option is set to true which turns on the e-mail notification feature. The SMTP server is also configured for mail.company.com. Those changes for the email notification options are set on the server. Finally a test message is sent to the administrator@mail.company.com addresses with the specified message text using the configured e-mail notification options. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtEmailOptions = Get-DtEmailNotificationOptions -ServiceHost $DtServerObject

$DtEmailOptions.Enabled = $true

$DtEmailOptions.SmtpServer = "mail.company.com"

Set-DtEmailNotificationOptions -ServiceHost $DtServerObjectAlpha -Options $DtEmailOptions

Test-DtEmailNotification -ServiceHost $DtServerObjectAlpha -Options $DtEmailOptions -To "administrator@mail.company.com" -Body "This is a test Double-Take message."

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Test-DtScript

This cmdlet tests the specified script on the specified server using the credentials from Set-DtScriptCredentials. If necessary, manually undo any changes that you do not want after testing the script. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Test-DtScript [-Path] <String> [-Arguments] <String> [-InteractionMode] <DesktopInteractionMode> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Path<String>

Specify the full path and script name.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Arguments<String>

Specify any arguments that need to be passed to the script.

Required? | false
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-InteractionMode<DesktopInteractionMode>

Specify if the script processing will be displayed on the screen, by using the value Interact, or if the script will execute silently in the background, by using the value None.

Required? | false
Position? | 4
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE 1------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then the script called ScriptName (located in C:\PathDir) is run, using the arguments arg1 and arg2. The script will display on screen. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Test-DtScript -ServiceHost $DtServerObjectAlpha -Path "C:\PathDir\ScriptName" -Arguments "arg1 arg2" -InteractionMode Interact

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha

------------------EXAMPLE 2------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then PowerShell is launched and the arguments passed to PowerShell are the PowerShell script myscript.ps1 (located in C:\my scripts) and the arguments ars1 and arg2. The PowerShell execution policy is set to RemoteSigned so the PowerShell script will execute. The script is set to run silently in the background. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Test-DtScript -ServiceHost $DtServerObjectAlpha -Path "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -Arguments "-File ""C:\my scripts\myscript.ps1"" ""-Arg1 arg1 -Arg2 arg2"" -ExecutionPolicy RemoteSigned" -InteractionMode None

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Test-DtScriptCredentials

This cmdlet tests the specified credentials on the specified server to confirm if they have administrative rights. For this cmdlet, the -ServiceHost could be your source or target server.

Syntax

Test-DtScriptCredentials [-Credential] <PSCredential> [-ServiceHost] <Server> [<CommonParameters>]

Test-DtScriptCredentials [-UserName] <String> [-Password] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Credential<PSCredential>

Specify the credential object returned from the Windows PowerShell Get-Credential cmdlet. This password will not be visible because Windows stores an encrypted password.

Required? | true
Position? | 2
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-UserName<String>

Specify a user name. If you are using a domain, specify domain\user name.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Password<String>

Specify the password associated with the user you have entered. This password will be visible in plain text.

Required? | true
Position? | 3
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then you will be prompted for credentials for the domain\administrator account and those credentials will be stored in the variable DtCredentials. Finally, the credentials will be tested to confirm if they have administrative rights on the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

$DtCredentials = Get-Credential domain\administrator

Test-DtScriptCredentials -ServiceHost $DtServerObjectAlpha -Credential $DtCredentials

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Test-DtVmwareCertificatePolicy

This cmdlet tests the VMWare server certificate policy and if unsuccessful, returns the certificate in use and the corresponding error message. For this cmdlet, the -ServiceHost needs to be the target server.

Syntax

Test-DtVmwareCertificatePolicy [-VmwareServer] <String> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-VmwareServer<String>

Specify the name of the VMware server (ESX host or vCenter) where the target server is located.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The server $DTServerObjectBeta is tested to see if the current policy or any valid certificates will allow a connection to the specified VMware server. In this example, assume the return is false. The VMware certificate policy on the server $DTServerObjectBeta is then set to allow all certificates to be installed. The certificate from the Test-DtVmwareCertificatePolicy false return is then installed on the server $DTServerObjectBeta. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$TestResult = Test-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6

Set-DtVmwareCertificatePolicy -ServiceHost $DtServerObjectBeta -VmwareServer 112.47.15.6 -Policy AllowAll

Install-DtVmwareCertificate -ServiceHost $DtServerObjectBeta -Certificate $TestResult[1]

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Undo-DtJobFailover

This cmdlet starts the undo failover process for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Undo-DtJobFailover [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Undo-DtJobFailover [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The undo failover process is then started. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Undo-DtJobFailover -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Uninstall-DoubleTake

This cmdlet uninstalls Double-Take on the specified server.

Syntax

Uninstall-DoubleTake [-RemoteServer] <Server> [-AsJob] <SwitchParameter> [<CommonParameters>]

Parameters
-RemoteServer<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-AsJob<SwitchParameter>

Specify if you want the installation to occur asynchronously in the background, returning the PowerShell command immediately. You can get the status of each installation using the Windows PowerShell Get-Job command. Without this parameter, each push installation specified will be executed synchronously and the current activity of the current installation will be displayed.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server alpha using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectAlpha. Then Double-Take is uninstalled from the server. The connections for the server object are then closed.

$DtServerObjectAlpha= New-DtServer -Name alpha -UserName domain\administrator -Password password

Uninstall-Doubletake -RemoteServer $DtServerObjectAlpha

Disconnect-DtServer -ServiceHost $DtServerObjectAlpha


Update-DtShares

This cmdlet updates source share information on the target for the specified job. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Update-DtShares [-JobId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Update-DtShares [-JobInfo] <JobInfo> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. Shares are then updated on the target for the job. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

Update-DtShares -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Wait-DtConfirmJobOptions

This cmdlet waits for the job validation process triggered by Confirm-DtJobOptions to complete before processing any additional cmdlets. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Wait-DtConfirmJobOptions [-Token] <ActivityToken> [-Any] <SwitchParameter> [-Timeout] <Int32> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-Token<ActivityToken>

Specify the confirm action object returned from the Confirm-DtJobOption cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false
-Any<SwitchParameter>

Only wait for the first validation to finish before continuing.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-Timeout<Int32>

Specify the length of time, in seconds, to wait for the process to complete. For example, 120 would wait two minutes and then the next cmdlet would processed. If you set the timeout to zero (0), there is no timeout delay and the next cmdlet is immediately processed. If you do not specify a timeout parameter, the timeout will default to forever.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The job options used by the job are confirmed, and the validation result is stored in DtValidation. The script then waits until the validation is complete before continuing. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtValidation = Confirm-DtJobOptions -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -JobOptions $DtJob.Options

Wait-DtConfirmJobOptions -ServiceHost $DtServerObjectBeta -Token $DtValidation

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


Wait-DtMirrorComplete

This cmdlet waits for the mirroring process to complete before processing any additional cmdlets. For this cmdlet, the -ServiceHost should be your target server.

Syntax

Wait-DtMirrorComplete [-JobId] <Guid> [-PollingInterval] <Nullable`1> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Wait-DtMirrorComplete [-JobInfo] <JobInfo> [-PollingInterval] <Nullable`1> [-ConnectionId] <Guid> [-ServiceHost] <Server> [<CommonParameters>]

Parameters
-PollingInterval<Nullable`1>

Specify the amount of time, in hh:mm:ss, to wait before checking to see if the mirror has completed.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-ConnectionId<Guid>

Specify the connection ID returned from the Get-DtConnectionIds cmdlet.

Required? | false
Position? | named
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobId<Guid>

Specify the job GUID returned from the New-DtJob cmdlet or the Id within the job information returned from the Get-DtJob cmdlet.

Required? | true
Position? | 2
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
-JobInfo<JobInfo>

Specify the job information returned from the Get-DtJob cmdlet. The job information can be piped from the Get-DtJob cmdlet.

Required? | true
Position? | named
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
-ServiceHost<Server>

Specify the server object returned from the New-DtServer cmdlet.

Required? | true
Position? | 1
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

------------------EXAMPLE------------------

A server object is created for the server beta using the domain\administrator and password credentials. It assigns the server object to the variable called DtServerObjectBeta. The job(s) are retrieved from DtServerObjectBeta, but only the job information where the source machine name is equivalent to the name stored in the variable DtServerObjectAlpha is retrieved. That information is then stored in the variable DtJobForAlpha. The mirror options are stored in DtMirrorChecksum. The ComparisonCriteria value is changed to checksum and the Options are set to Synchronize and CalculateDifferences. Then the mirror is started for the job using the stored mirroring options. The script will wait for mirroring to complete before continuing. The script will check ever five minutes to see if mirroring is complete. The connections for the server object are then closed.

$DtServerObjectBeta = New-DtServer -Name beta -UserName domain\administrator -Password password

$DtJobForAlpha = Get-DtJob -ServiceHost $DtServerObjectBeta | Where-Object {$_.Statistics.CoreConnectionDetails.SourceMachineName -eq $DtServerObjectAlpha}

$DtMirrorChecksum = New-Object DoubleTake.Core.Contract.Connection.MirrorParameters

$DtMirrorChecksum.ComparisonCriteria = "Checksum"

$DtMirrorChecksum.Options = "Synchronize,CalculateDifferences"

Start-DtMirror -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -MirrorParameters $DtMirrorChecksum

Wait-DtMirrorComplete -ServiceHost $DtServerObjectBeta -JobId $DtJobForAlpha.Id -PollingInterval "00:05:00"

Disconnect-DtServer -ServiceHost $DtServerObjectBeta


DoubleTake.Common Namespaces

Namespaces
Namespace | Description
DoubleTake.Common.Contract |
DoubleTake.Common.Tasks |


DoubleTake.Common.Contract Namespace

Classes
 | Class | Description
Public class | ChangedItems | Indicates the workload items whose status changed as the result of modifying a workload.
Public class | Credentials | Represents credentials used to authenticate with a service.
Public class | EmailNotificationOptions |
Public class | EventLogEntryData2 | Represents an entry in the Windows event log.
Public class | LogicalItem | Represents an item that can be protected in workload. Logical items are meaningful to the user outside of a specific file system item.
Public class | LogMessage | Represents a message in the engine or management service text log file.
Public class | PathTransformation | Represents a transform path for a replication rule.
Public class | PhysicalItem | Represents an item that can be protected in workload. Physical items map directly to file system items.
Public class | PhysicalRule | Defines a physical rule for replicating data.
Public class | Volume | Represents a volume on a server.
Public class | Workload | Describes the data on a server that will be protected as part of a job.
Public class | WorkloadSupportSummary | Represents a summary of the licensing determination process for a workload type.
Public class | WorkloadType | Describes the type of workloads that can be created on a server.
Enumerations
 | Enumeration | Description
Public enumeration | FileSystemAttributes | Describes the attributes of a file system item.
Public enumeration | InclusionMode | Indicates whether a certain data path in a workload should be replicated.
Public enumeration | RecursionMode | Indicates whether recursion is used when replicating a data path.
Public enumeration | SaturationLevel | Indicates the saturation level of a protectable item.
Public enumeration | SmtpConnectionSecurity |


ChangedItems Class

Indicates the workload items whose status changed as the result of modifying a workload.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractChangedItems

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ChangedItems : IExtensibleDataObject
Public Class ChangedItems
    Implements IExtensibleDataObject
public ref class ChangedItems : IExtensibleDataObject
DoubleTake.Common.Contract.ChangedItems = function();

Type.createClass(
    'DoubleTake.Common.Contract.ChangedItems',
    null,
    IExtensibleDataObject);

The ChangedItems type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedItems |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalItems | This value represents the logical items that changed.
Public property | LogicalRules | This value is the current logical rules of the workload.
Public property | PhysicalItems | This value represents the physical items that changed.
Public property | PhysicalRules | This value represents the current physical rules of the workload.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


ChangedItems Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ChangedItems()
Public Sub New
public:
ChangedItems()
DoubleTake.Common.Contract.ChangedItems = function();
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems Properties

The ChangedItems type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalItems | This value represents the logical items that changed.
Public property | LogicalRules | This value is the current logical rules of the workload.
Public property | PhysicalItems | This value represents the physical items that changed.
Public property | PhysicalRules | This value represents the current physical rules of the workload.
Top
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.ExtensionData Property

Double-Take SOAP SDK 8.2

ChangedItemsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.LogicalItems Property

ChangedItemsLogicalItems Property

This value represents the logical items that changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalItem[] LogicalItems { get; set; }
Public Property LogicalItems As LogicalItem()
    Get
    Set
public:
property array<LogicalItem^>^ LogicalItems {
    array<LogicalItem^>^ get ();
    void set (array<LogicalItem^>^ value);
}
function get_LogicalItems();
function set_LogicalItems(value);

Property Value

Type: LogicalItem
An array of LogicalItem that indicates the logical items that changed.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.LogicalRules Property

ChangedItemsLogicalRules Property

This value is the current logical rules of the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_LogicalRules();
function set_LogicalRules(value);

Property Value

Type: String
An array of String that represents the current logical rules of this workload.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.PhysicalItems Property

ChangedItemsPhysicalItems Property

This value represents the physical items that changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalItem[] PhysicalItems { get; set; }
Public Property PhysicalItems As PhysicalItem()
    Get
    Set
public:
property array<PhysicalItem^>^ PhysicalItems {
    array<PhysicalItem^>^ get ();
    void set (array<PhysicalItem^>^ value);
}
function get_PhysicalItems();
function set_PhysicalItems(value);

Property Value

Type: PhysicalItem
An array of PhysicalItem that indicates the physical items that changed.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


ChangedItems.PhysicalRules Property

ChangedItemsPhysicalRules Property

This value represents the current physical rules of the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRule()
    Get
    Set
public:
property array<PhysicalRule^>^ PhysicalRules {
    array<PhysicalRule^>^ get ();
    void set (array<PhysicalRule^>^ value);
}
function get_PhysicalRules();
function set_PhysicalRules(value);

Property Value

Type: PhysicalRule
An array of PhysicalRule that represents the current physical rules of this workload.
See Also

Reference

ChangedItems Class
DoubleTake.Common.Contract Namespace


Credentials Class

Represents credentials used to authenticate with a service.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractCredentials

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class Credentials : IExtensibleDataObject
Public Class Credentials
    Implements IExtensibleDataObject
public ref class Credentials : IExtensibleDataObject
DoubleTake.Common.Contract.Credentials = function();

Type.createClass(
    'DoubleTake.Common.Contract.Credentials',
    null,
    IExtensibleDataObject);

The Credentials type exposes the following members.

Constructors
 | Name | Description
Public method | Credentials | Initializes a new instance of the Credentials class.
Public method | Credentials(NetworkCredential) | Initializes a new instance of the Credentials class.
Public method | Credentials(String, String, String) |
Top
Properties
 | Name | Description
Public property | Domain | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Password | This value is the password.
Public property | UserName | This value is the name of the user.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
Operators
Name | Description
(Credentials to NetworkCredential) | Performs an implicit conversion from Credentials to NetworkCredential.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Credentials Constructor

Overload List
 | Name | Description
Public method | Credentials | Initializes a new instance of the Credentials class.
Public method | Credentials(NetworkCredential) | Initializes a new instance of the Credentials class.
Public method | Credentials(String, String, String) |
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Constructor

Initializes a new instance of the Credentials class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials()
Public Sub New
public:
Credentials()
DoubleTake.Common.Contract.Credentials = function();
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Constructor (NetworkCredential)

Initializes a new instance of the Credentials class.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials(
    NetworkCredential credentials
)
Public Sub New (
    credentials As NetworkCredential
)
public:
Credentials(
    NetworkCredential^ credentials
)
DoubleTake.Common.Contract.Credentials = function(credentials);

Parameters

credentials
Type: System.NetNetworkCredential
The credentials.
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Constructor (String, String, String)

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials(
    string userName,
    string password,
    string domain
)
Public Sub New (
    userName As String,
    password As String,
    domain As String
)
public:
Credentials(
    String^ userName,
    String^ password,
    String^ domain
)
DoubleTake.Common.Contract.Credentials = function(userName, password, domain);

Parameters

userName
Type: SystemString
password
Type: SystemString
domain
Type: SystemString
See Also

Reference

Credentials Class
Credentials Overload
DoubleTake.Common.Contract Namespace


Credentials Properties

The Credentials type exposes the following members.

Properties
 | Name | Description
Public property | Domain | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Password | This value is the password.
Public property | UserName | This value is the name of the user.
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.Domain Property

CredentialsDomain Property

This value is the name of the domain.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
function get_Domain();
function set_Domain(value);

Property Value

Type: String
The domain.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.ExtensionData Property

CredentialsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.Password Property

CredentialsPassword Property

This value is the password.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
function get_Password();
function set_Password(value);

Property Value

Type: String
The password.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.UserName Property

CredentialsUserName Property

This value is the name of the user.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
function get_UserName();
function set_UserName(value);

Property Value

Type: String
The user name.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Methods

The Credentials type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.GetDeserializedObject Method

CredentialsGetDeserializedObject Method

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials.GetObjectToSerialize Method

CredentialsGetObjectToSerialize Method

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Type Conversions

The Credentials type exposes the following members.

Operators
Name | Description
(Credentials to NetworkCredential) | Performs an implicit conversion from Credentials to NetworkCredential.
Top
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


Credentials Implicit Conversion (Credentials to NetworkCredential)

Credentials Conversion (Credentials to NetworkCredential)

Performs an implicit conversion from Credentials to NetworkCredential.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static implicit operator NetworkCredential (
    Credentials credentials
)
Public Shared Widening Operator CType (
    credentials As Credentials
) As NetworkCredential
static implicit operator NetworkCredential^ (
    Credentials^ credentials
)
JavaScript does not support the declaration of new casting operators.

Parameters

credentials
Type: DoubleTake.Common.ContractCredentials
The credentials.

Return Value

Type: NetworkCredential
The result of the conversion.
See Also

Reference

Credentials Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions Class

Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractEmailNotificationOptions

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class EmailNotificationOptions : IExtensibleDataObject
Public Class EmailNotificationOptions
    Implements IExtensibleDataObject
public ref class EmailNotificationOptions : IExtensibleDataObject
DoubleTake.Common.Contract.EmailNotificationOptions = function();

Type.createClass(
    'DoubleTake.Common.Contract.EmailNotificationOptions',
    null,
    IExtensibleDataObject);

The EmailNotificationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationOptions |
Top
Properties
 | Name | Description
Public property | ConnectionSecurity | This value represents the SMTP server connection security.
Public property | Enabled | This value is true if email notification is enabled; otherwise, it is false.
Public property | EntryIdFilter | This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.
Public property | EntryTypeFilter | This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | From | This value is the e-mail address that will be placed in the From field of the email message.
Public property | IncludeEventDescriptionInSubject | This value is true if the event description is included in the email subject; otherwise, it is false.
Public property | LoginToSmtpServer | This value is true if you must log in to the SMTP server; otherwise, it is false.
Public property | SmtpCredentials | This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.
Public property | SmtpPort | This value is the SMTP port. The default port is 25.
Public property | SmtpServer | This value is the name of the SMTP server.
Public property | SubjectPrefix | This value is the text that will be added to the beginning of the email subject.
Public property | To | This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


EmailNotificationOptions Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EmailNotificationOptions()
Public Sub New
public:
EmailNotificationOptions()
DoubleTake.Common.Contract.EmailNotificationOptions = function();
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions Properties

The EmailNotificationOptions type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionSecurity | This value represents the SMTP server connection security.
Public property | Enabled | This value is true if email notification is enabled; otherwise, it is false.
Public property | EntryIdFilter | This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.
Public property | EntryTypeFilter | This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | From | This value is the e-mail address that will be placed in the From field of the email message.
Public property | IncludeEventDescriptionInSubject | This value is true if the event description is included in the email subject; otherwise, it is false.
Public property | LoginToSmtpServer | This value is true if you must log in to the SMTP server; otherwise, it is false.
Public property | SmtpCredentials | This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.
Public property | SmtpPort | This value is the SMTP port. The default port is 25.
Public property | SmtpServer | This value is the name of the SMTP server.
Public property | SubjectPrefix | This value is the text that will be added to the beginning of the email subject.
Public property | To | This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.
Top
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.ConnectionSecurity Property

EmailNotificationOptionsConnectionSecurity Property

This value represents the SMTP server connection security.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SmtpConnectionSecurity ConnectionSecurity { get; set; }
Public Property ConnectionSecurity As SmtpConnectionSecurity
    Get
    Set
public:
property SmtpConnectionSecurity ConnectionSecurity {
    SmtpConnectionSecurity get ();
    void set (SmtpConnectionSecurity value);
}
function get_ConnectionSecurity();
function set_ConnectionSecurity(value);

Property Value

Type: SmtpConnectionSecurity
Connection security
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.Enabled Property

EmailNotificationOptionsEnabled Property

This value is true if email notification is enabled; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
function get_Enabled();
function set_Enabled(value);

Property Value

Type: Boolean
if enabled; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.EntryIdFilter Property

EmailNotificationOptionsEntryIdFilter Property

This value is one or more comma-delimited Windows Event Log entry IDs for which email notifications should be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string EntryIdFilter { get; set; }
Public Property EntryIdFilter As String
    Get
    Set
public:
property String^ EntryIdFilter {
    String^ get ();
    void set (String^ value);
}
function get_EntryIdFilter();
function set_EntryIdFilter(value);

Property Value

Type: String
The entry id filter.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.EntryTypeFilter Property

EmailNotificationOptionsEntryTypeFilter Property

This value is one or more comma-delimited Windows Event Log entry types (error, warning, or information) for which email notifications should be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string EntryTypeFilter { get; set; }
Public Property EntryTypeFilter As String
    Get
    Set
public:
property String^ EntryTypeFilter {
    String^ get ();
    void set (String^ value);
}
function get_EntryTypeFilter();
function set_EntryTypeFilter(value);

Property Value

Type: String
The entry type filter.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.ExtensionData Property

EmailNotificationOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.From Property

EmailNotificationOptionsFrom Property

This value is the e-mail address that will be placed in the From field of the email message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string From { get; set; }
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
function get_From();
function set_From(value);

Property Value

Type: String
An e-mail address that will be placed in the From field of the e-mail message.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.IncludeEventDescriptionInSubject Property

EmailNotificationOptionsIncludeEventDescriptionInSubject Property

This value is true if the event description is included in the email subject; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IncludeEventDescriptionInSubject { get; set; }
Public Property IncludeEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IncludeEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
function get_IncludeEventDescriptionInSubject();
function set_IncludeEventDescriptionInSubject(value);

Property Value

Type: Boolean
if the event description is to be included in the subject; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.LoginToSmtpServer Property

EmailNotificationOptionsLoginToSmtpServer Property

This value is true if you must log in to the SMTP server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool LoginToSmtpServer { get; set; }
Public Property LoginToSmtpServer As Boolean
    Get
    Set
public:
property bool LoginToSmtpServer {
    bool get ();
    void set (bool value);
}
function get_LoginToSmtpServer();
function set_LoginToSmtpServer(value);

Property Value

Type: Boolean
to login to the SMTP server; otherwise, .
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpCredentials Property

EmailNotificationOptionsSmtpCredentials Property

This value represents the credentials used to log into the SMTP server. Do not set this value if you want to user the SMTP server anonymously.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials SmtpCredentials { get; set; }
Public Property SmtpCredentials As Credentials
    Get
    Set
public:
property Credentials^ SmtpCredentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_SmtpCredentials();
function set_SmtpCredentials(value);

Property Value

Type: Credentials
The SMTP credentials.
Remarks
Set this value to if you would like to use the SMTP server anonymously.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpPort Property

EmailNotificationOptionsSmtpPort Property

This value is the SMTP port. The default port is 25.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> SmtpPort { get; set; }
Public Property SmtpPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SmtpPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_SmtpPort();
function set_SmtpPort(value);

Property Value

Type: Nullable Int32
The SMTP port.
Remarks
Set this property to to use the default SMTP port (25).
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SmtpServer Property

EmailNotificationOptionsSmtpServer Property

This value is the name of the SMTP server.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}
function get_SmtpServer();
function set_SmtpServer(value);

Property Value

Type: String
The SMTP server.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.SubjectPrefix Property

EmailNotificationOptionsSubjectPrefix Property

This value is the text that will be added to the beginning of the email subject.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
function get_SubjectPrefix();
function set_SubjectPrefix(value);

Property Value

Type: String
The subject prefix.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EmailNotificationOptions.To Property

EmailNotificationOptionsTo Property

This value can contain one or more comma-delimited e-mail addresses to which the email notifications will be sent.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
function get_To();
function set_To(value);

Property Value

Type: String
A string containing one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent.
See Also

Reference

EmailNotificationOptions Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2 Class

Represents an entry in the Windows event log.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractEventLogEntryData2

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class EventLogEntryData2 : IExtensibleDataObject
Public Class EventLogEntryData2
    Implements IExtensibleDataObject
public ref class EventLogEntryData2 : IExtensibleDataObject
DoubleTake.Common.Contract.EventLogEntryData2 = function();

Type.createClass(
    'DoubleTake.Common.Contract.EventLogEntryData2',
    null,
    IExtensibleDataObject);

The EventLogEntryData2 type exposes the following members.

Constructors
 | Name | Description
Public method | EventLogEntryData2 |
Top
Properties
 | Name | Description
Public property | Category | This value is the text associated with the CategoryNumber.
Public property | CategoryNumber | This value is the category number of the event.
Public property | EntryType | This value is the type of event.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Index | This value is the index of this event in the event log.
Public property | InstanceId | The value is a resource identifier that designates the message text for the event.
Public property | MachineName | This value is the name of the server that generated the event.
Public property | Message | This value is the localized event message.
Public property | ReplacementStrings | This value includes any replacement strings associated with the event.
Public property | Source | This value is the name of the application that generated the event.
Public property | TimeGenerated | This value is the local time when the event was generated.
Public property | TimeWritten | This value is the local time when the event was written to the event log.
Public property | UserName | This value is the name of the user that generated the event.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


EventLogEntryData2 Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EventLogEntryData2()
Public Sub New
public:
EventLogEntryData2()
DoubleTake.Common.Contract.EventLogEntryData2 = function();
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2 Properties

The EventLogEntryData2 type exposes the following members.

Properties
 | Name | Description
Public property | Category | This value is the text associated with the CategoryNumber.
Public property | CategoryNumber | This value is the category number of the event.
Public property | EntryType | This value is the type of event.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Index | This value is the index of this event in the event log.
Public property | InstanceId | The value is a resource identifier that designates the message text for the event.
Public property | MachineName | This value is the name of the server that generated the event.
Public property | Message | This value is the localized event message.
Public property | ReplacementStrings | This value includes any replacement strings associated with the event.
Public property | Source | This value is the name of the application that generated the event.
Public property | TimeGenerated | This value is the local time when the event was generated.
Public property | TimeWritten | This value is the local time when the event was written to the event log.
Public property | UserName | This value is the name of the user that generated the event.
Top
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.Category Property

EventLogEntryData2Category Property

This value is the text associated with the CategoryNumber.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
function get_Category();
function set_Category(value);

Property Value

Type: String
The text associated with the [P:CategoryNumber] for this entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.CategoryNumber Property

EventLogEntryData2CategoryNumber Property

This value is the category number of the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public short CategoryNumber { get; set; }
Public Property CategoryNumber As Short
    Get
    Set
public:
property short CategoryNumber {
    short get ();
    void set (short value);
}
function get_CategoryNumber();
function set_CategoryNumber(value);

Property Value

Type: Int16
The category number of the event log entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.EntryType Property

EventLogEntryData2EntryType Property

This value is the type of event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EventLogEntryType EntryType { get; set; }
Public Property EntryType As EventLogEntryType
    Get
    Set
public:
property EventLogEntryType EntryType {
    EventLogEntryType get ();
    void set (EventLogEntryType value);
}
function get_EntryType();
function set_EntryType(value);

Property Value

Type: EventLogEntryType
The event type of this entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.ExtensionData Property

EventLogEntryData2ExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.Index Property

EventLogEntryData2Index Property

This value is the index of this event in the event log.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
function get_Index();
function set_Index(value);

Property Value

Type: Int32
The index of this entry in the event log.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.InstanceId Property

EventLogEntryData2InstanceId Property

The value is a resource identifier that designates the message text for the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long InstanceId { get; set; }
Public Property InstanceId As Long
    Get
    Set
public:
property long long InstanceId {
    long long get ();
    void set (long long value);
}
function get_InstanceId();
function set_InstanceId(value);

Property Value

Type: Int64
The resource identifier that designates the message text of the event entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.MachineName Property

EventLogEntryData2MachineName Property

This value is the name of the server that generated the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
function get_MachineName();
function set_MachineName(value);

Property Value

Type: String
The name of the computer on which this entry was generated.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.Message Property

EventLogEntryData2Message Property

This value is the localized event message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
function get_Message();
function set_Message(value);

Property Value

Type: String
The localized message associated with this event entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.ReplacementStrings Property

EventLogEntryData2ReplacementStrings Property

This value includes any replacement strings associated with the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ReplacementStrings { get; set; }
Public Property ReplacementStrings As String()
    Get
    Set
public:
property array<String^>^ ReplacementStrings {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ReplacementStrings();
function set_ReplacementStrings(value);

Property Value

Type: String
The replacement strings associated with the event log entry.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.Source Property

EventLogEntryData2Source Property

This value is the name of the application that generated the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
function get_Source();
function set_Source(value);

Property Value

Type: String
The name of the application that generated this event.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.TimeGenerated Property

EventLogEntryData2TimeGenerated Property

This value is the local time when the event was generated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimeGenerated { get; set; }
Public Property TimeGenerated As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeGenerated {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimeGenerated();
function set_TimeGenerated(value);

Property Value

Type: DateTimeOffset
The local time at which this event was generated.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.TimeWritten Property

EventLogEntryData2TimeWritten Property

This value is the local time when the event was written to the event log.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimeWritten { get; set; }
Public Property TimeWritten As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeWritten {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimeWritten();
function set_TimeWritten(value);

Property Value

Type: DateTimeOffset
The local time at which this event was written to the log.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


EventLogEntryData2.UserName Property

EventLogEntryData2UserName Property

This value is the name of the user that generated the event.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
function get_UserName();
function set_UserName(value);

Property Value

Type: String
The name of the user who is responsible for this event.
See Also

Reference

EventLogEntryData2 Class
DoubleTake.Common.Contract Namespace


FileSystemAttributes Enumeration

Describes the attributes of a file system item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FileSystemAttributes
Public Enumeration FileSystemAttributes
public enum class FileSystemAttributes
DoubleTake.Common.Contract.FileSystemAttributes = function();
DoubleTake.Common.Contract.FileSystemAttributes.createEnum('DoubleTake.Common.Contract.FileSystemAttributes', false);
Members
Member name | Value | Description
ReadOnly | 1 | The file system item is read-only.
Hidden | 2 | The file system item is hidden.
System | 4 | The file system item is a system item.
Directory | 16 | The file system item is a directory.
Archive | 32 | The file system item is marked to be archived.
Normal | 128 | The file system item is normal.
Temporary | 256 | The file system item is temporary.
SparseFile | 512 | The file system item is a sparse file.
ReparsePoint | 1024 | The file system item is a reparse point.
Compressed | 2048 | The file system item is compressed.
Offline | 4096 | The file system item is offline.
NotContentIndexed | 8192 | The file system item is not content indexed.
Encrypted | 16384 | The file system item is encrypted.
See Also

Reference

DoubleTake.Common.Contract Namespace


InclusionMode Enumeration

Indicates whether a certain data path in a workload should be replicated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum InclusionMode
Public Enumeration InclusionMode
public enum class InclusionMode
DoubleTake.Common.Contract.InclusionMode = function();
DoubleTake.Common.Contract.InclusionMode.createEnum('DoubleTake.Common.Contract.InclusionMode', false);
Members
Member name | Value | Description
Include | 0 | The data path is included in replication.
Exclude | 1 | The data path is excluded from replication.
See Also

Reference

DoubleTake.Common.Contract Namespace


LogicalItem Class

Represents an item that can be protected in workload. Logical items are meaningful to the user outside of a specific file system item.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractLogicalItem

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class LogicalItem : IExtensibleDataObject
Public Class LogicalItem
    Implements IExtensibleDataObject
public ref class LogicalItem : IExtensibleDataObject
DoubleTake.Common.Contract.LogicalItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.LogicalItem',
    null,
    IExtensibleDataObject);

The LogicalItem type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalItem |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | Gets or sets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. Typically this name is displayed in the user interface.
Public property | PartitionName | Gets or sets the partition name for this item.
Public property | Path | Gets or sets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Public property | SaturationDefault | This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


LogicalItem Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalItem()
Public Sub New
public:
LogicalItem()
DoubleTake.Common.Contract.LogicalItem = function();
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem Properties

The LogicalItem type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | Gets or sets a value indicating whether this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. Typically this name is displayed in the user interface.
Public property | PartitionName | Gets or sets the partition name for this item.
Public property | Path | Gets or sets the path that unique identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.
Public property | SaturationDefault | This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.ExtensionData Property

LogicalItemExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.IsContainer Property

LogicalItemIsContainer Property

Gets or sets a value indicating whether this item is a container of other items.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
virtual property bool IsContainer {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsContainer();
function set_IsContainer(value);

Property Value

Type: Boolean
if this item is a container; otherwise, .
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.IsReadOnly Property

LogicalItemIsReadOnly Property

Gets or sets a value indicating whether this item is read only; that is, its [P:Saturation] cannot be changed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this item is read only; otherwise, .
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.ItemType Property

LogicalItemItemType Property

Gets or sets the type of this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
virtual property String^ ItemType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_ItemType();
function set_ItemType(value);

Property Value

Type: String
The type of this item.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Metadata Property

LogicalItemMetadata Property

This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
This property is used to specify any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but one must be able to determine the format and decipher the metadata based on the type.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Name Property

LogicalItemName Property

Gets or sets the name of this item. Typically this name is displayed in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this item.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.PartitionName Property

LogicalItemPartitionName Property

Gets or sets the partition name for this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PartitionName { get; set; }
Public Property PartitionName As String
    Get
    Set
public:
virtual property String^ PartitionName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_PartitionName();
function set_PartitionName(value);

Property Value

Type: String
The partition name of this item.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Path Property

LogicalItemPath Property

Gets or sets the path that unique identifies this item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of this item.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.Saturation Property

LogicalItemSaturation Property

Gets or sets the saturation level of this item. Typically this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
virtual property SaturationLevel Saturation {
    SaturationLevel get () sealed;
    void set (SaturationLevel value) sealed;
}
function get_Saturation();
function set_Saturation(value);

Property Value

Type: SaturationLevel
The saturation level.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogicalItem.SaturationDefault Property

LogicalItemSaturationDefault Property

This value is the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel SaturationDefault { get; set; }
Public Property SaturationDefault As SaturationLevel
    Get
    Set
public:
property SaturationLevel SaturationDefault {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
function get_SaturationDefault();
function set_SaturationDefault(value);

Property Value

Type: SaturationLevel
The default saturation level.
See Also

Reference

LogicalItem Class
DoubleTake.Common.Contract Namespace


LogMessage Class

Represents a message in the engine or management service text log file.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractLogMessage

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class LogMessage : IExtensibleDataObject
Public Class LogMessage
    Implements IExtensibleDataObject
public ref class LogMessage : IExtensibleDataObject
DoubleTake.Common.Contract.LogMessage = function();

Type.createClass(
    'DoubleTake.Common.Contract.LogMessage',
    null,
    IExtensibleDataObject);

The LogMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessage |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hash | This value is the message hash which is used to differentiate messages written with the same Timestamp.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Source | This value identifies the service (Double-Take or Double-Take Management Service) that generated the log message.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


LogMessage Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogMessage()
Public Sub New
public:
LogMessage()
DoubleTake.Common.Contract.LogMessage = function();
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage Properties

The LogMessage type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hash | This value is the message hash which is used to differentiate messages written with the same Timestamp.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Source | This value identifies the service (Double-Take or Double-Take Management Service) that generated the log message.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.ExtensionData Property

LogMessageExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Hash Property

LogMessageHash Property

This value is the message hash which is used to differentiate messages written with the same Timestamp.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Hash { get; set; }
Public Property Hash As Integer
    Get
    Set
public:
property int Hash {
    int get ();
    void set (int value);
}
function get_Hash();
function set_Hash(value);

Property Value

Type: Int32
The hash.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Id Property

LogMessageId Property

This value is the message ID.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Int32
The message id.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.MessageType Property

LogMessageMessageType Property

This value is the type of log message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MessageType { get; set; }
Public Property MessageType As Integer
    Get
    Set
public:
property int MessageType {
    int get ();
    void set (int value);
}
function get_MessageType();
function set_MessageType(value);

Property Value

Type: Int32
The message type.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.ProcessId Property

LogMessageProcessId Property

This value is the process ID of the process that generated the message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ProcessId { get; set; }
Public Property ProcessId As Integer
    Get
    Set
public:
property int ProcessId {
    int get ();
    void set (int value);
}
function get_ProcessId();
function set_ProcessId(value);

Property Value

Type: Int32
The process id of the process that generated this message.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Sequence Property

LogMessageSequence Property

This value is the sequence number of this message in the log file.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
function get_Sequence();
function set_Sequence(value);

Property Value

Type: Int32
The message's sequence number within the log file.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Source Property

LogMessageSource Property

This value identifies the service (Double-Take or Double-Take Management Service) that generated the log message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
function get_Source();
function set_Source(value);

Property Value

Type: String
The log file source.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Text Property

LogMessageText Property

This value is the content of the log message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
function get_Text();
function set_Text(value);

Property Value

Type: String
The descriptive portion of the message.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.ThreadId Property

LogMessageThreadId Property

This value is the thread ID of the thread that generated the message.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
function get_ThreadId();
function set_ThreadId(value);

Property Value

Type: Int32
The thread id of the thread that generated this message.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.Timestamp Property

LogMessageTimestamp Property

This value is the local time when the message was generated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTime
The local time when this message was generated.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


LogMessage.TimestampOffset Property

LogMessageTimestampOffset Property

This value is the relative UTC time when the message was generated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimestampOffset { get; set; }
Public Property TimestampOffset As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimestampOffset {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimestampOffset();
function set_TimestampOffset(value);

Property Value

Type: DateTimeOffset
The time when this message was generated, relative to UTC.
See Also

Reference

LogMessage Class
DoubleTake.Common.Contract Namespace


PathTransformation Class

Represents a transform path for a replication rule.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPathTransformation

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class PathTransformation : IExtensibleDataObject
Public NotInheritable Class PathTransformation
    Implements IExtensibleDataObject
public ref class PathTransformation sealed : IExtensibleDataObject
DoubleTake.Common.Contract.PathTransformation = function();

Type.createClass(
    'DoubleTake.Common.Contract.PathTransformation',
    null,
    IExtensibleDataObject);

The PathTransformation type exposes the following members.

Constructors
 | Name | Description
Public method | PathTransformation |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourcePath | This value is the path on the source.
Public property | TargetPath | This value is the path on the target.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PathTransformation Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation()
Public Sub New
public:
PathTransformation()
DoubleTake.Common.Contract.PathTransformation = function();
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation Properties

The PathTransformation type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourcePath | This value is the path on the source.
Public property | TargetPath | This value is the path on the target.
Top
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.ExtensionData Property

PathTransformationExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.SourcePath Property

PathTransformationSourcePath Property

This value is the path on the source.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePath { get; set; }
Public Property SourcePath As String
    Get
    Set
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}
function get_SourcePath();
function set_SourcePath(value);

Property Value

Type: String
The source path.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.TargetPath Property

PathTransformationTargetPath Property

This value is the path on the target.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
function get_TargetPath();
function set_TargetPath(value);

Property Value

Type: String
The target path.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation Methods

The PathTransformation type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.Clone Method

PathTransformationClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PathTransformation.ToString Method

PathTransformationToString Method

Returns a String that represents this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PathTransformation Class
DoubleTake.Common.Contract Namespace


PhysicalItem Class

Represents an item that can be protected in workload. Physical items map directly to file system items.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalItem : IExtensibleDataObject
Public Class PhysicalItem
    Implements IExtensibleDataObject
public ref class PhysicalItem : IExtensibleDataObject
DoubleTake.Common.Contract.PhysicalItem = function();

Type.createClass(
    'DoubleTake.Common.Contract.PhysicalItem',
    null,
    IExtensibleDataObject);

The PhysicalItem type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalItem |
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes.
Public property | CreationTime | This value is the time when the item was created.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.
Public property | ItemType | This value is the type of item.
Public property | LastAccessTime | This value is the time when the item was last accessed.
Public property | LastWriteTime | This value is the time when the item was last written to.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface.
Public property | PartitionName | This value is the partition name of the item.
Public property | Path | This value is the path of the item.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | This value is the physical size of the item.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PhysicalItem Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalItem()
Public Sub New
public:
PhysicalItem()
DoubleTake.Common.Contract.PhysicalItem = function();
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem Properties

The PhysicalItem type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes.
Public property | CreationTime | This value is the time when the item was created.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false.
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.
Public property | ItemType | This value is the type of item.
Public property | LastAccessTime | This value is the time when the item was last accessed.
Public property | LastWriteTime | This value is the time when the item was last written to.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface.
Public property | PartitionName | This value is the partition name of the item.
Public property | Path | This value is the path of the item.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | This value is the physical size of the item.
Top
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Attributes Property

PhysicalItemAttributes Property

This value represents the file system attributes.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<FileSystemAttributes> Attributes { get; set; }
Public Property Attributes As Nullable(Of FileSystemAttributes)
    Get
    Set
public:
property Nullable<FileSystemAttributes> Attributes {
    Nullable<FileSystemAttributes> get ();
    void set (Nullable<FileSystemAttributes> value);
}
function get_Attributes();
function set_Attributes(value);

Property Value

Type: Nullable FileSystemAttributes
The FileSystemAttributes of this item, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.CreationTime Property

PhysicalItemCreationTime Property

This value is the time when the item was created.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> CreationTime { get; set; }
Public Property CreationTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_CreationTime();
function set_CreationTime(value);

Property Value

Type: Nullable DateTime
The time this item was created, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.ExtensionData Property

PhysicalItemExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.IsContainer Property

PhysicalItemIsContainer Property

This value is true if the item is a container of other items; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
virtual property bool IsContainer {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsContainer();
function set_IsContainer(value);

Property Value

Type: Boolean
if this item is a container; otherwise, .
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.IsReadOnly Property

PhysicalItemIsReadOnly Property

This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
virtual property bool IsReadOnly {
    bool get () sealed;
    void set (bool value) sealed;
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this item is read only; otherwise, .
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.ItemType Property

PhysicalItemItemType Property

This value is the type of item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
virtual property String^ ItemType {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_ItemType();
function set_ItemType(value);

Property Value

Type: String
The type of this item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.LastAccessTime Property

PhysicalItemLastAccessTime Property

This value is the time when the item was last accessed.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> LastAccessTime { get; set; }
Public Property LastAccessTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_LastAccessTime();
function set_LastAccessTime(value);

Property Value

Type: Nullable DateTime
The time this item was last accessed, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.LastWriteTime Property

PhysicalItemLastWriteTime Property

This value is the time when the item was last written to.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> LastWriteTime { get; set; }
Public Property LastWriteTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastWriteTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_LastWriteTime();
function set_LastWriteTime(value);

Property Value

Type: Nullable DateTime
The time this item was last written to, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace
DateTime


PhysicalItem.Metadata Property

PhysicalItemMetadata Property

This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
This property is used to specify any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but one must be able to determine the format and decipher the metadata based on the type.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Name Property

PhysicalItemName Property

This value is the name of the item. Typically, this name is used for display in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.PartitionName Property

PhysicalItemPartitionName Property

This value is the partition name of the item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PartitionName { get; set; }
Public Property PartitionName As String
    Get
    Set
public:
virtual property String^ PartitionName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_PartitionName();
function set_PartitionName(value);

Property Value

Type: String
The partition name of this item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Path Property

PhysicalItemPath Property

This value is the path of the item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
virtual property String^ Path {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of this item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Saturation Property

PhysicalItemSaturation Property

This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
virtual property SaturationLevel Saturation {
    SaturationLevel get () sealed;
    void set (SaturationLevel value) sealed;
}
function get_Saturation();
function set_Saturation(value);

Property Value

Type: SaturationLevel
The saturation level.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalItem.Size Property

PhysicalItemSize Property

This value is the physical size of the item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<long> Size { get; set; }
Public Property Size As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Size {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
function get_Size();
function set_Size(value);

Property Value

Type: Nullable Int64
The physical size of the item, or if this property does not apply to this type of item.
See Also

Reference

PhysicalItem Class
DoubleTake.Common.Contract Namespace


PhysicalRule Class

Defines a physical rule for replicating data.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalRule

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalRule : IExtensibleDataObject
Public Class PhysicalRule
    Implements IExtensibleDataObject
public ref class PhysicalRule : IExtensibleDataObject
DoubleTake.Common.Contract.PhysicalRule = function();

Type.createClass(
    'DoubleTake.Common.Contract.PhysicalRule',
    null,
    IExtensibleDataObject);

The PhysicalRule type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRule |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Inclusion | This value represents if the rule will be included in or excluded from replication.
Public property | IsReadOnly | This value is true if the rule is read-only; otherwise, it is false.
Public property | Metadata | This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
Public property | Path | This value is the path of the data to be replicated.
Public property | Recursion | This value represents if the rule will be applied to this path only or to all children of the path as well.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


PhysicalRule Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule()
Public Sub New
public:
PhysicalRule()
DoubleTake.Common.Contract.PhysicalRule = function();
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule Properties

The PhysicalRule type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Inclusion | This value represents if the rule will be included in or excluded from replication.
Public property | IsReadOnly | This value is true if the rule is read-only; otherwise, it is false.
Public property | Metadata | This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
Public property | Path | This value is the path of the data to be replicated.
Public property | Recursion | This value represents if the rule will be applied to this path only or to all children of the path as well.
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.ExtensionData Property

PhysicalRuleExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Inclusion Property

PhysicalRuleInclusion Property

This value represents if the rule will be included in or excluded from replication.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public InclusionMode Inclusion { get; set; }
Public Property Inclusion As InclusionMode
    Get
    Set
public:
property InclusionMode Inclusion {
    InclusionMode get ();
    void set (InclusionMode value);
}
function get_Inclusion();
function set_Inclusion(value);

Property Value

Type: InclusionMode
The inclusion mode.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.IsReadOnly Property

PhysicalRuleIsReadOnly Property

This value is true if the rule is read-only; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
function get_IsReadOnly();
function set_IsReadOnly(value);

Property Value

Type: Boolean
if this rule is read only; otherwise, .
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Metadata Property

PhysicalRuleMetadata Property

This value is any additional metadata for the rule. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
function get_Metadata();
function set_Metadata(value);

Property Value

Type: String
The metadata.
Remarks
Use this property to store additional rule information. This property can be used by specialized workload implementations to provide additional hints to the job-creation process.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Path Property

PhysicalRulePath Property

This value is the path of the data to be replicated.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path of the data to be replicated.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Recursion Property

PhysicalRuleRecursion Property

This value represents if the rule will be applied to this path only or to all children of the path as well.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RecursionMode Recursion { get; set; }
Public Property Recursion As RecursionMode
    Get
    Set
public:
property RecursionMode Recursion {
    RecursionMode get ();
    void set (RecursionMode value);
}
function get_Recursion();
function set_Recursion(value);

Property Value

Type: RecursionMode
The recursion mode.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule Methods

The PhysicalRule type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Clone Method

PhysicalRuleClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method

PhysicalRuleEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(PhysicalRule) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method (Object)

PhysicalRuleEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

PhysicalRule Class
Equals Overload
DoubleTake.Common.Contract Namespace


PhysicalRule.Equals Method (PhysicalRule)

PhysicalRuleEquals Method (PhysicalRule)

Indicates whether the current object is equal to another object of the same type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Equals(
    PhysicalRule other
)
Public Function Equals (
    other As PhysicalRule
) As Boolean
public:
virtual bool Equals(
    PhysicalRule^ other
) sealed
function Equals(other);

Parameters

other
Type: DoubleTake.Common.ContractPhysicalRule
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .
See Also

Reference

PhysicalRule Class
Equals Overload
DoubleTake.Common.Contract Namespace


PhysicalRule.GetHashCode Method

PhysicalRuleGetHashCode Method

Returns a hash code for this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


PhysicalRule.ToString Method

PhysicalRuleToString Method

Returns a String that represents this instance.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PhysicalRule Class
DoubleTake.Common.Contract Namespace


RecursionMode Enumeration

Indicates whether recursion is used when replicating a data path.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum RecursionMode
Public Enumeration RecursionMode
public enum class RecursionMode
DoubleTake.Common.Contract.RecursionMode = function();
DoubleTake.Common.Contract.RecursionMode.createEnum('DoubleTake.Common.Contract.RecursionMode', false);
Members
Member name | Value | Description
Recursive | 0 | The physical rule will be applied to this path and all of its children paths.
NonRecursive | 1 | The physical rule will be applied to this path only.
See Also

Reference

DoubleTake.Common.Contract Namespace


SaturationLevel Enumeration

Indicates the saturation level of a protectable item.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum SaturationLevel
Public Enumeration SaturationLevel
public enum class SaturationLevel
DoubleTake.Common.Contract.SaturationLevel = function();
DoubleTake.Common.Contract.SaturationLevel.createEnum('DoubleTake.Common.Contract.SaturationLevel', false);
Members
Member name | Value | Description
Unknown | 0 | The saturation level is unknown.
None | 1 | The item will not be replicated.
Partial | 2 | Some, but not all, of the item will be replicated.
Full | 3 | The item and all of its children (if a container) will be replicated.
Error | 4 | An error occurred while calculating the saturation for the item.
See Also

Reference

DoubleTake.Common.Contract Namespace


SmtpConnectionSecurity Enumeration

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum SmtpConnectionSecurity
Public Enumeration SmtpConnectionSecurity
public enum class SmtpConnectionSecurity
DoubleTake.Common.Contract.SmtpConnectionSecurity = function();
DoubleTake.Common.Contract.SmtpConnectionSecurity.createEnum('DoubleTake.Common.Contract.SmtpConnectionSecurity', false);
Members
Member name | Value | Description
Plain | 0 | The security is plain.
SSL | 1 | The security is Secure Sockets Layer.
TLS | 2 | The security is Transport Layer Security.
See Also

Reference

DoubleTake.Common.Contract Namespace


Volume Class

Represents a volume on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class Volume : PhysicalItem
Public Class Volume
    Inherits PhysicalItem
public ref class Volume : public PhysicalItem
DoubleTake.Common.Contract.Volume = function();

Type.createClass(
    'DoubleTake.Common.Contract.Volume',
    DoubleTake.Common.Contract.PhysicalItem);

The Volume type exposes the following members.

Constructors
 | Name | Description
Public method | Volume | This value is true if the volume is a container of other volumes; otherwise, it is false.
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume.
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DriveFormat | This value is the file system format of the volume.
Public property | DriveType | This value is the drive type.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported.
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false.
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume.
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume.
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume.
Public property | VolumeType | This value is the type of volume.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Volume Constructor

This value is true if the volume is a container of other volumes; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Volume()
Public Sub New
public:
Volume()
DoubleTake.Common.Contract.Volume = function();
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume Properties

The Volume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume.
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DriveFormat | This value is the file system format of the volume.
Public property | DriveType | This value is the drive type.
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported.
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false.
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume.
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume.
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume.
Public property | VolumeType | This value is the type of volume.
Top
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.AvailableFreeSpace Property

VolumeAvailableFreeSpace Property

This value is the amount of free space on the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long AvailableFreeSpace { get; set; }
Public Property AvailableFreeSpace As Long
    Get
    Set
public:
property long long AvailableFreeSpace {
    long long get ();
    void set (long long value);
}
function get_AvailableFreeSpace();
function set_AvailableFreeSpace(value);

Property Value

Type: Int64
The available free space on this volume.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.DriveFormat Property

VolumeDriveFormat Property

This value is the file system format of the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveFormat { get; set; }
Public Property DriveFormat As String
    Get
    Set
public:
property String^ DriveFormat {
    String^ get ();
    void set (String^ value);
}
function get_DriveFormat();
function set_DriveFormat(value);

Property Value

Type: String
The format of the drive.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.DriveType Property

VolumeDriveType Property

This value is the drive type.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DriveType DriveType { get; set; }
Public Property DriveType As DriveType
    Get
    Set
public:
property DriveType DriveType {
    DriveType get ();
    void set (DriveType value);
}
function get_DriveType();
function set_DriveType(value);

Property Value

Type: DriveType
The type of the drive.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.IsSupported Property

VolumeIsSupported Property

Whether or not this volume is supported.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSupported { get; set; }
Public Property IsSupported As Boolean
    Get
    Set
public:
property bool IsSupported {
    bool get ();
    void set (bool value);
}
function get_IsSupported();
function set_IsSupported(value);

Property Value

Type: Boolean
if this volume is supported; otherwise, .
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.IsSystemDrive Property

VolumeIsSystemDrive Property

This value is true if the volume is the system volume; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSystemDrive { get; set; }
Public Property IsSystemDrive As Boolean
    Get
    Set
public:
property bool IsSystemDrive {
    bool get ();
    void set (bool value);
}
function get_IsSystemDrive();
function set_IsSystemDrive(value);

Property Value

Type: Boolean
if this volume is the system drive; otherwise, .
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.Label Property

VolumeLabel Property

This value is the label assigned to the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
function get_Label();
function set_Label(value);

Property Value

Type: String
The volume label.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.ShortNameBehavior Property

VolumeShortNameBehavior Property

Gets or sets a value indicating the Short Name Behavior for this volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShortNameBehavior { get; set; }
Public Property ShortNameBehavior As Boolean
    Get
    Set
public:
property bool ShortNameBehavior {
    bool get ();
    void set (bool value);
}
function get_ShortNameBehavior();
function set_ShortNameBehavior(value);

Property Value

Type: Boolean
enabled = 0, disabled = 1
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.TotalSize Property

VolumeTotalSize Property

This value is the total size of the volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalSize { get; set; }
Public Property TotalSize As Long
    Get
    Set
public:
property long long TotalSize {
    long long get ();
    void set (long long value);
}
function get_TotalSize();
function set_TotalSize(value);

Property Value

Type: Int64
The total size of the volume.
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Volume.VolumeType Property

VolumeVolumeType Property

This value is the type of volume.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeType { get; set; }
Public Property VolumeType As String
    Get
    Set
public:
property String^ VolumeType {
    String^ get ();
    void set (String^ value);
}
function get_VolumeType();
function set_VolumeType(value);

Property Value

Type: String
if this volume is the system drive; otherwise, .
See Also

Reference

Volume Class
DoubleTake.Common.Contract Namespace


Workload Class

Describes the data on a server that will be protected as part of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkload

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class Workload : IExtensibleDataObject
Public Class Workload
    Implements IExtensibleDataObject
public ref class Workload : IExtensibleDataObject
DoubleTake.Common.Contract.Workload = function();

Type.createClass(
    'DoubleTake.Common.Contract.Workload',
    null,
    IExtensibleDataObject);

The Workload type exposes the following members.

Constructors
 | Name | Description
Public method | Workload |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalRules | This value is the logical replication rules that define the workload.
Public property | PhysicalRules | This value represents the physical replication rules that define the workload.
Public property | RecoveryImageDataPath | This value is for image based recoveries and is the full path to the recovery image.
Public property | RecoveryImageId | This value is for image based recoveries and is the ID of the recovery image.
Public property | RecoverySnapshotSetId | This value is for image based recoveries and is the ID of a recovery snapshot.
Public property | WorkloadTypeName | This value is the workload type name. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


Workload Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Workload()
Public Sub New
public:
Workload()
DoubleTake.Common.Contract.Workload = function();
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload Properties

The Workload type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalRules | This value is the logical replication rules that define the workload.
Public property | PhysicalRules | This value represents the physical replication rules that define the workload.
Public property | RecoveryImageDataPath | This value is for image based recoveries and is the full path to the recovery image.
Public property | RecoveryImageId | This value is for image based recoveries and is the ID of the recovery image.
Public property | RecoverySnapshotSetId | This value is for image based recoveries and is the ID of a recovery snapshot.
Public property | WorkloadTypeName | This value is the workload type name. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Top
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.ExtensionData Property

WorkloadExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.LogicalRules Property

WorkloadLogicalRules Property

This value is the logical replication rules that define the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_LogicalRules();
function set_LogicalRules(value);

Property Value

Type: String
An array of String that represents the logical replication rules that compose this workload.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.PhysicalRules Property

WorkloadPhysicalRules Property

This value represents the physical replication rules that define the workload.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalRule[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRule()
    Get
    Set
public:
property array<PhysicalRule^>^ PhysicalRules {
    array<PhysicalRule^>^ get ();
    void set (array<PhysicalRule^>^ value);
}
function get_PhysicalRules();
function set_PhysicalRules(value);

Property Value

Type: PhysicalRule
An array of PhysicalRule that represents the physical replication rules that compose this workload.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoveryImageDataPath Property

WorkloadRecoveryImageDataPath Property

This value is for image based recoveries and is the full path to the recovery image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string RecoveryImageDataPath { get; set; }
Public Property RecoveryImageDataPath As String
    Get
    Set
public:
property String^ RecoveryImageDataPath {
    String^ get ();
    void set (String^ value);
}
function get_RecoveryImageDataPath();
function set_RecoveryImageDataPath(value);

Property Value

Type: String
Full path to the root of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoveryImageId Property

WorkloadRecoveryImageId Property

This value is for image based recoveries and is the ID of the recovery image.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid RecoveryImageId { get; set; }
Public Property RecoveryImageId As Guid
    Get
    Set
public:
property Guid RecoveryImageId {
    Guid get ();
    void set (Guid value);
}
function get_RecoveryImageId();
function set_RecoveryImageId(value);

Property Value

Type: Guid
Unique identifier of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.RecoverySnapshotSetId Property

WorkloadRecoverySnapshotSetId Property

This value is for image based recoveries and is the ID of a recovery snapshot.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid RecoverySnapshotSetId { get; set; }
Public Property RecoverySnapshotSetId As Guid
    Get
    Set
public:
property Guid RecoverySnapshotSetId {
    Guid get ();
    void set (Guid value);
}
function get_RecoverySnapshotSetId();
function set_RecoverySnapshotSetId(value);

Property Value

Type: Guid
Unique identifier of the image
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


Workload.WorkloadTypeName Property

WorkloadWorkloadTypeName Property

This value is the workload type name.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

FullServerImageProtection—DR full server protection job

FullServerImageRecovery—DR full server recovery job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string WorkloadTypeName { get; set; }
Public Property WorkloadTypeName As String
    Get
    Set
public:
property String^ WorkloadTypeName {
    String^ get ();
    void set (String^ value);
}
function get_WorkloadTypeName();
function set_WorkloadTypeName(value);

Property Value

Type: String
The name of the workload type.
See Also

Reference

Workload Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Class

Represents a summary of the licensing determination process for a workload type.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkloadSupportSummary

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class WorkloadSupportSummary : IExtensibleDataObject
Public Class WorkloadSupportSummary
    Implements IExtensibleDataObject
public ref class WorkloadSupportSummary : IExtensibleDataObject
DoubleTake.Common.Contract.WorkloadSupportSummary = function();

Type.createClass(
    'DoubleTake.Common.Contract.WorkloadSupportSummary',
    null,
    IExtensibleDataObject);

The WorkloadSupportSummary type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadSupportSummary |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Reason | This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.
Public property | ReasonFormatParameters | This value is format parameters for Reason.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadSupportSummary()
Public Sub New
public:
WorkloadSupportSummary()
DoubleTake.Common.Contract.WorkloadSupportSummary = function();
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary Properties

The WorkloadSupportSummary type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Reason | This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.
Public property | ReasonFormatParameters | This value is format parameters for Reason.
Top
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.ExtensionData Property

WorkloadSupportSummaryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.Reason Property

WorkloadSupportSummaryReason Property

This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use ReasonFormatParameters.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: String
The reason why the workload type is licensed or not.
Remarks
This value can be a string resource ID used for obtaining the reason text in the client or the reason text itself. If the reason text needs to be formatted with parameters, use the ReasonFormatParameters property.
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace


WorkloadSupportSummary.ReasonFormatParameters Property

WorkloadSupportSummaryReasonFormatParameters Property

This value is format parameters for Reason.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ReasonFormatParameters { get; set; }
Public Property ReasonFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ReasonFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ReasonFormatParameters();
function set_ReasonFormatParameters(value);

Property Value

Type: String
The reason format parameters.
See Also

Reference

WorkloadSupportSummary Class
DoubleTake.Common.Contract Namespace
WorkloadSupportSummary.Reason


WorkloadType Class

Describes the type of workloads that can be created on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractWorkloadType

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class WorkloadType : IExtensibleDataObject
Public Class WorkloadType
    Implements IExtensibleDataObject
public ref class WorkloadType : IExtensibleDataObject
DoubleTake.Common.Contract.WorkloadType = function();

Type.createClass(
    'DoubleTake.Common.Contract.WorkloadType',
    null,
    IExtensibleDataObject);

The WorkloadType type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadType |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsLicensed | This value is true if this type of workload is licensed for the server; otherwise, it is false.
Public property | IsPresent | This value is true if this type of workload is present on the server; otherwise, it is false.
Public property | Name | This value is the workload type name. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property | SupportSummary | This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
Top
See Also

Reference

DoubleTake.Common.Contract Namespace


WorkloadType Constructor

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadType()
Public Sub New
public:
WorkloadType()
DoubleTake.Common.Contract.WorkloadType = function();
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType Properties

The WorkloadType type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsLicensed | This value is true if this type of workload is licensed for the server; otherwise, it is false.
Public property | IsPresent | This value is true if this type of workload is present on the server; otherwise, it is false.
Public property | Name | This value is the workload type name. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property | SupportSummary | This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
Top
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.ExtensionData Property

WorkloadTypeExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.IsLicensed Property

WorkloadTypeIsLicensed Property

This value is true if this type of workload is licensed for the server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsLicensed { get; set; }
Public Property IsLicensed As Boolean
    Get
    Set
public:
property bool IsLicensed {
    bool get ();
    void set (bool value);
}
function get_IsLicensed();
function set_IsLicensed(value);

Property Value

Type: Boolean
if this type of workload is licensed; otherwise, .
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.IsPresent Property

WorkloadTypeIsPresent Property

This value is true if this type of workload is present on the server; otherwise, it is false.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsPresent { get; set; }
Public Property IsPresent As Boolean
    Get
    Set
public:
property bool IsPresent {
    bool get ();
    void set (bool value);
}
function get_IsPresent();
function set_IsPresent(value);

Property Value

Type: Boolean
if this instance is present; otherwise, .
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.Name Property

WorkloadTypeName Property

This value is the workload type name.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

FullServerImageProtection—DR full server protection job

FullServerImageRecovery—DR full server recovery job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the workload type..
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


WorkloadType.SupportSummary Property

WorkloadTypeSupportSummary Property

This value is a summary of the licensing for the workload type. The summary can be null if there is no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.

Namespace: DoubleTake.Common.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public WorkloadSupportSummary SupportSummary { get; set; }
Public Property SupportSummary As WorkloadSupportSummary
    Get
    Set
public:
property WorkloadSupportSummary^ SupportSummary {
    WorkloadSupportSummary^ get ();
    void set (WorkloadSupportSummary^ value);
}
function get_SupportSummary();
function set_SupportSummary(value);

Property Value

Type: WorkloadSupportSummary
The summary of the licensing for this workload type.
Remarks
The summary can be null if there's no reason to report any details about the license calculation. Otherwise, it should be non-null and populated with details about the license calculation that the client can use for reporting purposes.
See Also

Reference

WorkloadType Class
DoubleTake.Common.Contract Namespace


DoubleTake.Common.Tasks Namespace

Classes
 | Class | Description
Public class | ActivityStatusEntry |
Public class | ActivityToken |
Enumerations
 | Enumeration | Description
Public enumeration | ActivityCompletionStatus |


ActivityCompletionStatus Enumeration

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ActivityCompletionStatus
Public Enumeration ActivityCompletionStatus
public enum class ActivityCompletionStatus
DoubleTake.Common.Tasks.ActivityCompletionStatus = function();
DoubleTake.Common.Tasks.ActivityCompletionStatus.createEnum('DoubleTake.Common.Tasks.ActivityCompletionStatus', false);
Members
Member name | Value | Description
Pending | 0 |
Running | 1 |
Completed | 2 |
Canceled | 3 |
Faulted | 4 |
See Also

Reference

DoubleTake.Common.Tasks Namespace


ActivityStatusEntry Class

Inheritance Hierarchy
SystemObject
DoubleTake.Common.TasksActivityStatusEntry

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivityStatusEntry
Public Class ActivityStatusEntry
public ref class ActivityStatusEntry
DoubleTake.Common.Tasks.ActivityStatusEntry = function();

Type.createClass(
    'DoubleTake.Common.Tasks.ActivityStatusEntry');

The ActivityStatusEntry type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityStatusEntry |
Top
Properties
 | Name | Description
Public property | Duration |
Public property | MessageFormatParameters |
Public property | MessageId |
Public property | RequesterUserName |
Public property | Status |
Public property | TimeStamp |
Public property | Token |
Top
See Also

Reference

DoubleTake.Common.Tasks Namespace


ActivityStatusEntry Constructor

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityStatusEntry()
Public Sub New
public:
ActivityStatusEntry()
DoubleTake.Common.Tasks.ActivityStatusEntry = function();
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry Properties

The ActivityStatusEntry type exposes the following members.

Properties
 | Name | Description
Public property | Duration |
Public property | MessageFormatParameters |
Public property | MessageId |
Public property | RequesterUserName |
Public property | Status |
Public property | TimeStamp |
Public property | Token |
Top
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.Duration Property

ActivityStatusEntryDuration Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Duration();
function set_Duration(value);

Property Value

Type: TimeSpan
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.MessageFormatParameters Property

ActivityStatusEntryMessageFormatParameters Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.MessageId Property

ActivityStatusEntryMessageId Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
function get_MessageId();
function set_MessageId(value);

Property Value

Type: String
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.RequesterUserName Property

ActivityStatusEntryRequesterUserName Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string RequesterUserName { get; set; }
Public Property RequesterUserName As String
    Get
    Set
public:
property String^ RequesterUserName {
    String^ get ();
    void set (String^ value);
}
function get_RequesterUserName();
function set_RequesterUserName(value);

Property Value

Type: String
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.Status Property

ActivityStatusEntryStatus Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityCompletionStatus Status { get; set; }
Public Property Status As ActivityCompletionStatus
    Get
    Set
public:
property ActivityCompletionStatus Status {
    ActivityCompletionStatus get ();
    void set (ActivityCompletionStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: ActivityCompletionStatus
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.TimeStamp Property

ActivityStatusEntryTimeStamp Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimeStamp { get; set; }
Public Property TimeStamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeStamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimeStamp();
function set_TimeStamp(value);

Property Value

Type: DateTimeOffset
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityStatusEntry.Token Property

ActivityStatusEntryToken Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityToken Token { get; set; }
Public Property Token As ActivityToken
    Get
    Set
public:
property ActivityToken^ Token {
    ActivityToken^ get ();
    void set (ActivityToken^ value);
}
function get_Token();
function set_Token(value);

Property Value

Type: ActivityToken
See Also

Reference

ActivityStatusEntry Class
DoubleTake.Common.Tasks Namespace


ActivityToken Class

Inheritance Hierarchy
SystemObject
DoubleTake.Common.TasksActivityToken

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivityToken
Public Class ActivityToken
public ref class ActivityToken
DoubleTake.Common.Tasks.ActivityToken = function();

Type.createClass(
    'DoubleTake.Common.Tasks.ActivityToken');

The ActivityToken type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityToken |
Top
Properties
 | Name | Description
Public property | ActivityNameFormatParameters |
Public property | ActivityNameId |
Public property | Id |
Top
See Also

Reference

DoubleTake.Common.Tasks Namespace


ActivityToken Constructor

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivityToken()
Public Sub New
public:
ActivityToken()
DoubleTake.Common.Tasks.ActivityToken = function();
See Also

Reference

ActivityToken Class
DoubleTake.Common.Tasks Namespace


ActivityToken Properties

The ActivityToken type exposes the following members.

Properties
 | Name | Description
Public property | ActivityNameFormatParameters |
Public property | ActivityNameId |
Public property | Id |
Top
See Also

Reference

ActivityToken Class
DoubleTake.Common.Tasks Namespace


ActivityToken.ActivityNameFormatParameters Property

ActivityTokenActivityNameFormatParameters Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] ActivityNameFormatParameters { get; set; }
Public Property ActivityNameFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ActivityNameFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_ActivityNameFormatParameters();
function set_ActivityNameFormatParameters(value);

Property Value

Type: String
See Also

Reference

ActivityToken Class
DoubleTake.Common.Tasks Namespace


ActivityToken.ActivityNameId Property

ActivityTokenActivityNameId Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ActivityNameId { get; set; }
Public Property ActivityNameId As String
    Get
    Set
public:
property String^ ActivityNameId {
    String^ get ();
    void set (String^ value);
}
function get_ActivityNameId();
function set_ActivityNameId(value);

Property Value

Type: String
See Also

Reference

ActivityToken Class
DoubleTake.Common.Tasks Namespace


ActivityToken.Id Property

ActivityTokenId Property

Namespace: DoubleTake.Common.Tasks
Assembly: DoubleTake.PowerShell.Common (in DoubleTake.PowerShell.Common.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

ActivityToken Class
DoubleTake.Common.Tasks Namespace


DoubleTake.Core Namespaces

Namespaces
Namespace | Description
DoubleTake.Core.Contract |
DoubleTake.Core.Contract.Connection |
DoubleTake.Core.Contract.Job |
DoubleTake.Core.Contract.Monitor |
DoubleTake.Core.Contract.Options |
DoubleTake.Core.Contract.UVRA |


DoubleTake.Core.Contract Namespace

Classes
 | Class | Description
Public class | ActivationCode | Represents an activation code which entitles a user to a license to use the product.
Public class | ActivationStatus | Represents the current licensing status of a server.
Public class | DiskOptions |
Public class | ImageDeleteInfo | Represents information about how to delete an image.
Public class | ImageInfo | Represents information about an image used in an image based job.
Public class | ImageVhdInfo | Represents information about a virtual hard disk used to store an image in an image based job.
Public class | NetworkInterfaceInfo | Represents a network interface on a server.
Public class | OperatingSystemInfo | Represent the operating system of a server.
Public class | OperatingSystemVersion | Represents the version of an operating system.
Public class | PathBlockingEntry | A path blocking entry.
Public class | ProductInfo | Represents information about a product.
Public class | ProductVersion | Represents the version of a product.
Public class | ServerInfo | Represents information about a server.
Public class | UnicastIPAddressInfo | Represents a unicast IP address.
Public class | VolumeOptions | Represents a volume to protect and any changes to it's base configuration
Enumerations
 | Enumeration | Description
Public enumeration | AccessLevel | Represents the resulting access level when credentials are provided to the engine service.
Public enumeration | DesktopInteractionMode | Represents the interaction mode.
Public enumeration | EngineJobType | Defines possible types of an engine connection. These values are referred to as "job types" in the engine infrastructure; they should not be confused with the JobType property.
Public enumeration | ImageType | Defines possible types of an image.
Public enumeration | LicenseType | Indicates the type of license permitted by an ActivationCode.
Public enumeration | OperatingSystemArchitecture | Defines possible architectures for an operating system.
Public enumeration | OperatingSystemProductType | Defines possible product types for an operating system.
Public enumeration | PathBlockingMode | This value represents if the path is blocked.
Public enumeration | ReplicationSetUsageType | Defines possible usage types for a replication set.
Public enumeration | VhdDeleteActionType | Represents which virtual disks should be deleted when the protection is deleted.


AccessLevel Enumeration

Represents the resulting access level when credentials are provided to the engine service.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum AccessLevel
Public Enumeration AccessLevel
public enum class AccessLevel
DoubleTake.Core.Contract.AccessLevel = function();
DoubleTake.Core.Contract.AccessLevel.createEnum('DoubleTake.Core.Contract.AccessLevel', false);
Members
Member name | Value | Description
Unknown | -1 | The access level is unknown.
NoAccess | 0 | The credentials are not authenticated.
MonitorOnlyAccess | 1 | This access level is associated with membership in the Double-Take Monitors or dtmon security group.
FullAccess | 2 | This access level is associated with membership in the Double-Take Admin or dtadmin security group.
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationCode Class

Represents an activation code which entitles a user to a license to use the product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractActivationCode

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationCode : IExtensibleDataObject
Public Class ActivationCode
    Implements IExtensibleDataObject
public ref class ActivationCode : IExtensibleDataObject
DoubleTake.Core.Contract.ActivationCode = function();

Type.createClass(
    'DoubleTake.Core.Contract.ActivationCode',
    null,
    IExtensibleDataObject);

The ActivationCode type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCode |
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the attributes of the license.
Public property | Code | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | ExpirationDate | The value is the license expiration date.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEvaluation | This value is true if the license key is an evaluation license; otherwise, it is false.
Public property | IsExpired | This value is true if the license is expired; otherwise, it is false.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Public property | LicenseType | This value represents the type of license.
Public property | MajorVersion | This value is the major version of the release associated with this license.
Public property | MinorVersion | This value is the minor version of the release associated with this license.
Public property | ProductCode | This value is the product code associated with this license.
Public property | ProductName | This value is the product name associated with this license.
Public property | SerialNumber | This value is the serial number associated with this license.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationCode Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode()
Public Sub New
public:
ActivationCode()
DoubleTake.Core.Contract.ActivationCode = function();
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode Properties

The ActivationCode type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the attributes of the license.
Public property | Code | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | ExpirationDate | The value is the license expiration date.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEvaluation | This value is true if the license key is an evaluation license; otherwise, it is false.
Public property | IsExpired | This value is true if the license is expired; otherwise, it is false.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Public property | LicenseType | This value represents the type of license.
Public property | MajorVersion | This value is the major version of the release associated with this license.
Public property | MinorVersion | This value is the minor version of the release associated with this license.
Public property | ProductCode | This value is the product code associated with this license.
Public property | ProductName | This value is the product name associated with this license.
Public property | SerialNumber | This value is the serial number associated with this license.
Top
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.Attributes Property

ActivationCodeAttributes Property

This value represents the attributes of the license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationAttribute[] Attributes { get; set; }
Public Property Attributes As ActivationAttribute()
    Get
    Set
public:
property array<ActivationAttribute^>^ Attributes {
    array<ActivationAttribute^>^ get ();
    void set (array<ActivationAttribute^>^ value);
}
function get_Attributes();
function set_Attributes(value);

Property Value

Type: ActivationAttribute
An array of ActivationAttribute that represents the attributes this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.Code Property

ActivationCodeCode Property

This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
function get_Code();
function set_Code(value);

Property Value

Type: String
The text of the activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ExpirationDate Property

ActivationCodeExpirationDate Property

The value is the license expiration date.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
function get_ExpirationDate();
function set_ExpirationDate(value);

Property Value

Type: DateTime
The expiration date of this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ExtensionData Property

ActivationCodeExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsEvaluation Property

ActivationCodeIsEvaluation Property

This value is true if the license key is an evaluation license; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEvaluation { get; set; }
Public Property IsEvaluation As Boolean
    Get
    Set
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}
function get_IsEvaluation();
function set_IsEvaluation(value);

Property Value

Type: Boolean
if this this activation code represents an evaluation license; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsExpired Property

ActivationCodeIsExpired Property

This value is true if the license is expired; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsExpired { get; set; }
Public Property IsExpired As Boolean
    Get
    Set
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}
function get_IsExpired();
function set_IsExpired(value);

Property Value

Type: Boolean
if this activation code is expired; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsNodeLocked Property

ActivationCodeIsNodeLocked Property

This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
function get_IsNodeLocked();
function set_IsNodeLocked(value);

Property Value

Type: Boolean
if this this activation code represents a node-locked license; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.IsValid Property

ActivationCodeIsValid Property

This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
function get_IsValid();
function set_IsValid(value);

Property Value

Type: Boolean
if this activation code is valid; otherwise, .
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.LicenseType Property

ActivationCodeLicenseType Property

This value represents the type of license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LicenseType LicenseType { get; set; }
Public Property LicenseType As LicenseType
    Get
    Set
public:
property LicenseType LicenseType {
    LicenseType get ();
    void set (LicenseType value);
}
function get_LicenseType();
function set_LicenseType(value);

Property Value

Type: LicenseType
A LicenseType value that indicates the type of license this activation code entitle the user to.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.MajorVersion Property

ActivationCodeMajorVersion Property

This value is the major version of the release associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
function get_MajorVersion();
function set_MajorVersion(value);

Property Value

Type: Int32
The major version of the release associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.MinorVersion Property

ActivationCodeMinorVersion Property

This value is the minor version of the release associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
function get_MinorVersion();
function set_MinorVersion(value);

Property Value

Type: Int32
The minor version of the release associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ProductCode Property

ActivationCodeProductCode Property

This value is the product code associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
function get_ProductCode();
function set_ProductCode(value);

Property Value

Type: Int32
The product code associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.ProductName Property

ActivationCodeProductName Property

This value is the product name associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
function get_ProductName();
function set_ProductName(value);

Property Value

Type: String
The name of the product associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationCode.SerialNumber Property

ActivationCodeSerialNumber Property

This value is the serial number associated with this license.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int SerialNumber { get; set; }
Public Property SerialNumber As Integer
    Get
    Set
public:
property int SerialNumber {
    int get ();
    void set (int value);
}
function get_SerialNumber();
function set_SerialNumber(value);

Property Value

Type: Int32
The serial number associated with this activation code.
See Also

Reference

ActivationCode Class
DoubleTake.Core.Contract Namespace


ActivationStatus Class

Represents the current licensing status of a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractActivationStatus

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationStatus : IExtensibleDataObject
Public Class ActivationStatus
    Implements IExtensibleDataObject
public ref class ActivationStatus : IExtensibleDataObject
DoubleTake.Core.Contract.ActivationStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.ActivationStatus',
    null,
    IExtensibleDataObject);

The ActivationStatus type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationStatus |
Top
Properties
 | Name | Description
Public property | AddOnCodes | This value represents the current add-on licenses on this server. This property is no longer used.
Public property | Codes | This value represents the current licenses on this server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ActivationStatus Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationStatus()
Public Sub New
public:
ActivationStatus()
DoubleTake.Core.Contract.ActivationStatus = function();
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus Properties

The ActivationStatus type exposes the following members.

Properties
 | Name | Description
Public property | AddOnCodes | This value represents the current add-on licenses on this server. This property is no longer used.
Public property | Codes | This value represents the current licenses on this server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public property | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.AddOnCodes Property

ActivationStatusAddOnCodes Property

This value represents the current add-on licenses on this server. This property is no longer used.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode[] AddOnCodes { get; set; }
Public Property AddOnCodes As ActivationCode()
    Get
    Set
public:
property array<ActivationCode^>^ AddOnCodes {
    array<ActivationCode^>^ get ();
    void set (array<ActivationCode^>^ value);
}
function get_AddOnCodes();
function set_AddOnCodes(value);

Property Value

Type: ActivationCode
An array of ActivationCode that represents the current add-on codes on this server.
Remarks
Add-on codes are not used by recent versions of the product. A single installation of the product may have any number of activation codes, and these are returned by the [P:Codes] property. This property is provided only for compatibility with older versions.
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.Codes Property

ActivationStatusCodes Property

This value represents the current licenses on this server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCode[] Codes { get; set; }
Public Property Codes As ActivationCode()
    Get
    Set
public:
property array<ActivationCode^>^ Codes {
    array<ActivationCode^>^ get ();
    void set (array<ActivationCode^>^ value);
}
function get_Codes();
function set_Codes(value);

Property Value

Type: ActivationCode
An array of ActivationCode that represents the current activation codes on this server.
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.ExtensionData Property

ActivationStatusExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.IsNodeLocked Property

ActivationStatusIsNodeLocked Property

This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
function get_IsNodeLocked();
function set_IsNodeLocked(value);

Property Value

Type: Boolean
if the license on this server is node locked; otherwise, .
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


ActivationStatus.IsValid Property

ActivationStatusIsValid Property

This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
function get_IsValid();
function set_IsValid(value);

Property Value

Type: Boolean
if the license on this server is valid; otherwise, .
See Also

Reference

ActivationStatus Class
DoubleTake.Core.Contract Namespace


DesktopInteractionMode Enumeration

Represents the interaction mode.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum DesktopInteractionMode
Public Enumeration DesktopInteractionMode
public enum class DesktopInteractionMode
DoubleTake.Core.Contract.DesktopInteractionMode = function();
DoubleTake.Core.Contract.DesktopInteractionMode.createEnum('DoubleTake.Core.Contract.DesktopInteractionMode', false);
Members
Member name | Value | Description
None | 0 | The script will execute silently in the background.
Interact | 1 | Script processing will be displayed on screen.
See Also

Reference

DoubleTake.Core.Contract Namespace


DiskOptions Class

Inheritance Hierarchy
SystemObject
Disk
DoubleTake.Core.ContractDiskOptions

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class DiskOptions : Disk
Public Class DiskOptions
    Inherits Disk
public ref class DiskOptions : public Disk
DoubleTake.Core.Contract.DiskOptions = function();

Type.createClass(
    'DoubleTake.Core.Contract.DiskOptions',
    DoubleTake.Common.Contract.Disk);

The DiskOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DiskOptions |
Top
Properties
 | Name | Description
Public property | DesiredSizeInB | This value is the desired size in bytes of the new disk.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | VirtualDiskPath | This value is the path on the host where the disk should be stored.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


DiskOptions Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DiskOptions()
Public Sub New
public:
DiskOptions()
DoubleTake.Core.Contract.DiskOptions = function();
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions Properties

The DiskOptions type exposes the following members.

Properties
 | Name | Description
Public property | DesiredSizeInB | This value is the desired size in bytes of the new disk.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | VirtualDiskPath | This value is the path on the host where the disk should be stored.
Top
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.DesiredSizeInB Property

DiskOptionsDesiredSizeInB Property

This value is the desired size in bytes of the new disk.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long DesiredSizeInB { get; set; }
Public Property DesiredSizeInB As Long
    Get
    Set
public:
property long long DesiredSizeInB {
    long long get ();
    void set (long long value);
}
function get_DesiredSizeInB();
function set_DesiredSizeInB(value);

Property Value

Type: Int64
The desired size in bytes.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.DiskControllerType Property

DiskOptionsDiskControllerType Property

This value is the disk controller.

IDE—Use this value to create an IDE disk.

SCSI—Use this value to create a SCSI disk.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
function get_DiskControllerType();
function set_DiskControllerType(value);

Property Value

Type: String
The type of the disk controller.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.DiskProvisioningType Property

DiskOptionsDiskProvisioningType Property

This value is the disk type.

Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks.

Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks.

Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
function get_DiskProvisioningType();
function set_DiskProvisioningType(value);

Property Value

Type: String
The type of the disk provisioning.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.PreexistingDiskPath Property

DiskOptionsPreexistingDiskPath Property

This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_PreexistingDiskPath();
function set_PreexistingDiskPath(value);

Property Value

Type: String
The path of this pre-existing path.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.VirtualDiskPath Property

DiskOptionsVirtualDiskPath Property

This value is the path on the host where the disk should be stored.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_VirtualDiskPath();
function set_VirtualDiskPath(value);

Property Value

Type: String
The path of this item.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions Methods

The DiskOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


DiskOptions.Clone Method

DiskOptionsClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

DiskOptions Class
DoubleTake.Core.Contract Namespace


EngineJobType Enumeration

Defines possible types of an engine connection. These values are referred to as "job types" in the engine infrastructure; they should not be confused with the JobType property.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum EngineJobType
Public Enumeration EngineJobType
public enum class EngineJobType
DoubleTake.Core.Contract.EngineJobType = function();
DoubleTake.Core.Contract.EngineJobType.createEnum('DoubleTake.Core.Contract.EngineJobType', false);
Members
Member name | Value | Description
NormalJob | 0 | This value is a files and folders connection.
ImageJob | 1 | This value is a Double-Take DR protection connection. This option is no longer needed.
RecoveryJob | 2 | This value is a Double-Take DR recovery connection. This option is no longer needed.
FullServerJob | 4 | This value is a full server connection.
GeoClusterJob | 8 | This value is a GeoCluster Replicate Disk resource connection.
MigrationJob | 16 | This value is a Double-Take Move connection.
FullServerRevertJob | 32 | This value is a full server reverse connection.
VraRecoveryJob | 64 | This value is a full server to ESX or Hyper-V reverse connection.
VraMigrationJob | 128 | This value is a full server to ESX or Hyper-V Double-Take Move connection.
DataOnlyOption | 256 | This value is for a connection that is replicating data only.
VraJob | 512 | This value is a full server to ESX or Hyper-V Double-Take Availability connection.
HyperVJob | 1024 | This value is a Hyper-V connection.
Win32MirrorOption | 2048 | This value is a connection that will override the server default and use the Win32 mirroring driver.
SourceConnectionResourceJob | 4096 | This value is a connection protecting a source cluster.
FullServerBackupJob | 8192 | This value is a full server reverse connection.
UvraJob | 16384 | This value is a full server to ESX appliance job.
NonClientAccessibleSnapshot | 32768 | This value indicates that snapshots created for this connections should not have the VSS_CTX_CLIENT_ACCESSIBLE context.
FFO | 65536 | This value is a full server job for Linux. This is not the real value for engine job type, but is for CreateConnectionAction to create a connection.
LVRA_JOB | 131072 | This value is a full server to ESX job for Linux. It is usually a connection to the local server (the source is same as the target) where the target drive is an iSCSI hosted by a Linux appliance. This is not the real value for engine job type, but is for CreateConnectionAction to create connection.
Invalid | 65535 | This value is an unknown connection.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageDeleteInfo Class

Represents information about how to delete an image.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageDeleteInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageDeleteInfo : IExtensibleDataObject
Public Class ImageDeleteInfo
    Implements IExtensibleDataObject
public ref class ImageDeleteInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageDeleteInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageDeleteInfo',
    null,
    IExtensibleDataObject);

The ImageDeleteInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDeleteInfo |
Top
Properties
 | Name | Description
Public property | DeleteImage | This value is true if the image should be deleted; otherwise it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image you want to delete. The image contains the protected data from the source.
Public property | VhdDeleteAction | This value represents which virtual disks should be deleted when the protection is deleted.
Public property | VhdsToDelete | This value is a list of virtual disk files to delete. It is specified by the full path and file name to the virtual disk file.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageDeleteInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageDeleteInfo()
Public Sub New
public:
ImageDeleteInfo()
DoubleTake.Core.Contract.ImageDeleteInfo = function();
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo Properties

The ImageDeleteInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeleteImage | This value is true if the image should be deleted; otherwise it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image you want to delete. The image contains the protected data from the source.
Public property | VhdDeleteAction | This value represents which virtual disks should be deleted when the protection is deleted.
Public property | VhdsToDelete | This value is a list of virtual disk files to delete. It is specified by the full path and file name to the virtual disk file.
Top
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.DeleteImage Property

ImageDeleteInfoDeleteImage Property

This value is true if the image should be deleted; otherwise it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteImage { get; set; }
Public Property DeleteImage As Boolean
    Get
    Set
public:
property bool DeleteImage {
    bool get ();
    void set (bool value);
}
function get_DeleteImage();
function set_DeleteImage(value);

Property Value

Type: Boolean
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.ExtensionData Property

ImageDeleteInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.ImageId Property

ImageDeleteInfoImageId Property

This value is the unique ID of the image you want to delete. The image contains the protected data from the source.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.VhdDeleteAction Property

ImageDeleteInfoVhdDeleteAction Property

This value represents which virtual disks should be deleted when the protection is deleted.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VhdDeleteActionType VhdDeleteAction { get; set; }
Public Property VhdDeleteAction As VhdDeleteActionType
    Get
    Set
public:
property VhdDeleteActionType VhdDeleteAction {
    VhdDeleteActionType get ();
    void set (VhdDeleteActionType value);
}
function get_VhdDeleteAction();
function set_VhdDeleteAction(value);

Property Value

Type: VhdDeleteActionType
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageDeleteInfo.VhdsToDelete Property

ImageDeleteInfoVhdsToDelete Property

This value is a list of virtual disk files to delete. It is specified by the full path and file name to the virtual disk file.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> VhdsToDelete { get; set; }
Public Property VhdsToDelete As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDelete {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_VhdsToDelete();
function set_VhdsToDelete(value);

Property Value

Type: IEnumerable String
See Also

Reference

ImageDeleteInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo Class

Represents information about an image used in an image based job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageInfo : IExtensibleDataObject
Public Class ImageInfo
    Implements IExtensibleDataObject
public ref class ImageInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageInfo',
    null,
    IExtensibleDataObject);

The ImageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInfo |
Top
Properties
 | Name | Description
Public property | CreationTimestamp | This value is the date and time when the image was created.
Public property | Description | This value is the description of the image.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the image unique ID.
Public property | ImageName | This value is the name of the image. This value does not need to be unique.
Public property | ImageType | This value represents the type of image.
Public property | ProtectionConnectionId | This value is the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | This value is the job name, if there is a protection job using the image.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceImageMountLocation | This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | This value is the name of the source that contained the original image data.
Public property | State | This values is the state of the target.
Public property | VhdFiles | This value represents information about a virtual hard disk used to store an image.
Top
Fields
Name | Description
DescriptionPropertyName |
ImageCreationTimestampPropertyName |
ImageNamePropertyName |
ImageTypePropertyName |
OriginalImageProtectionJobIdPropertyName |
OriginalSourceDomainRole |
OriginalSourceNetworkIdPropertyName |
OriginalSourceSystemStateDirectories |
OriginalSourceSystemStateVolumes |
ProtectionConnectionIdPropertyName |
ProtectionJobIdPropertyName |
ProtectionJobPropertyName |
RepSetNamePropertyName |
SourceNamePropertyName |
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageInfo()
Public Sub New
public:
ImageInfo()
DoubleTake.Core.Contract.ImageInfo = function();
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo Properties

The ImageInfo type exposes the following members.

Properties
 | Name | Description
Public property | CreationTimestamp | This value is the date and time when the image was created.
Public property | Description | This value is the description of the image.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the image unique ID.
Public property | ImageName | This value is the name of the image. This value does not need to be unique.
Public property | ImageType | This value represents the type of image.
Public property | ProtectionConnectionId | This value is the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | This value is the job name, if there is a protection job using the image.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceImageMountLocation | This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | This value is the name of the source that contained the original image data.
Public property | State | This values is the state of the target.
Public property | VhdFiles | This value represents information about a virtual hard disk used to store an image.
Top
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.CreationTimestamp Property

ImageInfoCreationTimestamp Property

This value is the date and time when the image was created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime CreationTimestamp { get; set; }
Public Property CreationTimestamp As DateTime
    Get
    Set
public:
property DateTime CreationTimestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_CreationTimestamp();
function set_CreationTimestamp(value);

Property Value

Type: DateTime
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Description Property

ImageInfoDescription Property

This value is the description of the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
function get_Description();
function set_Description(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ExtensionData Property

ImageInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Id Property

ImageInfoId Property

This value is the image unique ID.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageName Property

ImageInfoImageName Property

This value is the name of the image. This value does not need to be unique.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
function get_ImageName();
function set_ImageName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageType Property

ImageInfoImageType Property

This value represents the type of image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageType ImageType { get; set; }
Public Property ImageType As ImageType
    Get
    Set
public:
property ImageType ImageType {
    ImageType get ();
    void set (ImageType value);
}
function get_ImageType();
function set_ImageType(value);

Property Value

Type: ImageType
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionConnectionId Property

ImageInfoProtectionConnectionId Property

This value is the connection ID, if there is a protection job using the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ProtectionConnectionId { get; set; }
Public Property ProtectionConnectionId As String
    Get
    Set
public:
property String^ ProtectionConnectionId {
    String^ get ();
    void set (String^ value);
}
function get_ProtectionConnectionId();
function set_ProtectionConnectionId(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobName Property

ImageInfoProtectionJobName Property

This value is the job name, if there is a protection job using the image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ProtectionJobName { get; set; }
Public Property ProtectionJobName As String
    Get
    Set
public:
property String^ ProtectionJobName {
    String^ get ();
    void set (String^ value);
}
function get_ProtectionJobName();
function set_ProtectionJobName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.Snapshots Property

ImageInfoSnapshots Property

This value represents the current list of snapshots for the connection.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceImageMountLocation Property

ImageInfoSourceImageMountLocation Property

This value is the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceImageMountLocation { get; set; }
Public Property SourceImageMountLocation As String
    Get
    Set
public:
property String^ SourceImageMountLocation {
    String^ get ();
    void set (String^ value);
}
function get_SourceImageMountLocation();
function set_SourceImageMountLocation(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceName Property

ImageInfoSourceName Property

This value is the name of the source that contained the original image data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
function get_SourceName();
function set_SourceName(value);

Property Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.State Property

ImageInfoState Property

This values is the state of the target.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates State { get; set; }
Public Property State As TargetStates
    Get
    Set
public:
property TargetStates State {
    TargetStates get ();
    void set (TargetStates value);
}
function get_State();
function set_State(value);

Property Value

Type: TargetStates
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.VhdFiles Property

ImageInfoVhdFiles Property

This value represents information about a virtual hard disk used to store an image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo[] VhdFiles { get; set; }
Public Property VhdFiles As ImageVhdInfo()
    Get
    Set
public:
property array<ImageVhdInfo^>^ VhdFiles {
    array<ImageVhdInfo^>^ get ();
    void set (array<ImageVhdInfo^>^ value);
}
function get_VhdFiles();
function set_VhdFiles(value);

Property Value

Type: ImageVhdInfo
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo Fields

The ImageInfo type exposes the following members.

Fields
Name | Description
DescriptionPropertyName |
ImageCreationTimestampPropertyName |
ImageNamePropertyName |
ImageTypePropertyName |
OriginalImageProtectionJobIdPropertyName |
OriginalSourceDomainRole |
OriginalSourceNetworkIdPropertyName |
OriginalSourceSystemStateDirectories |
OriginalSourceSystemStateVolumes |
ProtectionConnectionIdPropertyName |
ProtectionJobIdPropertyName |
ProtectionJobPropertyName |
RepSetNamePropertyName |
SourceNamePropertyName |
Top
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.DescriptionPropertyName Field

ImageInfoDescriptionPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string DescriptionPropertyName
Public Shared ReadOnly DescriptionPropertyName As String
public:
static initonly String^ DescriptionPropertyName
var DoubleTake.Core.Contract.ImageInfo.DescriptionPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageCreationTimestampPropertyName Field

ImageInfoImageCreationTimestampPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageCreationTimestampPropertyName
Public Shared ReadOnly ImageCreationTimestampPropertyName As String
public:
static initonly String^ ImageCreationTimestampPropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageCreationTimestampPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageNamePropertyName Field

ImageInfoImageNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageNamePropertyName
Public Shared ReadOnly ImageNamePropertyName As String
public:
static initonly String^ ImageNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ImageTypePropertyName Field

ImageInfoImageTypePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ImageTypePropertyName
Public Shared ReadOnly ImageTypePropertyName As String
public:
static initonly String^ ImageTypePropertyName
var DoubleTake.Core.Contract.ImageInfo.ImageTypePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalImageProtectionJobIdPropertyName Field

ImageInfoOriginalImageProtectionJobIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalImageProtectionJobIdPropertyName
Public Shared ReadOnly OriginalImageProtectionJobIdPropertyName As String
public:
static initonly String^ OriginalImageProtectionJobIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.OriginalImageProtectionJobIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceDomainRole Field

ImageInfoOriginalSourceDomainRole Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceDomainRole
Public Shared ReadOnly OriginalSourceDomainRole As String
public:
static initonly String^ OriginalSourceDomainRole
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceDomainRole

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceNetworkIdPropertyName Field

ImageInfoOriginalSourceNetworkIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceNetworkIdPropertyName
Public Shared ReadOnly OriginalSourceNetworkIdPropertyName As String
public:
static initonly String^ OriginalSourceNetworkIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceNetworkIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceSystemStateDirectories Field

ImageInfoOriginalSourceSystemStateDirectories Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceSystemStateDirectories
Public Shared ReadOnly OriginalSourceSystemStateDirectories As String
public:
static initonly String^ OriginalSourceSystemStateDirectories
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceSystemStateDirectories

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.OriginalSourceSystemStateVolumes Field

ImageInfoOriginalSourceSystemStateVolumes Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string OriginalSourceSystemStateVolumes
Public Shared ReadOnly OriginalSourceSystemStateVolumes As String
public:
static initonly String^ OriginalSourceSystemStateVolumes
var DoubleTake.Core.Contract.ImageInfo.OriginalSourceSystemStateVolumes

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionConnectionIdPropertyName Field

ImageInfoProtectionConnectionIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionConnectionIdPropertyName
Public Shared ReadOnly ProtectionConnectionIdPropertyName As String
public:
static initonly String^ ProtectionConnectionIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionConnectionIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobIdPropertyName Field

ImageInfoProtectionJobIdPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionJobIdPropertyName
Public Shared ReadOnly ProtectionJobIdPropertyName As String
public:
static initonly String^ ProtectionJobIdPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionJobIdPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.ProtectionJobPropertyName Field

ImageInfoProtectionJobPropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string ProtectionJobPropertyName
Public Shared ReadOnly ProtectionJobPropertyName As String
public:
static initonly String^ ProtectionJobPropertyName
var DoubleTake.Core.Contract.ImageInfo.ProtectionJobPropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.RepSetNamePropertyName Field

ImageInfoRepSetNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string RepSetNamePropertyName
Public Shared ReadOnly RepSetNamePropertyName As String
public:
static initonly String^ RepSetNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.RepSetNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageInfo.SourceNamePropertyName Field

ImageInfoSourceNamePropertyName Field

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static readonly string SourceNamePropertyName
Public Shared ReadOnly SourceNamePropertyName As String
public:
static initonly String^ SourceNamePropertyName
var DoubleTake.Core.Contract.ImageInfo.SourceNamePropertyName

Field Value

Type: String
See Also

Reference

ImageInfo Class
DoubleTake.Core.Contract Namespace


ImageType Enumeration

Defines possible types of an image.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ImageType
Public Enumeration ImageType
public enum class ImageType
DoubleTake.Core.Contract.ImageType = function();
DoubleTake.Core.Contract.ImageType.createEnum('DoubleTake.Core.Contract.ImageType', false);
Members
Member name | Value | Description
DataOnly | 0 | The image was created by a data only protection.
FullServer | 1 | The image was created by full server protection.
Unknown | 2 | The image is an unknown origin.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageVhdInfo Class

Represents information about a virtual hard disk used to store an image in an image based job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractImageVhdInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageVhdInfo : IExtensibleDataObject
Public Class ImageVhdInfo
    Implements IExtensibleDataObject
public ref class ImageVhdInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ImageVhdInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ImageVhdInfo',
    null,
    IExtensibleDataObject);

The ImageVhdInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ImageVhdInfo |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FilePath | This value is the full path and file name of the .vhd image file.
Public property | FormatType | This value is the file system format for the image, for example NTFS or ReFS.
Public property | SizeInMB | This value is the size of the .vhd image file in megabytes.
Public property | UseExistingVhd | This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.
Public property | VolumeLetter | This value is the volume letter of the original volume this image is storing.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ImageVhdInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo()
Public Sub New
public:
ImageVhdInfo()
DoubleTake.Core.Contract.ImageVhdInfo = function();
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo Properties

The ImageVhdInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FilePath | This value is the full path and file name of the .vhd image file.
Public property | FormatType | This value is the file system format for the image, for example NTFS or ReFS.
Public property | SizeInMB | This value is the size of the .vhd image file in megabytes.
Public property | UseExistingVhd | This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.
Public property | VolumeLetter | This value is the volume letter of the original volume this image is storing.
Top
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.ExtensionData Property

ImageVhdInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.FilePath Property

ImageVhdInfoFilePath Property

This value is the full path and file name of the .vhd image file.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
function get_FilePath();
function set_FilePath(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.FormatType Property

ImageVhdInfoFormatType Property

This value is the file system format for the image, for example NTFS or ReFS.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string FormatType { get; set; }
Public Property FormatType As String
    Get
    Set
public:
property String^ FormatType {
    String^ get ();
    void set (String^ value);
}
function get_FormatType();
function set_FormatType(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.SizeInMB Property

ImageVhdInfoSizeInMB Property

This value is the size of the .vhd image file in megabytes.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long SizeInMB { get; set; }
Public Property SizeInMB As Long
    Get
    Set
public:
property long long SizeInMB {
    long long get ();
    void set (long long value);
}
function get_SizeInMB();
function set_SizeInMB(value);

Property Value

Type: Int64
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.UseExistingVhd Property

ImageVhdInfoUseExistingVhd Property

This value is true if an existing .vhd file should be used; otherwise, it is false. If you set this value to true, but no existing .vhd file exists, you will receive an error during job creation. If you set this value to false and an existing .vhd file exists, the file will be deleted and a new one will be created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseExistingVhd { get; set; }
Public Property UseExistingVhd As Boolean
    Get
    Set
public:
property bool UseExistingVhd {
    bool get ();
    void set (bool value);
}
function get_UseExistingVhd();
function set_UseExistingVhd(value);

Property Value

Type: Boolean
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


ImageVhdInfo.VolumeLetter Property

ImageVhdInfoVolumeLetter Property

This value is the volume letter of the original volume this image is storing.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VolumeLetter { get; set; }
Public Property VolumeLetter As String
    Get
    Set
public:
property String^ VolumeLetter {
    String^ get ();
    void set (String^ value);
}
function get_VolumeLetter();
function set_VolumeLetter(value);

Property Value

Type: String
See Also

Reference

ImageVhdInfo Class
DoubleTake.Core.Contract Namespace


LicenseType Enumeration

Indicates the type of license permitted by an ActivationCode.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum LicenseType
Public Enumeration LicenseType
public enum class LicenseType
DoubleTake.Core.Contract.LicenseType = function();
DoubleTake.Core.Contract.LicenseType.createEnum('DoubleTake.Core.Contract.LicenseType', false);
Members
Member name | Value | Description
NotApplicable | 0 | The license type is not applicable.
Limited | 1 | The license type is an evaluation license.
Single | 2 | The license type is a single server license.
Site | 3 | The license type is a site license.
NodeLockedKey | 4 | The key is an activation key.
See Also

Reference

DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Class

Represents a network interface on a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractNetworkInterfaceInfo
DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class NetworkInterfaceInfo : IExtensibleDataObject
Public Class NetworkInterfaceInfo
    Implements IExtensibleDataObject
public ref class NetworkInterfaceInfo : IExtensibleDataObject
DoubleTake.Core.Contract.NetworkInterfaceInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.NetworkInterfaceInfo',
    null,
    IExtensibleDataObject);

The NetworkInterfaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceInfo |
Top
Properties
 | Name | Description
Public property | Description | This value is the description of the NIC.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC.
Public property | DnsServers | This value is the DNS server assigned to the NIC.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Gateways | This value is the gateway assigned to the NIC.
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).
Public property | Index | Do not use this property. Double-Take uses it internally.
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally.
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC.
Public property | MacAddress | This value represents the MAC address of the NIC.
Public property | Name | This value is the friendly name of the NIC.
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC.
Public property | ServiceName | This value is the service name of the NIC.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo()
Public Sub New
public:
NetworkInterfaceInfo()
DoubleTake.Core.Contract.NetworkInterfaceInfo = function();
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo Properties

The NetworkInterfaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | This value is the description of the NIC.
Public property | DnsDomain | This value is the DNS domain assigned to the NIC.
Public property | DnsServers | This value is the DNS server assigned to the NIC.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Gateways | This value is the gateway assigned to the NIC.
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).
Public property | Index | Do not use this property. Double-Take uses it internally.
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally.
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC.
Public property | MacAddress | This value represents the MAC address of the NIC.
Public property | Name | This value is the friendly name of the NIC.
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC.
Public property | ServiceName | This value is the service name of the NIC.
Top
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Description Property

NetworkInterfaceInfoDescription Property

This value is the description of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
function get_Description();
function set_Description(value);

Property Value

Type: String
The description of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.DnsDomain Property

NetworkInterfaceInfoDnsDomain Property

This value is the DNS domain assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
function get_DnsDomain();
function set_DnsDomain(value);

Property Value

Type: String
The DNS Domain .
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.DnsServers Property

NetworkInterfaceInfoDnsServers Property

This value is the DNS server assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_DnsServers();
function set_DnsServers(value);

Property Value

Type: String
The DNS servers.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.ExtensionData Property

NetworkInterfaceInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Gateways Property

NetworkInterfaceInfoGateways Property

This value is the gateway assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Gateways();
function set_Gateways(value);

Property Value

Type: String
The gateways.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Guid Property

NetworkInterfaceInfoGuid Property

This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL).

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: String
The unique identifier of the network interface.
Remarks
This value is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the BCL.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Index Property

NetworkInterfaceInfoIndex Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
function get_Index();
function set_Index(value);

Property Value

Type: Int32
The index of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.InterfaceIndex Property

NetworkInterfaceInfoInterfaceIndex Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
function get_InterfaceIndex();
function set_InterfaceIndex(value);

Property Value

Type: Int32
The index of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.IPAddresses Property

NetworkInterfaceInfoIPAddresses Property

This value represents the IP addresses assigned to the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] IPAddresses { get; set; }
Public Property IPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ IPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_IPAddresses();
function set_IPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
An array of UnicastIPAddressInfo that represents the IP addresses on the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.MacAddress Property

NetworkInterfaceInfoMacAddress Property

This value represents the MAC address of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
function get_MacAddress();
function set_MacAddress(value);

Property Value

Type: String
The MAC address.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.Name Property

NetworkInterfaceInfoName Property

This value is the friendly name of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The friendly name of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.PnpInstanceId Property

NetworkInterfaceInfoPnpInstanceId Property

This value is the plug and play instance ID of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
function get_PnpInstanceId();
function set_PnpInstanceId(value);

Property Value

Type: String
The PNP instance id.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


NetworkInterfaceInfo.ServiceName Property

NetworkInterfaceInfoServiceName Property

This value is the service name of the NIC.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
The service name of the network interface.
See Also

Reference

NetworkInterfaceInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemArchitecture Enumeration

Defines possible architectures for an operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum OperatingSystemArchitecture
Public Enumeration OperatingSystemArchitecture
public enum class OperatingSystemArchitecture
DoubleTake.Core.Contract.OperatingSystemArchitecture = function();
DoubleTake.Core.Contract.OperatingSystemArchitecture.createEnum('DoubleTake.Core.Contract.OperatingSystemArchitecture', false);
Members
Member name | Value | Description
x86 | 0 | The operating systems uses the 32-bit architecture.
x64 | 9 | The operating system uses the AMD 64-bit architecture.
ia64 | 6 | The operating system uses the Itanium 64-bit architecture.
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemInfo Class

Represent the operating system of a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractOperatingSystemInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class OperatingSystemInfo : IExtensibleDataObject
Public Class OperatingSystemInfo
    Implements IExtensibleDataObject
public ref class OperatingSystemInfo : IExtensibleDataObject
DoubleTake.Core.Contract.OperatingSystemInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.OperatingSystemInfo',
    null,
    IExtensibleDataObject);

The OperatingSystemInfo type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemInfo |
Top
Properties
 | Name | Description
Public property | Architecture | This value represents the operating system architecture.
Public property | CSDVersion | This value is the version of the operating system service pack as a number.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasBCDTemplate | Gets or sets the flag indicating whether or not the file BCD-Template exists.
Public property | ProductSuite | This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.
Public property | ProductType | This value represents the type of operating system.
Public property | ServicePack | This value is the version of the operating system service pack as a string.
Public property | Version | This value is the version of the operating system as a number.
Public property | VersionString | This value is the version of the operating system as a string.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemInfo()
Public Sub New
public:
OperatingSystemInfo()
DoubleTake.Core.Contract.OperatingSystemInfo = function();
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo Properties

The OperatingSystemInfo type exposes the following members.

Properties
 | Name | Description
Public property | Architecture | This value represents the operating system architecture.
Public property | CSDVersion | This value is the version of the operating system service pack as a number.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasBCDTemplate | Gets or sets the flag indicating whether or not the file BCD-Template exists.
Public property | ProductSuite | This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.
Public property | ProductType | This value represents the type of operating system.
Public property | ServicePack | This value is the version of the operating system service pack as a string.
Public property | Version | This value is the version of the operating system as a number.
Public property | VersionString | This value is the version of the operating system as a string.
Top
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.Architecture Property

OperatingSystemInfoArchitecture Property

This value represents the operating system architecture.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemArchitecture Architecture { get; set; }
Public Property Architecture As OperatingSystemArchitecture
    Get
    Set
public:
property OperatingSystemArchitecture Architecture {
    OperatingSystemArchitecture get ();
    void set (OperatingSystemArchitecture value);
}
function get_Architecture();
function set_Architecture(value);

Property Value

Type: OperatingSystemArchitecture
A OperatingSystemArchitecture value representing the architecture of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.CSDVersion Property

OperatingSystemInfoCSDVersion Property

This value is the version of the operating system service pack as a number.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int CSDVersion { get; set; }
Public Property CSDVersion As Integer
    Get
    Set
public:
property int CSDVersion {
    int get ();
    void set (int value);
}
function get_CSDVersion();
function set_CSDVersion(value);

Property Value

Type: Int32
The service pack major number.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ExtensionData Property

OperatingSystemInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.HasBCDTemplate Property

OperatingSystemInfoHasBCDTemplate Property

Gets or sets the flag indicating whether or not the file BCD-Template exists.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool HasBCDTemplate { get; set; }
Public Property HasBCDTemplate As Boolean
    Get
    Set
public:
property bool HasBCDTemplate {
    bool get ();
    void set (bool value);
}
function get_HasBCDTemplate();
function set_HasBCDTemplate(value);

Property Value

Type: Boolean
a boolean flag set to TRUE if the file exists
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ProductSuite Property

OperatingSystemInfoProductSuite Property

This value is the Windows OSVERSIONINFOEX structure, which contains operating system version information including major and minor version numbers, a build number, a platform identifier, and information about product suites and the latest service pack installed on the system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ProductSuite { get; set; }
Public Property ProductSuite As Integer
    Get
    Set
public:
property int ProductSuite {
    int get ();
    void set (int value);
}
function get_ProductSuite();
function set_ProductSuite(value);

Property Value

Type: Int32
A bit mask that identifies the product suites available on the system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ProductType Property

OperatingSystemInfoProductType Property

This value represents the type of operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemProductType ProductType { get; set; }
Public Property ProductType As OperatingSystemProductType
    Get
    Set
public:
property OperatingSystemProductType ProductType {
    OperatingSystemProductType get ();
    void set (OperatingSystemProductType value);
}
function get_ProductType();
function set_ProductType(value);

Property Value

Type: OperatingSystemProductType
A OperatingSystemProductType representing the product type of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.ServicePack Property

OperatingSystemInfoServicePack Property

This value is the version of the operating system service pack as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ServicePack { get; set; }
Public Property ServicePack As String
    Get
    Set
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
function get_ServicePack();
function set_ServicePack(value);

Property Value

Type: String
The service pack number of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.Version Property

OperatingSystemInfoVersion Property

This value is the version of the operating system as a number.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion Version { get; set; }
Public Property Version As OperatingSystemVersion
    Get
    Set
public:
property OperatingSystemVersion^ Version {
    OperatingSystemVersion^ get ();
    void set (OperatingSystemVersion^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: OperatingSystemVersion
A OperatingSystemVersion value representing the version of the operating system.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemInfo.VersionString Property

OperatingSystemInfoVersionString Property

This value is the version of the operating system as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VersionString { get; set; }
Public Property VersionString As String
    Get
    Set
public:
property String^ VersionString {
    String^ get ();
    void set (String^ value);
}
function get_VersionString();
function set_VersionString(value);

Property Value

Type: String
The version of the operating system as a string.
See Also

Reference

OperatingSystemInfo Class
DoubleTake.Core.Contract Namespace


OperatingSystemProductType Enumeration

Defines possible product types for an operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum OperatingSystemProductType
Public Enumeration OperatingSystemProductType
public enum class OperatingSystemProductType
DoubleTake.Core.Contract.OperatingSystemProductType = function();
DoubleTake.Core.Contract.OperatingSystemProductType.createEnum('DoubleTake.Core.Contract.OperatingSystemProductType', false);
Members
Member name | Value | Description
None | 0 | The operating system product type is not defined.
Workstation | 1 | The operating system is workstation.
DomainController | 2 | The operating system is a domain controller.
Server | 3 | The operating system is server.
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemVersion Class

Represents the version of an operating system.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractOperatingSystemVersion

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class OperatingSystemVersion : IExtensibleDataObject
Public Class OperatingSystemVersion
    Implements IExtensibleDataObject
public ref class OperatingSystemVersion : IExtensibleDataObject
DoubleTake.Core.Contract.OperatingSystemVersion = function();

Type.createClass(
    'DoubleTake.Core.Contract.OperatingSystemVersion',
    null,
    IExtensibleDataObject);

The OperatingSystemVersion type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemVersion |
Top
Properties
 | Name | Description
Public property | Build | This value is the build number of the operating system.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Major | This value is the major version of the operating system.
Public property | Minor | This value is the minor version of the operating system.
Public property | Revision | This value is the revision number of the operating system.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


OperatingSystemVersion Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemVersion()
Public Sub New
public:
OperatingSystemVersion()
DoubleTake.Core.Contract.OperatingSystemVersion = function();
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion Properties

The OperatingSystemVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build | This value is the build number of the operating system.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Major | This value is the major version of the operating system.
Public property | Minor | This value is the minor version of the operating system.
Public property | Revision | This value is the revision number of the operating system.
Top
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Build Property

OperatingSystemVersionBuild Property

This value is the build number of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
function get_Build();
function set_Build(value);

Property Value

Type: Int32
The build number of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.ExtensionData Property

OperatingSystemVersionExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Major Property

OperatingSystemVersionMajor Property

This value is the major version of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
function get_Major();
function set_Major(value);

Property Value

Type: Int32
The major version of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Minor Property

OperatingSystemVersionMinor Property

This value is the minor version of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
function get_Minor();
function set_Minor(value);

Property Value

Type: Int32
The minor version of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


OperatingSystemVersion.Revision Property

OperatingSystemVersionRevision Property

This value is the revision number of the operating system.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
function get_Revision();
function set_Revision(value);

Property Value

Type: Int32
The revision number of the operating system.
See Also

Reference

OperatingSystemVersion Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry Class

A path blocking entry.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractPathBlockingEntry

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class PathBlockingEntry : IExtensibleDataObject
Public Class PathBlockingEntry
    Implements IExtensibleDataObject
public ref class PathBlockingEntry : IExtensibleDataObject
DoubleTake.Core.Contract.PathBlockingEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.PathBlockingEntry',
    null,
    IExtensibleDataObject);

The PathBlockingEntry type exposes the following members.

Constructors
 | Name | Description
Public method | PathBlockingEntry |
Top
Properties
 | Name | Description
Public property | BlockingMode | This value represents if the path is blocked.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Paths | This value is the paths that are blocked.
Public property | SourceAddress | This value is the source IP address that corresponds to the connection that has the blocked paths.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


PathBlockingEntry Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathBlockingEntry()
Public Sub New
public:
PathBlockingEntry()
DoubleTake.Core.Contract.PathBlockingEntry = function();
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry Properties

The PathBlockingEntry type exposes the following members.

Properties
 | Name | Description
Public property | BlockingMode | This value represents if the path is blocked.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Paths | This value is the paths that are blocked.
Public property | SourceAddress | This value is the source IP address that corresponds to the connection that has the blocked paths.
Top
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.BlockingMode Property

PathBlockingEntryBlockingMode Property

This value represents if the path is blocked.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathBlockingMode BlockingMode { get; set; }
Public Property BlockingMode As PathBlockingMode
    Get
    Set
public:
property PathBlockingMode BlockingMode {
    PathBlockingMode get ();
    void set (PathBlockingMode value);
}
function get_BlockingMode();
function set_BlockingMode(value);

Property Value

Type: PathBlockingMode
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.ExtensionData Property

PathBlockingEntryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.Paths Property

PathBlockingEntryPaths Property

This value is the paths that are blocked.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Paths();
function set_Paths(value);

Property Value

Type: String
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingEntry.SourceAddress Property

PathBlockingEntrySourceAddress Property

This value is the source IP address that corresponds to the connection that has the blocked paths.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
function get_SourceAddress();
function set_SourceAddress(value);

Property Value

Type: String
See Also

Reference

PathBlockingEntry Class
DoubleTake.Core.Contract Namespace


PathBlockingMode Enumeration

This value represents if the path is blocked.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum PathBlockingMode
Public Enumeration PathBlockingMode
public enum class PathBlockingMode
DoubleTake.Core.Contract.PathBlockingMode = function();
DoubleTake.Core.Contract.PathBlockingMode.createEnum('DoubleTake.Core.Contract.PathBlockingMode', false);
Members
Member name | Value | Description
Blocked | 0 | The path is blocked for writing, except by Double-Take.
Unblocked | 1 | The path is unblocked for writing.
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductInfo Class

Represents information about a product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractProductInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ProductInfo : IExtensibleDataObject
Public Class ProductInfo
    Implements IExtensibleDataObject
public ref class ProductInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ProductInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ProductInfo',
    null,
    IExtensibleDataObject);

The ProductInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfo |
Top
Properties
 | Name | Description
Public property | ActivationStatus | This value represents the activation of the server.
Public property | CanPauseTarget | This value is true if target operations can be paused; otherwise, it is false.
Public property | CanResumeTarget | This value is true if target operations can be resumed; otherwise, it is false.
Public property | EngineModuleStatus | Do not use this property. Double-Take uses it internally.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GatewaySessionKey | Do not use this property. Double-Take uses it internally.
Public property | InstallationPath | This value is the installation path.
Public property | LocalEndpoints | This value is the local endpoints.
Public property | MachineName | This value is the name of the machine.
Public property | ManagementServiceVersion | This value is the version of the Management Service on the server.
Public property | Name | This value is the name of the product on the server.
Public property | NatEndpoints | This value is the NAT endpoints.
Public property | ReservedAddress | This value is the reserved IP address for the server.
Public property | UniqueId | This value is the unique ID of the server.
Public property | Version | This value is the version of the product on the server.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo()
Public Sub New
public:
ProductInfo()
DoubleTake.Core.Contract.ProductInfo = function();
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo Properties

The ProductInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationStatus | This value represents the activation of the server.
Public property | CanPauseTarget | This value is true if target operations can be paused; otherwise, it is false.
Public property | CanResumeTarget | This value is true if target operations can be resumed; otherwise, it is false.
Public property | EngineModuleStatus | Do not use this property. Double-Take uses it internally.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GatewaySessionKey | Do not use this property. Double-Take uses it internally.
Public property | InstallationPath | This value is the installation path.
Public property | LocalEndpoints | This value is the local endpoints.
Public property | MachineName | This value is the name of the machine.
Public property | ManagementServiceVersion | This value is the version of the Management Service on the server.
Public property | Name | This value is the name of the product on the server.
Public property | NatEndpoints | This value is the NAT endpoints.
Public property | ReservedAddress | This value is the reserved IP address for the server.
Public property | UniqueId | This value is the unique ID of the server.
Public property | Version | This value is the version of the product on the server.
Top
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ActivationStatus Property

ProductInfoActivationStatus Property

This value represents the activation of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationStatus ActivationStatus { get; set; }
Public Property ActivationStatus As ActivationStatus
    Get
    Set
public:
property ActivationStatus^ ActivationStatus {
    ActivationStatus^ get ();
    void set (ActivationStatus^ value);
}
function get_ActivationStatus();
function set_ActivationStatus(value);

Property Value

Type: ActivationStatus
The activation status of the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.CanPauseTarget Property

ProductInfoCanPauseTarget Property

This value is true if target operations can be paused; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
function get_CanPauseTarget();
function set_CanPauseTarget(value);

Property Value

Type: Boolean
if target operations can be paused; otherwise, .
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.CanResumeTarget Property

ProductInfoCanResumeTarget Property

This value is true if target operations can be resumed; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
function get_CanResumeTarget();
function set_CanResumeTarget(value);

Property Value

Type: Boolean
if target operations can be resumed; otherwise, .
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.EngineModuleStatus Property

ProductInfoEngineModuleStatus Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int EngineModuleStatus { get; set; }
Public Property EngineModuleStatus As Integer
    Get
    Set
public:
property int EngineModuleStatus {
    int get ();
    void set (int value);
}
function get_EngineModuleStatus();
function set_EngineModuleStatus(value);

Property Value

Type: Int32
The engine module status.
Remarks
This value is only used internally and is not exposed as a data contract member.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.EnginePort Property

ProductInfoEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Int32
The port on which the engine is listening.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ExtensionData Property

ProductInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.GatewaySessionKey Property

ProductInfoGatewaySessionKey Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long GatewaySessionKey { get; set; }
Public Property GatewaySessionKey As Long
    Get
    Set
public:
property long long GatewaySessionKey {
    long long get ();
    void set (long long value);
}
function get_GatewaySessionKey();
function set_GatewaySessionKey(value);

Property Value

Type: Int64
The session key.
Remarks
The property supports the infrastructure and is not intended to be used by client code.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.InstallationPath Property

ProductInfoInstallationPath Property

This value is the installation path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string InstallationPath { get; set; }
Public Property InstallationPath As String
    Get
    Set
public:
property String^ InstallationPath {
    String^ get ();
    void set (String^ value);
}
function get_InstallationPath();
function set_InstallationPath(value);

Property Value

Type: String
The installation path.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.LocalEndpoints Property

ProductInfoLocalEndpoints Property

This value is the local endpoints.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> LocalEndpoints { get; set; }
Public Property LocalEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ LocalEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_LocalEndpoints();
function set_LocalEndpoints(value);

Property Value

Type: IEnumerable String
The local endpoints.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.MachineName Property

ProductInfoMachineName Property

This value is the name of the machine.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
function get_MachineName();
function set_MachineName(value);

Property Value

Type: String
The name of the machine.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ManagementServiceVersion Property

ProductInfoManagementServiceVersion Property

This value is the version of the Management Service on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion ManagementServiceVersion { get; set; }
Public Property ManagementServiceVersion As ProductVersion
    Get
    Set
public:
property ProductVersion^ ManagementServiceVersion {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_ManagementServiceVersion();
function set_ManagementServiceVersion(value);

Property Value

Type: ProductVersion
The version of the management service on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.Name Property

ProductInfoName Property

This value is the name of the product on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the product on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.NatEndpoints Property

ProductInfoNatEndpoints Property

This value is the NAT endpoints.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> NatEndpoints { get; set; }
Public Property NatEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ NatEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_NatEndpoints();
function set_NatEndpoints(value);

Property Value

Type: IEnumerable String
The NAT end points.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.ReservedAddress Property

ProductInfoReservedAddress Property

This value is the reserved IP address for the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReservedAddress { get; set; }
Public Property ReservedAddress As String
    Get
    Set
public:
property String^ ReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_ReservedAddress();
function set_ReservedAddress(value);

Property Value

Type: String
The reserved IP address for the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.UniqueId Property

ProductInfoUniqueId Property

This value is the unique ID of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
function get_UniqueId();
function set_UniqueId(value);

Property Value

Type: String
The unique id of the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductInfo.Version Property

ProductInfoVersion Property

This value is the version of the product on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion Version { get; set; }
Public Property Version As ProductVersion
    Get
    Set
public:
property ProductVersion^ Version {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: ProductVersion
The version of the product on the server.
See Also

Reference

ProductInfo Class
DoubleTake.Core.Contract Namespace


ProductVersion Class

Represents the version of a product.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractProductVersion

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ProductVersion : IExtensibleDataObject
Public Class ProductVersion
    Implements IExtensibleDataObject
public ref class ProductVersion : IExtensibleDataObject
DoubleTake.Core.Contract.ProductVersion = function();

Type.createClass(
    'DoubleTake.Core.Contract.ProductVersion',
    null,
    IExtensibleDataObject);

The ProductVersion type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVersion |
Top
Properties
 | Name | Description
Public property | Build | This value is the build (or sequence number) of the product.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hotfix | This value is the hotfix (or limited release) of the product.
Public property | Major | This value is the major version of the product.
Public property | Minor | This value is the minor version of the product.
Public property | ServicePack | This value is the service pack version of the product.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ProductVersion Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion()
Public Sub New
public:
ProductVersion()
DoubleTake.Core.Contract.ProductVersion = function();
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion Properties

The ProductVersion type exposes the following members.

Properties
 | Name | Description
Public property | Build | This value is the build (or sequence number) of the product.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hotfix | This value is the hotfix (or limited release) of the product.
Public property | Major | This value is the major version of the product.
Public property | Minor | This value is the minor version of the product.
Public property | ServicePack | This value is the service pack version of the product.
Top
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Build Property

ProductVersionBuild Property

This value is the build (or sequence number) of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
function get_Build();
function set_Build(value);

Property Value

Type: Int32
The build (sequence) number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ExtensionData Property

ProductVersionExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Hotfix Property

ProductVersionHotfix Property

This value is the hotfix (or limited release) of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Hotfix { get; set; }
Public Property Hotfix As Integer
    Get
    Set
public:
property int Hotfix {
    int get ();
    void set (int value);
}
function get_Hotfix();
function set_Hotfix(value);

Property Value

Type: Int32
The hotfix number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Major Property

ProductVersionMajor Property

This value is the major version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
function get_Major();
function set_Major(value);

Property Value

Type: Int32
The major version number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.Minor Property

ProductVersionMinor Property

This value is the minor version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
function get_Minor();
function set_Minor(value);

Property Value

Type: Int32
The minor version number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ServicePack Property

ProductVersionServicePack Property

This value is the service pack version of the product.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ServicePack { get; set; }
Public Property ServicePack As Integer
    Get
    Set
public:
property int ServicePack {
    int get ();
    void set (int value);
}
function get_ServicePack();
function set_ServicePack(value);

Property Value

Type: Int32
The service pack number.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion Methods

The ProductVersion type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ProductVersion.ToString Method

ProductVersionToString Method

Returns a String that represents this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

ProductVersion Class
DoubleTake.Core.Contract Namespace


ReplicationSetUsageType Enumeration

Defines possible usage types for a replication set.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ReplicationSetUsageType
Public Enumeration ReplicationSetUsageType
public enum class ReplicationSetUsageType
DoubleTake.Core.Contract.ReplicationSetUsageType = function();
DoubleTake.Core.Contract.ReplicationSetUsageType.createEnum('DoubleTake.Core.Contract.ReplicationSetUsageType', false);
Members
Member name | Value | Description
Invalid | -1 | This value is an unknown data set type.
Normal | 0 | This value is a files and folders data set.
SystemState | 1 | This value is a full server data set.
GeoCluster | 2 | This value is a GeoCluster data set.
Remarks
Values of this enumeration should not be sent between client and server.
See Also

Reference

DoubleTake.Core.Contract Namespace


ServerInfo Class

Represents information about a server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractServerInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ServerInfo : IExtensibleDataObject
Public Class ServerInfo
    Implements IExtensibleDataObject
public ref class ServerInfo : IExtensibleDataObject
DoubleTake.Core.Contract.ServerInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.ServerInfo',
    null,
    IExtensibleDataObject);

The ServerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ServerInfo |
Top
Properties
 | Name | Description
Public property | BiosGuid | This value is the BIOS unique ID.
Public property | BootVolume | This value is the server's boot volume.
Public property | CoresPerProcessor | This value is the number of cores per processor on the server.
Public property | Disks | This value represents the disks on the server that has volume(s) on it.
Public property | Domain | This value is the domain the server is a member of.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullyQualifiedDomain | This value is the fully qualified domain name.
Public property | HalInternalName | This value is the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | The value is the version of the hardware abstraction layer (HAL).
Public property | IsClustered | This value is true if this the server is part of a cluster; otherwise, it is false.
Public property | IsHostedByHyperV | This value is true if the server is hosted by Hyper-V; otherwise, it is false.
Public property | IsHostedByVMware | This value is true if the server is hosted by VMware; otherwise, it is false.
Public property | IsHostedByXen | This value is true if the server is hosted by Xen; otherwise, it is false.
Public property | IsHyperVHost | This value is true if the server is a Hyper-V host; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is enabled; otherwise, it is false.
Public property | IsSBS | This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.
Public property | IsSSE | This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.
Public property | LogicalProcessorCount | Gets or sets the number of logical processors including threads.
Public property | LvmOptions | This value represents the Linux Volume Manager (LVM) options.
Public property | ManagementPort | This value is the port where the Management Service is listening.
Public property | MemorySize | This value is the amount of memory on the server.
Public property | Name | This value is the name of the server.
Public property | NetworkInterfaces | This value represents the NICs on the server.
Public property | NodeLockedServerInfo | This value is the server information needed for an activation key.
Public property | OperatingSystem | This value is the operating system on the server.
Public property | ProcessorCount | This value is the processor count on the server.
Public property | ProgramFilesPath | This value is the server's program files path.
Public property | SystemPath | This value is the server's system path.
Public property | SystemRoot | This value is the server's system root path.
Public property | SystemStateDefinition | Do not use this property. Double-Take uses it internally.
Public property | SystemVolume | This value is the server's system volume.
Public property | Volumes | This value represents the volumes on the server.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


ServerInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServerInfo()
Public Sub New
public:
ServerInfo()
DoubleTake.Core.Contract.ServerInfo = function();
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo Properties

The ServerInfo type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | This value is the BIOS unique ID.
Public property | BootVolume | This value is the server's boot volume.
Public property | CoresPerProcessor | This value is the number of cores per processor on the server.
Public property | Disks | This value represents the disks on the server that has volume(s) on it.
Public property | Domain | This value is the domain the server is a member of.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullyQualifiedDomain | This value is the fully qualified domain name.
Public property | HalInternalName | This value is the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | The value is the version of the hardware abstraction layer (HAL).
Public property | IsClustered | This value is true if this the server is part of a cluster; otherwise, it is false.
Public property | IsHostedByHyperV | This value is true if the server is hosted by Hyper-V; otherwise, it is false.
Public property | IsHostedByVMware | This value is true if the server is hosted by VMware; otherwise, it is false.
Public property | IsHostedByXen | This value is true if the server is hosted by Xen; otherwise, it is false.
Public property | IsHyperVHost | This value is true if the server is a Hyper-V host; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is enabled; otherwise, it is false.
Public property | IsSBS | This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.
Public property | IsSSE | This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.
Public property | LogicalProcessorCount | Gets or sets the number of logical processors including threads.
Public property | LvmOptions | This value represents the Linux Volume Manager (LVM) options.
Public property | ManagementPort | This value is the port where the Management Service is listening.
Public property | MemorySize | This value is the amount of memory on the server.
Public property | Name | This value is the name of the server.
Public property | NetworkInterfaces | This value represents the NICs on the server.
Public property | NodeLockedServerInfo | This value is the server information needed for an activation key.
Public property | OperatingSystem | This value is the operating system on the server.
Public property | ProcessorCount | This value is the processor count on the server.
Public property | ProgramFilesPath | This value is the server's program files path.
Public property | SystemPath | This value is the server's system path.
Public property | SystemRoot | This value is the server's system root path.
Public property | SystemStateDefinition | Do not use this property. Double-Take uses it internally.
Public property | SystemVolume | This value is the server's system volume.
Public property | Volumes | This value represents the volumes on the server.
Top
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.BiosGuid Property

ServerInfoBiosGuid Property

This value is the BIOS unique ID.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
function get_BiosGuid();
function set_BiosGuid(value);

Property Value

Type: Guid
The BIOS GUID.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.BootVolume Property

ServerInfoBootVolume Property

This value is the server's boot volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string BootVolume { get; set; }
Public Property BootVolume As String
    Get
    Set
public:
property String^ BootVolume {
    String^ get ();
    void set (String^ value);
}
function get_BootVolume();
function set_BootVolume(value);

Property Value

Type: String
The boot volume.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.CoresPerProcessor Property

ServerInfoCoresPerProcessor Property

This value is the number of cores per processor on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int CoresPerProcessor { get; set; }
Public Property CoresPerProcessor As Integer
    Get
    Set
public:
property int CoresPerProcessor {
    int get ();
    void set (int value);
}
function get_CoresPerProcessor();
function set_CoresPerProcessor(value);

Property Value

Type: Int32
The number of cores per processor. Value of 0 used for unknown/unspecified.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Disks Property

ServerInfoDisks Property

This value represents the disks on the server that has volume(s) on it.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Disk[] Disks { get; set; }
Public Property Disks As Disk()
    Get
    Set
public:
property array<Disk^>^ Disks {
    array<Disk^>^ get ();
    void set (array<Disk^>^ value);
}
function get_Disks();
function set_Disks(value);

Property Value

Type: Disk
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Domain Property

ServerInfoDomain Property

This value is the domain the server is a member of.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
function get_Domain();
function set_Domain(value);

Property Value

Type: String
The domain the server is a member of.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ExtensionData Property

ServerInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.FullyQualifiedDomain Property

ServerInfoFullyQualifiedDomain Property

This value is the fully qualified domain name.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string FullyQualifiedDomain { get; set; }
Public Property FullyQualifiedDomain As String
    Get
    Set
public:
property String^ FullyQualifiedDomain {
    String^ get ();
    void set (String^ value);
}
function get_FullyQualifiedDomain();
function set_FullyQualifiedDomain(value);

Property Value

Type: String
The fully qualified domain name of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.HalInternalName Property

ServerInfoHalInternalName Property

This value is the internal name of the hardware abstraction layer (HAL).

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string HalInternalName { get; set; }
Public Property HalInternalName As String
    Get
    Set
public:
property String^ HalInternalName {
    String^ get ();
    void set (String^ value);
}
function get_HalInternalName();
function set_HalInternalName(value);

Property Value

Type: String
The internal name of the hardware abstraction layer (HAL).
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.HalVersion Property

ServerInfoHalVersion Property

The value is the version of the hardware abstraction layer (HAL).

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string HalVersion { get; set; }
Public Property HalVersion As String
    Get
    Set
public:
property String^ HalVersion {
    String^ get ();
    void set (String^ value);
}
function get_HalVersion();
function set_HalVersion(value);

Property Value

Type: String
The version of the hardware abstraction layer.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsClustered Property

ServerInfoIsClustered Property

This value is true if this the server is part of a cluster; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
function get_IsClustered();
function set_IsClustered(value);

Property Value

Type: Boolean
if this the server is part of a cluster; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByHyperV Property

ServerInfoIsHostedByHyperV Property

This value is true if the server is hosted by Hyper-V; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByHyperV { get; set; }
Public Property IsHostedByHyperV As Boolean
    Get
    Set
public:
property bool IsHostedByHyperV {
    bool get ();
    void set (bool value);
}
function get_IsHostedByHyperV();
function set_IsHostedByHyperV(value);

Property Value

Type: Boolean
if the server is hosted by Hyper-V; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByVMware Property

ServerInfoIsHostedByVMware Property

This value is true if the server is hosted by VMware; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByVMware { get; set; }
Public Property IsHostedByVMware As Boolean
    Get
    Set
public:
property bool IsHostedByVMware {
    bool get ();
    void set (bool value);
}
function get_IsHostedByVMware();
function set_IsHostedByVMware(value);

Property Value

Type: Boolean
if the server is hosted by VMware; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHostedByXen Property

ServerInfoIsHostedByXen Property

This value is true if the server is hosted by Xen; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHostedByXen { get; set; }
Public Property IsHostedByXen As Boolean
    Get
    Set
public:
property bool IsHostedByXen {
    bool get ();
    void set (bool value);
}
function get_IsHostedByXen();
function set_IsHostedByXen(value);

Property Value

Type: Boolean
if the server is hosted by Xen; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsHyperVHost Property

ServerInfoIsHyperVHost Property

This value is true if the server is a Hyper-V host; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsHyperVHost { get; set; }
Public Property IsHyperVHost As Boolean
    Get
    Set
public:
property bool IsHyperVHost {
    bool get ();
    void set (bool value);
}
function get_IsHyperVHost();
function set_IsHyperVHost(value);

Property Value

Type: Boolean
if the server is a Hyper-V host; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsReplicationEnabled Property

ServerInfoIsReplicationEnabled Property

This value is true if replication is enabled; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
function get_IsReplicationEnabled();
function set_IsReplicationEnabled(value);

Property Value

Type: Boolean
if replication is enabled; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsSBS Property

ServerInfoIsSBS Property

This value is true if the server is running Microsoft Windows Small Business Server; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSBS { get; set; }
Public Property IsSBS As Boolean
    Get
    Set
public:
property bool IsSBS {
    bool get ();
    void set (bool value);
}
function get_IsSBS();
function set_IsSBS(value);

Property Value

Type: Boolean
if the server is running Microsoft Windows Small Business Server; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.IsSSE Property

ServerInfoIsSSE Property

This value is true if the server is running Microsoft Windows Storage Server; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSSE { get; set; }
Public Property IsSSE As Boolean
    Get
    Set
public:
property bool IsSSE {
    bool get ();
    void set (bool value);
}
function get_IsSSE();
function set_IsSSE(value);

Property Value

Type: Boolean
if the server is running Microsoft Windows Storage Server; otherwise, .
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.LogicalProcessorCount Property

ServerInfoLogicalProcessorCount Property

Gets or sets the number of logical processors including threads.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int LogicalProcessorCount { get; set; }
Public Property LogicalProcessorCount As Integer
    Get
    Set
public:
property int LogicalProcessorCount {
    int get ();
    void set (int value);
}
function get_LogicalProcessorCount();
function set_LogicalProcessorCount(value);

Property Value

Type: Int32
The number of logical processors.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.LvmOptions Property

ServerInfoLvmOptions Property

This value represents the Linux Volume Manager (LVM) options.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions LvmOptions { get; set; }
Public Property LvmOptions As LvmOptions
    Get
    Set
public:
property LvmOptions^ LvmOptions {
    LvmOptions^ get ();
    void set (LvmOptions^ value);
}
function get_LvmOptions();
function set_LvmOptions(value);

Property Value

Type: LvmOptions
The LVM Options
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ManagementPort Property

ServerInfoManagementPort Property

This value is the port where the Management Service is listening.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ManagementPort { get; set; }
Public Property ManagementPort As Integer
    Get
    Set
public:
property int ManagementPort {
    int get ();
    void set (int value);
}
function get_ManagementPort();
function set_ManagementPort(value);

Property Value

Type: Int32
The port where the management service is listening.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.MemorySize Property

ServerInfoMemorySize Property

This value is the amount of memory on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MemorySize { get; set; }
Public Property MemorySize As Long
    Get
    Set
public:
property long long MemorySize {
    long long get ();
    void set (long long value);
}
function get_MemorySize();
function set_MemorySize(value);

Property Value

Type: Int64
The amount of memory on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Name Property

ServerInfoName Property

This value is the name of the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.NetworkInterfaces Property

ServerInfoNetworkInterfaces Property

This value represents the NICs on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] NetworkInterfaces { get; set; }
Public Property NetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ NetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_NetworkInterfaces();
function set_NetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
An array of NetworkInterfaceInfo representing the network interfaces on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.NodeLockedServerInfo Property

ServerInfoNodeLockedServerInfo Property

This value is the server information needed for an activation key.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string NodeLockedServerInfo { get; set; }
Public Property NodeLockedServerInfo As String
    Get
    Set
public:
property String^ NodeLockedServerInfo {
    String^ get ();
    void set (String^ value);
}
function get_NodeLockedServerInfo();
function set_NodeLockedServerInfo(value);

Property Value

Type: String
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.OperatingSystem Property

ServerInfoOperatingSystem Property

This value is the operating system on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OperatingSystemInfo OperatingSystem { get; set; }
Public Property OperatingSystem As OperatingSystemInfo
    Get
    Set
public:
property OperatingSystemInfo^ OperatingSystem {
    OperatingSystemInfo^ get ();
    void set (OperatingSystemInfo^ value);
}
function get_OperatingSystem();
function set_OperatingSystem(value);

Property Value

Type: OperatingSystemInfo
An OperatingSytemInfo representing the operating system on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ProcessorCount Property

ServerInfoProcessorCount Property

This value is the processor count on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ProcessorCount { get; set; }
Public Property ProcessorCount As Integer
    Get
    Set
public:
property int ProcessorCount {
    int get ();
    void set (int value);
}
function get_ProcessorCount();
function set_ProcessorCount(value);

Property Value

Type: Int32
The processor count of the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.ProgramFilesPath Property

ServerInfoProgramFilesPath Property

This value is the server's program files path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ProgramFilesPath { get; set; }
Public Property ProgramFilesPath As String
    Get
    Set
public:
property String^ ProgramFilesPath {
    String^ get ();
    void set (String^ value);
}
function get_ProgramFilesPath();
function set_ProgramFilesPath(value);

Property Value

Type: String
The program files path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemPath Property

ServerInfoSystemPath Property

This value is the server's system path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemPath { get; set; }
Public Property SystemPath As String
    Get
    Set
public:
property String^ SystemPath {
    String^ get ();
    void set (String^ value);
}
function get_SystemPath();
function set_SystemPath(value);

Property Value

Type: String
The system path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemRoot Property

ServerInfoSystemRoot Property

This value is the server's system root path.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemRoot { get; set; }
Public Property SystemRoot As String
    Get
    Set
public:
property String^ SystemRoot {
    String^ get ();
    void set (String^ value);
}
function get_SystemRoot();
function set_SystemRoot(value);

Property Value

Type: String
The system root path.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemStateDefinition Property

ServerInfoSystemStateDefinition Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemStateDefinition { get; set; }
Public Property SystemStateDefinition As String
    Get
    Set
public:
property String^ SystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
function get_SystemStateDefinition();
function set_SystemStateDefinition(value);

Property Value

Type: String
The system state definition as an XML string.
Remarks
This property is used to support the infrastructure and is not intended to be used by client code.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.SystemVolume Property

ServerInfoSystemVolume Property

This value is the server's system volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemVolume { get; set; }
Public Property SystemVolume As String
    Get
    Set
public:
property String^ SystemVolume {
    String^ get ();
    void set (String^ value);
}
function get_SystemVolume();
function set_SystemVolume(value);

Property Value

Type: String
The system volume.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


ServerInfo.Volumes Property

ServerInfoVolumes Property

This value represents the volumes on the server.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] Volumes { get; set; }
Public Property Volumes As Volume()
    Get
    Set
public:
property array<Volume^>^ Volumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: Volume
An array of Volume representing the volumes on the server.
See Also

Reference

ServerInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Class

Represents a unicast IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractUnicastIPAddressInfo

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class UnicastIPAddressInfo : IExtensibleDataObject
Public Class UnicastIPAddressInfo
    Implements IExtensibleDataObject
public ref class UnicastIPAddressInfo : IExtensibleDataObject
DoubleTake.Core.Contract.UnicastIPAddressInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.UnicastIPAddressInfo',
    null,
    IExtensibleDataObject);

The UnicastIPAddressInfo type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastIPAddressInfo |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddress | This value is the IP address as a string.
Public property | IPv4Mask | This value is the the IPv4 subnet mask.
Public property | IsDHCP | This value is true if the IP address is a DHCP assigned address; otherwise, it is false.
Public property | IsNAT | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | IsOnline | This value is true if the IP address is online; otherwise, it is false.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo()
Public Sub New
public:
UnicastIPAddressInfo()
DoubleTake.Core.Contract.UnicastIPAddressInfo = function();
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Properties

The UnicastIPAddressInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddress | This value is the IP address as a string.
Public property | IPv4Mask | This value is the the IPv4 subnet mask.
Public property | IsDHCP | This value is true if the IP address is a DHCP assigned address; otherwise, it is false.
Public property | IsNAT | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | IsOnline | This value is true if the IP address is online; otherwise, it is false.
Top
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.ExtensionData Property

UnicastIPAddressInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IPAddress Property

UnicastIPAddressInfoIPAddress Property

This value is the IP address as a string.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
function get_IPAddress();
function set_IPAddress(value);

Property Value

Type: String
The IP address as a string.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IPv4Mask Property

UnicastIPAddressInfoIPv4Mask Property

This value is the the IPv4 subnet mask.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string IPv4Mask { get; set; }
Public Property IPv4Mask As String
    Get
    Set
public:
property String^ IPv4Mask {
    String^ get ();
    void set (String^ value);
}
function get_IPv4Mask();
function set_IPv4Mask(value);

Property Value

Type: String
The IPv4 mask.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsDHCP Property

UnicastIPAddressInfoIsDHCP Property

This value is true if the IP address is a DHCP assigned address; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsDHCP { get; set; }
Public Property IsDHCP As Boolean
    Get
    Set
public:
property bool IsDHCP {
    bool get ();
    void set (bool value);
}
function get_IsDHCP();
function set_IsDHCP(value);

Property Value

Type: Boolean
if this address is a DHCP-assigned address; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsNAT Property

UnicastIPAddressInfoIsNAT Property

This value is true if the IP address is a public NAT address; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNAT { get; set; }
Public Property IsNAT As Boolean
    Get
    Set
public:
property bool IsNAT {
    bool get ();
    void set (bool value);
}
function get_IsNAT();
function set_IsNAT(value);

Property Value

Type: Boolean
if this instance is NAT; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.IsOnline Property

UnicastIPAddressInfoIsOnline Property

This value is true if the IP address is online; otherwise, it is false.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
function get_IsOnline();
function set_IsOnline(value);

Property Value

Type: Boolean
true if this instance is online; otherwise, false.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo Methods

The UnicastIPAddressInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.Equals Method

UnicastIPAddressInfoEquals Method

Indicates whether the current object is equal to another object of the same type.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Equals(
    UnicastIPAddressInfo other
)
Public Function Equals (
    other As UnicastIPAddressInfo
) As Boolean
public:
virtual bool Equals(
    UnicastIPAddressInfo^ other
) sealed
function Equals(other);

Parameters

other
Type: DoubleTake.Core.ContractUnicastIPAddressInfo
An object to compare with this object.

Return Value

Type: Boolean
if the current object is equal to the other parameter; otherwise, .
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


UnicastIPAddressInfo.GetHashCode Method

UnicastIPAddressInfoGetHashCode Method

Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

UnicastIPAddressInfo Class
DoubleTake.Core.Contract Namespace


VhdDeleteActionType Enumeration

Represents which virtual disks should be deleted when the protection is deleted.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum VhdDeleteActionType
Public Enumeration VhdDeleteActionType
public enum class VhdDeleteActionType
DoubleTake.Core.Contract.VhdDeleteActionType = function();
DoubleTake.Core.Contract.VhdDeleteActionType.createEnum('DoubleTake.Core.Contract.VhdDeleteActionType', false);
Members
Member name | Value | Description
KeepAll | 0 | Do not delete any virtual disks. You will be able to reuse the virtual disks for another protection job.
DeleteAll | 1 | Delete all virtual disks. You will not be able to reuse the virtual disks for another protection job.
UseVhdsToDelete | 2 | Delete the virtual disks identified in VhdsToDelete. You will not be able to reuse the deleted virtual disks for another protection job.
See Also

Reference

DoubleTake.Core.Contract Namespace


VolumeOptions Class

Represents a volume to protect and any changes to it's base configuration
Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRALogicalVolume
DoubleTake.Core.Contract.UVRAPhysicalVolume

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeOptions : Volume
Public Class VolumeOptions
    Inherits Volume
public ref class VolumeOptions : public Volume
DoubleTake.Core.Contract.VolumeOptions = function();

Type.createClass(
    'DoubleTake.Core.Contract.VolumeOptions',
    DoubleTake.Common.Contract.Volume);

The VolumeOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeOptions |
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}}
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored.
Public property | VolumeSignature | This value is the volume signature.
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract Namespace


VolumeOptions Constructor

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions()
Public Sub New
public:
VolumeOptions()
DoubleTake.Core.Contract.VolumeOptions = function();
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions Properties

The VolumeOptions type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume.
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}}
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored.
Public property | VolumeSignature | This value is the volume signature.
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DesiredSize Property

VolumeOptionsDesiredSize Property

This value is the desired size of the new volume.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long DesiredSize { get; set; }
Public Property DesiredSize As Long
    Get
    Set
public:
property long long DesiredSize {
    long long get ();
    void set (long long value);
}
function get_DesiredSize();
function set_DesiredSize(value);

Property Value

Type: Int64
The desired size.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DiskControllerType Property

VolumeOptionsDiskControllerType Property

This value is the disk controller.

IDE—Use this value to create an IDE disk.

SCSI—Use this value to create a SCSI disk.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
function get_DiskControllerType();
function set_DiskControllerType(value);

Property Value

Type: String
The type of the disk controller.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.DiskProvisioningType Property

VolumeOptionsDiskProvisioningType Property

This value is the disk type.

Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks.

Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks.

Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
function get_DiskProvisioningType();
function set_DiskProvisioningType(value);

Property Value

Type: String
The type of the disk provisioning.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.Guid Property

VolumeOptionsGuid Property

Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}}

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
Disk UUID of an existing virtual disk.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.PreexistingDiskPath Property

VolumeOptionsPreexistingDiskPath Property

This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_PreexistingDiskPath();
function set_PreexistingDiskPath(value);

Property Value

Type: String
The path of this preexisting path.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.VirtualDiskPath Property

VolumeOptionsVirtualDiskPath Property

This value is the path on the host where the volume should be stored.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
function get_VirtualDiskPath();
function set_VirtualDiskPath(value);

Property Value

Type: String
The path of this item.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.VolumeSignature Property

VolumeOptionsVolumeSignature Property

This value is the volume signature.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_VolumeSignature();
function set_VolumeSignature(value);

Property Value

Type: Byte
The volume signature.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions Methods

The VolumeOptions type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


VolumeOptions.Clone Method

VolumeOptionsClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

VolumeOptions Class
DoubleTake.Core.Contract Namespace


DoubleTake.Core.Contract.Connection Namespace

Classes
 | Class | Description
Public class | BandwidthLimit | Used for specifying the current or new bandwidth limit and/or mode.
Public class | BandwidthSchedule | Specifies a bandwidth limiting schedule for a connection. Used for both displaying and configuring the bandwidth schedule.
Public class | BandwidthScheduleEntry | An entry in a bandwidth limiting schedule.
Public class | BandwidthSpecification | Represents a commonly-used bandwidth size, as identified by a text description and a numberic speed. For example, "T1" is assocated with 193,000 bytes per second.
Public class | CompressionLevel | Represents a compression level that can be applied to a connection.
Public class | ConnectionSchedule |
Public class | ConnectionStartParameters | Used to define the parameters used when creating a connection that mirrors and replicates the protected data from the source to the target.
Public class | MirrorParameters |
Public class | OrphansSchedule | This value is true if orphan files (files in the target path location that are not present on the source) will be deleted; otherwise, it is false. There is currently no schedule (time-related options) for orphan files. They can only be on or off.
Public class | RestoreParameters | Represents the parameters required to start a restore operation for a connection.
Public class | ScriptPoint |
Public class | SnapshotEntry | Represents a snapshot created by the Windows Volume Snapshot Service.
Public class | SnapshotSchedule |
Public class | SourceQueueSnapshotEntry |
Public class | TargetStateInfo | Represents an engine connection from the perspective of the target server.
Public class | TaskParameters | Specifies a script or executable to be run along with its corresponding command-line arguments.
Public class | VerifySchedule |
Enumerations
 | Enumeration | Description
Public enumeration | BandwidthScheduleMode | Defines the mode of a bandwidth schedule.
Public enumeration | BandwidthSpecificationType | Defines possible types of bandwidth specifications.
Public enumeration | ClusterResourceState | Cluster Resource State Enumerations
Public enumeration | MirrorComparisonCriteria | Specifies how to compare files during a difference mirror or when running a verification report.
Public enumeration | MirrorOperationOptions | Specifies what to do when a verify mirror operation is performed.
Public enumeration | MirrorState | The operational state of mirroring.
Public enumeration | ReplicationState | The operational state of replication.
Public enumeration | RestoreOptions | Defines options that can be applied when restoring data.
Public enumeration | ScriptExecutionMode |
Public enumeration | ScriptPointType |
Public enumeration | SnapshotAttributes |
Public enumeration | SnapshotCreationReason | Indicates possible triggers for how a snapshot was taken.
Public enumeration | SnapshotState |
Public enumeration | TargetStates | Represent possible states of the target server.
Public enumeration | TransmissionMode | The operational state of data transmission from the source to target server.
Public enumeration | Weekdays | Defines the days of the week and common combinations of weekdays.


BandwidthLimit Class

Used for specifying the current or new bandwidth limit and/or mode.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthLimit

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class BandwidthLimit : IExtensibleDataObject
Public Class BandwidthLimit
    Implements IExtensibleDataObject
public ref class BandwidthLimit : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthLimit = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthLimit',
    null,
    IExtensibleDataObject);

The BandwidthLimit type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthLimit |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthLimit()
Public Sub New
public:
BandwidthLimit()
DoubleTake.Core.Contract.Connection.BandwidthLimit = function();
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit Properties

The BandwidthLimit type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode.
Top
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.ExtensionData Property

BandwidthLimitExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.Limit Property

BandwidthLimitLimit Property

This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The limit in Bps (bytes/second).
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthLimit.Mode Property

BandwidthLimitMode Property

This value is the bandwidth limiting mode.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The mode bandwidth limiting mode.
See Also

Reference

BandwidthLimit Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Class

Specifies a bandwidth limiting schedule for a connection. Used for both displaying and configuring the bandwidth schedule.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthSchedule : IExtensibleDataObject
Public NotInheritable Class BandwidthSchedule
    Implements IExtensibleDataObject
public ref class BandwidthSchedule sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthSchedule',
    null,
    IExtensibleDataObject);

The BandwidthSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSchedule |
Top
Properties
 | Name | Description
Public property | Current | This value is the current bandwidth schedule entry being used.
Public property | Entries | This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSchedule()
Public Sub New
public:
BandwidthSchedule()
DoubleTake.Core.Contract.Connection.BandwidthSchedule = function();
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule Properties

The BandwidthSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Current | This value is the current bandwidth schedule entry being used.
Public property | Entries | This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.
Top
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Current Property

BandwidthScheduleCurrent Property

This value is the current bandwidth schedule entry being used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry Current { get; set; }
Public Property Current As BandwidthScheduleEntry
    Get
    Set
public:
property BandwidthScheduleEntry^ Current {
    BandwidthScheduleEntry^ get ();
    void set (BandwidthScheduleEntry^ value);
}
function get_Current();
function set_Current(value);

Property Value

Type: BandwidthScheduleEntry
The active bandwidth schedule entry.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Entries Property

BandwidthScheduleEntries Property

This value represents the bandwidth schedule. This value is copied from BandwidthOptions.Entries.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry[] Entries { get; set; }
Public Property Entries As BandwidthScheduleEntry()
    Get
    Set
public:
property array<BandwidthScheduleEntry^>^ Entries {
    array<BandwidthScheduleEntry^>^ get ();
    void set (array<BandwidthScheduleEntry^>^ value);
}
function get_Entries();
function set_Entries(value);

Property Value

Type: BandwidthScheduleEntry
The array of bandwidth schedule entries.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.ExtensionData Property

BandwidthScheduleExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSchedule.Mode Property

BandwidthScheduleMode Property

This value is the bandwidth limiting mode. This value is copied from BandwidthOptions.Mode.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The current bandwidth schedule mode for a connection.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace
DoubleTake.Core.Contract.ConnectionBandwidthScheduleMode


BandwidthSchedule.Specifications Property

BandwidthScheduleSpecifications Property

This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied from BandwidthOptions.Specification.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecification()
    Get
    Set
public:
property array<BandwidthSpecification^>^ Specifications {
    array<BandwidthSpecification^>^ get ();
    void set (array<BandwidthSpecification^>^ value);
}
function get_Specifications();
function set_Specifications(value);

Property Value

Type: BandwidthSpecification
The bandwidth specifications.
See Also

Reference

BandwidthSchedule Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Class

An entry in a bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionBandwidthScheduleEntry

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthScheduleEntry : IExtensibleDataObject
Public NotInheritable Class BandwidthScheduleEntry
    Implements IExtensibleDataObject
public ref class BandwidthScheduleEntry sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry',
    null,
    IExtensibleDataObject);

The BandwidthScheduleEntry type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleEntry |
Top
Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleEntry()
Public Sub New
public:
BandwidthScheduleEntry()
DoubleTake.Core.Contract.Connection.BandwidthScheduleEntry = function();
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry Properties

The BandwidthScheduleEntry type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.DaysOfWeek Property

BandwidthScheduleEntryDaysOfWeek Property

This values is the days of the week to which the entry applies.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
function get_DaysOfWeek();
function set_DaysOfWeek(value);

Property Value

Type: Weekdays
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.ExtensionData Property

BandwidthScheduleEntryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.IsUnlimited Property

BandwidthScheduleEntryIsUnlimited Property

This value is true if the entry allows unlimited bandwidth; otherwise, it is false. entry is active.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
function get_IsUnlimited();
function set_IsUnlimited(value);

Property Value

Type: Boolean
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.Limit Property

BandwidthScheduleEntryLimit Property

This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.Name Property

BandwidthScheduleEntryName Property

This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleEntry.StartTime Property

BandwidthScheduleEntryStartTime Property

This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

BandwidthScheduleEntry Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthScheduleMode Enumeration

Defines the mode of a bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthScheduleMode
Public Enumeration BandwidthScheduleMode
public enum class BandwidthScheduleMode
DoubleTake.Core.Contract.Connection.BandwidthScheduleMode = function();
DoubleTake.Core.Contract.Connection.BandwidthScheduleMode.createEnum('DoubleTake.Core.Contract.Connection.BandwidthScheduleMode', false);
Members
Member name | Value | Description
NotLimited | 0 | Bandwidth is not limited.
Fixed | 1 | Bandwidth is limited to a fixed value.
Scheduled | 2 | Bandwidth is limited according to scheduled values.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Class

Represents a commonly-used bandwidth size, as identified by a text description and a numberic speed. For example, "T1" is assocated with 193,000 bytes per second.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionBandwidthSpecification

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthSpecification : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthSpecification
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthSpecification sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.BandwidthSpecification = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.BandwidthSpecification',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthSpecification type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSpecification |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Key | This value is a common name that represents a bandwidth specifications, for example T1.
Public property | Type | This value represents the bandwidth specification associated with the type of network (LAN or WAN).
Public property | Value | This value is the bandwidth limit in bytes per second.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification()
Public Sub New
public:
BandwidthSpecification()
DoubleTake.Core.Contract.Connection.BandwidthSpecification = function();
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification Properties

The BandwidthSpecification type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Key | This value is a common name that represents a bandwidth specifications, for example T1.
Public property | Type | This value represents the bandwidth specification associated with the type of network (LAN or WAN).
Public property | Value | This value is the bandwidth limit in bytes per second.
Top
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.ExtensionData Property

BandwidthSpecificationExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Key Property

BandwidthSpecificationKey Property

This value is a common name that represents a bandwidth specifications, for example T1.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
function get_Key();
function set_Key(value);

Property Value

Type: String
The name of the bandwidth specification.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Type Property

BandwidthSpecificationType Property

This value represents the bandwidth specification associated with the type of network (LAN or WAN).

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecificationType Type { get; set; }
Public Property Type As BandwidthSpecificationType
    Get
    Set
public:
property BandwidthSpecificationType Type {
    BandwidthSpecificationType get ();
    void set (BandwidthSpecificationType value);
}
function get_Type();
function set_Type(value);

Property Value

Type: BandwidthSpecificationType
The type of the bandwidth specification.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecification.Value Property

BandwidthSpecificationValue Property

This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
function get_Value();
function set_Value(value);

Property Value

Type: Int64
The speed of the bandwidth specification, in bytes per second.
See Also

Reference

BandwidthSpecification Class
DoubleTake.Core.Contract.Connection Namespace


BandwidthSpecificationType Enumeration

Defines possible types of bandwidth specifications.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthSpecificationType
Public Enumeration BandwidthSpecificationType
public enum class BandwidthSpecificationType
DoubleTake.Core.Contract.Connection.BandwidthSpecificationType = function();
DoubleTake.Core.Contract.Connection.BandwidthSpecificationType.createEnum('DoubleTake.Core.Contract.Connection.BandwidthSpecificationType', false);
Members
Member name | Value | Description
LAN | 0 | This value is the bandwidth associated with local area networks.
WAN | 1 | This value is the bandwidth associated with wide area networks.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ClusterResourceState Enumeration

Cluster Resource State Enumerations

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ClusterResourceState
Public Enumeration ClusterResourceState
public enum class ClusterResourceState
DoubleTake.Core.Contract.Connection.ClusterResourceState = function();
DoubleTake.Core.Contract.Connection.ClusterResourceState.createEnum('DoubleTake.Core.Contract.Connection.ClusterResourceState', false);
Members
Member name | Value | Description
Uninitialized | 0 | A cluster resource is not used.
OfflinePending | 1 | The resource state changed to offline pending.
Offline | 2 | The resource state changed to offline.
OnlinePending | 3 | The resource state changed to online pending.
Online | 4 | The resource state changed to online.
ResourceNotFound | 5 | The cluster resource was not found on the cluster.
Reconnected | 6 | The cluster resource reconnected. This could be due to a node roll.
Connected | 7 | The cluster resource is connected and online.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Class

Represents a compression level that can be applied to a connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionCompressionLevel

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CompressionLevel : IExtensibleDataObject
Public Class CompressionLevel
    Implements IExtensibleDataObject
public ref class CompressionLevel : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.CompressionLevel = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.CompressionLevel',
    null,
    IExtensibleDataObject);

The CompressionLevel type exposes the following members.

Constructors
 | Name | Description
Public method | CompressionLevel |
Top
Properties
 | Name | Description
Public property | Algorithm | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Level | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel()
Public Sub New
public:
CompressionLevel()
DoubleTake.Core.Contract.Connection.CompressionLevel = function();
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Properties

The CompressionLevel type exposes the following members.

Properties
 | Name | Description
Public property | Algorithm | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Level | The algorithm and level properties are used together in the following combinations. Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1. Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10. Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21. High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.
Top
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Algorithm Property

CompressionLevelAlgorithm Property

The algorithm and level properties are used together in the following combinations.

Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1.

Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10.

Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21.

High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Algorithm { get; set; }
Public Property Algorithm As Integer
    Get
    Set
public:
property int Algorithm {
    int get ();
    void set (int value);
}
function get_Algorithm();
function set_Algorithm(value);

Property Value

Type: Int32
The compression algorithm.
Remarks
The specific compression algorithm that is used by the source server to compress the data and by the target server to decompress the data. This value doesn't have any inherent meaning; it is simply a value shared between servers.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.ExtensionData Property

CompressionLevelExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Level Property

CompressionLevelLevel Property

The algorithm and level properties are used together in the following combinations.

Disabled—Compression is disabled if the level equals -1. The algorithm value is ignored when level equals -1.

Low compression—Compression is enabled at a low level if level equals 0 and algorithm equals 10.

Medium compression—Compression is enabled at a medium level if level equals 1 and algorithm equals 21.

High compression—Compression is enabled at a high level if level equals 2 and algorithm equals 31.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
function get_Level();
function set_Level(value);

Property Value

Type: Int32
The level of compression.
Remarks
This value is a 0-based index into the list of compression algorithms that are shared by both the source and target servers. Typically, there are three levels of compression: 0 (Low), 1 (Medium) and 2 (High). A value of -1 means that compression is not used.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel Methods

The CompressionLevel type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Top
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Clone Method

CompressionLevelClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.Equals Method

CompressionLevelEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


CompressionLevel.GetHashCode Method

CompressionLevelGetHashCode Method

Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

CompressionLevel Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Class

Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ConnectionSchedule : IExtensibleDataObject
Public NotInheritable Class ConnectionSchedule
    Implements IExtensibleDataObject
public ref class ConnectionSchedule sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionSchedule',
    null,
    IExtensibleDataObject);

The ConnectionSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionSchedule |
Top
Properties
 | Name | Description
Public property | Archive | This property is no longer used.
Public property | Bandwidth | This value represents the bandwidth schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Orphans | This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.
Public property | Transmission | This property is no longer used.
Public property | Verify | This value represents the verification schedule.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionSchedule()
Public Sub New
public:
ConnectionSchedule()
DoubleTake.Core.Contract.Connection.ConnectionSchedule = function();
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule Properties

The ConnectionSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Archive | This property is no longer used.
Public property | Bandwidth | This value represents the bandwidth schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Orphans | This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.
Public property | Transmission | This property is no longer used.
Public property | Verify | This value represents the verification schedule.
Top
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Archive Property

ConnectionScheduleArchive Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveSchedule Archive { get; set; }
Public Property Archive As ArchiveSchedule
    Get
    Set
public:
property ArchiveSchedule^ Archive {
    ArchiveSchedule^ get ();
    void set (ArchiveSchedule^ value);
}
function get_Archive();
function set_Archive(value);

Property Value

Type: ArchiveSchedule
The archive.
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Bandwidth Property

ConnectionScheduleBandwidth Property

This value represents the bandwidth schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSchedule Bandwidth { get; set; }
Public Property Bandwidth As BandwidthSchedule
    Get
    Set
public:
property BandwidthSchedule^ Bandwidth {
    BandwidthSchedule^ get ();
    void set (BandwidthSchedule^ value);
}
function get_Bandwidth();
function set_Bandwidth(value);

Property Value

Type: BandwidthSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.ExtensionData Property

ConnectionScheduleExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Orphans Property

ConnectionScheduleOrphans Property

This value represents if orphan files (files in the target path location that are not present on the source) will be deleted. There is currently no schedule (time-related options) for orphan files. They can only be deleted or left on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OrphansSchedule Orphans { get; set; }
Public Property Orphans As OrphansSchedule
    Get
    Set
public:
property OrphansSchedule^ Orphans {
    OrphansSchedule^ get ();
    void set (OrphansSchedule^ value);
}
function get_Orphans();
function set_Orphans(value);

Property Value

Type: OrphansSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Transmission Property

ConnectionScheduleTransmission Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionSchedule Transmission { get; set; }
Public Property Transmission As TransmissionSchedule
    Get
    Set
public:
property TransmissionSchedule^ Transmission {
    TransmissionSchedule^ get ();
    void set (TransmissionSchedule^ value);
}
function get_Transmission();
function set_Transmission(value);

Property Value

Type: TransmissionSchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionSchedule.Verify Property

ConnectionScheduleVerify Property

This value represents the verification schedule.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VerifySchedule Verify { get; set; }
Public Property Verify As VerifySchedule
    Get
    Set
public:
property VerifySchedule^ Verify {
    VerifySchedule^ get ();
    void set (VerifySchedule^ value);
}
function get_Verify();
function set_Verify(value);

Property Value

Type: VerifySchedule
See Also

Reference

ConnectionSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Class

Used to define the parameters used when creating a connection that mirrors and replicates the protected data from the source to the target.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionConnectionStartParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ConnectionStartParameters : IExtensibleDataObject
Public NotInheritable Class ConnectionStartParameters
    Implements IExtensibleDataObject
public ref class ConnectionStartParameters sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ConnectionStartParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ConnectionStartParameters',
    null,
    IExtensibleDataObject);

The ConnectionStartParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStartParameters |
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used.
Public property | CompressionLevel | This value represents the compression to use for data passed over the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEncrypted | This value is true if the connection data is to be encrypted; otherwise, it is false.
Public property | IsMirrorEnabled | This value is true if a mirror is started when the connection is created; otherwise, it is false.
Public property | IsPathBlockingEnabled | This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is started when the connection is created; otherwise, it is false.
Public property | IsRestore | This value is true if the connection is a restoration mirror; otherwise, it is false.
Public property | MirrorParameters | This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.
Public property | Schedule | This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.
Public property | ScriptPoints | This value represents the scripts to be run at specific points during mirroring.
Public property | SnapshotSchedule | This value represents the snapshot schedule for the target.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters()
Public Sub New
public:
ConnectionStartParameters()
DoubleTake.Core.Contract.Connection.ConnectionStartParameters = function();
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters Properties

The ConnectionStartParameters type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used.
Public property | CompressionLevel | This value represents the compression to use for data passed over the connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsEncrypted | This value is true if the connection data is to be encrypted; otherwise, it is false.
Public property | IsMirrorEnabled | This value is true if a mirror is started when the connection is created; otherwise, it is false.
Public property | IsPathBlockingEnabled | This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.
Public property | IsReplicationEnabled | This value is true if replication is started when the connection is created; otherwise, it is false.
Public property | IsRestore | This value is true if the connection is a restoration mirror; otherwise, it is false.
Public property | MirrorParameters | This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.
Public property | Schedule | This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.
Public property | ScriptPoints | This value represents the scripts to be run at specific points during mirroring.
Public property | SnapshotSchedule | This value represents the snapshot schedule for the target.
Top
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.ArchiveBinLocation Property

ConnectionStartParametersArchiveBinLocation Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
function get_ArchiveBinLocation();
function set_ArchiveBinLocation(value);

Property Value

Type: String
The archive bin location.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.CompressionLevel Property

ConnectionStartParametersCompressionLevel Property

This value represents the compression to use for data passed over the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
    Get
    Set
public:
property CompressionLevel^ CompressionLevel {
    CompressionLevel^ get ();
    void set (CompressionLevel^ value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: CompressionLevel
The compression level.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace
ConnectionStartParametersCompressionLevel


ConnectionStartParameters.ExtensionData Property

ConnectionStartParametersExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsEncrypted Property

ConnectionStartParametersIsEncrypted Property

This value is true if the connection data is to be encrypted; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEncrypted { get; set; }
Public Property IsEncrypted As Boolean
    Get
    Set
public:
property bool IsEncrypted {
    bool get ();
    void set (bool value);
}
function get_IsEncrypted();
function set_IsEncrypted(value);

Property Value

Type: Boolean
if the connection data is to be encrypted; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsMirrorEnabled Property

ConnectionStartParametersIsMirrorEnabled Property

This value is true if a mirror is started when the connection is created; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsMirrorEnabled { get; set; }
Public Property IsMirrorEnabled As Boolean
    Get
    Set
public:
property bool IsMirrorEnabled {
    bool get ();
    void set (bool value);
}
function get_IsMirrorEnabled();
function set_IsMirrorEnabled(value);

Property Value

Type: Boolean
if a mirror is to be started; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsPathBlockingEnabled Property

ConnectionStartParametersIsPathBlockingEnabled Property

This value is true if the destination paths on the target are blocked for writing, except by Double-Take; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsPathBlockingEnabled { get; set; }
Public Property IsPathBlockingEnabled As Boolean
    Get
    Set
public:
property bool IsPathBlockingEnabled {
    bool get ();
    void set (bool value);
}
function get_IsPathBlockingEnabled();
function set_IsPathBlockingEnabled(value);

Property Value

Type: Boolean
if path blocking is enabled; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsReplicationEnabled Property

ConnectionStartParametersIsReplicationEnabled Property

This value is true if replication is started when the connection is created; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
function get_IsReplicationEnabled();
function set_IsReplicationEnabled(value);

Property Value

Type: Boolean
if replication will be enabled; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.IsRestore Property

ConnectionStartParametersIsRestore Property

This value is true if the connection is a restoration mirror; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsRestore { get; set; }
Public Property IsRestore As Boolean
    Get
    Set
public:
property bool IsRestore {
    bool get ();
    void set (bool value);
}
function get_IsRestore();
function set_IsRestore(value);

Property Value

Type: Boolean
if this connection is a restore connection; otherwise, .
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.MirrorParameters Property

ConnectionStartParametersMirrorParameters Property

This value represents the mirror parameters used for the connection. If this value is null, the default mirror parameters will be used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorParameters MirrorParameters { get; set; }
Public Property MirrorParameters As MirrorParameters
    Get
    Set
public:
property MirrorParameters^ MirrorParameters {
    MirrorParameters^ get ();
    void set (MirrorParameters^ value);
}
function get_MirrorParameters();
function set_MirrorParameters(value);

Property Value

Type: MirrorParameters
The mirror parameters.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.Schedule Property

ConnectionStartParametersSchedule Property

This value represents the bandwidth, orphans, and verification schedule. These schedule settings will be applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you are creating, any schedule changes will be applied to that connection as well.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionSchedule Schedule { get; set; }
Public Property Schedule As ConnectionSchedule
    Get
    Set
public:
property ConnectionSchedule^ Schedule {
    ConnectionSchedule^ get ();
    void set (ConnectionSchedule^ value);
}
function get_Schedule();
function set_Schedule(value);

Property Value

Type: ConnectionSchedule
The schedule.
Remarks
Note that some schedule settings will get applied to all connections that share the same route to the same target. Therefore, if a connection exists over the same route to the same target as the connection you're creating, these schedule changes will be applied to that connection as well.
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.ScriptPoints Property

ConnectionStartParametersScriptPoints Property

This value represents the scripts to be run at specific points during mirroring.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPoint[] ScriptPoints { get; set; }
Public Property ScriptPoints As ScriptPoint()
    Get
    Set
public:
property array<ScriptPoint^>^ ScriptPoints {
    array<ScriptPoint^>^ get ();
    void set (array<ScriptPoint^>^ value);
}
function get_ScriptPoints();
function set_ScriptPoints(value);

Property Value

Type: ScriptPoint
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


ConnectionStartParameters.SnapshotSchedule Property

ConnectionStartParametersSnapshotSchedule Property

This value represents the snapshot schedule for the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSchedule SnapshotSchedule { get; set; }
Public Property SnapshotSchedule As SnapshotSchedule
    Get
    Set
public:
property SnapshotSchedule^ SnapshotSchedule {
    SnapshotSchedule^ get ();
    void set (SnapshotSchedule^ value);
}
function get_SnapshotSchedule();
function set_SnapshotSchedule(value);

Property Value

Type: SnapshotSchedule
See Also

Reference

ConnectionStartParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorComparisonCriteria Enumeration

Specifies how to compare files during a difference mirror or when running a verification report.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorComparisonCriteria
Public Enumeration MirrorComparisonCriteria
public enum class MirrorComparisonCriteria
DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria = function();
DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria.createEnum('DoubleTake.Core.Contract.Connection.MirrorComparisonCriteria', false);
Members
Member name | Value | Description
None | 0 | Double-Take will not perform any comparison between the files on the source and target.
Newer | 1 | Double-Take will compare file attributes between the files on the source and target.
Checksum | 2 | Double-Take will compare file attributes and file data between files on the source and target.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorOperationOptions Enumeration

Specifies what to do when a verify mirror operation is performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorOperationOptions
Public Enumeration MirrorOperationOptions
public enum class MirrorOperationOptions
DoubleTake.Core.Contract.Connection.MirrorOperationOptions = function();
DoubleTake.Core.Contract.Connection.MirrorOperationOptions.createEnum('DoubleTake.Core.Contract.Connection.MirrorOperationOptions', false);
Members
Member name | Value | Description
None | 0 | Double-Take will not mirror any files.
Synchronize | 1 | Double-Take will mirror the files from the source to the target. If you use this property by itself, all files will be mirrored. If you use this property with CalculateDifferences, only the differences will be mirrored.
Report | 2 | Double-Take will only report the differences found between the source protected data set and the replica on the target. You must use this option with CalculateDifferences in order for the differences to be reported.
CalculateDifferences | 4 | The mirroring operation will calculate the differences between the source protected data and the replica on the target using MirrorComparisonCriteria.
CalculateSize | 8 | The mirroring operation will calculate the size of the source protected data set.
ProcessOrphans | 16 | The mirroring operation will process orphan files (files in the target path location that are not present on the source).
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Class

Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionMirrorParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class MirrorParameters : IExtensibleDataObject
Public NotInheritable Class MirrorParameters
    Implements IExtensibleDataObject
public ref class MirrorParameters sealed : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.MirrorParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.MirrorParameters',
    null,
    IExtensibleDataObject);

The MirrorParameters type exposes the following members.

Constructors
 | Name | Description
Public method | MirrorParameters |
Top
Properties
 | Name | Description
Public property | ComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Options | This value represents what mirror operation will be performed.
Public property | OverrideJobOrphansProcessing | This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorParameters()
Public Sub New
public:
MirrorParameters()
DoubleTake.Core.Contract.Connection.MirrorParameters = function();
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters Properties

The MirrorParameters type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Options | This value represents what mirror operation will be performed.
Public property | OverrideJobOrphansProcessing | This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.
Top
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.ComparisonCriteria Property

MirrorParametersComparisonCriteria Property

This value represents how to compare the source protected data and the replica on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria ComparisonCriteria { get; set; }
Public Property ComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria ComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_ComparisonCriteria();
function set_ComparisonCriteria(value);

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.ExtensionData Property

MirrorParametersExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains the extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.Options Property

MirrorParametersOptions Property

This value represents what mirror operation will be performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
function get_Options();
function set_Options(value);

Property Value

Type: MirrorOperationOptions
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorParameters.OverrideJobOrphansProcessing Property

MirrorParametersOverrideJobOrphansProcessing Property

This value is true if the job's orphan file setting is to be overridden; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool OverrideJobOrphansProcessing { get; set; }
Public Property OverrideJobOrphansProcessing As Boolean
    Get
    Set
public:
property bool OverrideJobOrphansProcessing {
    bool get ();
    void set (bool value);
}
function get_OverrideJobOrphansProcessing();
function set_OverrideJobOrphansProcessing(value);

Property Value

Type: Boolean
if the job's orphans processing setting is to be overridden; otherwise, .
See Also

Reference

MirrorParameters Class
DoubleTake.Core.Contract.Connection Namespace


MirrorState Enumeration

The operational state of mirroring.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum MirrorState
Public Enumeration MirrorState
public enum class MirrorState
DoubleTake.Core.Contract.Connection.MirrorState = function();
DoubleTake.Core.Contract.Connection.MirrorState.createEnum('DoubleTake.Core.Contract.Connection.MirrorState', false);
Members
Member name | Value | Description
Calculating | 0 | The size of the replication set is being calculated.
Idle | 1 | No data is being mirrored to the target.
Mirror | 2 | Data is being mirrored to the target.
Pause | 3 | Mirroring is paused.
RemoveOrphans | 4 | Orphan files (files in the target path location that are not present on the source) are being deleted.
RepsetVerify | 5 | The source protected data set is being verified against the target replica data.
Restore | 6 | Replica data from the target is being restored to the source.
Stopped | 7 | Mirroring is stopped.
Waiting | 8 | Mirroring is complete, but data is still being written to the target.
Unknown | 9 | The mirror is in an unknown or error state.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Class

This value is true if orphan files (files in the target path location that are not present on the source) will be deleted; otherwise, it is false. There is currently no schedule (time-related options) for orphan files. They can only be on or off.
Inheritance Hierarchy
SystemObject
ScheduleItem
DoubleTake.Core.Contract.ConnectionOrphansSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class OrphansSchedule : ScheduleItem
Public Class OrphansSchedule
    Inherits ScheduleItem
public ref class OrphansSchedule : public ScheduleItem
DoubleTake.Core.Contract.Connection.OrphansSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.OrphansSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The OrphansSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | OrphansSchedule |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public OrphansSchedule()
Public Sub New
public:
OrphansSchedule()
DoubleTake.Core.Contract.Connection.OrphansSchedule = function();
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule Methods

The OrphansSchedule type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


OrphansSchedule.Clone Method

OrphansScheduleClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

OrphansSchedule Class
DoubleTake.Core.Contract.Connection Namespace


ReplicationState Enumeration

The operational state of replication.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ReplicationState
Public Enumeration ReplicationState
public enum class ReplicationState
DoubleTake.Core.Contract.Connection.ReplicationState = function();
DoubleTake.Core.Contract.Connection.ReplicationState.createEnum('DoubleTake.Core.Contract.Connection.ReplicationState', false);
Members
Member name | Value | Description
NotReplicating | 0 | Replication is stopped.
OutOfMemory | 1 | Replication memory has been exhausted.
Pending | 2 | Replication is pending.
Replicating | 3 | Data is being replicated to the target.
Unknown | 4 | Replication is in an unknown or error state.
Watchdog | 5 | The Double-Take service is not receiving replication operations from the Double-Take driver. Check the event log for driver related issues.
Ready | 6 | There is no data to replicate.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreOptions Enumeration

Defines options that can be applied when restoring data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreOptions
Public Enumeration RestoreOptions
public enum class RestoreOptions
DoubleTake.Core.Contract.Connection.RestoreOptions = function();
DoubleTake.Core.Contract.Connection.RestoreOptions.createEnum('DoubleTake.Core.Contract.Connection.RestoreOptions', false);
Members
Member name | Value | Description
None | 0 | No additional restoration options will be used.
UseTargetWorkload | 1 | Use the workload information that is stored on the target instead of any workload information that is persisted on the source.
RestoreWorkloadToSource | 2 | Restore the workload information from the target to the source. This property can only be used with UseTargetWorkload.
OverwriteExistingFiles | 4 | Overwrite all existing files on the source during the restoration.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Class

Represents the parameters required to start a restore operation for a connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionRestoreParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RestoreParameters : IExtensibleDataObject
Public Class RestoreParameters
    Implements IExtensibleDataObject
public ref class RestoreParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.RestoreParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.RestoreParameters',
    null,
    IExtensibleDataObject);

The RestoreParameters type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreParameters |
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used
Public property | ArchiveOption | This property is no longer used.
Public property | CompressionLevel | This value represents how data will be compressed when it is transmitted from the source to the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | OriginalSourceName | This value is the name of the original source server from the original protection job.
Public property | OriginalTargetRoute | This value is the route for the original target server from the original protection job.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | ProcessOrphans | This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | RestoreOptions | This value represents additional options used for the restoration process.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreParameters()
Public Sub New
public:
RestoreParameters()
DoubleTake.Core.Contract.Connection.RestoreParameters = function();
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters Properties

The RestoreParameters type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | This property is no longer used
Public property | ArchiveOption | This property is no longer used.
Public property | CompressionLevel | This value represents how data will be compressed when it is transmitted from the source to the target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MirrorComparisonCriteria | This value represents how to compare the source protected data and the replica on the target.
Public property | OriginalSourceName | This value is the name of the original source server from the original protection job.
Public property | OriginalTargetRoute | This value is the route for the original target server from the original protection job.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | ProcessOrphans | This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | RestoreOptions | This value represents additional options used for the restoration process.
Top
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ArchiveBinLocation Property

RestoreParametersArchiveBinLocation Property

This property is no longer used

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
function get_ArchiveBinLocation();
function set_ArchiveBinLocation(value);

Property Value

Type: String
The archive bin location.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ArchiveOption Property

RestoreParametersArchiveOption Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ArchiveRestoreOption ArchiveOption { get; set; }
Public Property ArchiveOption As ArchiveRestoreOption
    Get
    Set
public:
property ArchiveRestoreOption ArchiveOption {
    ArchiveRestoreOption get ();
    void set (ArchiveRestoreOption value);
}
function get_ArchiveOption();
function set_ArchiveOption(value);

Property Value

Type: ArchiveRestoreOption
The archive option.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.CompressionLevel Property

RestoreParametersCompressionLevel Property

This value represents how data will be compressed when it is transmitted from the source to the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevel
    Get
    Set
public:
property CompressionLevel^ CompressionLevel {
    CompressionLevel^ get ();
    void set (CompressionLevel^ value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: CompressionLevel
The compression level.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ExtensionData Property

RestoreParametersExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.MirrorComparisonCriteria Property

RestoreParametersMirrorComparisonCriteria Property

This value represents how to compare the source protected data and the replica on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria MirrorComparisonCriteria { get; set; }
Public Property MirrorComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria MirrorComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_MirrorComparisonCriteria();
function set_MirrorComparisonCriteria(value);

Property Value

Type: MirrorComparisonCriteria
The comparison criteria.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.OriginalSourceName Property

RestoreParametersOriginalSourceName Property

This value is the name of the original source server from the original protection job.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalSourceName { get; set; }
Public Property OriginalSourceName As String
    Get
    Set
public:
property String^ OriginalSourceName {
    String^ get ();
    void set (String^ value);
}
function get_OriginalSourceName();
function set_OriginalSourceName(value);

Property Value

Type: String
The name of the original source.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.OriginalTargetRoute Property

RestoreParametersOriginalTargetRoute Property

This value is the route for the original target server from the original protection job.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalTargetRoute { get; set; }
Public Property OriginalTargetRoute As String
    Get
    Set
public:
property String^ OriginalTargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_OriginalTargetRoute();
function set_OriginalTargetRoute(value);

Property Value

Type: String
The original target route.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.PathTransformations Property

RestoreParametersPathTransformations Property

This value represents where the source protected data will be located on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ProcessOrphans Property

RestoreParametersProcessOrphans Property

This value is true if the orphan files (files in the target path location that are not present on the source) are to be deleted; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ProcessOrphans { get; set; }
Public Property ProcessOrphans As Boolean
    Get
    Set
public:
property bool ProcessOrphans {
    bool get ();
    void set (bool value);
}
function get_ProcessOrphans();
function set_ProcessOrphans(value);

Property Value

Type: Boolean
if orphans are to be processed; otherwise, .
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.ReplicationSetName Property

RestoreParametersReplicationSetName Property

This value is the name of the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicationSetName();
function set_ReplicationSetName(value);

Property Value

Type: String
The name of the replication set.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


RestoreParameters.RestoreOptions Property

RestoreParametersRestoreOptions Property

This value represents additional options used for the restoration process.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptions
    Get
    Set
public:
property RestoreOptions RestoreOptions {
    RestoreOptions get ();
    void set (RestoreOptions value);
}
function get_RestoreOptions();
function set_RestoreOptions(value);

Property Value

Type: RestoreOptions
The options.
See Also

Reference

RestoreParameters Class
DoubleTake.Core.Contract.Connection Namespace


ScriptExecutionMode Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ScriptExecutionMode
Public Enumeration ScriptExecutionMode
public enum class ScriptExecutionMode
DoubleTake.Core.Contract.Connection.ScriptExecutionMode = function();
DoubleTake.Core.Contract.Connection.ScriptExecutionMode.createEnum('DoubleTake.Core.Contract.Connection.ScriptExecutionMode', false);
Members
Member name | Value | Description
Synchronous | 0 | Double-Take will wait while the script is executed.
Asynchronous | 1 | Double-Take will not wait while the script is executed.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Class

Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionScriptPoint

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class ScriptPoint : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class ScriptPoint
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class ScriptPoint sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.ScriptPoint = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.ScriptPoint',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The ScriptPoint type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptPoint |
Top
Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExecutionMode | This value represents if Double-Take will wait while executing the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InteractionMode | This value represents if script processing will display on screen.
Public property | Path | This value is the full path and file name of the script.
Public property | Type | This value represents the type of script to execute.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPoint()
Public Sub New
public:
ScriptPoint()
DoubleTake.Core.Contract.Connection.ScriptPoint = function();
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint Properties

The ScriptPoint type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExecutionMode | This value represents if Double-Take will wait while executing the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InteractionMode | This value represents if script processing will display on screen.
Public property | Path | This value is the full path and file name of the script.
Public property | Type | This value represents the type of script to execute.
Top
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Arguments Property

ScriptPointArguments Property

This value is a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The arguments.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.ExecutionMode Property

ScriptPointExecutionMode Property

This value represents if Double-Take will wait while executing the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptExecutionMode ExecutionMode { get; set; }
Public Property ExecutionMode As ScriptExecutionMode
    Get
    Set
public:
property ScriptExecutionMode ExecutionMode {
    ScriptExecutionMode get ();
    void set (ScriptExecutionMode value);
}
function get_ExecutionMode();
function set_ExecutionMode(value);

Property Value

Type: ScriptExecutionMode
The execution mode.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.ExtensionData Property

ScriptPointExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.InteractionMode Property

ScriptPointInteractionMode Property

This value represents if script processing will display on screen.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DesktopInteractionMode InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode InteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
function get_InteractionMode();
function set_InteractionMode(value);

Property Value

Type: DesktopInteractionMode
The interaction mode.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Path Property

ScriptPointPath Property

This value is the full path and file name of the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
The path.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPoint.Type Property

ScriptPointType Property

This value represents the type of script to execute.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ScriptPointType Type { get; set; }
Public Property Type As ScriptPointType
    Get
    Set
public:
property ScriptPointType Type {
    ScriptPointType get ();
    void set (ScriptPointType value);
}
function get_Type();
function set_Type(value);

Property Value

Type: ScriptPointType
The type.
See Also

Reference

ScriptPoint Class
DoubleTake.Core.Contract.Connection Namespace


ScriptPointType Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ScriptPointType
Public Enumeration ScriptPointType
public enum class ScriptPointType
DoubleTake.Core.Contract.Connection.ScriptPointType = function();
DoubleTake.Core.Contract.Connection.ScriptPointType.createEnum('DoubleTake.Core.Contract.Connection.ScriptPointType', false);
Members
Member name | Value | Description
MirrorStart | 0 | The script is executed when the target receives the first mirror operation. In the case of a difference mirror, this may be a long time after the mirror is started because the script does not start until the first different data is received on the target. If the data is synchronized and a difference mirror finds nothing to mirror, the script will not be executed.
MirrorComplete | 1 | The script is executed when a mirror is completed. Because the mirror statistics may indicate a mirror is at 99-100% when it is actually still processing (for example, if files were added after the job size was calculated, if there are alternate data streams, and so on), the script will not start until all of the mirror data has been completely processed on the target.
MirrorStop | 2 | The script is executed when a mirror is stopped, which may be caused by an auto-disconnect occurring while a mirror is running, the service is shutdown while a mirror is running, or if you stop a mirror manually.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotAttributes Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotAttributes
Public Enumeration SnapshotAttributes
public enum class SnapshotAttributes
DoubleTake.Core.Contract.Connection.SnapshotAttributes = function();
DoubleTake.Core.Contract.Connection.SnapshotAttributes.createEnum('DoubleTake.Core.Contract.Connection.SnapshotAttributes', false);
Members
Member name | Value | Description
None | 0 |
JobManaged | 1 |
ActiveTest | 2 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotCreationReason Enumeration

Indicates possible triggers for how a snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotCreationReason
Public Enumeration SnapshotCreationReason
public enum class SnapshotCreationReason
DoubleTake.Core.Contract.Connection.SnapshotCreationReason = function();
DoubleTake.Core.Contract.Connection.SnapshotCreationReason.createEnum('DoubleTake.Core.Contract.Connection.SnapshotCreationReason', false);
Members
Member name | Value | Description
Manual | 0 | A user took the snapshot.
Automatic | 1 | Double-Take automatically took the snapshot.
Scheduled | 2 | Double-Take took the snapshot according to a snapshot schedule.
Deferred | 3 | Double-Take took the snapshot as part of a snapshot scheduled, although it did not occur at the specified interval because the job between the source and target was not in a good state.
DataTest | 4 | Double-Take took the snapshot as part of a test.
Coordinated | 5 | Double-Take took the coordinated.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Class

Represents a snapshot created by the Windows Volume Snapshot Service.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionSnapshotEntry

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class SnapshotEntry : ObservableObject,
    IExtensibleDataObject
Public Class SnapshotEntry
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class SnapshotEntry : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.SnapshotEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.SnapshotEntry',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The SnapshotEntry type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotEntry |
Top
Properties
 | Name | Description
Public property | Attributes |
Public property | Comment | This value is any description associated with the snapshot.
Public property | ConName | This value is the connectionName (conName, repsetName) for the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID for the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | States | This value represents the state of the target associated with the snapshot.
Public property | Timestamp | This value is the time when the snapshot was taken.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry()
Public Sub New
public:
SnapshotEntry()
DoubleTake.Core.Contract.Connection.SnapshotEntry = function();
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry Properties

The SnapshotEntry type exposes the following members.

Properties
 | Name | Description
Public property | Attributes |
Public property | Comment | This value is any description associated with the snapshot.
Public property | ConName | This value is the connectionName (conName, repsetName) for the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID for the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | States | This value represents the state of the target associated with the snapshot.
Public property | Timestamp | This value is the time when the snapshot was taken.
Top
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Attributes Property

SnapshotEntryAttributes Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotAttributes Attributes { get; set; }
Public Property Attributes As SnapshotAttributes
    Get
    Set
public:
property SnapshotAttributes Attributes {
    SnapshotAttributes get ();
    void set (SnapshotAttributes value);
}
function get_Attributes();
function set_Attributes(value);

Property Value

Type: SnapshotAttributes
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Comment Property

SnapshotEntryComment Property

This value is any description associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
function get_Comment();
function set_Comment(value);

Property Value

Type: String
The comment associate with this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.ConName Property

SnapshotEntryConName Property

This value is the connectionName (conName, repsetName) for the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ConName { get; set; }
Public Property ConName As String
    Get
    Set
public:
property String^ ConName {
    String^ get ();
    void set (String^ value);
}
function get_ConName();
function set_ConName(value);

Property Value

Type: String
The unique identifier of this connection.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.ExtensionData Property

SnapshotEntryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Id Property

SnapshotEntryId Property

This value is the unique ID for the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Reason Property

SnapshotEntryReason Property

This value represents why the snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotCreationReason Reason { get; set; }
Public Property Reason As SnapshotCreationReason
    Get
    Set
public:
property SnapshotCreationReason Reason {
    SnapshotCreationReason get ();
    void set (SnapshotCreationReason value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: SnapshotCreationReason
The reason for taking this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.States Property

SnapshotEntryStates Property

This value represents the state of the target associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates States { get; set; }
Public Property States As TargetStates
    Get
    Set
public:
property TargetStates States {
    TargetStates get ();
    void set (TargetStates value);
}
function get_States();
function set_States(value);

Property Value

Type: TargetStates
The states of the target server associated with this snapshot.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotEntry.Timestamp Property

SnapshotEntryTimestamp Property

This value is the time when the snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTimeOffset
The time when this snapshot was taken.
See Also

Reference

SnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Class

Inheritance Hierarchy
SystemObject
ScheduleItem
DoubleTake.Core.Contract.ConnectionSnapshotSchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class SnapshotSchedule : ScheduleItem
Public NotInheritable Class SnapshotSchedule
    Inherits ScheduleItem
public ref class SnapshotSchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.SnapshotSchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.SnapshotSchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The SnapshotSchedule type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotSchedule |
Top
Properties
 | Name | Description
Public property | Interval | This value is the interval for taking snapshots.
Public property | MaxNumberOfSnapshots | This value is the maximum number of snapshots that will be retained.
Public property | StartTime | This value is the when the snapshot schedule should start.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSchedule()
Public Sub New
public:
SnapshotSchedule()
DoubleTake.Core.Contract.Connection.SnapshotSchedule = function();
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule Properties

The SnapshotSchedule type exposes the following members.

Properties
 | Name | Description
Public property | Interval | This value is the interval for taking snapshots.
Public property | MaxNumberOfSnapshots | This value is the maximum number of snapshots that will be retained.
Public property | StartTime | This value is the when the snapshot schedule should start.
Top
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.Interval Property

SnapshotScheduleInterval Property

This value is the interval for taking snapshots.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: TimeSpan
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.MaxNumberOfSnapshots Property

SnapshotScheduleMaxNumberOfSnapshots Property

This value is the maximum number of snapshots that will be retained.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MaxNumberOfSnapshots { get; set; }
Public Property MaxNumberOfSnapshots As Integer
    Get
    Set
public:
property int MaxNumberOfSnapshots {
    int get ();
    void set (int value);
}
function get_MaxNumberOfSnapshots();
function set_MaxNumberOfSnapshots(value);

Property Value

Type: Int32
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotSchedule.StartTime Property

SnapshotScheduleStartTime Property

This value is the when the snapshot schedule should start.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

SnapshotSchedule Class
DoubleTake.Core.Contract.Connection Namespace


SnapshotState Enumeration

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum SnapshotState
Public Enumeration SnapshotState
public enum class SnapshotState
DoubleTake.Core.Contract.Connection.SnapshotState = function();
DoubleTake.Core.Contract.Connection.SnapshotState.createEnum('DoubleTake.Core.Contract.Connection.SnapshotState', false);
Members
Member name | Value | Description
Complete | 0 |
Pending | 1 |
Error | 2 |
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry Class

Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.ConnectionSourceQueueSnapshotEntry

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class SourceQueueSnapshotEntry : ObservableObject,
    IExtensibleDataObject
Public Class SourceQueueSnapshotEntry
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class SourceQueueSnapshotEntry : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Connection.SourceQueueSnapshotEntry = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.SourceQueueSnapshotEntry',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The SourceQueueSnapshotEntry type exposes the following members.

Constructors
 | Name | Description
Public method | SourceQueueSnapshotEntry |
Top
Properties
 | Name | Description
Public property | CorrelationId | This value is the Coordinated ID for the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobId |
Public property | Quality | This value represents the quality associated with the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | SnapshotSetId | This value is the Coordinated ID for the snapshot.
Public property | SourceAddress | This value is the stored source address.
Public property | State |
Public property | TargetStates | This value represents the state of the target associated with the snapshot.
Public property | TimeStampCompleted | This value is the time when the snapshot was completed.
Public property | TimeStampRequested | This value is the time when the snapshot was requested.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SourceQueueSnapshotEntry()
Public Sub New
public:
SourceQueueSnapshotEntry()
DoubleTake.Core.Contract.Connection.SourceQueueSnapshotEntry = function();
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry Properties

The SourceQueueSnapshotEntry type exposes the following members.

Properties
 | Name | Description
Public property | CorrelationId | This value is the Coordinated ID for the snapshot.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobId |
Public property | Quality | This value represents the quality associated with the snapshot.
Public property | Reason | This value represents why the snapshot was taken.
Public property | SnapshotSetId | This value is the Coordinated ID for the snapshot.
Public property | SourceAddress | This value is the stored source address.
Public property | State |
Public property | TargetStates | This value represents the state of the target associated with the snapshot.
Public property | TimeStampCompleted | This value is the time when the snapshot was completed.
Public property | TimeStampRequested | This value is the time when the snapshot was requested.
Top
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.CorrelationId Property

SourceQueueSnapshotEntryCorrelationId Property

This value is the Coordinated ID for the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid CorrelationId { get; set; }
Public Property CorrelationId As Guid
    Get
    Set
public:
property Guid CorrelationId {
    Guid get ();
    void set (Guid value);
}
function get_CorrelationId();
function set_CorrelationId(value);

Property Value

Type: Guid
The unique identifier of this snapshot.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.ExtensionData Property

SourceQueueSnapshotEntryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.JobId Property

SourceQueueSnapshotEntryJobId Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid JobId { get; set; }
Public Property JobId As Guid
    Get
    Set
public:
property Guid JobId {
    Guid get ();
    void set (Guid value);
}
function get_JobId();
function set_JobId(value);

Property Value

Type: Guid
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.Quality Property

SourceQueueSnapshotEntryQuality Property

This value represents the quality associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotQuality Quality { get; set; }
Public Property Quality As SnapshotQuality
    Get
    Set
public:
property SnapshotQuality Quality {
    SnapshotQuality get ();
    void set (SnapshotQuality value);
}
function get_Quality();
function set_Quality(value);

Property Value

Type: SnapshotQuality
The quality associated with this snapshot.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.Reason Property

SourceQueueSnapshotEntryReason Property

This value represents why the snapshot was taken.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotCreationReason Reason { get; set; }
Public Property Reason As SnapshotCreationReason
    Get
    Set
public:
property SnapshotCreationReason Reason {
    SnapshotCreationReason get ();
    void set (SnapshotCreationReason value);
}
function get_Reason();
function set_Reason(value);

Property Value

Type: SnapshotCreationReason
The reason for taking this snapshot.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.SnapshotSetId Property

SourceQueueSnapshotEntrySnapshotSetId Property

This value is the Coordinated ID for the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid SnapshotSetId { get; set; }
Public Property SnapshotSetId As Guid
    Get
    Set
public:
property Guid SnapshotSetId {
    Guid get ();
    void set (Guid value);
}
function get_SnapshotSetId();
function set_SnapshotSetId(value);

Property Value

Type: Guid
The unique identifier of this snapshot.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.SourceAddress Property

SourceQueueSnapshotEntrySourceAddress Property

This value is the stored source address.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
function get_SourceAddress();
function set_SourceAddress(value);

Property Value

Type: String
This value is the stored source address.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.State Property

SourceQueueSnapshotEntryState Property

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotState State { get; set; }
Public Property State As SnapshotState
    Get
    Set
public:
property SnapshotState State {
    SnapshotState get ();
    void set (SnapshotState value);
}
function get_State();
function set_State(value);

Property Value

Type: SnapshotState
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.TargetStates Property

SourceQueueSnapshotEntryTargetStates Property

This value represents the state of the target associated with the snapshot.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetStates { get; set; }
Public Property TargetStates As TargetStates
    Get
    Set
public:
property TargetStates TargetStates {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetStates();
function set_TargetStates(value);

Property Value

Type: TargetStates
The states of the target server associated with this snapshot.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.TimeStampCompleted Property

SourceQueueSnapshotEntryTimeStampCompleted Property

This value is the time when the snapshot was completed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimeStampCompleted { get; set; }
Public Property TimeStampCompleted As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeStampCompleted {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimeStampCompleted();
function set_TimeStampCompleted(value);

Property Value

Type: DateTimeOffset
The time when this snapshot was completed.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


SourceQueueSnapshotEntry.TimeStampRequested Property

SourceQueueSnapshotEntryTimeStampRequested Property

This value is the time when the snapshot was requested.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimeStampRequested { get; set; }
Public Property TimeStampRequested As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeStampRequested {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimeStampRequested();
function set_TimeStampRequested(value);

Property Value

Type: DateTimeOffset
The time when this snapshot was requested.
See Also

Reference

SourceQueueSnapshotEntry Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Class

Represents an engine connection from the perspective of the target server.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionTargetStateInfo

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetStateInfo : IExtensibleDataObject
Public Class TargetStateInfo
    Implements IExtensibleDataObject
public ref class TargetStateInfo : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.TargetStateInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TargetStateInfo',
    null,
    IExtensibleDataObject);

The TargetStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateInfo |
Top
Properties
 | Name | Description
Public property | ConnectionId | This value is the unique ID assigned to the connection.
Public property | ConnectTime | This value is the time when the connection was created.
Public property | EngineConnectionId | This value is the unique ID assigned to the replication engine connection.
Public property | EngineJobType | This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasSnapshotSchedule | This value is true if the connection has a snapshot schedule; otherwise, it is false.
Public property | LastUpdateTime | This value is the last time the target connection information was updated.
Public property | NextScheduledSnapshot | This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Paths | This value is the paths of the replica data on the target.
Public property | QueueBytes | This value is the number of bytes in the target queue.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | ReplicationSetUsageType | This value defines the possible usage types for the protected data set.
Public property | ScheduledSnapshotInterval | This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceEndpoint | This value is the IP endpoint used to communicate with Double-Take on the source.
Public property | SourceEndpointFromSource | This value is the default address for the source server as provided by the source server.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceVersion | This value is the Double-Take product version on the source.
Public property | TargetEndpoint | This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
Public property | TargetStates | This values is the state of the target.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStateInfo()
Public Sub New
public:
TargetStateInfo()
DoubleTake.Core.Contract.Connection.TargetStateInfo = function();
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo Properties

The TargetStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId | This value is the unique ID assigned to the connection.
Public property | ConnectTime | This value is the time when the connection was created.
Public property | EngineConnectionId | This value is the unique ID assigned to the replication engine connection.
Public property | EngineJobType | This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HasSnapshotSchedule | This value is true if the connection has a snapshot schedule; otherwise, it is false.
Public property | LastUpdateTime | This value is the last time the target connection information was updated.
Public property | NextScheduledSnapshot | This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Paths | This value is the paths of the replica data on the target.
Public property | QueueBytes | This value is the number of bytes in the target queue.
Public property | ReplicationSetName | This value is the name of the protected data set.
Public property | ReplicationSetUsageType | This value defines the possible usage types for the protected data set.
Public property | ScheduledSnapshotInterval | This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.
Public property | Snapshots | This value represents the current list of snapshots for the connection.
Public property | SourceEndpoint | This value is the IP endpoint used to communicate with Double-Take on the source.
Public property | SourceEndpointFromSource | This value is the default address for the source server as provided by the source server.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceVersion | This value is the Double-Take product version on the source.
Public property | TargetEndpoint | This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
Public property | TargetStates | This values is the state of the target.
Top
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ConnectionId Property

TargetStateInfoConnectionId Property

This value is the unique ID assigned to the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Guid
The unique identifier of the connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ConnectTime Property

TargetStateInfoConnectTime Property

This value is the time when the connection was created.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset ConnectTime { get; set; }
Public Property ConnectTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset ConnectTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_ConnectTime();
function set_ConnectTime(value);

Property Value

Type: DateTimeOffset
The time this connection was created.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.EngineConnectionId Property

TargetStateInfoEngineConnectionId Property

This value is the unique ID assigned to the replication engine connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
function get_EngineConnectionId();
function set_EngineConnectionId(value);

Property Value

Type: Int32
The engine connection id.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.EngineJobType Property

TargetStateInfoEngineJobType Property

This value is the job type according to the replication engine. (These jobs are not the same as JobInfo.JobType.)

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
function get_EngineJobType();
function set_EngineJobType(value);

Property Value

Type: EngineJobType
The engine job type of the connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ExtensionData Property

TargetStateInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.HasSnapshotSchedule Property

TargetStateInfoHasSnapshotSchedule Property

This value is true if the connection has a snapshot schedule; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool HasSnapshotSchedule { get; set; }
Public Property HasSnapshotSchedule As Boolean
    Get
    Set
public:
property bool HasSnapshotSchedule {
    bool get ();
    void set (bool value);
}
function get_HasSnapshotSchedule();
function set_HasSnapshotSchedule(value);

Property Value

Type: Boolean
if the connection has a snapshot schedule; otherwise, .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.LastUpdateTime Property

TargetStateInfoLastUpdateTime Property

This value is the last time the target connection information was updated.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastUpdateTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_LastUpdateTime();
function set_LastUpdateTime(value);

Property Value

Type: DateTimeOffset
The last time this target connection information was updated.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.NextScheduledSnapshot Property

TargetStateInfoNextScheduledSnapshot Property

This value is the time of the next scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset NextScheduledSnapshot { get; set; }
Public Property NextScheduledSnapshot As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextScheduledSnapshot {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_NextScheduledSnapshot();
function set_NextScheduledSnapshot(value);

Property Value

Type: DateTimeOffset
The time of the next scheduled snapshot.
Remarks
This property is only valid when HasSnapshotSchedule is .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.Paths Property

TargetStateInfoPaths Property

This value is the paths of the replica data on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_Paths();
function set_Paths(value);

Property Value

Type: String
The paths used on the target server.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.QueueBytes Property

TargetStateInfoQueueBytes Property

This value is the number of bytes in the target queue.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long QueueBytes { get; set; }
Public Property QueueBytes As Long
    Get
    Set
public:
property long long QueueBytes {
    long long get ();
    void set (long long value);
}
function get_QueueBytes();
function set_QueueBytes(value);

Property Value

Type: Int64
The target queue bytes.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ReplicationSetName Property

TargetStateInfoReplicationSetName Property

This value is the name of the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicationSetName();
function set_ReplicationSetName(value);

Property Value

Type: String
The name of the replication set.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ReplicationSetUsageType Property

TargetStateInfoReplicationSetUsageType Property

This value defines the possible usage types for the protected data set.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicationSetUsageType ReplicationSetUsageType { get; set; }
Public Property ReplicationSetUsageType As ReplicationSetUsageType
    Get
    Set
public:
property ReplicationSetUsageType ReplicationSetUsageType {
    ReplicationSetUsageType get ();
    void set (ReplicationSetUsageType value);
}
function get_ReplicationSetUsageType();
function set_ReplicationSetUsageType(value);

Property Value

Type: ReplicationSetUsageType
The usage type of the replication set that is connected.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.ScheduledSnapshotInterval Property

TargetStateInfoScheduledSnapshotInterval Property

This value is the interval for the scheduled snapshot. This property is only valid when HasSnapshotSchedule is true.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan ScheduledSnapshotInterval { get; set; }
Public Property ScheduledSnapshotInterval As TimeSpan
    Get
    Set
public:
property TimeSpan ScheduledSnapshotInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_ScheduledSnapshotInterval();
function set_ScheduledSnapshotInterval(value);

Property Value

Type: TimeSpan
The scheduled snapshot interval.
Remarks
This is only valid when HasSnapshotSchedule is .
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.Snapshots Property

TargetStateInfoSnapshots Property

This value represents the current list of snapshots for the connection.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
The current list of snapshots taken for this connection.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceEndpoint Property

TargetStateInfoSourceEndpoint Property

This value is the IP endpoint used to communicate with Double-Take on the source.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The source endpoint.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceEndpointFromSource Property

TargetStateInfoSourceEndpointFromSource Property

This value is the default address for the source server as provided by the source server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpointFromSource { get; set; }
Public Property SourceEndpointFromSource As String
    Get
    Set
public:
property String^ SourceEndpointFromSource {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpointFromSource();
function set_SourceEndpointFromSource(value);

Property Value

Type: String
The default address for the source server as provided by the source server.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceMachineName Property

TargetStateInfoSourceMachineName Property

This value is the name of the source server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source machine.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.SourceVersion Property

TargetStateInfoSourceVersion Property

This value is the Double-Take product version on the source.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductVersion SourceVersion { get; set; }
Public Property SourceVersion As ProductVersion
    Get
    Set
public:
property ProductVersion^ SourceVersion {
    ProductVersion^ get ();
    void set (ProductVersion^ value);
}
function get_SourceVersion();
function set_SourceVersion(value);

Property Value

Type: ProductVersion
The product version of the source machine.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.TargetEndpoint Property

TargetStateInfoTargetEndpoint Property

This value is the destination endpoint of the socket connection. If there is a NAT router between the source and target, this value represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetEndpoint { get; set; }
Public Property TargetEndpoint As String
    Get
    Set
public:
property String^ TargetEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_TargetEndpoint();
function set_TargetEndpoint(value);

Property Value

Type: String
The destination endpoint of the socket connection.
Remarks
When there is a NAT firewall between the source and the target, this represents the target's private address (translated from the public address). In other words, this will not match the target endpoint specified for the target route of the connection from the source's perspective.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStateInfo.TargetStates Property

TargetStateInfoTargetStates Property

This values is the state of the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetStates { get; set; }
Public Property TargetStates As TargetStates
    Get
    Set
public:
property TargetStates TargetStates {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetStates();
function set_TargetStates(value);

Property Value

Type: TargetStates
The target states.
See Also

Reference

TargetStateInfo Class
DoubleTake.Core.Contract.Connection Namespace


TargetStates Enumeration

Represent possible states of the target server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum TargetStates
Public Enumeration TargetStates
public enum class TargetStates
DoubleTake.Core.Contract.Connection.TargetStates = function();
DoubleTake.Core.Contract.Connection.TargetStates.createEnum('DoubleTake.Core.Contract.Connection.TargetStates', false);
Members
Member name | Value | Description
Good | 0 | The target is in a good state.
Mirroring | 1 | Mirroring is in progress.
MirrorStopped | 2 | Mirroring was stopped. A remirror should be performed.
OpDropped | 4 | The target detected than an operation was dropped on the network. A remirror should be performed.
Retrying | 8 | The target is retrying a write operation.
Paused | 16 | Writing to the target server has been paused by the user.
PausePending | 32 | Writing to the target server has been paused by the user.
RestoreRequired | 64 | The data on the source and target may not be synchronized because of a failover condition. This state will remain until a restore or remirror is completed.
ReplicationPending | 128 | The connection has been established and replication is enabled, but the first replication operation has not been transmitted yet.
SnapshotReverted | 256 | The data on the source and target may not be synchronized because a snapshot was applied on the target. This state will remain until a restore or remirror is completed.
FailoverUnblocked | 512 | This property is no longer used.
Disconnected | 1024 | The target server cannot be contacted.
SroImage | 2048 | The target server contains a Double-Take DR protection image. This option is no longer needed.
FailoverMonitoring | 4096 | The target is monitoring the source for a failure.
TransactionsPending | 8192 | There are transactional NTFS (TxF) operations pending.
GCReplicationComplete | 16384 | GeoCluster replication is complete.
MarkedForDeletion | 32768 | The connection is marked for deletion when the source comes back online.
JobNotReadyOnTarget | 65536 | The target server may not be ready to resume transmission, for example due to disks being offline.
TargetPathBlocked | 2147483648 | Writing to the replica path location on the target is blocked.
Unknown | -4294967296 | The target state cannot be determined.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TaskParameters Class

Specifies a script or executable to be run along with its corresponding command-line arguments.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.ConnectionTaskParameters

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TaskParameters : IExtensibleDataObject
Public Class TaskParameters
    Implements IExtensibleDataObject
public ref class TaskParameters : IExtensibleDataObject
DoubleTake.Core.Contract.Connection.TaskParameters = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.TaskParameters',
    null,
    IExtensibleDataObject);

The TaskParameters type exposes the following members.

Constructors
 | Name | Description
Public method | TaskParameters |
Top
Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Script | This value is the full path and file name of the script.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


TaskParameters Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TaskParameters()
Public Sub New
public:
TaskParameters()
DoubleTake.Core.Contract.Connection.TaskParameters = function();
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters Properties

The TaskParameters type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | This value is a comma-separated list of valid arguments required to execute the script.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Script | This value is the full path and file name of the script.
Top
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.Arguments Property

TaskParametersArguments Property

This value is a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
function get_Arguments();
function set_Arguments(value);

Property Value

Type: String
The command-line arguments.
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.ExtensionData Property

TaskParametersExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TaskParameters.Script Property

TaskParametersScript Property

This value is the full path and file name of the script.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}
function get_Script();
function set_Script(value);

Property Value

Type: String
See Also

Reference

TaskParameters Class
DoubleTake.Core.Contract.Connection Namespace


TransmissionMode Enumeration

The operational state of data transmission from the source to target server.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum TransmissionMode
Public Enumeration TransmissionMode
public enum class TransmissionMode
DoubleTake.Core.Contract.Connection.TransmissionMode = function();
DoubleTake.Core.Contract.Connection.TransmissionMode.createEnum('DoubleTake.Core.Contract.Connection.TransmissionMode', false);
Members
Member name | Value | Description
Error | 0 | Transmission is in an error state.
Paused | 1 | Transmission is paused.
Started | 2 | Transmission is active.
Scheduled | 3 | Transmission is pending a schedule.
Stopped | 4 | Transmission is stopped.
Unknown | 5 | Transmission is unknown.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Class

Inheritance Hierarchy
SystemObject
ScheduleItem
DoubleTake.Core.Contract.ConnectionVerifySchedule

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class VerifySchedule : ScheduleItem
Public NotInheritable Class VerifySchedule
    Inherits ScheduleItem
public ref class VerifySchedule sealed : public ScheduleItem
DoubleTake.Core.Contract.Connection.VerifySchedule = function();

Type.createClass(
    'DoubleTake.Core.Contract.Connection.VerifySchedule',
    DoubleTake.Core.Contract.Connection.ScheduleItem);

The VerifySchedule type exposes the following members.

Constructors
 | Name | Description
Public method | VerifySchedule |
Top
Properties
 | Name | Description
Public property | Criteria | This value represents how to compare the source protected data and the replica on the target.
Public property | Interval | This value is the interval for taking snapshots.
Public property | Options | This value represents what mirror operation will be performed.
Public property | StartTime | This value is the when the verification schedule should start.
Top
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Constructor

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VerifySchedule()
Public Sub New
public:
VerifySchedule()
DoubleTake.Core.Contract.Connection.VerifySchedule = function();
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule Properties

The VerifySchedule type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | This value represents how to compare the source protected data and the replica on the target.
Public property | Interval | This value is the interval for taking snapshots.
Public property | Options | This value represents what mirror operation will be performed.
Public property | StartTime | This value is the when the verification schedule should start.
Top
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Criteria Property

VerifyScheduleCriteria Property

This value represents how to compare the source protected data and the replica on the target.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorComparisonCriteria Criteria { get; set; }
Public Property Criteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria Criteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
function get_Criteria();
function set_Criteria(value);

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Interval Property

VerifyScheduleInterval Property

This value is the interval for taking snapshots.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Interval();
function set_Interval(value);

Property Value

Type: TimeSpan
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.Options Property

VerifyScheduleOptions Property

This value represents what mirror operation will be performed.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
function get_Options();
function set_Options(value);

Property Value

Type: MirrorOperationOptions
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


VerifySchedule.StartTime Property

VerifyScheduleStartTime Property

This value is the when the verification schedule should start.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
See Also

Reference

VerifySchedule Class
DoubleTake.Core.Contract.Connection Namespace


Weekdays Enumeration

Defines the days of the week and common combinations of weekdays.

Namespace: DoubleTake.Core.Contract.Connection
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum Weekdays
Public Enumeration Weekdays
public enum class Weekdays
DoubleTake.Core.Contract.Connection.Weekdays = function();
DoubleTake.Core.Contract.Connection.Weekdays.createEnum('DoubleTake.Core.Contract.Connection.Weekdays', false);
Members
Member name | Value | Description
None | 0 | No days of the week are specified.
Sunday | 1 | Sunday is specified.
Monday | 2 | Monday is specified.
Tuesday | 4 | Tuesday is specified.
Wednesday | 8 | Wednesday is specified.
Thursday | 16 | Thursday is specified.
Friday | 32 | Friday is specified.
Saturday | 64 | Saturday is specified.
Weekends | 65 | Saturday and Sunday are specified.
Workdays | 62 | Monday, Tuesday, Wednesday, Thursday, and Friday are specified.
All | 127 | All days of the week are specified.
See Also

Reference

DoubleTake.Core.Contract.Connection Namespace


DoubleTake.Core.Contract.Job Namespace

Classes
 | Class | Description
Public class | JobInfo | Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.


JobInfo Class

Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.JobJobInfo

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobInfo : ObservableObject, IExtensibleDataObject
Public Class JobInfo
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class JobInfo : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Job.JobInfo = function();

Type.createClass(
    'DoubleTake.Core.Contract.Job.JobInfo',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The JobInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfo |
Top
Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the connection info array.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID.
Public property | IsStarted | Gets or sets a value indicating whether this job is started.
Public property | Parameters | Gets or sets the parameters.
Public property | SourceAddress | Gets or sets the source address that the job host is using to talk to the source of this job.
Top
See Also

Reference

DoubleTake.Core.Contract.Job Namespace


JobInfo Constructor

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobInfo()
Public Sub New
public:
JobInfo()
DoubleTake.Core.Contract.Job.JobInfo = function();
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo Properties

The JobInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionInfo | Gets or sets the connection info array.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Guid | Gets or sets the GUID.
Public property | IsStarted | Gets or sets a value indicating whether this job is started.
Public property | Parameters | Gets or sets the parameters.
Public property | SourceAddress | Gets or sets the source address that the job host is using to talk to the source of this job.
Top
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.ConnectionInfo Property

JobInfoConnectionInfo Property

Gets or sets the connection info array.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionInfo[] ConnectionInfo { get; set; }
Public Property ConnectionInfo As ConnectionInfo()
    Get
    Set
public:
property array<ConnectionInfo^>^ ConnectionInfo {
    array<ConnectionInfo^>^ get ();
    void set (array<ConnectionInfo^>^ value);
}
function get_ConnectionInfo();
function set_ConnectionInfo(value);

Property Value

Type: ConnectionInfo
The connection info array.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.ExtensionData Property

JobInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.Guid Property

JobInfoGuid Property

Gets or sets the GUID.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
function get_Guid();
function set_Guid(value);

Property Value

Type: Guid
The GUID.
Remarks
This data contract is new to 5.2.1. It is not used in 5.2.0.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.IsStarted Property

JobInfoIsStarted Property

Gets or sets a value indicating whether this job is started.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsStarted { get; set; }
Public Property IsStarted As Boolean
    Get
    Set
public:
property bool IsStarted {
    bool get ();
    void set (bool value);
}
function get_IsStarted();
function set_IsStarted(value);

Property Value

Type: Boolean
true if this job is started; otherwise, false.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.Parameters Property

JobInfoParameters Property

Gets or sets the parameters.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobParameters Parameters { get; set; }
Public Property Parameters As JobParameters
    Get
    Set
public:
property JobParameters^ Parameters {
    JobParameters^ get ();
    void set (JobParameters^ value);
}
function get_Parameters();
function set_Parameters(value);

Property Value

Type: JobParameters
The parameters.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


JobInfo.SourceAddress Property

JobInfoSourceAddress Property

Gets or sets the source address that the job host is using to talk to the source of this job.

Namespace: DoubleTake.Core.Contract.Job
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo SourceAddress { get; set; }
Public Property SourceAddress As UnicastIPAddressInfo
    Get
    Set
public:
property UnicastIPAddressInfo^ SourceAddress {
    UnicastIPAddressInfo^ get ();
    void set (UnicastIPAddressInfo^ value);
}
function get_SourceAddress();
function set_SourceAddress(value);

Property Value

Type: UnicastIPAddressInfo
The source address.
See Also

Reference

JobInfo Class
DoubleTake.Core.Contract.Job Namespace


DoubleTake.Core.Contract.Monitor Namespace

Classes
 | Class | Description
Public class | FailoverScriptConfiguration | Used to specify the paths of scripts to be run at different stages of the failover and failback operations. The script arguments may also be specified with this data contract.
Public class | MonitorConfiguration |
Public class | MonitoredAddressConfiguration | Used to specify the configuration of a single IP address that is to be monitored for failover.
Public class | MonitoredAddressStatus | Represents the status of a monitored IP address.
Enumerations
 | Enumeration | Description
Public enumeration | FailoverDataAction | Specifies the action to take on the queued or applied target data before failing over the source server identity to the target server.
Public enumeration | FailoverIPAddressesOption | Used to indicate which addresses should be applied to the target server when a failover operation is performed on a failover monitor.
Public enumeration | FailoverItems | Used to indicate what identity items are failed over to the target when a failover operation is performed on a failover monitor.
Public enumeration | FailoverProcessingOptions | Used to specify how the failover is processed.
Public enumeration | FailoverReplaceActions | Used to indicate what identity items are to be replaced on the target with the identity items from the source.
Public enumeration | FailoverTrigger | Used to specify when a failover operation is triggered with respect to the failure of the monitored IP addresses.
Public enumeration | FailoverType | Used to indicate whether we are failing over an entire server or not.
Public enumeration | HighAvailabilityState | Defines the state of a failover monitor.
Public enumeration | PingMethods |
Public enumeration | RestoreStates | Defines the state of a restore connection.


FailoverDataAction Enumeration

Specifies the action to take on the queued or applied target data before failing over the source server identity to the target server.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverDataAction
Public Enumeration FailoverDataAction
public enum class FailoverDataAction
DoubleTake.Core.Contract.Monitor.FailoverDataAction = function();
DoubleTake.Core.Contract.Monitor.FailoverDataAction.createEnum('DoubleTake.Core.Contract.Monitor.FailoverDataAction', false);
Members
Member name | Value | Description
Apply | 0 | This value will apply the data in the target queue before starting failover.
Flush | 1 | This value will discard the data in the target queue and start failover immediately.
Revert | 2 | If the target data is in a bad state, this value will revert to the last good snapshot, if snapshots are available. If the target data is in a good state or no snapshots are available, this value will apply the data in the target queue and then failover.
Unknown | 3 | The action is unknown.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverIPAddressesOption Enumeration

Used to indicate which addresses should be applied to the target server when a failover operation is performed on a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverIPAddressesOption
Public Enumeration FailoverIPAddressesOption
public enum class FailoverIPAddressesOption
DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption = function();
DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption.createEnum('DoubleTake.Core.Contract.Monitor.FailoverIPAddressesOption', false);
Members
Member name | Value | Description
Monitored | 0 | Failover only the IP addresses that are being monitored.
All | 1 | Failover all of the IP address on the source. server.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverItems Enumeration

Used to indicate what identity items are failed over to the target when a failover operation is performed on a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverItems
Public Enumeration FailoverItems
public enum class FailoverItems
DoubleTake.Core.Contract.Monitor.FailoverItems = function();
DoubleTake.Core.Contract.Monitor.FailoverItems.createEnum('DoubleTake.Core.Contract.Monitor.FailoverItems', false);
Members
Member name | Value | Description
None | 0 | Nothing will be failed over.
IPAddresses | 1 | The IP addresses specified by MonitorConfiguration.FailoverIPAddressesOption will be applied to the target during failover.
Name | 2 | The NetBIOS name of the source server will be applied to the target during failover.
Shares | 4 | Shares included in the source workload will be added to the target during failover.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverProcessingOptions Enumeration

Used to specify how the failover is processed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverProcessingOptions
Public Enumeration FailoverProcessingOptions
public enum class FailoverProcessingOptions
DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions = function();
DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions.createEnum('DoubleTake.Core.Contract.Monitor.FailoverProcessingOptions', false);
Members
Member name | Value | Description
None | 0 | This value resets the flags so no failover processing options will be used.
UserInterventionRequired | 1 | The user must manually initiate failover when a failover condition is met.
UseShareFile | 2 | When failing over file shares, the persisted share file on the target should be used to create the shares on the target. Without this value, the target will attempt to obtain the shares from the source during failover, however, if the source is unavailable, no shares will be created on the target.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverReplaceActions Enumeration

Used to indicate what identity items are to be replaced on the target with the identity items from the source.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverReplaceActions
Public Enumeration FailoverReplaceActions
public enum class FailoverReplaceActions
DoubleTake.Core.Contract.Monitor.FailoverReplaceActions = function();
DoubleTake.Core.Contract.Monitor.FailoverReplaceActions.createEnum('DoubleTake.Core.Contract.Monitor.FailoverReplaceActions', false);
Members
Member name | Value | Description
Address | 2 | The IP addresses on the target will be replaced by the IP address from the source during failover.
Name | 1 | The NetBIOS name of the target will be replaced by the NetBIOS name from the source during failover.
None | 0 | This value resets the flags so no failover replace actions will be used.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Class

Used to specify the paths of scripts to be run at different stages of the failover and failback operations. The script arguments may also be specified with this data contract.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Core.Contract.MonitorFailoverScriptConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverScriptConfiguration : ObservableObject,
    IExtensibleDataObject
Public Class FailoverScriptConfiguration
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class FailoverScriptConfiguration : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The FailoverScriptConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverScriptConfiguration |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PostFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target after failback.
Public property | PostFailbackScriptArgs | This value is the comma-separated arguments for PostFailbackScript.
Public property | PostFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target after failover.
Public property | PostFailoverScriptArgs | This value is the comma-separated arguments for PostFailoverScript.
Public property | PreFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target before failback.
Public property | PreFailbackScriptArgs | This value is the comma-separated arguments for PreFailbackScript.
Public property | PreFailbackWait | This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.
Public property | PreFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target before failover.
Public property | PreFailoverScriptArgs | This value is the comma-separated arguments for PreFailoverScript.
Public property | PreFailoverWait | This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.
Public property | SourcePostFailbackScript | This value is the full path and file name of the script located on the source and to be run on the source after failback.
Public property | SourcePostFailbackScriptArgs | This value is the comma-separated arguments for SourcePostFailbackScript.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Constructor

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration()
Public Sub New
public:
FailoverScriptConfiguration()
DoubleTake.Core.Contract.Monitor.FailoverScriptConfiguration = function();
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration Properties

The FailoverScriptConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PostFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target after failback.
Public property | PostFailbackScriptArgs | This value is the comma-separated arguments for PostFailbackScript.
Public property | PostFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target after failover.
Public property | PostFailoverScriptArgs | This value is the comma-separated arguments for PostFailoverScript.
Public property | PreFailbackScript | This value is the full path and file name of the script located on the target and to be run on the target before failback.
Public property | PreFailbackScriptArgs | This value is the comma-separated arguments for PreFailbackScript.
Public property | PreFailbackWait | This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.
Public property | PreFailoverScript | This value is the full path and file name of the script located on the target and to be run on the target before failover.
Public property | PreFailoverScriptArgs | This value is the comma-separated arguments for PreFailoverScript.
Public property | PreFailoverWait | This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.
Public property | SourcePostFailbackScript | This value is the full path and file name of the script located on the source and to be run on the source after failback.
Public property | SourcePostFailbackScriptArgs | This value is the comma-separated arguments for SourcePostFailbackScript.
Top
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.ExtensionData Property

FailoverScriptConfigurationExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailbackScript Property

FailoverScriptConfigurationPostFailbackScript Property

This value is the full path and file name of the script located on the target and to be run on the target after failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailbackScript { get; set; }
Public Property PostFailbackScript As String
    Get
    Set
public:
property String^ PostFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_PostFailbackScript();
function set_PostFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailbackScriptArgs Property

FailoverScriptConfigurationPostFailbackScriptArgs Property

This value is the comma-separated arguments for PostFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailbackScriptArgs { get; set; }
Public Property PostFailbackScriptArgs As String
    Get
    Set
public:
property String^ PostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PostFailbackScriptArgs();
function set_PostFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailoverScript Property

FailoverScriptConfigurationPostFailoverScript Property

This value is the full path and file name of the script located on the target and to be run on the target after failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailoverScript { get; set; }
Public Property PostFailoverScript As String
    Get
    Set
public:
property String^ PostFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_PostFailoverScript();
function set_PostFailoverScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PostFailoverScriptArgs Property

FailoverScriptConfigurationPostFailoverScriptArgs Property

This value is the comma-separated arguments for PostFailoverScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PostFailoverScriptArgs { get; set; }
Public Property PostFailoverScriptArgs As String
    Get
    Set
public:
property String^ PostFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PostFailoverScriptArgs();
function set_PostFailoverScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackScript Property

FailoverScriptConfigurationPreFailbackScript Property

This value is the full path and file name of the script located on the target and to be run on the target before failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailbackScript { get; set; }
Public Property PreFailbackScript As String
    Get
    Set
public:
property String^ PreFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_PreFailbackScript();
function set_PreFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackScriptArgs Property

FailoverScriptConfigurationPreFailbackScriptArgs Property

This value is the comma-separated arguments for PreFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailbackScriptArgs { get; set; }
Public Property PreFailbackScriptArgs As String
    Get
    Set
public:
property String^ PreFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PreFailbackScriptArgs();
function set_PreFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailbackWait Property

FailoverScriptConfigurationPreFailbackWait Property

This value is true if Double-Take will wait for PreFailbackScript to complete before continuing with the failback operation; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool PreFailbackWait { get; set; }
Public Property PreFailbackWait As Boolean
    Get
    Set
public:
property bool PreFailbackWait {
    bool get ();
    void set (bool value);
}
function get_PreFailbackWait();
function set_PreFailbackWait(value);

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverScript Property

FailoverScriptConfigurationPreFailoverScript Property

This value is the full path and file name of the script located on the target and to be run on the target before failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailoverScript { get; set; }
Public Property PreFailoverScript As String
    Get
    Set
public:
property String^ PreFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_PreFailoverScript();
function set_PreFailoverScript(value);

Property Value

Type: String
Remarks
This script is run on the target machine and the path must be a path to a script on the target machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverScriptArgs Property

FailoverScriptConfigurationPreFailoverScriptArgs Property

This value is the comma-separated arguments for PreFailoverScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PreFailoverScriptArgs { get; set; }
Public Property PreFailoverScriptArgs As String
    Get
    Set
public:
property String^ PreFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_PreFailoverScriptArgs();
function set_PreFailoverScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.PreFailoverWait Property

FailoverScriptConfigurationPreFailoverWait Property

This value is true if Double-Take will wait for PreFailoverScript to complete before continuing with the failover operation; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool PreFailoverWait { get; set; }
Public Property PreFailoverWait As Boolean
    Get
    Set
public:
property bool PreFailoverWait {
    bool get ();
    void set (bool value);
}
function get_PreFailoverWait();
function set_PreFailoverWait(value);

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.SourcePostFailbackScript Property

FailoverScriptConfigurationSourcePostFailbackScript Property

This value is the full path and file name of the script located on the source and to be run on the source after failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePostFailbackScript { get; set; }
Public Property SourcePostFailbackScript As String
    Get
    Set
public:
property String^ SourcePostFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_SourcePostFailbackScript();
function set_SourcePostFailbackScript(value);

Property Value

Type: String
Remarks
This script is run on the source machine and the path must be a path to a script on the source machine.
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverScriptConfiguration.SourcePostFailbackScriptArgs Property

FailoverScriptConfigurationSourcePostFailbackScriptArgs Property

This value is the comma-separated arguments for SourcePostFailbackScript.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourcePostFailbackScriptArgs { get; set; }
Public Property SourcePostFailbackScriptArgs As String
    Get
    Set
public:
property String^ SourcePostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
function get_SourcePostFailbackScriptArgs();
function set_SourcePostFailbackScriptArgs(value);

Property Value

Type: String
See Also

Reference

FailoverScriptConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


FailoverTrigger Enumeration

Used to specify when a failover operation is triggered with respect to the failure of the monitored IP addresses.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverTrigger
Public Enumeration FailoverTrigger
public enum class FailoverTrigger
DoubleTake.Core.Contract.Monitor.FailoverTrigger = function();
DoubleTake.Core.Contract.Monitor.FailoverTrigger.createEnum('DoubleTake.Core.Contract.Monitor.FailoverTrigger', false);
Members
Member name | Value | Description
OneAddressFails | 0 | A failover condition is met when one monitored IP address fails.
AllAddressesFail | 1 | A failover condition is met when all monitored IP addresses fail.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


FailoverType Enumeration

Used to indicate whether we are failing over an entire server or not.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverType
Public Enumeration FailoverType
public enum class FailoverType
DoubleTake.Core.Contract.Monitor.FailoverType = function();
DoubleTake.Core.Contract.Monitor.FailoverType.createEnum('DoubleTake.Core.Contract.Monitor.FailoverType', false);
Members
Member name | Value | Description
FullServer | 1 | The entire server is being failed over and internal Double-Take processing will determine what is failed over.
Normal | 0 | The parameters in MonitorConfiguration are used to process failover.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


HighAvailabilityState Enumeration

Defines the state of a failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum HighAvailabilityState
Public Enumeration HighAvailabilityState
public enum class HighAvailabilityState
DoubleTake.Core.Contract.Monitor.HighAvailabilityState = function();
DoubleTake.Core.Contract.Monitor.HighAvailabilityState.createEnum('DoubleTake.Core.Contract.Monitor.HighAvailabilityState', false);
Members
Member name | Value | Description
FailbackOccurring | 80 | Failback is occurring.
FailbackRemonitor | 96 | Failback is complete. The target is waiting to start monitoring the source again.
FailbackRequired | 64 | The source is failed over to the target. A failback needs to occur to restore the target to its original identity.
FailoverMonitoring | 16 | The target is monitoring the source for a failure. No failover condition has been met. triggered.
FailoverOccurring | 48 | Failover is occurring.
FailoverRequired | 32 | Failover is pending because a failover condition has been met but failover has not started yet.
Illegal | -1 | There is a problem determining the monitoring status.
None | 0 | The monitoring status has not yet been determined.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Class

Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitorConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitorConfiguration : IExtensibleDataObject
Public Class MonitorConfiguration
    Implements IExtensibleDataObject
public ref class MonitorConfiguration : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitorConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitorConfiguration',
    null,
    IExtensibleDataObject);

The MonitorConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorConfiguration |
Top
Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | This value represents the Active Directory credentials.
Public property | ActiveDirectoryOptions | This value represents the Active Directory options.
Public property | Addresses | This value represents the configuration of the IP addresses that should be monitored for failure.
Public property | DataAction | This value represents the action to take on the queued target data before failover.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverIPAddressesOption | This value represents which IP addresses should be applied to the target server during failover.
Public property | FailoverType | This value represents if an entire server is being failed over.
Public property | ItemsToFailover | This value represents what will be failed over to the target.
Public property | MaxScriptFailures | This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Name | This value is the name of the failover monitor.
Public property | ProcessingOptions | This value represents how the failover is processed.
Public property | ReplaceActions | This value represents what identity items are to be replaced on the target during failover.
Public property | ScriptMonitorEngine | This property is no longer used.
Public property | ScriptMonitorName | This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Scripts | This value represents the scripts that should be run at different stages of failover and failback.
Public property | SourceEndpoint | This value is the IP endpoint used to communicate with Double-Take on the source.
Public property | SSMLogPath | This value is the path of the system state (full server processor) log.
Public property | SSMManualReboot | This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.
Public property | SSMRecoveryType | This property is no longer used.
Public property | SSMSourceNicGuids | This value is the global unique IDs associated with the source NICs.
Public property | SSMStagingPath | This value is the path of the staged folders on the target.
Public property | SSMTargetNicGuids | This value is the global unique IDs associated with the target NICs.
Public property | Trigger | This value represents when a failover operation is triggered with respect to the monitored IP addresses.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Constructor

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration()
Public Sub New
public:
MonitorConfiguration()
DoubleTake.Core.Contract.Monitor.MonitorConfiguration = function();
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration Properties

The MonitorConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | This value represents the Active Directory credentials.
Public property | ActiveDirectoryOptions | This value represents the Active Directory options.
Public property | Addresses | This value represents the configuration of the IP addresses that should be monitored for failure.
Public property | DataAction | This value represents the action to take on the queued target data before failover.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverIPAddressesOption | This value represents which IP addresses should be applied to the target server during failover.
Public property | FailoverType | This value represents if an entire server is being failed over.
Public property | ItemsToFailover | This value represents what will be failed over to the target.
Public property | MaxScriptFailures | This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Name | This value is the name of the failover monitor.
Public property | ProcessingOptions | This value represents how the failover is processed.
Public property | ReplaceActions | This value represents what identity items are to be replaced on the target during failover.
Public property | ScriptMonitorEngine | This property is no longer used.
Public property | ScriptMonitorName | This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.
Public property | Scripts | This value represents the scripts that should be run at different stages of failover and failback.
Public property | SourceEndpoint | This value is the IP endpoint used to communicate with Double-Take on the source.
Public property | SSMLogPath | This value is the path of the system state (full server processor) log.
Public property | SSMManualReboot | This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.
Public property | SSMRecoveryType | This property is no longer used.
Public property | SSMSourceNicGuids | This value is the global unique IDs associated with the source NICs.
Public property | SSMStagingPath | This value is the path of the staged folders on the target.
Public property | SSMTargetNicGuids | This value is the global unique IDs associated with the target NICs.
Public property | Trigger | This value represents when a failover operation is triggered with respect to the monitored IP addresses.
Top
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ActiveDirectoryCredentials Property

MonitorConfigurationActiveDirectoryCredentials Property

This value represents the Active Directory credentials.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials ActiveDirectoryCredentials { get; set; }
Public Property ActiveDirectoryCredentials As Credentials
    Get
    Set
public:
property Credentials^ ActiveDirectoryCredentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_ActiveDirectoryCredentials();
function set_ActiveDirectoryCredentials(value);

Property Value

Type: Credentials
The active directory credentials.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ActiveDirectoryOptions Property

MonitorConfigurationActiveDirectoryOptions Property

This value represents the Active Directory options.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActiveDirectoryFailoverOptions ActiveDirectoryOptions { get; set; }
Public Property ActiveDirectoryOptions As ActiveDirectoryFailoverOptions
    Get
    Set
public:
property ActiveDirectoryFailoverOptions ActiveDirectoryOptions {
    ActiveDirectoryFailoverOptions get ();
    void set (ActiveDirectoryFailoverOptions value);
}
function get_ActiveDirectoryOptions();
function set_ActiveDirectoryOptions(value);

Property Value

Type: ActiveDirectoryFailoverOptions
The active directory options.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Addresses Property

MonitorConfigurationAddresses Property

This value represents the configuration of the IP addresses that should be monitored for failure.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressConfiguration[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressConfiguration()
    Get
    Set
public:
property array<MonitoredAddressConfiguration^>^ Addresses {
    array<MonitoredAddressConfiguration^>^ get ();
    void set (array<MonitoredAddressConfiguration^>^ value);
}
function get_Addresses();
function set_Addresses(value);

Property Value

Type: MonitoredAddressConfiguration
An array of MonitoredAddressConfiguration.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.DataAction Property

MonitorConfigurationDataAction Property

This value represents the action to take on the queued target data before failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverDataAction DataAction { get; set; }
Public Property DataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction DataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
function get_DataAction();
function set_DataAction(value);

Property Value

Type: FailoverDataAction
The FailoverDataAction.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ExtensionData Property

MonitorConfigurationExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.FailoverIPAddressesOption Property

MonitorConfigurationFailoverIPAddressesOption Property

This value represents which IP addresses should be applied to the target server during failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverIPAddressesOption FailoverIPAddressesOption { get; set; }
Public Property FailoverIPAddressesOption As FailoverIPAddressesOption
    Get
    Set
public:
property FailoverIPAddressesOption FailoverIPAddressesOption {
    FailoverIPAddressesOption get ();
    void set (FailoverIPAddressesOption value);
}
function get_FailoverIPAddressesOption();
function set_FailoverIPAddressesOption(value);

Property Value

Type: FailoverIPAddressesOption
The FailoverIPAddressesOption.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.FailoverType Property

MonitorConfigurationFailoverType Property

This value represents if an entire server is being failed over.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
function get_FailoverType();
function set_FailoverType(value);

Property Value

Type: FailoverType
The FailoverType.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ItemsToFailover Property

MonitorConfigurationItemsToFailover Property

This value represents what will be failed over to the target.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverItems ItemsToFailover { get; set; }
Public Property ItemsToFailover As FailoverItems
    Get
    Set
public:
property FailoverItems ItemsToFailover {
    FailoverItems get ();
    void set (FailoverItems value);
}
function get_ItemsToFailover();
function set_ItemsToFailover(value);

Property Value

Type: FailoverItems
The FailoverItems.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.MaxScriptFailures Property

MonitorConfigurationMaxScriptFailures Property

This value is the number of times a monitoring script can fail when using MonitoredAddressConfiguration.PingMethods.Script.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MaxScriptFailures { get; set; }
Public Property MaxScriptFailures As Integer
    Get
    Set
public:
property int MaxScriptFailures {
    int get ();
    void set (int value);
}
function get_MaxScriptFailures();
function set_MaxScriptFailures(value);

Property Value

Type: Int32
The max script failures.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Name Property

MonitorConfigurationName Property

This value is the name of the failover monitor.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the failover monitor.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ProcessingOptions Property

MonitorConfigurationProcessingOptions Property

This value represents how the failover is processed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverProcessingOptions ProcessingOptions { get; set; }
Public Property ProcessingOptions As FailoverProcessingOptions
    Get
    Set
public:
property FailoverProcessingOptions ProcessingOptions {
    FailoverProcessingOptions get ();
    void set (FailoverProcessingOptions value);
}
function get_ProcessingOptions();
function set_ProcessingOptions(value);

Property Value

Type: FailoverProcessingOptions
The processing options.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ReplaceActions Property

MonitorConfigurationReplaceActions Property

This value represents what identity items are to be replaced on the target during failover.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverReplaceActions ReplaceActions { get; set; }
Public Property ReplaceActions As FailoverReplaceActions
    Get
    Set
public:
property FailoverReplaceActions ReplaceActions {
    FailoverReplaceActions get ();
    void set (FailoverReplaceActions value);
}
function get_ReplaceActions();
function set_ReplaceActions(value);

Property Value

Type: FailoverReplaceActions
The replace actions.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ScriptMonitorEngine Property

MonitorConfigurationScriptMonitorEngine Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ScriptMonitorEngine { get; set; }
Public Property ScriptMonitorEngine As String
    Get
    Set
public:
property String^ ScriptMonitorEngine {
    String^ get ();
    void set (String^ value);
}
function get_ScriptMonitorEngine();
function set_ScriptMonitorEngine(value);

Property Value

Type: String
The script monitor engine.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.ScriptMonitorName Property

MonitorConfigurationScriptMonitorName Property

This value is the full path and name of a monitoring script when using MonitoredAddressConfiguration.PingMethods.Script.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ScriptMonitorName { get; set; }
Public Property ScriptMonitorName As String
    Get
    Set
public:
property String^ ScriptMonitorName {
    String^ get ();
    void set (String^ value);
}
function get_ScriptMonitorName();
function set_ScriptMonitorName(value);

Property Value

Type: String
The name of the script monitor.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Scripts Property

MonitorConfigurationScripts Property

This value represents the scripts that should be run at different stages of failover and failback.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverScriptConfiguration Scripts { get; set; }
Public Property Scripts As FailoverScriptConfiguration
    Get
    Set
public:
property FailoverScriptConfiguration^ Scripts {
    FailoverScriptConfiguration^ get ();
    void set (FailoverScriptConfiguration^ value);
}
function get_Scripts();
function set_Scripts(value);

Property Value

Type: FailoverScriptConfiguration
The FailoverScriptConfiguration.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SourceEndpoint Property

MonitorConfigurationSourceEndpoint Property

This value is the IP endpoint used to communicate with Double-Take on the source.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The source IP endpoint to be used to communicate with Double-Take on the source.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMLogPath Property

MonitorConfigurationSSMLogPath Property

This value is the path of the system state (full server processor) log.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMLogPath { get; set; }
Public Property SSMLogPath As String
    Get
    Set
public:
property String^ SSMLogPath {
    String^ get ();
    void set (String^ value);
}
function get_SSMLogPath();
function set_SSMLogPath(value);

Property Value

Type: String
The SSM log path.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMManualReboot Property

MonitorConfigurationSSMManualReboot Property

This value is true if the server has to be manually rebooted to apply the system state after failover; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SSMManualReboot { get; set; }
Public Property SSMManualReboot As Boolean
    Get
    Set
public:
property bool SSMManualReboot {
    bool get ();
    void set (bool value);
}
function get_SSMManualReboot();
function set_SSMManualReboot(value);

Property Value

Type: Boolean
if [SSM manual reboot]; otherwise, .
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMRecoveryType Property

MonitorConfigurationSSMRecoveryType Property

This property is no longer used.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SSMRecoveryType SSMRecoveryType { get; set; }
Public Property SSMRecoveryType As SSMRecoveryType
    Get
    Set
public:
property SSMRecoveryType SSMRecoveryType {
    SSMRecoveryType get ();
    void set (SSMRecoveryType value);
}
function get_SSMRecoveryType();
function set_SSMRecoveryType(value);

Property Value

Type: SSMRecoveryType
The type of the SSM recovery.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMSourceNicGuids Property

MonitorConfigurationSSMSourceNicGuids Property

This value is the global unique IDs associated with the source NICs.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMSourceNicGuids { get; set; }
Public Property SSMSourceNicGuids As String
    Get
    Set
public:
property String^ SSMSourceNicGuids {
    String^ get ();
    void set (String^ value);
}
function get_SSMSourceNicGuids();
function set_SSMSourceNicGuids(value);

Property Value

Type: String
The SSM source nic guids.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMStagingPath Property

MonitorConfigurationSSMStagingPath Property

This value is the path of the staged folders on the target.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMStagingPath { get; set; }
Public Property SSMStagingPath As String
    Get
    Set
public:
property String^ SSMStagingPath {
    String^ get ();
    void set (String^ value);
}
function get_SSMStagingPath();
function set_SSMStagingPath(value);

Property Value

Type: String
The SSM staging path.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.SSMTargetNicGuids Property

MonitorConfigurationSSMTargetNicGuids Property

This value is the global unique IDs associated with the target NICs.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SSMTargetNicGuids { get; set; }
Public Property SSMTargetNicGuids As String
    Get
    Set
public:
property String^ SSMTargetNicGuids {
    String^ get ();
    void set (String^ value);
}
function get_SSMTargetNicGuids();
function set_SSMTargetNicGuids(value);

Property Value

Type: String
The SSM target nic guids.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitorConfiguration.Trigger Property

MonitorConfigurationTrigger Property

This value represents when a failover operation is triggered with respect to the monitored IP addresses.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverTrigger Trigger { get; set; }
Public Property Trigger As FailoverTrigger
    Get
    Set
public:
property FailoverTrigger Trigger {
    FailoverTrigger get ();
    void set (FailoverTrigger value);
}
function get_Trigger();
function set_Trigger(value);

Property Value

Type: FailoverTrigger
The trigger.
See Also

Reference

MonitorConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Class

Used to specify the configuration of a single IP address that is to be monitored for failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitoredAddressConfiguration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoredAddressConfiguration : IExtensibleDataObject
Public Class MonitoredAddressConfiguration
    Implements IExtensibleDataObject
public ref class MonitoredAddressConfiguration : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration',
    null,
    IExtensibleDataObject);

The MonitoredAddressConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressConfiguration |
Top
Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MacAddress | This value is the MAC address of the NIC for the monitored IP address.
Public property | MaxPingAttempts | This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.
Public property | NicName | This value is the name of the NIC. On a Windows server, this is typically a global unique ID.
Public property | PingInterval | This value is the interval for how often the monitored IP address is pinged.
Public property | PingMethods | This value represents how the IP address is pinged.
Public property | SubnetMask | This value is the subnet mask of an IPv4 IP address.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Constructor

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressConfiguration()
Public Sub New
public:
MonitoredAddressConfiguration()
DoubleTake.Core.Contract.Monitor.MonitoredAddressConfiguration = function();
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration Properties

The MonitoredAddressConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MacAddress | This value is the MAC address of the NIC for the monitored IP address.
Public property | MaxPingAttempts | This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.
Public property | NicName | This value is the name of the NIC. On a Windows server, this is typically a global unique ID.
Public property | PingInterval | This value is the interval for how often the monitored IP address is pinged.
Public property | PingMethods | This value represents how the IP address is pinged.
Public property | SubnetMask | This value is the subnet mask of an IPv4 IP address.
Top
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.Address Property

MonitoredAddressConfigurationAddress Property

This value is the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
virtual property String^ Address {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The IP address.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.EnginePort Property

MonitoredAddressConfigurationEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.ExtensionData Property

MonitoredAddressConfigurationExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.MacAddress Property

MonitoredAddressConfigurationMacAddress Property

This value is the MAC address of the NIC for the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
function get_MacAddress();
function set_MacAddress(value);

Property Value

Type: String
The MAC address of a source NIC.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.MaxPingAttempts Property

MonitoredAddressConfigurationMaxPingAttempts Property

This value is the maximum number of ping attempts that will be attempted before considering the IP address to be failed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
function get_MaxPingAttempts();
function set_MaxPingAttempts(value);

Property Value

Type: Int16
The maximum number of ping attempts.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.NicName Property

MonitoredAddressConfigurationNicName Property

This value is the name of the NIC. On a Windows server, this is typically a global unique ID.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string NicName { get; set; }
Public Property NicName As String
    Get
    Set
public:
property String^ NicName {
    String^ get ();
    void set (String^ value);
}
function get_NicName();
function set_NicName(value);

Property Value

Type: String
The name of a NIC on the target.
Remarks
This is typically the GUID of the NIC on a Windows-based machine.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.PingInterval Property

MonitoredAddressConfigurationPingInterval Property

This value is the interval for how often the monitored IP address is pinged.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_PingInterval();
function set_PingInterval(value);

Property Value

Type: TimeSpan
The ping interval as a TimeSpan.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.PingMethods Property

MonitoredAddressConfigurationPingMethods Property

This value represents how the IP address is pinged.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PingMethods PingMethods { get; set; }
Public Property PingMethods As PingMethods
    Get
    Set
public:
property PingMethods PingMethods {
    PingMethods get ();
    void set (PingMethods value);
}
function get_PingMethods();
function set_PingMethods(value);

Property Value

Type: PingMethods
The PingMethods.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressConfiguration.SubnetMask Property

MonitoredAddressConfigurationSubnetMask Property

This value is the subnet mask of an IPv4 IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SubnetMask { get; set; }
Public Property SubnetMask As String
    Get
    Set
public:
property String^ SubnetMask {
    String^ get ();
    void set (String^ value);
}
function get_SubnetMask();
function set_SubnetMask(value);

Property Value

Type: String
The subnet mask.
Remarks
This only applies if this IP address is an IPv4 address.
See Also

Reference

MonitoredAddressConfiguration Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Class

Represents the status of a monitored IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.MonitorMonitoredAddressStatus

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoredAddressStatus : IExtensibleDataObject
Public Class MonitoredAddressStatus
    Implements IExtensibleDataObject
public ref class MonitoredAddressStatus : IExtensibleDataObject
DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus = function();

Type.createClass(
    'DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus',
    null,
    IExtensibleDataObject);

The MonitoredAddressStatus type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressStatus |
Top
Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | Alive | This value is true if the IP address is responding to pings; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverConditionMet | This value is true if the IP address is considered failed; otherwise, it is false.
Public property | RemainingTime | This value is the amount of time remaining before the IP address is considered failed.
Public property | WarningConditionMet | This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.
Top
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Constructor

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressStatus()
Public Sub New
public:
MonitoredAddressStatus()
DoubleTake.Core.Contract.Monitor.MonitoredAddressStatus = function();
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus Properties

The MonitoredAddressStatus type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the monitored IP address.
Public property | Alive | This value is true if the IP address is responding to pings; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverConditionMet | This value is true if the IP address is considered failed; otherwise, it is false.
Public property | RemainingTime | This value is the amount of time remaining before the IP address is considered failed.
Public property | WarningConditionMet | This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.
Top
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.Address Property

MonitoredAddressStatusAddress Property

This value is the monitored IP address.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
virtual property String^ Address {
    String^ get () sealed;
    void set (String^ value) sealed;
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The IP address that is being monitored.
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.Alive Property

MonitoredAddressStatusAlive Property

This value is true if the IP address is responding to pings; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
function get_Alive();
function set_Alive(value);

Property Value

Type: Boolean
if the IP address is responding to ping attempts; otherwise, .
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.ExtensionData Property

MonitoredAddressStatusExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.FailoverConditionMet Property

MonitoredAddressStatusFailoverConditionMet Property

This value is true if the IP address is considered failed; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool FailoverConditionMet { get; set; }
Public Property FailoverConditionMet As Boolean
    Get
    Set
public:
property bool FailoverConditionMet {
    bool get ();
    void set (bool value);
}
function get_FailoverConditionMet();
function set_FailoverConditionMet(value);

Property Value

Type: Boolean
if the IP address is considered failed; otherwise, .
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.RemainingTime Property

MonitoredAddressStatusRemainingTime Property

This value is the amount of time remaining before the IP address is considered failed.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan RemainingTime { get; set; }
Public Property RemainingTime As TimeSpan
    Get
    Set
public:
property TimeSpan RemainingTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_RemainingTime();
function set_RemainingTime(value);

Property Value

Type: TimeSpan
The time remaining before the IP address is considered failed.
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


MonitoredAddressStatus.WarningConditionMet Property

MonitoredAddressStatusWarningConditionMet Property

This value is true if the IP address is in a warning condition; otherwise, it is false. An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for three quarters of the number of attempts allowed to be missed before the IP address is considered failed. For example, if the value for MonitoredAddressConfiguration.MaxPingAttempts is 20, then this property will be true after 15 failed attempts.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarningConditionMet { get; set; }
Public Property WarningConditionMet As Boolean
    Get
    Set
public:
property bool WarningConditionMet {
    bool get ();
    void set (bool value);
}
function get_WarningConditionMet();
function set_WarningConditionMet(value);

Property Value

Type: Boolean
if the IP address is in a warning condition; otherwise, .
Remarks
An IP address is considered to be in a warning condition if it has failed to respond to ping attempts for 3/4 of the number of attempts are allowed to be missed before the IP address is considered failed. For example, if the value for MaxPingAttempts is 20, then this property will be after 15 failed attempts.
See Also

Reference

MonitoredAddressStatus Class
DoubleTake.Core.Contract.Monitor Namespace


PingMethods Enumeration

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum PingMethods
Public Enumeration PingMethods
public enum class PingMethods
DoubleTake.Core.Contract.Monitor.PingMethods = function();
DoubleTake.Core.Contract.Monitor.PingMethods.createEnum('DoubleTake.Core.Contract.Monitor.PingMethods', false);
Members
Member name | Value | Description
ForceUpdate | 256 | Do not use this property. Double-Take uses it internally.
Manual | 4 | The IP address will not be monitored for failure but is still eligible for failover.
Network | 1 | The IP address will be monitored using an ICMP ping.
None | 0 | The IP address will not be monitored for failure and cannot be failed over.
Script | 8 | The IP address will be monitored using a user scripted ping method. If you use this value, you must set MonitorConfiguration.ScriptMonitorEngine and MonitorConfiguration.ScriptMonitorName.
Service | 2 | The IP address will be monitored using the Double-Take service.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


RestoreStates Enumeration

Defines the state of a restore connection.

Namespace: DoubleTake.Core.Contract.Monitor
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreStates
Public Enumeration RestoreStates
public enum class RestoreStates
DoubleTake.Core.Contract.Monitor.RestoreStates = function();
DoubleTake.Core.Contract.Monitor.RestoreStates.createEnum('DoubleTake.Core.Contract.Monitor.RestoreStates', false);
Members
Member name | Value | Description
Connected | 4 | The restoration connection is active and is replicating.
Mirroring | 16 | The restoration connection is active and mirroring.
MirrorStopped | 32 | The restoration mirror has been stopped.
MultiConnect | 8 | There is more than one active restoration connection.
None | 0 | There is no restoration connection.
OldServer | 1 | The server is running an old version of Double-Take and the restoration status is not available.
OpDropped | 64 | A mirroring or replication operation has been dropped. A restoration remirorr is required.
OpRetrying | 128 | A mirroring or replication write operation is being retried.
Required | 2 | A restoration is required.
See Also

Reference

DoubleTake.Core.Contract.Monitor Namespace


DoubleTake.Core.Contract.Options Namespace

Classes
 | Class | Description
Public class | DnsServerDetail | Represents a DNS server that will be updated during DNS failover.
Public class | FullServerNicMappings | Represent the network interface mappings in a full-server failover job.
Public class | IPAddressMap | Represents the mapping between source IP address and target IP address when using DNS failover.
Public class | TargetServicesToStop | Represents how a service is handled on the target server in full-server failover job.
Enumerations
 | Enumeration | Description
Public enumeration | TargetServiceStatus | Represents the state of a service.


DnsServerDetail Class

Represents a DNS server that will be updated during DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsDnsServerDetail

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class DnsServerDetail : IExtensibleDataObject
Public Class DnsServerDetail
    Implements IExtensibleDataObject
public ref class DnsServerDetail : IExtensibleDataObject
DoubleTake.Core.Contract.Options.DnsServerDetail = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.DnsServerDetail',
    null,
    IExtensibleDataObject);

The DnsServerDetail type exposes the following members.

Constructors
 | Name | Description
Public method | DnsServerDetail |
Top
Properties
 | Name | Description
Public property | Address | This value is the IP address of the DNS server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Origin | This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
Public property | SelectedForUpdate | This value is true if the DNS server will be updated during failover; otherwise, it is false.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Constructor

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DnsServerDetail()
Public Sub New
public:
DnsServerDetail()
DoubleTake.Core.Contract.Options.DnsServerDetail = function();
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Properties

The DnsServerDetail type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the IP address of the DNS server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Origin | This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
Public property | SelectedForUpdate | This value is true if the DNS server will be updated during failover; otherwise, it is false.
Top
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.Address Property

DnsServerDetailAddress Property

This value is the IP address of the DNS server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
The address of the DNS server.
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.ExtensionData Property

DnsServerDetailExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.Origin Property

DnsServerDetailOrigin Property

This value is the origin of the DNS server, which indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
function get_Origin();
function set_Origin(value);

Property Value

Type: String
The origin of the DNS server.
Remarks
This property indicates if the DNS server was discovered from the source server, the target server, both servers, or manually specified by the user.
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.SelectedForUpdate Property

DnsServerDetailSelectedForUpdate Property

This value is true if the DNS server will be updated during failover; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SelectedForUpdate { get; set; }
Public Property SelectedForUpdate As Boolean
    Get
    Set
public:
property bool SelectedForUpdate {
    bool get ();
    void set (bool value);
}
function get_SelectedForUpdate();
function set_SelectedForUpdate(value);

Property Value

Type: Boolean
if this DNS server will be updated during DNS failover; otherwise, .
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail Methods

The DnsServerDetail type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


DnsServerDetail.ToString Method

DnsServerDetailToString Method

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DnsServerDetail Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Class

Represent the network interface mappings in a full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsFullServerNicMappings

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerNicMappings : IExtensibleDataObject
Public Class FullServerNicMappings
    Implements IExtensibleDataObject
public ref class FullServerNicMappings : IExtensibleDataObject
DoubleTake.Core.Contract.Options.FullServerNicMappings = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.FullServerNicMappings',
    null,
    IExtensibleDataObject);

The FullServerNicMappings type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerNicMappings |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceNic | This value is the NIC on the source server.
Public property | TargetNic | This value is the NIC on the target server.
Public property | TargetNicList | This value is the list of NICs on the target server.
Public property | TestFailoverTargetNic | This value is the NIC on the test failover target server.
Public property | TestFailoverTargetNicList | This value is the list of NICs on the test failover target server.
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Constructor

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerNicMappings()
Public Sub New
public:
FullServerNicMappings()
DoubleTake.Core.Contract.Options.FullServerNicMappings = function();
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings Properties

The FullServerNicMappings type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceNic | This value is the NIC on the source server.
Public property | TargetNic | This value is the NIC on the target server.
Public property | TargetNicList | This value is the list of NICs on the target server.
Public property | TestFailoverTargetNic | This value is the NIC on the test failover target server.
Public property | TestFailoverTargetNicList | This value is the list of NICs on the test failover target server.
Top
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.ExtensionData Property

FullServerNicMappingsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.SourceNic Property

FullServerNicMappingsSourceNic Property

This value is the NIC on the source server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceNic { get; set; }
Public Property SourceNic As String
    Get
    Set
public:
property String^ SourceNic {
    String^ get ();
    void set (String^ value);
}
function get_SourceNic();
function set_SourceNic(value);

Property Value

Type: String
The network interface on the source server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TargetNic Property

FullServerNicMappingsTargetNic Property

This value is the NIC on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
function get_TargetNic();
function set_TargetNic(value);

Property Value

Type: String
The network interface on the target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TargetNicList Property

FullServerNicMappingsTargetNicList Property

This value is the list of NICs on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TargetNicList { get; set; }
Public Property TargetNicList As String()
    Get
    Set
public:
property array<String^>^ TargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TargetNicList();
function set_TargetNicList(value);

Property Value

Type: String
The target list of network interfaces on the target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TestFailoverTargetNic Property

FullServerNicMappingsTestFailoverTargetNic Property

This value is the NIC on the test failover target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestFailoverTargetNic { get; set; }
Public Property TestFailoverTargetNic As String
    Get
    Set
public:
property String^ TestFailoverTargetNic {
    String^ get ();
    void set (String^ value);
}
function get_TestFailoverTargetNic();
function set_TestFailoverTargetNic(value);

Property Value

Type: String
The network interface on the test failover target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


FullServerNicMappings.TestFailoverTargetNicList Property

FullServerNicMappingsTestFailoverTargetNicList Property

This value is the list of NICs on the test failover target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TestFailoverTargetNicList { get; set; }
Public Property TestFailoverTargetNicList As String()
    Get
    Set
public:
property array<String^>^ TestFailoverTargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TestFailoverTargetNicList();
function set_TestFailoverTargetNicList(value);

Property Value

Type: String
The test failover target list of network interfaces on the test failover target server.
See Also

Reference

FullServerNicMappings Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Class

Represents the mapping between source IP address and target IP address when using DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsIPAddressMap

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class IPAddressMap : IExtensibleDataObject
Public Class IPAddressMap
    Implements IExtensibleDataObject
public ref class IPAddressMap : IExtensibleDataObject
DoubleTake.Core.Contract.Options.IPAddressMap = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.IPAddressMap',
    null,
    IExtensibleDataObject);

The IPAddressMap type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressMap |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | SourceIP | This value is the IP address on the source server.
Public property | TargetIP | This value is the IP address on the target server.
Public property | TtlValue | This value is the time to live value in seconds.
Top
Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


IPAddressMap Constructor

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IPAddressMap()
Public Sub New
public:
IPAddressMap()
DoubleTake.Core.Contract.Options.IPAddressMap = function();
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Properties

The IPAddressMap type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | SourceIP | This value is the IP address on the source server.
Public property | TargetIP | This value is the IP address on the target server.
Public property | TtlValue | This value is the time to live value in seconds.
Top
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ExtensionData Property

IPAddressMapExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ShouldUpdateTtl Property

IPAddressMapShouldUpdateTtl Property

This value is true if the time to live value should be updated; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
function get_ShouldUpdateTtl();
function set_ShouldUpdateTtl(value);

Property Value

Type: Boolean
if the time-to-live value should be updated for this record; otherwise, .
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.SourceIP Property

IPAddressMapSourceIP Property

This value is the IP address on the source server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceIP { get; set; }
Public Property SourceIP As String
    Get
    Set
public:
property String^ SourceIP {
    String^ get ();
    void set (String^ value);
}
function get_SourceIP();
function set_SourceIP(value);

Property Value

Type: String
The IP address on the source server.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.TargetIP Property

IPAddressMapTargetIP Property

This value is the IP address on the target server.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetIP { get; set; }
Public Property TargetIP As String
    Get
    Set
public:
property String^ TargetIP {
    String^ get ();
    void set (String^ value);
}
function get_TargetIP();
function set_TargetIP(value);

Property Value

Type: String
The IP address on the target server.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.TtlValue Property

IPAddressMapTtlValue Property

This value is the time to live value in seconds.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
function get_TtlValue();
function set_TtlValue(value);

Property Value

Type: Int32
The TTL value, in seconds.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap Methods

The IPAddressMap type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


IPAddressMap.ToString Method

IPAddressMapToString Method

Returns a String that represents this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

IPAddressMap Class
DoubleTake.Core.Contract.Options Namespace


TargetServiceStatus Enumeration

Represents the state of a service.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum TargetServiceStatus
Public Enumeration TargetServiceStatus
public enum class TargetServiceStatus
DoubleTake.Core.Contract.Options.TargetServiceStatus = function();
DoubleTake.Core.Contract.Options.TargetServiceStatus.createEnum('DoubleTake.Core.Contract.Options.TargetServiceStatus', false);
Members
Member name | Value | Description
Stopped | 0 | The service is stopped.
Started | 1 | The service is started.
StopPending | 2 | The service is pending a stop.
StartPending | 3 | The service is pending a start.
ResumePending | 4 | The service is pending a resume.
PausePending | 5 | The service is pending a pause.
Paused | 6 | The service is paused.
Unknown | 7 | The state of the service is unknown.
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Class

Represents how a service is handled on the target server in full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.OptionsTargetServicesToStop

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetServicesToStop : IExtensibleDataObject
Public Class TargetServicesToStop
    Implements IExtensibleDataObject
public ref class TargetServicesToStop : IExtensibleDataObject
DoubleTake.Core.Contract.Options.TargetServicesToStop = function();

Type.createClass(
    'DoubleTake.Core.Contract.Options.TargetServicesToStop',
    null,
    IExtensibleDataObject);

The TargetServicesToStop type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesToStop |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failover | This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.
Public property | IsCritical | This value is true if the service is considered critical; otherwise, it is false.
Public property | KeepRunningNonCritical | This value is true if the non-critical service should be kept running; otherwise, it is false.
Public property | ServiceDescription | This value is the service description.
Public property | ServiceName | This value is the name of the service.
Public property | State | This value represents the state of a service
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a System.String that represents the current object (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Constructor

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesToStop()
Public Sub New
public:
TargetServicesToStop()
DoubleTake.Core.Contract.Options.TargetServicesToStop = function();
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Properties

The TargetServicesToStop type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Failover | This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.
Public property | IsCritical | This value is true if the service is considered critical; otherwise, it is false.
Public property | KeepRunningNonCritical | This value is true if the non-critical service should be kept running; otherwise, it is false.
Public property | ServiceDescription | This value is the service description.
Public property | ServiceName | This value is the name of the service.
Public property | State | This value represents the state of a service
Top
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ExtensionData Property

TargetServicesToStopExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.Failover Property

TargetServicesToStopFailover Property

This value is true if the service should be started after failover; otherwise, it is false. In addition to starting this service after failover, this value is whether the service will be stopped during failback.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Failover { get; set; }
Public Property Failover As Boolean
    Get
    Set
public:
property bool Failover {
    bool get ();
    void set (bool value);
}
function get_Failover();
function set_Failover(value);

Property Value

Type: Boolean
if this service should be started after failover; otherwise, .
Remarks
In addition to starting this service after failover, this value indicates whether the service will be stopped during failback.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.IsCritical Property

TargetServicesToStopIsCritical Property

This value is true if the service is considered critical; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsCritical { get; set; }
Public Property IsCritical As Boolean
    Get
    Set
public:
property bool IsCritical {
    bool get ();
    void set (bool value);
}
function get_IsCritical();
function set_IsCritical(value);

Property Value

Type: Boolean
if this service is critical; otherwise, .
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.KeepRunningNonCritical Property

TargetServicesToStopKeepRunningNonCritical Property

This value is true if the non-critical service should be kept running; otherwise, it is false.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool KeepRunningNonCritical { get; set; }
Public Property KeepRunningNonCritical As Boolean
    Get
    Set
public:
property bool KeepRunningNonCritical {
    bool get ();
    void set (bool value);
}
function get_KeepRunningNonCritical();
function set_KeepRunningNonCritical(value);

Property Value

Type: Boolean
if this non-critical service should be kept running; otherwise, .
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ServiceDescription Property

TargetServicesToStopServiceDescription Property

This value is the service description.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceDescription { get; set; }
Public Property ServiceDescription As String
    Get
    Set
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}
function get_ServiceDescription();
function set_ServiceDescription(value);

Property Value

Type: String
The service description.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ServiceName Property

TargetServicesToStopServiceName Property

This value is the name of the service.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
function get_ServiceName();
function set_ServiceName(value);

Property Value

Type: String
The name of the service.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.State Property

TargetServicesToStopState Property

This value represents the state of a service

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServiceStatus State { get; set; }
Public Property State As TargetServiceStatus
    Get
    Set
public:
property TargetServiceStatus State {
    TargetServiceStatus get ();
    void set (TargetServiceStatus value);
}
function get_State();
function set_State(value);

Property Value

Type: TargetServiceStatus
The state of this server.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop Methods

The TargetServicesToStop type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | ToString | Returns a System.String that represents the current object (Overrides ObjectToString.)
Top
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.Equals Method

TargetServicesToStopEquals Method

Determines whether the specified Object is equal to this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
function Equals(obj);

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
if the specified Object is equal to this instance; otherwise, .
Exceptions
Exception | Condition
NullReferenceException | The obj parameter is null.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.GetHashCode Method

TargetServicesToStopGetHashCode Method

Returns a hash code for this instance.

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
function GetHashCode();

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


TargetServicesToStop.ToString Method

TargetServicesToStopToString Method

Returns a System.String that represents the current object

Namespace: DoubleTake.Core.Contract.Options
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

TargetServicesToStop Class
DoubleTake.Core.Contract.Options Namespace


DoubleTake.Core.Contract.UVRA Namespace

Classes
 | Class | Description
Public class | LogicalVolume |
Public class | LvmOptions |
Public class | PhysicalVolume |
Public class | VolumeGroup |


LogicalVolume Class

Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRALogicalVolume

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class LogicalVolume : VolumeOptions
Public Class LogicalVolume
    Inherits VolumeOptions
public ref class LogicalVolume : public VolumeOptions
DoubleTake.Core.Contract.UVRA.LogicalVolume = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.LogicalVolume',
    DoubleTake.Core.Contract.VolumeOptions);

The LogicalVolume type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalVolume |
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}} (Inherited from VolumeOptions.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | LogicalVolumeName | This value is the name of the logical volume.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Constructor

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalVolume()
Public Sub New
public:
LogicalVolume()
DoubleTake.Core.Contract.UVRA.LogicalVolume = function();
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Properties

The LogicalVolume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}} (Inherited from VolumeOptions.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | LogicalVolumeName | This value is the name of the logical volume.
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume.LogicalVolumeName Property

LogicalVolumeLogicalVolumeName Property

This value is the name of the logical volume.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string LogicalVolumeName { get; set; }
Public Property LogicalVolumeName As String
    Get
    Set
public:
property String^ LogicalVolumeName {
    String^ get ();
    void set (String^ value);
}
function get_LogicalVolumeName();
function set_LogicalVolumeName(value);

Property Value

Type: String
The logical volume name.
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LogicalVolume Methods

The LogicalVolume type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

LogicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Class

Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.UVRALvmOptions

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class LvmOptions : IExtensibleDataObject
Public Class LvmOptions
    Implements IExtensibleDataObject
public ref class LvmOptions : IExtensibleDataObject
DoubleTake.Core.Contract.UVRA.LvmOptions = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.LvmOptions',
    null,
    IExtensibleDataObject);

The LvmOptions type exposes the following members.

Constructors
 | Name | Description
Public method | LvmOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeGroup | This value represents the volume group properties.
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Constructor

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions()
Public Sub New
public:
LvmOptions()
DoubleTake.Core.Contract.UVRA.LvmOptions = function();
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions Properties

The LvmOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | VolumeGroup | This value represents the volume group properties.
Top
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions.ExtensionData Property

LvmOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


LvmOptions.VolumeGroup Property

LvmOptionsVolumeGroup Property

This value represents the volume group properties.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeGroup[] VolumeGroup { get; set; }
Public Property VolumeGroup As VolumeGroup()
    Get
    Set
public:
property array<VolumeGroup^>^ VolumeGroup {
    array<VolumeGroup^>^ get ();
    void set (array<VolumeGroup^>^ value);
}
function get_VolumeGroup();
function set_VolumeGroup(value);

Property Value

Type: VolumeGroup
See Also

Reference

LvmOptions Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Class

Inheritance Hierarchy
SystemObject
DoubleTake.Common.ContractPhysicalItem
DoubleTake.Common.ContractVolume
DoubleTake.Core.ContractVolumeOptions
DoubleTake.Core.Contract.UVRAPhysicalVolume

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class PhysicalVolume : VolumeOptions
Public Class PhysicalVolume
    Inherits VolumeOptions
public ref class PhysicalVolume : public VolumeOptions
DoubleTake.Core.Contract.UVRA.PhysicalVolume = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.PhysicalVolume',
    DoubleTake.Core.Contract.VolumeOptions);

The PhysicalVolume type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalVolume |
Top
Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}} (Inherited from VolumeOptions.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Constructor

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalVolume()
Public Sub New
public:
PhysicalVolume()
DoubleTake.Core.Contract.UVRA.PhysicalVolume = function();
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Properties

The PhysicalVolume type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | This value represents the file system attributes. (Inherited from PhysicalItem.)
Public property | AvailableFreeSpace | This value is the amount of free space on the volume. (Inherited from Volume.)
Public property | CreationTime | This value is the time when the item was created. (Inherited from PhysicalItem.)
Public property | DesiredSize | This value is the desired size of the new volume. (Inherited from VolumeOptions.)
Public property | DiskControllerType | This value is the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk. (Inherited from VolumeOptions.)
Public property | DiskProvisioningType | This value is the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V. (Inherited from VolumeOptions.)
Public property | DriveFormat | This value is the file system format of the volume. (Inherited from Volume.)
Public property | DriveType | This value is the drive type. (Inherited from Volume.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from PhysicalItem.)
Public property | Guid | Disk UUID of an existing virtual disk. The UUID of the virtual disks stays same(vmdks retain their UUID) even in case of disks vMotioned. So, this can be used to uniquely identify virtual disks across the vMotion. GUID => @{name="UUID";expr={$_.extensiondata.backing.uuid}} (Inherited from VolumeOptions.)
Public property | IsContainer | This value is true if the item is a container of other items; otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsReadOnly | This value is true if the item is read-only (meaning the Saturation cannot be changed); otherwise, it is false. (Inherited from PhysicalItem.)
Public property | IsSupported | Whether or not this volume is supported. (Inherited from Volume.)
Public property | IsSystemDrive | This value is true if the volume is the system volume; otherwise, it is false. (Inherited from Volume.)
Public property | ItemType | This value is the type of item. (Inherited from PhysicalItem.)
Public property | Label | This value is the label assigned to the volume. (Inherited from Volume.)
Public property | LastAccessTime | This value is the time when the item was last accessed. (Inherited from PhysicalItem.)
Public property | LastWriteTime | This value is the time when the item was last written to. (Inherited from PhysicalItem.)
Public property | Metadata | This value is any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type. (Inherited from PhysicalItem.)
Public property | Name | This value is the name of the item. Typically, this name is used for display in the user interface. (Inherited from PhysicalItem.)
Public property | PartitionName | This value is the partition name of the item. (Inherited from PhysicalItem.)
Public property | Path | This value is the path of the item. (Inherited from PhysicalItem.)
Public property | PreexistingDiskPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created. (Inherited from VolumeOptions.)
Public property | Saturation | This value represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface. (Inherited from PhysicalItem.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from Volume.)
Public property | Size | This value is the physical size of the item. (Inherited from PhysicalItem.)
Public property | TotalSize | This value is the total size of the volume. (Inherited from Volume.)
Public property | VirtualDiskPath | This value is the path on the host where the volume should be stored. (Inherited from VolumeOptions.)
Public property | VolumeSignature | This value is the volume signature. (Inherited from VolumeOptions.)
Public property | VolumeType | This value is the type of volume. (Inherited from Volume.)
Top
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


PhysicalVolume Methods

The PhysicalVolume type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from VolumeOptions.)
Top
See Also

Reference

PhysicalVolume Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Class

Inheritance Hierarchy
SystemObject
DoubleTake.Core.Contract.UVRAVolumeGroup

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeGroup : IExtensibleDataObject
Public Class VolumeGroup
    Implements IExtensibleDataObject
public ref class VolumeGroup : IExtensibleDataObject
DoubleTake.Core.Contract.UVRA.VolumeGroup = function();

Type.createClass(
    'DoubleTake.Core.Contract.UVRA.VolumeGroup',
    null,
    IExtensibleDataObject);

The VolumeGroup type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeGroup |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalVolume | This value represents the logical volumes in the volume group.
Public property | MaxPhysicalVolumeSize | This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.
Public property | Name | This value is the name of the volume group on the source.
Public property | PhysicalVolume | This value represents the physical volumes in the volume group.
Public property | PreexistingDisksPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceVolumeGroupSize | This value is the size of the volume group on the source.
Top
See Also

Reference

DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Constructor

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeGroup()
Public Sub New
public:
VolumeGroup()
DoubleTake.Core.Contract.UVRA.VolumeGroup = function();
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup Properties

The VolumeGroup type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalVolume | This value represents the logical volumes in the volume group.
Public property | MaxPhysicalVolumeSize | This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.
Public property | Name | This value is the name of the volume group on the source.
Public property | PhysicalVolume | This value represents the physical volumes in the volume group.
Public property | PreexistingDisksPath | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SourceVolumeGroupSize | This value is the size of the volume group on the source.
Top
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.ExtensionData Property

VolumeGroupExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.LogicalVolume Property

VolumeGroupLogicalVolume Property

This value represents the logical volumes in the volume group.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogicalVolume[] LogicalVolume { get; set; }
Public Property LogicalVolume As LogicalVolume()
    Get
    Set
public:
property array<LogicalVolume^>^ LogicalVolume {
    array<LogicalVolume^>^ get ();
    void set (array<LogicalVolume^>^ value);
}
function get_LogicalVolume();
function set_LogicalVolume(value);

Property Value

Type: LogicalVolume
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.MaxPhysicalVolumeSize Property

VolumeGroupMaxPhysicalVolumeSize Property

This value is the maximum size, in bytes, of the virtual disks used to create the volume group. The default value is equal to the maximum size that can be attached to the datastore you selected. That will depend on your ESX version, your file system version, and the block size of your datastore.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxPhysicalVolumeSize { get; set; }
Public Property MaxPhysicalVolumeSize As Long
    Get
    Set
public:
property long long MaxPhysicalVolumeSize {
    long long get ();
    void set (long long value);
}
function get_MaxPhysicalVolumeSize();
function set_MaxPhysicalVolumeSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.Name Property

VolumeGroupName Property

This value is the name of the volume group on the source.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.PhysicalVolume Property

VolumeGroupPhysicalVolume Property

This value represents the physical volumes in the volume group.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PhysicalVolume[] PhysicalVolume { get; set; }
Public Property PhysicalVolume As PhysicalVolume()
    Get
    Set
public:
property array<PhysicalVolume^>^ PhysicalVolume {
    array<PhysicalVolume^>^ get ();
    void set (array<PhysicalVolume^>^ value);
}
function get_PhysicalVolume();
function set_PhysicalVolume(value);

Property Value

Type: PhysicalVolume
The PhysicalVolumes
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.PreexistingDisksPath Property

VolumeGroupPreexistingDisksPath Property

This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PreexistingDisksPath { get; set; }
Public Property PreexistingDisksPath As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PreexistingDisksPath();
function set_PreexistingDisksPath(value);

Property Value

Type: String
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


VolumeGroup.SourceVolumeGroupSize Property

VolumeGroupSourceVolumeGroupSize Property

This value is the size of the volume group on the source.

Namespace: DoubleTake.Core.Contract.UVRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long SourceVolumeGroupSize { get; set; }
Public Property SourceVolumeGroupSize As Long
    Get
    Set
public:
property long long SourceVolumeGroupSize {
    long long get ();
    void set (long long value);
}
function get_SourceVolumeGroupSize();
function set_SourceVolumeGroupSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeGroup Class
DoubleTake.Core.Contract.UVRA Namespace


DoubleTake.Diagnostics.Contract Namespace

Classes
 | Class | Description
Public class | LogMessage | Represents an log message in a Double-Take message log.


LogMessage Class

Represents an log message in a Double-Take message log.
Inheritance Hierarchy
SystemObject
DoubleTake.Diagnostics.ContractLogMessage

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class LogMessage : IExtensibleDataObject
Public Class LogMessage
    Implements IExtensibleDataObject
public ref class LogMessage : IExtensibleDataObject
DoubleTake.Diagnostics.Contract.LogMessage = function();

Type.createClass(
    'DoubleTake.Diagnostics.Contract.LogMessage',
    null,
    IExtensibleDataObject);

The LogMessage type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessage |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

DoubleTake.Diagnostics.Contract Namespace


LogMessage Constructor

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LogMessage()
Public Sub New
public:
LogMessage()
DoubleTake.Diagnostics.Contract.LogMessage = function();
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage Properties

The LogMessage type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the message ID.
Public property | MessageType | This value is the type of log message.
Public property | ProcessId | This value is the process ID of the process that generated the message.
Public property | Sequence | This value is the sequence number of this message in the log file.
Public property | Text | This value is the content of the log message.
Public property | ThreadId | This value is the thread ID of the thread that generated the message.
Public property | Timestamp | This value is the local time when the message was generated.
Public property | TimestampOffset | This value is the relative UTC time when the message was generated.
Top
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ExtensionData Property

LogMessageExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Id Property

LogMessageId Property

This value is the message ID.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Int32
The message id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.MessageType Property

LogMessageMessageType Property

This value is the type of log message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MessageType { get; set; }
Public Property MessageType As Integer
    Get
    Set
public:
property int MessageType {
    int get ();
    void set (int value);
}
function get_MessageType();
function set_MessageType(value);

Property Value

Type: Int32
The message type.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ProcessId Property

LogMessageProcessId Property

This value is the process ID of the process that generated the message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ProcessId { get; set; }
Public Property ProcessId As Integer
    Get
    Set
public:
property int ProcessId {
    int get ();
    void set (int value);
}
function get_ProcessId();
function set_ProcessId(value);

Property Value

Type: Int32
The process id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Sequence Property

LogMessageSequence Property

This value is the sequence number of this message in the log file.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
function get_Sequence();
function set_Sequence(value);

Property Value

Type: Int32
The message's sequence number within the log file.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Text Property

LogMessageText Property

This value is the content of the log message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
function get_Text();
function set_Text(value);

Property Value

Type: String
The textual part of the message.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.ThreadId Property

LogMessageThreadId Property

This value is the thread ID of the thread that generated the message.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
function get_ThreadId();
function set_ThreadId(value);

Property Value

Type: Int32
The thread id.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.Timestamp Property

LogMessageTimestamp Property

This value is the local time when the message was generated.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTime
The message's timestamp.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


LogMessage.TimestampOffset Property

LogMessageTimestampOffset Property

This value is the relative UTC time when the message was generated.

Namespace: DoubleTake.Diagnostics.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset TimestampOffset { get; set; }
Public Property TimestampOffset As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimestampOffset {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_TimestampOffset();
function set_TimestampOffset(value);

Property Value

Type: DateTimeOffset
The message's timestamp relative to UTC.
See Also

Reference

LogMessage Class
DoubleTake.Diagnostics.Contract Namespace


DoubleTake.Jobs Namespaces

Namespaces
Namespace | Description
DoubleTake.Jobs.Contract |
DoubleTake.Jobs.Contract.FullServer |
DoubleTake.Jobs.Contract.ImageBased |
DoubleTake.Jobs.Contract.Scheduling |


DoubleTake.Jobs.Contract Namespace

Classes
 | Class | Description
Public class | ApplicationOptions | Represents options for configuring an application protection job.
Public class | CloudOptions | Cloud related job options.
Public class | ClusterOptions | Cluster related job options
Public class | CoreConnectionDetails | Represents details of an underlying engine connection used by a job.
Public class | CoreConnectionOptions | Represents option for configuring an underlying engine connection used by a job.
Public class | CoreMonitorDetails | Represents details of an underlying engine monitor used by a job.
Public class | CoreMonitorOptions | Represents options for configuring an underlying engine monitor used by a job.
Public class | CoreQualificationResults | Represents information that may be needed to configure an engine connection.
Public class | CutoverDetails | Represents the details of a cutover operation.
Public class | DeleteOptions | Defines the options provided when deleting a job.
Public class | DnsDomainDetails | Represents a DNS domain that will be updated during DNS failover.
Public class | DNSOptions | Represents the options for DNS failover on a job.
Public class | EngineControlStatus | Represents the status of an engine connection used by a job.
Public class | FailbackOptions | Represents the options used when failing back a job.
Public class | FailoverOptions | Represents the options used when failing over a job.
Public class | FailoverReport |
Public class | Feature | Represents a services endpoint that provides additional features for a job.
Public class | FullServerFailoverOptions | Represents options for working with the full server failover feature of a job.
Public class | FullServerTestFailoverOptions | FullServer TestFailover related options
Public class | ImageProtectionOptions | Represents options for working with the image protection feature of a job.
Public class | ImageRecoveryOptions | Represents options for working with the image recovery feature of a job.
Public class | JobAction | Represents an action recently reported by a job.
Public class | JobInfo | Represents a job.
Public class | JobOptions | Represents the user-configurable options of a job.
Public class | JobQualificationResults | Defines a set of values that represent the possible options when creating or editing a job.
Public class | JobStatistics | Represents the current statistics for a job.
Public class | JobStatus | Represents the current status of a job.
Public class | MachineInfoClass | Data about the target machine
Public class | MonitoringOptions | Represents the options for monitoring services.
Public class | RecommendedFailbackOptions | Includes the recommended options for failing back a job and additional information that can be used to customize failback options.
Public class | RecommendedFailoverOptions | Includes the recommended options for failing over a job and additional information that can be used to customize failover options.
Public class | RecommendedJobOptions | Represents the recommended options for a job and potential values for those options.
Public class | RecommendedRestoreOptions | Includes the recommended options for restoring job and additional information that can be used to customize restore options.
Public class | RestoreOptions | Represents the options used when restoring a job.
Public class | ReverseOptions |
Public class | ServiceInformation | Contains information about a service.
Public class | ServiceMonitoringOptions | A data contract representing the options for monitoring services on a source.
Public class | SnapshotDetails |
Public class | SnapshotSetInfo |
Public class | SystemStateOptions | Represents options for using the system state feature of a job.
Public class | TargetFileServerQualificationResults | Represents target configuration information for clustered files and folders jobs.
Public class | TargetServicesOptions | Represents options for configuring how target services function after failover.
Public class | TestFailoverOptions |
Public class | TestFailoverPersistedState |
Public class | TestFailoverServerCredential | Represents the testfailover server (address, port, and credentials) required to work for fullserver testfailover.
Public class | TimesClass | Time at various points of the failover.
Public class | UnmanagedConnectionOptions | Represents options for configuring an unmanaged connection job.
Public class | VerificationStep | Represents a step in a verification task.
Public class | VRAOptions | Represents options for configuring the Virtual Recovery Assistant feature.
Public class | VRAQualificationResults | Represents information that may be needed to configure a VRA job.
Enumerations
 | Enumeration | Description
Public enumeration | ActionStatus | Represents the status of a job action.
Public enumeration | DiskConfigStrategy | Disk configuration strategy for the replica
Public enumeration | FailoverMode | Indicates the style of failover.
Public enumeration | FailoverStyle | Type of failover being used.
Public enumeration | FailoverType | Indicates the type of failover.
Public enumeration | Health | Indicates the health of a job.
Public enumeration | HighLevelState | Defines the possible high-level states of a job.
Public enumeration | RestoreStatus | Indicates the status of a restore operation.
Public enumeration | VerificationStatus | Indicates the status of a verification task or step.


ActionStatus Enumeration

Represents the status of a job action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum ActionStatus
Public Enumeration ActionStatus
public enum class ActionStatus
DoubleTake.Jobs.Contract.ActionStatus = function();
DoubleTake.Jobs.Contract.ActionStatus.createEnum('DoubleTake.Jobs.Contract.ActionStatus', false);
Members
Member name | Value | Description
Pending | 0 | The action has not yet started.
Running | 1 | The action is running.
Completed | 2 | The action has completed successfully.
Cancelled | 3 | The action was cancelled.
Faulted | 4 | The action encountered an error.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ApplicationOptions Class

Represents options for configuring an application protection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractApplicationOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ApplicationOptions : IExtensibleDataObject
Public Class ApplicationOptions
    Implements IExtensibleDataObject
public ref class ApplicationOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ApplicationOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ApplicationOptions',
    null,
    IExtensibleDataObject);

The ApplicationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationOptions |
Top
Properties
 | Name | Description
Public property | AagInstances | This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.
Public property | DnsRecordLocks | Do not use this property. Double-Take uses it internally.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsAag | Do not use this property. Double-Take uses it internally.
Public property | MonitoredServiceRepeatCount | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | MonitoredServices | This property is no longer used. See MonitorConfiguration.ScriptMonitorName.
Public property | MonitorScript | This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.
Public property | RestartService | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | SourceDomain | This value is the source server's primary domain.
Public property | SourceName | This value is the name of the source server.
Public property | TargetDomain | This value is the target server's primary domain.
Public property | TargetName | This value is the name of the target server.
Public property | TestPostFailoverScript | This value is the path and name of the script to run after the target is brought online during a test failover.
Public property | TestPostFailoverScriptArguments | This value is the arguments for the TestPostFailoverScript.
Public property | TestPreFailbackScript | This value is the path and name of the script to run before failing back after a test failover.
Public property | TestPreFailbackScriptArguments | This value is the arguments for the TestPreFailbackScript.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ApplicationOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ApplicationOptions()
Public Sub New
public:
ApplicationOptions()
DoubleTake.Jobs.Contract.ApplicationOptions = function();
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions Properties

The ApplicationOptions type exposes the following members.

Properties
 | Name | Description
Public property | AagInstances | This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.
Public property | DnsRecordLocks | Do not use this property. Double-Take uses it internally.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsAag | Do not use this property. Double-Take uses it internally.
Public property | MonitoredServiceRepeatCount | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | MonitoredServices | This property is no longer used. See MonitorConfiguration.ScriptMonitorName.
Public property | MonitorScript | This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.
Public property | RestartService | This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.
Public property | SourceDomain | This value is the source server's primary domain.
Public property | SourceName | This value is the name of the source server.
Public property | TargetDomain | This value is the target server's primary domain.
Public property | TargetName | This value is the name of the target server.
Public property | TestPostFailoverScript | This value is the path and name of the script to run after the target is brought online during a test failover.
Public property | TestPostFailoverScriptArguments | This value is the arguments for the TestPostFailoverScript.
Public property | TestPreFailbackScript | This value is the path and name of the script to run before failing back after a test failover.
Public property | TestPreFailbackScriptArguments | This value is the arguments for the TestPreFailbackScript.
Top
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.AagInstances Property

ApplicationOptionsAagInstances Property

This value is the instance name corresponding to the SQL AlwaysOn Availability Group Server. This value should never contain more than one entry.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> AagInstances { get; set; }
Public Property AagInstances As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AagInstances {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_AagInstances();
function set_AagInstances(value);

Property Value

Type: IEnumerable String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.DnsRecordLocks Property

ApplicationOptionsDnsRecordLocks Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<DnsRecordLockOptions> DnsRecordLocks { get; set; }
Public Property DnsRecordLocks As IEnumerable(Of DnsRecordLockOptions)
    Get
    Set
public:
property IEnumerable<DnsRecordLockOptions^>^ DnsRecordLocks {
    IEnumerable<DnsRecordLockOptions^>^ get ();
    void set (IEnumerable<DnsRecordLockOptions^>^ value);
}
function get_DnsRecordLocks();
function set_DnsRecordLocks(value);

Property Value

Type: IEnumerable DnsRecordLockOptions
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.ExtensionData Property

ApplicationOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.IsAag Property

ApplicationOptionsIsAag Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsAag { get; set; }
Public Property IsAag As Boolean
    Get
    Set
public:
property bool IsAag {
    bool get ();
    void set (bool value);
}
function get_IsAag();
function set_IsAag(value);

Property Value

Type: Boolean
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitoredServiceRepeatCount Property

ApplicationOptionsMonitoredServiceRepeatCount Property

This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int MonitoredServiceRepeatCount { get; set; }
Public Property MonitoredServiceRepeatCount As Integer
    Get
    Set
public:
property int MonitoredServiceRepeatCount {
    int get ();
    void set (int value);
}
function get_MonitoredServiceRepeatCount();
function set_MonitoredServiceRepeatCount(value);

Property Value

Type: Int32
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitoredServices Property

ApplicationOptionsMonitoredServices Property

This property is no longer used. See MonitorConfiguration.ScriptMonitorName.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] MonitoredServices { get; set; }
Public Property MonitoredServices As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ MonitoredServices {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_MonitoredServices();
function set_MonitoredServices(value);

Property Value

Type: ServiceInformation
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.MonitorScript Property

ApplicationOptionsMonitorScript Property

This property is no longer used. See CoreMonitorOptions.MonitorConfiguration.ScriptMonitorName.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MonitorScript { get; set; }
Public Property MonitorScript As String
    Get
    Set
public:
property String^ MonitorScript {
    String^ get ();
    void set (String^ value);
}
function get_MonitorScript();
function set_MonitorScript(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.RestartService Property

ApplicationOptionsRestartService Property

This property is no longer used. See MonitoringOptions.ServiceMonitoringOptions.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool RestartService { get; set; }
Public Property RestartService As Boolean
    Get
    Set
public:
property bool RestartService {
    bool get ();
    void set (bool value);
}
function get_RestartService();
function set_RestartService(value);

Property Value

Type: Boolean
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.SourceDomain Property

ApplicationOptionsSourceDomain Property

This value is the source server's primary domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceDomain { get; set; }
Public Property SourceDomain As String
    Get
    Set
public:
property String^ SourceDomain {
    String^ get ();
    void set (String^ value);
}
function get_SourceDomain();
function set_SourceDomain(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.SourceName Property

ApplicationOptionsSourceName Property

This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
function get_SourceName();
function set_SourceName(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TargetDomain Property

ApplicationOptionsTargetDomain Property

This value is the target server's primary domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDomain { get; set; }
Public Property TargetDomain As String
    Get
    Set
public:
property String^ TargetDomain {
    String^ get ();
    void set (String^ value);
}
function get_TargetDomain();
function set_TargetDomain(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TargetName Property

ApplicationOptionsTargetName Property

This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
function get_TargetName();
function set_TargetName(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPostFailoverScript Property

ApplicationOptionsTestPostFailoverScript Property

This value is the path and name of the script to run after the target is brought online during a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPostFailoverScript { get; set; }
Public Property TestPostFailoverScript As String
    Get
    Set
public:
property String^ TestPostFailoverScript {
    String^ get ();
    void set (String^ value);
}
function get_TestPostFailoverScript();
function set_TestPostFailoverScript(value);

Property Value

Type: String
Remarks
If arguments are passed, file to be executed should be enclosed in quotations
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPostFailoverScriptArguments Property

ApplicationOptionsTestPostFailoverScriptArguments Property

This value is the arguments for the TestPostFailoverScript.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPostFailoverScriptArguments { get; set; }
Public Property TestPostFailoverScriptArguments As String
    Get
    Set
public:
property String^ TestPostFailoverScriptArguments {
    String^ get ();
    void set (String^ value);
}
function get_TestPostFailoverScriptArguments();
function set_TestPostFailoverScriptArguments(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPreFailbackScript Property

ApplicationOptionsTestPreFailbackScript Property

This value is the path and name of the script to run before failing back after a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPreFailbackScript { get; set; }
Public Property TestPreFailbackScript As String
    Get
    Set
public:
property String^ TestPreFailbackScript {
    String^ get ();
    void set (String^ value);
}
function get_TestPreFailbackScript();
function set_TestPreFailbackScript(value);

Property Value

Type: String
Remarks
If arguments are passed, file to be executed should be enclosed in quotations
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


ApplicationOptions.TestPreFailbackScriptArguments Property

ApplicationOptionsTestPreFailbackScriptArguments Property

This value is the arguments for the TestPreFailbackScript.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestPreFailbackScriptArguments { get; set; }
Public Property TestPreFailbackScriptArguments As String
    Get
    Set
public:
property String^ TestPreFailbackScriptArguments {
    String^ get ();
    void set (String^ value);
}
function get_TestPreFailbackScriptArguments();
function set_TestPreFailbackScriptArguments(value);

Property Value

Type: String
See Also

Reference

ApplicationOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions Class

Cloud related job options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCloudOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CloudOptions
Public Class CloudOptions
public ref class CloudOptions
DoubleTake.Jobs.Contract.CloudOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CloudOptions');

The CloudOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CloudOptions |
Top
Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CloudOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CloudOptions()
Public Sub New
public:
CloudOptions()
DoubleTake.Jobs.Contract.CloudOptions = function();
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions Properties

The CloudOptions type exposes the following members.

Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions.EngineJobType Property

CloudOptionsEngineJobType Property

Gets or sets the engine job type for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
function get_EngineJobType();
function set_EngineJobType(value);

Property Value

Type: EngineJobType
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


CloudOptions.HardLinkLogPath Property

CloudOptionsHardLinkLogPath Property

Gets or sets the path for the hard link processing log/report.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string HardLinkLogPath { get; set; }
Public Property HardLinkLogPath As String
    Get
    Set
public:
property String^ HardLinkLogPath {
    String^ get ();
    void set (String^ value);
}
function get_HardLinkLogPath();
function set_HardLinkLogPath(value);

Property Value

Type: String
See Also

Reference

CloudOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Class

Cluster related job options
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractClusterOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ClusterOptions
Public Class ClusterOptions
public ref class ClusterOptions
DoubleTake.Jobs.Contract.ClusterOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ClusterOptions');

The ClusterOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterOptions |
Top
Properties
 | Name | Description
Public property | DependOnResources | This value is the dependent resources.
Public property | OriginalSourceClusterId | This value is the unique ID of the source cluster.
Public property | SourceClusterName | This value is the name of the source cluster.
Public property | SourceGroupName | The value is the name of the source group.
Public property | SourceIsCluster | This value is true if the source is a cluster; otherwise, it is false.
Public property | TargetClusterName | This value is the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | This value is the optional name of the target cluster resource prefix.
Public property | TargetClusterStoragePath | This value is the location of the target cluster storage.
Public property | TargetGroupName | This value is the name of the target group.
Public property | TargetIsCluster | This value is true if the target is a cluster; otherwise, it is false.
Public property | TargetVirtualServers | This value is the name of the target virtual servers.
Top
Fields
 | Name | Description
Public field | InitializeOnTargetNodeMove | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ClusterOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterOptions()
Public Sub New
public:
ClusterOptions()
DoubleTake.Jobs.Contract.ClusterOptions = function();
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Properties

The ClusterOptions type exposes the following members.

Properties
 | Name | Description
Public property | DependOnResources | This value is the dependent resources.
Public property | OriginalSourceClusterId | This value is the unique ID of the source cluster.
Public property | SourceClusterName | This value is the name of the source cluster.
Public property | SourceGroupName | The value is the name of the source group.
Public property | SourceIsCluster | This value is true if the source is a cluster; otherwise, it is false.
Public property | TargetClusterName | This value is the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | This value is the optional name of the target cluster resource prefix.
Public property | TargetClusterStoragePath | This value is the location of the target cluster storage.
Public property | TargetGroupName | This value is the name of the target group.
Public property | TargetIsCluster | This value is true if the target is a cluster; otherwise, it is false.
Public property | TargetVirtualServers | This value is the name of the target virtual servers.
Top
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.DependOnResources Property

ClusterOptionsDependOnResources Property

This value is the dependent resources.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> DependOnResources { get; set; }
Public Property DependOnResources As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ DependOnResources {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_DependOnResources();
function set_DependOnResources(value);

Property Value

Type: IEnumerable String
The list of resources to depend on.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.OriginalSourceClusterId Property

ClusterOptionsOriginalSourceClusterId Property

This value is the unique ID of the source cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string OriginalSourceClusterId { get; set; }
Public Property OriginalSourceClusterId As String
    Get
    Set
public:
property String^ OriginalSourceClusterId {
    String^ get ();
    void set (String^ value);
}
function get_OriginalSourceClusterId();
function set_OriginalSourceClusterId(value);

Property Value

Type: String
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceClusterName Property

ClusterOptionsSourceClusterName Property

This value is the name of the source cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceClusterName { get; set; }
Public Property SourceClusterName As String
    Get
    Set
public:
property String^ SourceClusterName {
    String^ get ();
    void set (String^ value);
}
function get_SourceClusterName();
function set_SourceClusterName(value);

Property Value

Type: String
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceGroupName Property

ClusterOptionsSourceGroupName Property

The value is the name of the source group.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceGroupName { get; set; }
Public Property SourceGroupName As String
    Get
    Set
public:
property String^ SourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_SourceGroupName();
function set_SourceGroupName(value);

Property Value

Type: String
The name of the source group.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.SourceIsCluster Property

ClusterOptionsSourceIsCluster Property

This value is true if the source is a cluster; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceIsCluster { get; set; }
Public Property SourceIsCluster As Boolean
    Get
    Set
public:
property bool SourceIsCluster {
    bool get ();
    void set (bool value);
}
function get_SourceIsCluster();
function set_SourceIsCluster(value);

Property Value

Type: Boolean
true if [source is cluster]; otherwise, false.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterName Property

ClusterOptionsTargetClusterName Property

This value is the name of the target cluster.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterName { get; set; }
Public Property TargetClusterName As String
    Get
    Set
public:
property String^ TargetClusterName {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterName();
function set_TargetClusterName(value);

Property Value

Type: String
The name of the target cluster.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterResourceNamePrefix Property

ClusterOptionsTargetClusterResourceNamePrefix Property

This value is the optional name of the target cluster resource prefix.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterResourceNamePrefix { get; set; }
Public Property TargetClusterResourceNamePrefix As String
    Get
    Set
public:
property String^ TargetClusterResourceNamePrefix {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterResourceNamePrefix();
function set_TargetClusterResourceNamePrefix(value);

Property Value

Type: String
The target cluster resource name prefix.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetClusterStoragePath Property

ClusterOptionsTargetClusterStoragePath Property

This value is the location of the target cluster storage.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetClusterStoragePath { get; set; }
Public Property TargetClusterStoragePath As String
    Get
    Set
public:
property String^ TargetClusterStoragePath {
    String^ get ();
    void set (String^ value);
}
function get_TargetClusterStoragePath();
function set_TargetClusterStoragePath(value);

Property Value

Type: String
The target cluster storage location.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetGroupName Property

ClusterOptionsTargetGroupName Property

This value is the name of the target group.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetGroupName { get; set; }
Public Property TargetGroupName As String
    Get
    Set
public:
property String^ TargetGroupName {
    String^ get ();
    void set (String^ value);
}
function get_TargetGroupName();
function set_TargetGroupName(value);

Property Value

Type: String
The name of the target group.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetIsCluster Property

ClusterOptionsTargetIsCluster Property

This value is true if the target is a cluster; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetIsCluster { get; set; }
Public Property TargetIsCluster As Boolean
    Get
    Set
public:
property bool TargetIsCluster {
    bool get ();
    void set (bool value);
}
function get_TargetIsCluster();
function set_TargetIsCluster(value);

Property Value

Type: Boolean
true if [target is cluster]; otherwise, false.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.TargetVirtualServers Property

ClusterOptionsTargetVirtualServers Property

This value is the name of the target virtual servers.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> TargetVirtualServers { get; set; }
Public Property TargetVirtualServers As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ TargetVirtualServers {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_TargetVirtualServers();
function set_TargetVirtualServers(value);

Property Value

Type: IEnumerable String
The name of the target virtual servers.
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions Fields

The ClusterOptions type exposes the following members.

Fields
 | Name | Description
Public field | InitializeOnTargetNodeMove | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


ClusterOptions.InitializeOnTargetNodeMove Field

ClusterOptionsInitializeOnTargetNodeMove Field

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool InitializeOnTargetNodeMove
Public InitializeOnTargetNodeMove As Boolean
public:
bool InitializeOnTargetNodeMove
var InitializeOnTargetNodeMove

Field Value

Type: Boolean
See Also

Reference

ClusterOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Class

Represents details of an underlying engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreConnectionDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreConnectionDetails : IExtensibleDataObject
Public Class CoreConnectionDetails
    Implements IExtensibleDataObject
public ref class CoreConnectionDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreConnectionDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreConnectionDetails',
    null,
    IExtensibleDataObject);

The CoreConnectionDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionDetails |
Top
Properties
 | Name | Description
Public property | BandwidthCollar | This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.
Public property | CompressionEnabled | This value is true if compression is enabled; otherwise, it is false.
Public property | CompressionLevel | This value is the current compression level.
Public property | ConnectionId | This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.
Public property | CurrentTime | This value is the time the connection detail was retrieved.
Public property | DiskQueueBytes | This value is the number of bytes queued on the target.
Public property | Encrypted | This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | This value is true if the initial mirror has completed; otherwise, it is false.
Public property | ManagedConnectionId | This value is the ID assigned to the connection by the Management Service.
Public property | MirrorBytesRemaining | This value is the number of remaining mirror bytes.
Public property | MirrorBytesSent | This value is the number of mirror bytes sent.
Public property | MirrorBytesSkipped | This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.
Public property | MirrorBytesTransmitted | The value is the number of mirror bytes transmitted.
Public property | MirrorEndTime | This value is the time when mirroring ended.
Public property | MirrorOpsQueued | This value is the number of mirror operations queued on the target.
Public property | MirrorPermillage | This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.
Public property | MirrorStartTime | This value is the time when mirroring started.
Public property | MirrorState | This value represents the state of mirroring.
Public property | PeerMemoryLow | This value is true if memory on the target is low; otherwise it is false.
Public property | ReplicationBytesQueued | This value is the number of replication bytes queued on the target.
Public property | ReplicationBytesSent | This value is the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | The value is the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | This value is the number of replication operations queued on the target.
Public property | ReplicationSetCalcInProgress | This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.
Public property | ReplicationState | This value represents the state of replication.
Public property | Restoring | This value is true if the connection is restoring data; otherwise, it is false.
Public property | SourceAccessLevel | This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | SourceAvailable | This value is true if the target can communicate with the source; otherwise, it is false.
Public property | SourceClusterResourceState | This value represents the state of the source cluster resource.
Public property | SourceEndpoint | This value is the source endpoint that is the route from the target back to the source.
Public property | SourceEngineAvailable | This value is true if the source replication engine is available; otherwise, it is false.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceRecoveryPointLatency | This value is the length of time replication is behind on the target compared to the source. This is the time period of data that would be lost if a failure were to occur at the current time.
Public property | SourceRecoveryPointTime | This value is the time that replication is synchronized between the source and target. The difference between the current time and this time is the time period of data that would be lost if a failure were to occur at the current time.
Public property | SourceUniqueId | This value is a unique ID assigned to the source.
Public property | StartTime | This value is the time the connection was started.
Public property | TargetAccessLevel | This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Public property | TargetEngineAvailable | This value is true if the target replication engine is available; otherwise, it is false.
Public property | TargetLoaded | This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetQueueBytes | This value is the number of bytes in the target queue.
Public property | TargetRoute | This value is the endpoint on the target that is the route the source is using for the connection. This route is in the format [address]:[port].
Public property | TargetState | This value represents the state of the target.
Public property | TargetUniqueId | This value is a unique ID assigned to the target.
Public property | TotalBytesSent | This value is the total number of bytes that have been sent for the connection.
Public property | TotalBytesTransmitted | This value is the total number of bytes that have been transmitted for the connection.
Public property | TotalOpsQueued | This value is the total number of operations queued on the target.
Public property | TransmissionMode | This value represents the state of data transmission from the source to the target.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails()
Public Sub New
public:
CoreConnectionDetails()
DoubleTake.Jobs.Contract.CoreConnectionDetails = function();
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails Properties

The CoreConnectionDetails type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.
Public property | CompressionEnabled | This value is true if compression is enabled; otherwise, it is false.
Public property | CompressionLevel | This value is the current compression level.
Public property | ConnectionId | This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.
Public property | CurrentTime | This value is the time the connection detail was retrieved.
Public property | DiskQueueBytes | This value is the number of bytes queued on the target.
Public property | Encrypted | This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | InitialMirrorComplete | This value is true if the initial mirror has completed; otherwise, it is false.
Public property | ManagedConnectionId | This value is the ID assigned to the connection by the Management Service.
Public property | MirrorBytesRemaining | This value is the number of remaining mirror bytes.
Public property | MirrorBytesSent | This value is the number of mirror bytes sent.
Public property | MirrorBytesSkipped | This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.
Public property | MirrorBytesTransmitted | The value is the number of mirror bytes transmitted.
Public property | MirrorEndTime | This value is the time when mirroring ended.
Public property | MirrorOpsQueued | This value is the number of mirror operations queued on the target.
Public property | MirrorPermillage | This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.
Public property | MirrorStartTime | This value is the time when mirroring started.
Public property | MirrorState | This value represents the state of mirroring.
Public property | PeerMemoryLow | This value is true if memory on the target is low; otherwise it is false.
Public property | ReplicationBytesQueued | This value is the number of replication bytes queued on the target.
Public property | ReplicationBytesSent | This value is the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | The value is the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | This value is the number of replication operations queued on the target.
Public property | ReplicationSetCalcInProgress | This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.
Public property | ReplicationState | This value represents the state of replication.
Public property | Restoring | This value is true if the connection is restoring data; otherwise, it is false.
Public property | SourceAccessLevel | This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | SourceAvailable | This value is true if the target can communicate with the source; otherwise, it is false.
Public property | SourceClusterResourceState | This value represents the state of the source cluster resource.
Public property | SourceEndpoint | This value is the source endpoint that is the route from the target back to the source.
Public property | SourceEngineAvailable | This value is true if the source replication engine is available; otherwise, it is false.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceRecoveryPointLatency | This value is the length of time replication is behind on the target compared to the source. This is the time period of data that would be lost if a failure were to occur at the current time.
Public property | SourceRecoveryPointTime | This value is the time that replication is synchronized between the source and target. The difference between the current time and this time is the time period of data that would be lost if a failure were to occur at the current time.
Public property | SourceUniqueId | This value is a unique ID assigned to the source.
Public property | StartTime | This value is the time the connection was started.
Public property | TargetAccessLevel | This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Public property | TargetEngineAvailable | This value is true if the target replication engine is available; otherwise, it is false.
Public property | TargetLoaded | This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetQueueBytes | This value is the number of bytes in the target queue.
Public property | TargetRoute | This value is the endpoint on the target that is the route the source is using for the connection. This route is in the format [address]:[port].
Public property | TargetState | This value represents the state of the target.
Public property | TargetUniqueId | This value is a unique ID assigned to the target.
Public property | TotalBytesSent | This value is the total number of bytes that have been sent for the connection.
Public property | TotalBytesTransmitted | This value is the total number of bytes that have been transmitted for the connection.
Public property | TotalOpsQueued | This value is the total number of operations queued on the target.
Public property | TransmissionMode | This value represents the state of data transmission from the source to the target.
Top
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.BandwidthCollar Property

CoreConnectionDetailsBandwidthCollar Property

This value is the current bandwidth limit. It may vary according to the bandwidth limit schedule.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
function get_BandwidthCollar();
function set_BandwidthCollar(value);

Property Value

Type: Int32
The current bandwidth limit.
Remarks
The bandwidth limit may vary according to the bandwidth limit schedule.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.CompressionEnabled Property

CoreConnectionDetailsCompressionEnabled Property

This value is true if compression is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
function get_CompressionEnabled();
function set_CompressionEnabled(value);

Property Value

Type: Boolean
if compression is enabled; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.CompressionLevel Property

CoreConnectionDetailsCompressionLevel Property

This value is the current compression level.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
function get_CompressionLevel();
function set_CompressionLevel(value);

Property Value

Type: Int32
The compression level.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ConnectionId Property

CoreConnectionDetailsConnectionId Property

This value is the ID assigned to the connection. The ID is a one-based index that resets each time the Double-Take service is restarted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Int32
The connection id.
Remarks
This series is reset each time the Double-Take service is restarted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.CurrentTime Property

CoreConnectionDetailsCurrentTime Property

This value is the time the connection detail was retrieved.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset CurrentTime { get; set; }
Public Property CurrentTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset CurrentTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_CurrentTime();
function set_CurrentTime(value);

Property Value

Type: DateTimeOffset
Connection CurrentTime.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.DiskQueueBytes Property

CoreConnectionDetailsDiskQueueBytes Property

This value is the number of bytes queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
function get_DiskQueueBytes();
function set_DiskQueueBytes(value);

Property Value

Type: Int64
The disk queue bytes.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.Encrypted Property

CoreConnectionDetailsEncrypted Property

This value is true if Double-Take is encrypting data before sending it to the target; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Encrypted { get; set; }
Public Property Encrypted As Boolean
    Get
    Set
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
function get_Encrypted();
function set_Encrypted(value);

Property Value

Type: Boolean
True if network data is being encrypted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ExtensionData Property

CoreConnectionDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.InitialMirrorComplete Property

CoreConnectionDetailsInitialMirrorComplete Property

This value is true if the initial mirror has completed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
function get_InitialMirrorComplete();
function set_InitialMirrorComplete(value);

Property Value

Type: Boolean
if the initial mirror has completed; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ManagedConnectionId Property

CoreConnectionDetailsManagedConnectionId Property

This value is the ID assigned to the connection by the Management Service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ManagedConnectionId { get; set; }
Public Property ManagedConnectionId As Guid
    Get
    Set
public:
property Guid ManagedConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ManagedConnectionId();
function set_ManagedConnectionId(value);

Property Value

Type: Guid
The managed connection id.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesRemaining Property

CoreConnectionDetailsMirrorBytesRemaining Property

This value is the number of remaining mirror bytes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesRemaining();
function set_MirrorBytesRemaining(value);

Property Value

Type: Int64
The number of mirror bytes remaining.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesSent Property

CoreConnectionDetailsMirrorBytesSent Property

This value is the number of mirror bytes sent.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSent();
function set_MirrorBytesSent(value);

Property Value

Type: Int64
The number of mirror bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesSkipped Property

CoreConnectionDetailsMirrorBytesSkipped Property

This value is the number of mirror bytes skipped. Bytes are skipped because the data is not different on the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesSkipped();
function set_MirrorBytesSkipped(value);

Property Value

Type: Int64
The number of mirror bytes skipped.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorBytesTransmitted Property

CoreConnectionDetailsMirrorBytesTransmitted Property

The value is the number of mirror bytes transmitted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_MirrorBytesTransmitted();
function set_MirrorBytesTransmitted(value);

Property Value

Type: Int64
The number of mirror bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorEndTime Property

CoreConnectionDetailsMirrorEndTime Property

This value is the time when mirroring ended.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset MirrorEndTime { get; set; }
Public Property MirrorEndTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset MirrorEndTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_MirrorEndTime();
function set_MirrorEndTime(value);

Property Value

Type: DateTimeOffset
Mirror EndTime.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorOpsQueued Property

CoreConnectionDetailsMirrorOpsQueued Property

This value is the number of mirror operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
function get_MirrorOpsQueued();
function set_MirrorOpsQueued(value);

Property Value

Type: Int64
The number of mirror ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorPermillage Property

CoreConnectionDetailsMirrorPermillage Property

This value is the percentage of the mirror that is complete. A mirror may be at 99-100% when it is actually still processing. For example, this may occur if files were added after the protected data set size was calculated or if there are alternate data streams in the protected data set.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
function get_MirrorPermillage();
function set_MirrorPermillage(value);

Property Value

Type: Int16
The mirror permillage.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorStartTime Property

CoreConnectionDetailsMirrorStartTime Property

This value is the time when mirroring started.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset MirrorStartTime { get; set; }
Public Property MirrorStartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset MirrorStartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_MirrorStartTime();
function set_MirrorStartTime(value);

Property Value

Type: DateTimeOffset
Mirror StartTime.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.MirrorState Property

CoreConnectionDetailsMirrorState Property

This value represents the state of mirroring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
function get_MirrorState();
function set_MirrorState(value);

Property Value

Type: MirrorState
The operational state of the mirror.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.PeerMemoryLow Property

CoreConnectionDetailsPeerMemoryLow Property

This value is true if memory on the target is low; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
function get_PeerMemoryLow();
function set_PeerMemoryLow(value);

Property Value

Type: Boolean
if the peer's memory is low; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesQueued Property

CoreConnectionDetailsReplicationBytesQueued Property

This value is the number of replication bytes queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesQueued();
function set_ReplicationBytesQueued(value);

Property Value

Type: Int64
The number of replication bytes queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesSent Property

CoreConnectionDetailsReplicationBytesSent Property

This value is the number of replication bytes sent.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesSent();
function set_ReplicationBytesSent(value);

Property Value

Type: Int64
The number of replication bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationBytesTransmitted Property

CoreConnectionDetailsReplicationBytesTransmitted Property

The value is the number of replication bytes transmitted.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_ReplicationBytesTransmitted();
function set_ReplicationBytesTransmitted(value);

Property Value

Type: Int64
The number of replication bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationOpsQueued Property

CoreConnectionDetailsReplicationOpsQueued Property

This value is the number of replication operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
function get_ReplicationOpsQueued();
function set_ReplicationOpsQueued(value);

Property Value

Type: Int64
The number of replication ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationSetCalcInProgress Property

CoreConnectionDetailsReplicationSetCalcInProgress Property

This value is true if the size of the protected data set is being calculated; otherwise, it is false. Mirroring will start while the size of the protected data set is being determined. While the calculation is in progress, the remaining byte count is not valid.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
function get_ReplicationSetCalcInProgress();
function set_ReplicationSetCalcInProgress(value);

Property Value

Type: Boolean
if the repset calculation is in progress; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.ReplicationState Property

CoreConnectionDetailsReplicationState Property

This value represents the state of replication.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
function get_ReplicationState();
function set_ReplicationState(value);

Property Value

Type: ReplicationState
The operational state of the replication.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.Restoring Property

CoreConnectionDetailsRestoring Property

This value is true if the connection is restoring data; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
function get_Restoring();
function set_Restoring(value);

Property Value

Type: Boolean
if the connection is restoring; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceAccessLevel Property

CoreConnectionDetailsSourceAccessLevel Property

This value is the source security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and SourceAvailable is false, Double-Take can connect to the source but was not able to determine at least Double-Take monitor access with the provided credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<AccessLevel> SourceAccessLevel { get; set; }
Public Property SourceAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> SourceAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
function get_SourceAccessLevel();
function set_SourceAccessLevel(value);

Property Value

Type: Nullable AccessLevel
The source access level.
Remarks
This nullable value will be if the access level has not been determined for whatever reason. If the value is non-null and [P:SourceAvailable] is , we were able to connect but not able to obtain at least monitor access with the provided credentials.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceAvailable Property

CoreConnectionDetailsSourceAvailable Property

This value is true if the target can communicate with the source; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceAvailable { get; set; }
Public Property SourceAvailable As Boolean
    Get
    Set
public:
property bool SourceAvailable {
    bool get ();
    void set (bool value);
}
function get_SourceAvailable();
function set_SourceAvailable(value);

Property Value

Type: Boolean
if the source server is available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceClusterResourceState Property

CoreConnectionDetailsSourceClusterResourceState Property

This value represents the state of the source cluster resource.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterResourceState SourceClusterResourceState { get; set; }
Public Property SourceClusterResourceState As ClusterResourceState
    Get
    Set
public:
property ClusterResourceState SourceClusterResourceState {
    ClusterResourceState get ();
    void set (ClusterResourceState value);
}
function get_SourceClusterResourceState();
function set_SourceClusterResourceState(value);

Property Value

Type: ClusterResourceState
The state of the source cluster resource.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceEndpoint Property

CoreConnectionDetailsSourceEndpoint Property

This value is the source endpoint that is the route from the target back to the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
function get_SourceEndpoint();
function set_SourceEndpoint(value);

Property Value

Type: String
The endpoint on the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceEngineAvailable Property

CoreConnectionDetailsSourceEngineAvailable Property

This value is true if the source replication engine is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceEngineAvailable { get; set; }
Public Property SourceEngineAvailable As Boolean
    Get
    Set
public:
property bool SourceEngineAvailable {
    bool get ();
    void set (bool value);
}
function get_SourceEngineAvailable();
function set_SourceEngineAvailable(value);

Property Value

Type: Boolean
if the source engine available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceMachineName Property

CoreConnectionDetailsSourceMachineName Property

This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceRecoveryPointLatency Property

CoreConnectionDetailsSourceRecoveryPointLatency Property

This value is the length of time replication is behind on the target compared to the source. This is the time period of data that would be lost if a failure were to occur at the current time.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long SourceRecoveryPointLatency { get; set; }
Public Property SourceRecoveryPointLatency As Long
    Get
    Set
public:
property long long SourceRecoveryPointLatency {
    long long get ();
    void set (long long value);
}
function get_SourceRecoveryPointLatency();
function set_SourceRecoveryPointLatency(value);

Property Value

Type: Int64
The source recovery point latency.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceRecoveryPointTime Property

CoreConnectionDetailsSourceRecoveryPointTime Property

This value is the time that replication is synchronized between the source and target. The difference between the current time and this time is the time period of data that would be lost if a failure were to occur at the current time.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset SourceRecoveryPointTime { get; set; }
Public Property SourceRecoveryPointTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset SourceRecoveryPointTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_SourceRecoveryPointTime();
function set_SourceRecoveryPointTime(value);

Property Value

Type: DateTimeOffset
The source recovery point time.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.SourceUniqueId Property

CoreConnectionDetailsSourceUniqueId Property

This value is a unique ID assigned to the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_SourceUniqueId();
function set_SourceUniqueId(value);

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.StartTime Property

CoreConnectionDetailsStartTime Property

This value is the time the connection was started.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTimeOffset
The time the connection was started.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetAccessLevel Property

CoreConnectionDetailsTargetAccessLevel Property

This value is the target security access. This value will be null if the Double-Take access level cannot be determined. If the value is not null and TargetAvailable is false, Double-Take can connect to the target but was not able to determine at least Double-Take monitor access with the provided credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<AccessLevel> TargetAccessLevel { get; set; }
Public Property TargetAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> TargetAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
function get_TargetAccessLevel();
function set_TargetAccessLevel(value);

Property Value

Type: Nullable AccessLevel
The target access level.
Remarks
This nullable value will be if the access level has not been determined for whatever reason. If the value is non-null and [P:TargetAvailable] is , we were able to connect but not able to obtain at least monitor access with the provided credentials.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetAvailable Property

CoreConnectionDetailsTargetAvailable Property

This value is true if the target is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetAvailable();
function set_TargetAvailable(value);

Property Value

Type: Boolean
if the target server is available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetEngineAvailable Property

CoreConnectionDetailsTargetEngineAvailable Property

This value is true if the target replication engine is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetEngineAvailable { get; set; }
Public Property TargetEngineAvailable As Boolean
    Get
    Set
public:
property bool TargetEngineAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetEngineAvailable();
function set_TargetEngineAvailable(value);

Property Value

Type: Boolean
if the target engine available; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetLoaded Property

CoreConnectionDetailsTargetLoaded Property

This value is true if the Double-Take target module is loaded on the server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
function get_TargetLoaded();
function set_TargetLoaded(value);

Property Value

Type: Boolean
if the target module is loaded; otherwise, .
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetMachineName Property

CoreConnectionDetailsTargetMachineName Property

This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
function get_TargetMachineName();
function set_TargetMachineName(value);

Property Value

Type: String
The name of the target server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetQueueBytes Property

CoreConnectionDetailsTargetQueueBytes Property

This value is the number of bytes in the target queue.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long TargetQueueBytes { get; set; }
Public Property TargetQueueBytes As Long
    Get
    Set
public:
property long long TargetQueueBytes {
    long long get ();
    void set (long long value);
}
function get_TargetQueueBytes();
function set_TargetQueueBytes(value);

Property Value

Type: Int64
The number of bytes in the target queue.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetRoute Property

CoreConnectionDetailsTargetRoute Property

This value is the endpoint on the target that is the route the source is using for the connection. This route is in the format [address]:[port].

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
function get_TargetRoute();
function set_TargetRoute(value);

Property Value

Type: String
The target route.
Remarks
This route is in the format [address]:[port].
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetState Property

CoreConnectionDetailsTargetState Property

This value represents the state of the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
function get_TargetState();
function set_TargetState(value);

Property Value

Type: TargetStates
The known operational states of the connection target.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TargetUniqueId Property

CoreConnectionDetailsTargetUniqueId Property

This value is a unique ID assigned to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_TargetUniqueId();
function set_TargetUniqueId(value);

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalBytesSent Property

CoreConnectionDetailsTotalBytesSent Property

This value is the total number of bytes that have been sent for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
function get_TotalBytesSent();
function set_TotalBytesSent(value);

Property Value

Type: Int64
The total bytes sent.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalBytesTransmitted Property

CoreConnectionDetailsTotalBytesTransmitted Property

This value is the total number of bytes that have been transmitted for the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
function get_TotalBytesTransmitted();
function set_TotalBytesTransmitted(value);

Property Value

Type: Int64
The total number of bytes transmitted.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TotalOpsQueued Property

CoreConnectionDetailsTotalOpsQueued Property

This value is the total number of operations queued on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
function get_TotalOpsQueued();
function set_TotalOpsQueued(value);

Property Value

Type: Int64
The total number of ops queued.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionDetails.TransmissionMode Property

CoreConnectionDetailsTransmissionMode Property

This value represents the state of data transmission from the source to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
function get_TransmissionMode();
function set_TransmissionMode(value);

Property Value

Type: TransmissionMode
The operational state of replication and mirroring.
See Also

Reference

CoreConnectionDetails Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Class

Represents option for configuring an underlying engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreConnectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreConnectionOptions : IExtensibleDataObject
Public Class CoreConnectionOptions
    Implements IExtensibleDataObject
public ref class CoreConnectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreConnectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreConnectionOptions',
    null,
    IExtensibleDataObject);

The CoreConnectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionOptions |
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | This value represents the parameters used to start the connection between the source and target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | TargetAddress | This value is the target IP address.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionOptions()
Public Sub New
public:
CoreConnectionOptions()
DoubleTake.Jobs.Contract.CoreConnectionOptions = function();
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions Properties

The CoreConnectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | This value represents the parameters used to start the connection between the source and target.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PathTransformations | This value represents where the source protected data will be located on the target.
Public property | TargetAddress | This value is the target IP address.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Top
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.ConnectionStartParameters Property

CoreConnectionOptionsConnectionStartParameters Property

This value represents the parameters used to start the connection between the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ConnectionStartParameters ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParameters
    Get
    Set
public:
property ConnectionStartParameters^ ConnectionStartParameters {
    ConnectionStartParameters^ get ();
    void set (ConnectionStartParameters^ value);
}
function get_ConnectionStartParameters();
function set_ConnectionStartParameters(value);

Property Value

Type: ConnectionStartParameters
The parameters used to start the connection between source and target servers.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.ExtensionData Property

CoreConnectionOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.PathTransformations Property

CoreConnectionOptionsPathTransformations Property

This value represents where the source protected data will be located on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.TargetAddress Property

CoreConnectionOptionsTargetAddress Property

This value is the target IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
function get_TargetAddress();
function set_TargetAddress(value);

Property Value

Type: String
The target address.
Remarks
This string must be a valid IPv4 or IPv6 address.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreConnectionOptions.TargetEnginePort Property

CoreConnectionOptionsTargetEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
function get_TargetEnginePort();
function set_TargetEnginePort(value);

Property Value

Type: Int32
The engine port on the target server.
See Also

Reference

CoreConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Class

Represents details of an underlying engine monitor used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreMonitorDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreMonitorDetails : IExtensibleDataObject
Public Class CoreMonitorDetails
    Implements IExtensibleDataObject
public ref class CoreMonitorDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreMonitorDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreMonitorDetails',
    null,
    IExtensibleDataObject);

The CoreMonitorDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorDetails |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HighAvailabilityState | This value represents the state of failover monitoring.
Public property | MonitoredAddressStatuses | This value represents the status of a monitored IP address.
Public property | MonitorId | This value is a unique ID for this failover monitor.
Public property | MonitorName | This value is the name for this failover monitor.
Public property | RestoreStates | This value represents the state of a restoration connection.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorDetails()
Public Sub New
public:
CoreMonitorDetails()
DoubleTake.Jobs.Contract.CoreMonitorDetails = function();
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails Properties

The CoreMonitorDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | HighAvailabilityState | This value represents the state of failover monitoring.
Public property | MonitoredAddressStatuses | This value represents the status of a monitored IP address.
Public property | MonitorId | This value is a unique ID for this failover monitor.
Public property | MonitorName | This value is the name for this failover monitor.
Public property | RestoreStates | This value represents the state of a restoration connection.
Public property | TargetAvailable | This value is true if the target is available; otherwise, it is false.
Top
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.ExtensionData Property

CoreMonitorDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.HighAvailabilityState Property

CoreMonitorDetailsHighAvailabilityState Property

This value represents the state of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public HighAvailabilityState HighAvailabilityState { get; set; }
Public Property HighAvailabilityState As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState HighAvailabilityState {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
function get_HighAvailabilityState();
function set_HighAvailabilityState(value);

Property Value

Type: HighAvailabilityState
The high availability state.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitoredAddressStatuses Property

CoreMonitorDetailsMonitoredAddressStatuses Property

This value represents the status of a monitored IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoredAddressStatus[] MonitoredAddressStatuses { get; set; }
Public Property MonitoredAddressStatuses As MonitoredAddressStatus()
    Get
    Set
public:
property array<MonitoredAddressStatus^>^ MonitoredAddressStatuses {
    array<MonitoredAddressStatus^>^ get ();
    void set (array<MonitoredAddressStatus^>^ value);
}
function get_MonitoredAddressStatuses();
function set_MonitoredAddressStatuses(value);

Property Value

Type: MonitoredAddressStatus
An array of MonitoredAddressStatus that represents the status of the monitored addresses.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitorId Property

CoreMonitorDetailsMonitorId Property

This value is a unique ID for this failover monitor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
function get_MonitorId();
function set_MonitorId(value);

Property Value

Type: Guid
The unique identifier of the monitor.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.MonitorName Property

CoreMonitorDetailsMonitorName Property

This value is the name for this failover monitor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MonitorName { get; set; }
Public Property MonitorName As String
    Get
    Set
public:
property String^ MonitorName {
    String^ get ();
    void set (String^ value);
}
function get_MonitorName();
function set_MonitorName(value);

Property Value

Type: String
The name of the monitor.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.RestoreStates Property

CoreMonitorDetailsRestoreStates Property

This value represents the state of a restoration connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
function get_RestoreStates();
function set_RestoreStates(value);

Property Value

Type: RestoreStates
The state of the restore operation.
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorDetails.TargetAvailable Property

CoreMonitorDetailsTargetAvailable Property

This value is true if the target is available; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
function get_TargetAvailable();
function set_TargetAvailable(value);

Property Value

Type: Boolean
if the target machine is available; otherwise, .
See Also

Reference

CoreMonitorDetails Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Class

Represents options for configuring an underlying engine monitor used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreMonitorOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreMonitorOptions : IExtensibleDataObject
Public Class CoreMonitorOptions
    Implements IExtensibleDataObject
public ref class CoreMonitorOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreMonitorOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreMonitorOptions',
    null,
    IExtensibleDataObject);

The CoreMonitorOptions type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorConfiguration | This value represents the configuration of failover monitoring.
Public property | ShouldPerformLanFailover | This value is for display in the console to determine which failover option should be selected by default.
Public property | TotalTimeAllowed | This value is the amount of time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.
Top
Fields
 | Name | Description
Public field | SourceDomain | This value is the name of the source domain.
Public field | SourceServer | This value is the name of the source server.
Public field | TargetDomain | This value is the name of the target domain.
Public field | TargetServer | This value is the name of the target server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions()
Public Sub New
public:
CoreMonitorOptions()
DoubleTake.Jobs.Contract.CoreMonitorOptions = function();
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Properties

The CoreMonitorOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | MonitorConfiguration | This value represents the configuration of failover monitoring.
Public property | ShouldPerformLanFailover | This value is for display in the console to determine which failover option should be selected by default.
Public property | TotalTimeAllowed | This value is the amount of time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.
Top
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.ExtensionData Property

CoreMonitorOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.MonitorConfiguration Property

CoreMonitorOptionsMonitorConfiguration Property

This value represents the configuration of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitorConfiguration MonitorConfiguration { get; set; }
Public Property MonitorConfiguration As MonitorConfiguration
    Get
    Set
public:
property MonitorConfiguration^ MonitorConfiguration {
    MonitorConfiguration^ get ();
    void set (MonitorConfiguration^ value);
}
function get_MonitorConfiguration();
function set_MonitorConfiguration(value);

Property Value

Type: MonitorConfiguration
The monitor configuration.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.ShouldPerformLanFailover Property

CoreMonitorOptionsShouldPerformLanFailover Property

This value is for display in the console to determine which failover option should be selected by default.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> ShouldPerformLanFailover { get; set; }
Public Property ShouldPerformLanFailover As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ShouldPerformLanFailover {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_ShouldPerformLanFailover();
function set_ShouldPerformLanFailover(value);

Property Value

Type: Nullable Boolean
if LAN (identity) failover should be performed, if WAN failover should be performed, or if the version of the service doesn't support this property.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TotalTimeAllowed Property

CoreMonitorOptionsTotalTimeAllowed Property

This value is the amount of time allowed without a successful ping before a failover condition is met.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan TotalTimeAllowed { get; set; }
Public Property TotalTimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TotalTimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_TotalTimeAllowed();
function set_TotalTimeAllowed(value);

Property Value

Type: TimeSpan
The total time allowed.
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.UseTotalTimeAllowed Property

CoreMonitorOptionsUseTotalTimeAllowed Property

This value is true if TotalTimeAllowed is used to determine when a failover condition is met; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseTotalTimeAllowed { get; set; }
Public Property UseTotalTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTotalTimeAllowed {
    bool get ();
    void set (bool value);
}
function get_UseTotalTimeAllowed();
function set_UseTotalTimeAllowed(value);

Property Value

Type: Boolean
if the TotalTimeAllowed property should be used; otherwise, .
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions Fields

The CoreMonitorOptions type exposes the following members.

Fields
 | Name | Description
Public field | SourceDomain | This value is the name of the source domain.
Public field | SourceServer | This value is the name of the source server.
Public field | TargetDomain | This value is the name of the target domain.
Public field | TargetServer | This value is the name of the target server.
Top
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.SourceDomain Field

CoreMonitorOptionsSourceDomain Field

This value is the name of the source domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceDomain
Public SourceDomain As String
public:
String^ SourceDomain
var SourceDomain

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.SourceServer Field

CoreMonitorOptionsSourceServer Field

This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceServer
Public SourceServer As String
public:
String^ SourceServer
var SourceServer

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TargetDomain Field

CoreMonitorOptionsTargetDomain Field

This value is the name of the target domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetDomain
Public TargetDomain As String
public:
String^ TargetDomain
var TargetDomain

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreMonitorOptions.TargetServer Field

CoreMonitorOptionsTargetServer Field

This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetServer
Public TargetServer As String
public:
String^ TargetServer
var TargetServer

Field Value

Type: String
See Also

Reference

CoreMonitorOptions Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Class

Represents information that may be needed to configure an engine connection.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCoreQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CoreQualificationResults : IExtensibleDataObject
Public Class CoreQualificationResults
    Implements IExtensibleDataObject
public ref class CoreQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.CoreQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CoreQualificationResults',
    null,
    IExtensibleDataObject);

The CoreQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | CoreQualificationResults |
Top
Properties
 | Name | Description
Public property | CompressionLevels | This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.
Public property | DefaultAllToOneBasePath | This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceEnginePort | This value is the port where the engine is listening.
Public property | SourceIPAddresses | This value represents the available IP addresses on the source.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceNetworkId | This value is the source network ID used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | This value represents the available NICs on the source.
Public property | SourceProductInfo | This value represents the Double-Take product info on the source.
Public property | SourceVolumes | This value represents the available volumes on the source.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Public property | TargetIPAddresses | This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetNetworkInterfaces | This value represents the available NICs on the target.
Public property | TargetProductInfo | This value represents the Double-Take product info on the target.
Public property | TargetVolumes | This value represents the available volumes on the target.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreQualificationResults()
Public Sub New
public:
CoreQualificationResults()
DoubleTake.Jobs.Contract.CoreQualificationResults = function();
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults Properties

The CoreQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.
Public property | DefaultAllToOneBasePath | This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceEnginePort | This value is the port where the engine is listening.
Public property | SourceIPAddresses | This value represents the available IP addresses on the source.
Public property | SourceMachineName | This value is the name of the source server.
Public property | SourceNetworkId | This value is the source network ID used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | This value represents the available NICs on the source.
Public property | SourceProductInfo | This value represents the Double-Take product info on the source.
Public property | SourceVolumes | This value represents the available volumes on the source.
Public property | TargetEnginePort | This value is the port where the engine is listening.
Public property | TargetIPAddresses | This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.
Public property | TargetMachineName | This value is the name of the target server.
Public property | TargetNetworkInterfaces | This value represents the available NICs on the target.
Public property | TargetProductInfo | This value represents the Double-Take product info on the target.
Public property | TargetVolumes | This value represents the available volumes on the target.
Top
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.CompressionLevels Property

CoreQualificationResultsCompressionLevels Property

This value is the compression level. It will be null if there is a problem getting the compression level from the source or target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CompressionLevel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevel()
    Get
    Set
public:
property array<CompressionLevel^>^ CompressionLevels {
    array<CompressionLevel^>^ get ();
    void set (array<CompressionLevel^>^ value);
}
function get_CompressionLevels();
function set_CompressionLevels(value);

Property Value

Type: CompressionLevel
The compression levels.
Remarks
This property will be if there is a problem getting the compression levels from both source and target servers.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.DefaultAllToOneBasePath Property

CoreQualificationResultsDefaultAllToOneBasePath Property

This value sets the default base path for the all to one path mapping, which configures the source replica data to be stored on a single volume on the target. The default is \source_name\volume_name. If you are protecting multiple volumes on the source, each volume would be stored on the same volume on the target. For example, C:\data and D:\files for the source Alpha would be stored in D:\alpha\C and D:\alpha\D, respectively.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DefaultAllToOneBasePath { get; set; }
Public Property DefaultAllToOneBasePath As String
    Get
    Set
public:
property String^ DefaultAllToOneBasePath {
    String^ get ();
    void set (String^ value);
}
function get_DefaultAllToOneBasePath();
function set_DefaultAllToOneBasePath(value);

Property Value

Type: String
The default all-to-one base path.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.ExtensionData Property

CoreQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceEnginePort Property

CoreQualificationResultsSourceEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
function get_SourceEnginePort();
function set_SourceEnginePort(value);

Property Value

Type: Int32
The source engine port.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceIPAddresses Property

CoreQualificationResultsSourceIPAddresses Property

This value represents the available IP addresses on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] SourceIPAddresses { get; set; }
Public Property SourceIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ SourceIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_SourceIPAddresses();
function set_SourceIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The source machine's available IP addresses.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceMachineName Property

CoreQualificationResultsSourceMachineName Property

This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
function get_SourceMachineName();
function set_SourceMachineName(value);

Property Value

Type: String
The name of the source machine.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceNetworkId Property

CoreQualificationResultsSourceNetworkId Property

This value is the source network ID used to communicate with the source from the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
function get_SourceNetworkId();
function set_SourceNetworkId(value);

Property Value

Type: String
The source network id.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceNetworkInterfaces Property

CoreQualificationResultsSourceNetworkInterfaces Property

This value represents the available NICs on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] SourceNetworkInterfaces { get; set; }
Public Property SourceNetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ SourceNetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_SourceNetworkInterfaces();
function set_SourceNetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
The source network interfaces.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceProductInfo Property

CoreQualificationResultsSourceProductInfo Property

This value represents the Double-Take product info on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo SourceProductInfo { get; set; }
Public Property SourceProductInfo As ProductInfo
    Get
    Set
public:
property ProductInfo^ SourceProductInfo {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
function get_SourceProductInfo();
function set_SourceProductInfo(value);

Property Value

Type: ProductInfo
The source product info.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.SourceVolumes Property

CoreQualificationResultsSourceVolumes Property

This value represents the available volumes on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] SourceVolumes { get; set; }
Public Property SourceVolumes As Volume()
    Get
    Set
public:
property array<Volume^>^ SourceVolumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_SourceVolumes();
function set_SourceVolumes(value);

Property Value

Type: Volume
The source volumes.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetEnginePort Property

CoreQualificationResultsTargetEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
function get_TargetEnginePort();
function set_TargetEnginePort(value);

Property Value

Type: Int32
The target engine port.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetIPAddresses Property

CoreQualificationResultsTargetIPAddresses Property

This value represents the available IP addresses on the target. These IP addresses are the possible values that can be used to populate CoreConnectionOptions.TargetAddress.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] TargetIPAddresses { get; set; }
Public Property TargetIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ TargetIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_TargetIPAddresses();
function set_TargetIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
The target machine's available IP addresses.
Remarks
These IP addresses are the possible values that can be used to populate the TargetAddress property in the CoreConnectionOptions class when configuring JobOptions.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetMachineName Property

CoreQualificationResultsTargetMachineName Property

This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
function get_TargetMachineName();
function set_TargetMachineName(value);

Property Value

Type: String
The name of the target machine.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetNetworkInterfaces Property

CoreQualificationResultsTargetNetworkInterfaces Property

This value represents the available NICs on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public NetworkInterfaceInfo[] TargetNetworkInterfaces { get; set; }
Public Property TargetNetworkInterfaces As NetworkInterfaceInfo()
    Get
    Set
public:
property array<NetworkInterfaceInfo^>^ TargetNetworkInterfaces {
    array<NetworkInterfaceInfo^>^ get ();
    void set (array<NetworkInterfaceInfo^>^ value);
}
function get_TargetNetworkInterfaces();
function set_TargetNetworkInterfaces(value);

Property Value

Type: NetworkInterfaceInfo
The target network interfaces.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetProductInfo Property

CoreQualificationResultsTargetProductInfo Property

This value represents the Double-Take product info on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ProductInfo TargetProductInfo { get; set; }
Public Property TargetProductInfo As ProductInfo
    Get
    Set
public:
property ProductInfo^ TargetProductInfo {
    ProductInfo^ get ();
    void set (ProductInfo^ value);
}
function get_TargetProductInfo();
function set_TargetProductInfo(value);

Property Value

Type: ProductInfo
The target product info.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CoreQualificationResults.TargetVolumes Property

CoreQualificationResultsTargetVolumes Property

This value represents the available volumes on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Volume[] TargetVolumes { get; set; }
Public Property TargetVolumes As Volume()
    Get
    Set
public:
property array<Volume^>^ TargetVolumes {
    array<Volume^>^ get ();
    void set (array<Volume^>^ value);
}
function get_TargetVolumes();
function set_TargetVolumes(value);

Property Value

Type: Volume
The target volumes.
See Also

Reference

CoreQualificationResults Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails Class

Represents the details of a cutover operation.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractCutoverDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class CutoverDetails : IExtensibleDataObject
Public Class CutoverDetails
    Implements IExtensibleDataObject
public ref class CutoverDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.CutoverDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.CutoverDetails',
    null,
    IExtensibleDataObject);

The CutoverDetails type exposes the following members.

Constructors
 | Name | Description
Public method | CutoverDetails |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PercentComplete | This value is the percentage of the cutover that is complete.
Public property | State | This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


CutoverDetails Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails()
Public Sub New
public:
CutoverDetails()
DoubleTake.Jobs.Contract.CutoverDetails = function();
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails Properties

The CutoverDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PercentComplete | This value is the percentage of the cutover that is complete.
Public property | State | This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.
Top
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.ExtensionData Property

CutoverDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.PercentComplete Property

CutoverDetailsPercentComplete Property

This value is the percentage of the cutover that is complete.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
function get_PercentComplete();
function set_PercentComplete(value);

Property Value

Type: Int32
The percentage complete of the cutover operation.
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


CutoverDetails.State Property

CutoverDetailsState Property

This value is the state of the cutover. If this value is 1, the cutover is idle. If this value is 1000, the cutover processing is complete. Negative numbers are error codes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
function get_State();
function set_State(value);

Property Value

Type: Int32
The state of the cutover operation.
See Also

Reference

CutoverDetails Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions Class

Defines the options provided when deleting a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDeleteOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class DeleteOptions : IExtensibleDataObject
Public Class DeleteOptions
    Implements IExtensibleDataObject
public ref class DeleteOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DeleteOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DeleteOptions',
    null,
    IExtensibleDataObject);

The DeleteOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteOptions |
Top
Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.
Public property | DeleteReplica | This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.
Public property | DiscardTargetQueue | This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageOptions | This value represents how the image of a DR protection job will be handled when a job is deleted. This option is no longer needed.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DeleteOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DeleteOptions()
Public Sub New
public:
DeleteOptions()
DoubleTake.Jobs.Contract.DeleteOptions = function();
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions Properties

The DeleteOptions type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.
Public property | DeleteReplica | This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.
Public property | DiscardTargetQueue | This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageOptions | This value represents how the image of a DR protection job will be handled when a job is deleted. This option is no longer needed.
Top
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DeleteOnClusterResourceOffline Property

DeleteOptionsDeleteOnClusterResourceOffline Property

This value is true if the job is deleted because the target cluster resource went offline; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteOnClusterResourceOffline { get; set; }
Public Property DeleteOnClusterResourceOffline As Boolean
    Get
    Set
public:
property bool DeleteOnClusterResourceOffline {
    bool get ();
    void set (bool value);
}
function get_DeleteOnClusterResourceOffline();
function set_DeleteOnClusterResourceOffline(value);

Property Value

Type: Boolean
true if delete is caused by target cluster resource going offline; otherwise, false.
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DeleteReplica Property

DeleteOptionsDeleteReplica Property

This value is true if the replica virtual machine should be deleted when the job is deleted; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
function get_DeleteReplica();
function set_DeleteReplica(value);

Property Value

Type: Boolean
if the replica virtual machine should be deleted; otherwise, .
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.DiscardTargetQueue Property

DeleteOptionsDiscardTargetQueue Property

This value is true if any operations in the target queue should be deleted when the job is deleted; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
function get_DiscardTargetQueue();
function set_DiscardTargetQueue(value);

Property Value

Type: Boolean
to discard the target queue; otherwise, .
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.ExtensionData Property

DeleteOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DeleteOptions.ImageOptions Property

DeleteOptionsImageOptions Property

This value represents how the image of a DR protection job will be handled when a job is deleted. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageDeleteInfo ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfo
    Get
    Set
public:
property ImageDeleteInfo^ ImageOptions {
    ImageDeleteInfo^ get ();
    void set (ImageDeleteInfo^ value);
}
function get_ImageOptions();
function set_ImageOptions(value);

Property Value

Type: ImageDeleteInfo
See Also

Reference

DeleteOptions Class
DoubleTake.Jobs.Contract Namespace


DiskConfigStrategy Enumeration

Disk configuration strategy for the replica

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum DiskConfigStrategy
Public Enumeration DiskConfigStrategy
public enum class DiskConfigStrategy
DoubleTake.Jobs.Contract.DiskConfigStrategy = function();
DoubleTake.Jobs.Contract.DiskConfigStrategy.createEnum('DoubleTake.Jobs.Contract.DiskConfigStrategy', false);
Members
Member name | Value | Description
CreateDiskPerVolume | 0 | Create replica disk per volume.
MatchingSource | 1 | Create the same disk and layout with the source on the replica.
Customization | 2 | Custom the disk layout on the replica.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Class

Represents a DNS domain that will be updated during DNS failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDnsDomainDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class DnsDomainDetails : IExtensibleDataObject
Public Class DnsDomainDetails
    Implements IExtensibleDataObject
public ref class DnsDomainDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.DnsDomainDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DnsDomainDetails',
    null,
    IExtensibleDataObject);

The DnsDomainDetails type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetails | Initializes a new instance of the DnsDomainDetails class.
Top
Properties
 | Name | Description
Public property | Credentials | This value represents the domain credentials.
Public property | DnsServers | This value represents a DNS server that will be updated during DNS failover.
Public property | DomainName | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddressMappings | This value represents the mapping between source IP address and target IP address when using DNS failover.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | TtlValue | This value is the time to live value in seconds.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Constructor

Initializes a new instance of the DnsDomainDetails class.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DnsDomainDetails()
Public Sub New
public:
DnsDomainDetails()
DoubleTake.Jobs.Contract.DnsDomainDetails = function();
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Properties

The DnsDomainDetails type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | This value represents the domain credentials.
Public property | DnsServers | This value represents a DNS server that will be updated during DNS failover.
Public property | DomainName | This value is the name of the domain.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IPAddressMappings | This value represents the mapping between source IP address and target IP address when using DNS failover.
Public property | ShouldUpdateTtl | This value is true if the time to live value should be updated; otherwise, it is false.
Public property | TtlValue | This value is the time to live value in seconds.
Top
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.Credentials Property

DnsDomainDetailsCredentials Property

This value represents the domain credentials.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Credentials Credentials { get; set; }
Public Property Credentials As Credentials
    Get
    Set
public:
property Credentials^ Credentials {
    Credentials^ get ();
    void set (Credentials^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: Credentials
The domain credentials.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.DnsServers Property

DnsDomainDetailsDnsServers Property

This value represents a DNS server that will be updated during DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DnsServerDetail[] DnsServers { get; set; }
Public Property DnsServers As DnsServerDetail()
    Get
    Set
public:
property array<DnsServerDetail^>^ DnsServers {
    array<DnsServerDetail^>^ get ();
    void set (array<DnsServerDetail^>^ value);
}
function get_DnsServers();
function set_DnsServers(value);

Property Value

Type: DnsServerDetail
The list of DNS servers to be updated.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.DomainName Property

DnsDomainDetailsDomainName Property

This value is the name of the domain.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
function get_DomainName();
function set_DomainName(value);

Property Value

Type: String
The name of the domain.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ExtensionData Property

DnsDomainDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.IPAddressMappings Property

DnsDomainDetailsIPAddressMappings Property

This value represents the mapping between source IP address and target IP address when using DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IPAddressMap[] IPAddressMappings { get; set; }
Public Property IPAddressMappings As IPAddressMap()
    Get
    Set
public:
property array<IPAddressMap^>^ IPAddressMappings {
    array<IPAddressMap^>^ get ();
    void set (array<IPAddressMap^>^ value);
}
function get_IPAddressMappings();
function set_IPAddressMappings(value);

Property Value

Type: IPAddressMap
The list of IP addresses to be updated.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ShouldUpdateTtl Property

DnsDomainDetailsShouldUpdateTtl Property

This value is true if the time to live value should be updated; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
function get_ShouldUpdateTtl();
function set_ShouldUpdateTtl(value);

Property Value

Type: Boolean
if the time-to-live value should be updated for this record; otherwise, .
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.TtlValue Property

DnsDomainDetailsTtlValue Property

This value is the time to live value in seconds.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
function get_TtlValue();
function set_TtlValue(value);

Property Value

Type: Int32
The TTL value, in seconds.
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails Methods

The DnsDomainDetails type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DnsDomainDetails.ToString Method

DnsDomainDetailsToString Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DnsDomainDetails Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Class

Represents the options for DNS failover on a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractDNSOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class DNSOptions : IExtensibleDataObject
Public Class DNSOptions
    Implements IExtensibleDataObject
public ref class DNSOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.DNSOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.DNSOptions',
    null,
    IExtensibleDataObject);

The DNSOptions type exposes the following members.

Constructors
 | Name | Description
Public method | DNSOptions |
Top
Properties
 | Name | Description
Public property | AdditionalDns | This value identifies any additional source DNS servers to update.
Public property | AllIPAddressesNeedMapping | This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.
Public property | AlternateTrustees | This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | This value represents the domains that will be updated during failover.
Public property | Enabled | This value is true if DNS failover is enabled; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceServerInWorkgroup | This value is true if the source is in a workgroup; otherwise, it is false.
Public property | SourceServerName | This value is the name of the source server.
Public property | TargetServerName | This value is the name of the target server.
Top
Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


DNSOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DNSOptions()
Public Sub New
public:
DNSOptions()
DoubleTake.Jobs.Contract.DNSOptions = function();
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Properties

The DNSOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | This value identifies any additional source DNS servers to update.
Public property | AllIPAddressesNeedMapping | This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.
Public property | AlternateTrustees | This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | This value represents the domains that will be updated during failover.
Public property | Enabled | This value is true if DNS failover is enabled; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceServerInWorkgroup | This value is true if the source is in a workgroup; otherwise, it is false.
Public property | SourceServerName | This value is the name of the source server.
Public property | TargetServerName | This value is the name of the target server.
Top
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AdditionalDns Property

DNSOptionsAdditionalDns Property

This value identifies any additional source DNS servers to update.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalDns { get; set; }
Public Property AdditionalDns As String()
    Get
    Set
public:
property array<String^>^ AdditionalDns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalDns();
function set_AdditionalDns(value);

Property Value

Type: String
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AllIPAddressesNeedMapping Property

DNSOptionsAllIPAddressesNeedMapping Property

This value is true if all IP addresses need to be mapped to a target IP address; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> AllIPAddressesNeedMapping { get; set; }
Public Property AllIPAddressesNeedMapping As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AllIPAddressesNeedMapping {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_AllIPAddressesNeedMapping();
function set_AllIPAddressesNeedMapping(value);

Property Value

Type: Nullable Boolean
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.AlternateTrustees Property

DNSOptionsAlternateTrustees Property

This value is the source server trustee, which overrides the default trustees of "NT AUTHORITY\SYSTEM" and the source computer account (for clustered environments).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AlternateTrustees { get; set; }
Public Property AlternateTrustees As String()
    Get
    Set
public:
property array<String^>^ AlternateTrustees {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AlternateTrustees();
function set_AlternateTrustees(value);

Property Value

Type: String
The source server trustees.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.Domains Property

DNSOptionsDomains Property

This value represents the domains that will be updated during failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DnsDomainDetails[] Domains { get; set; }
Public Property Domains As DnsDomainDetails()
    Get
    Set
public:
property array<DnsDomainDetails^>^ Domains {
    array<DnsDomainDetails^>^ get ();
    void set (array<DnsDomainDetails^>^ value);
}
function get_Domains();
function set_Domains(value);

Property Value

Type: DnsDomainDetails
The domains that will be updated during failover.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.Enabled Property

DNSOptionsEnabled Property

This value is true if DNS failover is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
function get_Enabled();
function set_Enabled(value);

Property Value

Type: Boolean
if DNS failover is enabled; otherwise, .
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.ExtensionData Property

DNSOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.SourceServerInWorkgroup Property

DNSOptionsSourceServerInWorkgroup Property

This value is true if the source is in a workgroup; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceServerInWorkgroup { get; set; }
Public Property SourceServerInWorkgroup As Boolean
    Get
    Set
public:
property bool SourceServerInWorkgroup {
    bool get ();
    void set (bool value);
}
function get_SourceServerInWorkgroup();
function set_SourceServerInWorkgroup(value);

Property Value

Type: Boolean
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.SourceServerName Property

DNSOptionsSourceServerName Property

This value is the name of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceServerName { get; set; }
Public Property SourceServerName As String
    Get
    Set
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}
function get_SourceServerName();
function set_SourceServerName(value);

Property Value

Type: String
The name of the source server.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.TargetServerName Property

DNSOptionsTargetServerName Property

This value is the name of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetServerName { get; set; }
Public Property TargetServerName As String
    Get
    Set
public:
property String^ TargetServerName {
    String^ get ();
    void set (String^ value);
}
function get_TargetServerName();
function set_TargetServerName(value);

Property Value

Type: String
The name of the target server.
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions Methods

The DNSOptions type exposes the following members.

Methods
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


DNSOptions.ToString Method

DNSOptionsToString Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
See Also

Reference

DNSOptions Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus Class

Represents the status of an engine connection used by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractEngineControlStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class EngineControlStatus : IExtensibleDataObject
Public Class EngineControlStatus
    Implements IExtensibleDataObject
public ref class EngineControlStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.EngineControlStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.EngineControlStatus',
    null,
    IExtensibleDataObject);

The EngineControlStatus type exposes the following members.

Constructors
 | Name | Description
Public method | EngineControlStatus |
Top
Properties
 | Name | Description
Public property | CanPauseMirror | This value is true if mirroring can be paused; otherwise, it is false.
Public property | CanPauseTarget | This value is true if the target can be paused; otherwise, it is false.
Public property | CanPauseTransmission | This value is true if transmission can be paused; otherwise, it is false.
Public property | CanProcessOrphans | This value is true if the orphan file removal process can be started; otherwise, it is false.
Public property | CanResumeMirror | This value is true if mirroring can be resumed; otherwise, it is false.
Public property | CanResumeTarget | This value is true if the target can be resumed; otherwise, it is false.
Public property | CanResumeTransmission | This value is true if transmission can be resumed; otherwise, it is false.
Public property | CanSetBandwidth | This value is true if a bandwidth limit can be set; otherwise, it is false.
Public property | CanStartMirror | This value is true if mirroring can be started; otherwise, it is false.
Public property | CanStartTransmission | This value is true if transmission can be started; otherwise, it is false.
Public property | CanStopMirror | This value is true if mirroring can be stopped; otherwise, it is false.
Public property | CanTakeSnapshot | This value is true if the target can take a snapshot of the replica data; otherwise, it is false.
Public property | CanUpdateShares | This value is true if source share information can be updated; otherwise, it is false.
Public property | CanVerify | This value is true if verification of the source data to the target replica data can be started; otherwise, it is false.
Public property | ConnectionId | This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Role | This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


EngineControlStatus Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EngineControlStatus()
Public Sub New
public:
EngineControlStatus()
DoubleTake.Jobs.Contract.EngineControlStatus = function();
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus Properties

The EngineControlStatus type exposes the following members.

Properties
 | Name | Description
Public property | CanPauseMirror | This value is true if mirroring can be paused; otherwise, it is false.
Public property | CanPauseTarget | This value is true if the target can be paused; otherwise, it is false.
Public property | CanPauseTransmission | This value is true if transmission can be paused; otherwise, it is false.
Public property | CanProcessOrphans | This value is true if the orphan file removal process can be started; otherwise, it is false.
Public property | CanResumeMirror | This value is true if mirroring can be resumed; otherwise, it is false.
Public property | CanResumeTarget | This value is true if the target can be resumed; otherwise, it is false.
Public property | CanResumeTransmission | This value is true if transmission can be resumed; otherwise, it is false.
Public property | CanSetBandwidth | This value is true if a bandwidth limit can be set; otherwise, it is false.
Public property | CanStartMirror | This value is true if mirroring can be started; otherwise, it is false.
Public property | CanStartTransmission | This value is true if transmission can be started; otherwise, it is false.
Public property | CanStopMirror | This value is true if mirroring can be stopped; otherwise, it is false.
Public property | CanTakeSnapshot | This value is true if the target can take a snapshot of the replica data; otherwise, it is false.
Public property | CanUpdateShares | This value is true if source share information can be updated; otherwise, it is false.
Public property | CanVerify | This value is true if verification of the source data to the target replica data can be started; otherwise, it is false.
Public property | ConnectionId | This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Role | This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.
Top
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseMirror Property

EngineControlStatusCanPauseMirror Property

This value is true if mirroring can be paused; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseMirror { get; set; }
Public Property CanPauseMirror As Boolean
    Get
    Set
public:
property bool CanPauseMirror {
    bool get ();
    void set (bool value);
}
function get_CanPauseMirror();
function set_CanPauseMirror(value);

Property Value

Type: Boolean
if mirroring can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseTarget Property

EngineControlStatusCanPauseTarget Property

This value is true if the target can be paused; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
function get_CanPauseTarget();
function set_CanPauseTarget(value);

Property Value

Type: Boolean
if the target can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanPauseTransmission Property

EngineControlStatusCanPauseTransmission Property

This value is true if transmission can be paused; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPauseTransmission { get; set; }
Public Property CanPauseTransmission As Boolean
    Get
    Set
public:
property bool CanPauseTransmission {
    bool get ();
    void set (bool value);
}
function get_CanPauseTransmission();
function set_CanPauseTransmission(value);

Property Value

Type: Boolean
if transmission can be paused; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanProcessOrphans Property

EngineControlStatusCanProcessOrphans Property

This value is true if the orphan file removal process can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanProcessOrphans { get; set; }
Public Property CanProcessOrphans As Boolean
    Get
    Set
public:
property bool CanProcessOrphans {
    bool get ();
    void set (bool value);
}
function get_CanProcessOrphans();
function set_CanProcessOrphans(value);

Property Value

Type: Boolean
if a process orphans operation can be performed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeMirror Property

EngineControlStatusCanResumeMirror Property

This value is true if mirroring can be resumed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeMirror { get; set; }
Public Property CanResumeMirror As Boolean
    Get
    Set
public:
property bool CanResumeMirror {
    bool get ();
    void set (bool value);
}
function get_CanResumeMirror();
function set_CanResumeMirror(value);

Property Value

Type: Boolean
if mirroring can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeTarget Property

EngineControlStatusCanResumeTarget Property

This value is true if the target can be resumed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
function get_CanResumeTarget();
function set_CanResumeTarget(value);

Property Value

Type: Boolean
if the target can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanResumeTransmission Property

EngineControlStatusCanResumeTransmission Property

This value is true if transmission can be resumed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanResumeTransmission { get; set; }
Public Property CanResumeTransmission As Boolean
    Get
    Set
public:
property bool CanResumeTransmission {
    bool get ();
    void set (bool value);
}
function get_CanResumeTransmission();
function set_CanResumeTransmission(value);

Property Value

Type: Boolean
if transmission can be resumed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanSetBandwidth Property

EngineControlStatusCanSetBandwidth Property

This value is true if a bandwidth limit can be set; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanSetBandwidth { get; set; }
Public Property CanSetBandwidth As Boolean
    Get
    Set
public:
property bool CanSetBandwidth {
    bool get ();
    void set (bool value);
}
function get_CanSetBandwidth();
function set_CanSetBandwidth(value);

Property Value

Type: Boolean
if this the bandwidth limit can be set; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStartMirror Property

EngineControlStatusCanStartMirror Property

This value is true if mirroring can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStartMirror { get; set; }
Public Property CanStartMirror As Boolean
    Get
    Set
public:
property bool CanStartMirror {
    bool get ();
    void set (bool value);
}
function get_CanStartMirror();
function set_CanStartMirror(value);

Property Value

Type: Boolean
if this instance can start mirror; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStartTransmission Property

EngineControlStatusCanStartTransmission Property

This value is true if transmission can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStartTransmission { get; set; }
Public Property CanStartTransmission As Boolean
    Get
    Set
public:
property bool CanStartTransmission {
    bool get ();
    void set (bool value);
}
function get_CanStartTransmission();
function set_CanStartTransmission(value);

Property Value

Type: Boolean
if transmission can be started; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanStopMirror Property

EngineControlStatusCanStopMirror Property

This value is true if mirroring can be stopped; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStopMirror { get; set; }
Public Property CanStopMirror As Boolean
    Get
    Set
public:
property bool CanStopMirror {
    bool get ();
    void set (bool value);
}
function get_CanStopMirror();
function set_CanStopMirror(value);

Property Value

Type: Boolean
if mirroring can be stopped; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanTakeSnapshot Property

EngineControlStatusCanTakeSnapshot Property

This value is true if the target can take a snapshot of the replica data; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanTakeSnapshot { get; set; }
Public Property CanTakeSnapshot As Boolean
    Get
    Set
public:
property bool CanTakeSnapshot {
    bool get ();
    void set (bool value);
}
function get_CanTakeSnapshot();
function set_CanTakeSnapshot(value);

Property Value

Type: Boolean
if a snapshot can be taken; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanUpdateShares Property

EngineControlStatusCanUpdateShares Property

This value is true if source share information can be updated; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanUpdateShares { get; set; }
Public Property CanUpdateShares As Boolean
    Get
    Set
public:
property bool CanUpdateShares {
    bool get ();
    void set (bool value);
}
function get_CanUpdateShares();
function set_CanUpdateShares(value);

Property Value

Type: Boolean
if shares can be updated; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.CanVerify Property

EngineControlStatusCanVerify Property

This value is true if verification of the source data to the target replica data can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanVerify { get; set; }
Public Property CanVerify As Boolean
    Get
    Set
public:
property bool CanVerify {
    bool get ();
    void set (bool value);
}
function get_CanVerify();
function set_CanVerify(value);

Property Value

Type: Boolean
if verification can be performed; otherwise, .
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.ConnectionId Property

EngineControlStatusConnectionId Property

This value is a unique ID that needs to be provided to the replication engine control methods for controlling the replication engine connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
function get_ConnectionId();
function set_ConnectionId(value);

Property Value

Type: Guid
The connection id.
Remarks
This is a unique id that needs be provided to the engine control methods for controlling the engine connection represented by this instance.
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.ExtensionData Property

EngineControlStatusExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
A structure that contains extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


EngineControlStatus.Role Property

EngineControlStatusRole Property

This value is the role of the replication engine for the job. Jobs may use more than one replication engine connection in their operation. This property provides a way to differentiate between the replication engine connections for display purposes.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
function get_Role();
function set_Role(value);

Property Value

Type: String
The role.
Remarks
Jobs may use more than one engine connection in their operation. This property provides a way to differentiate between the engine connections for display purposes.
See Also

Reference

EngineControlStatus Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions Class

Represents the options used when failing back a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailbackOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FailbackOptions : IExtensibleDataObject
Public Class FailbackOptions
    Implements IExtensibleDataObject
public ref class FailbackOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FailbackOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailbackOptions',
    null,
    IExtensibleDataObject);

The FailbackOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FailbackOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NewMonitorOptions | This value represents the options for configuring failover monitoring after a job has been restored to a new source server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailbackOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailbackOptions()
Public Sub New
public:
FailbackOptions()
DoubleTake.Jobs.Contract.FailbackOptions = function();
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions Properties

The FailbackOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NewMonitorOptions | This value represents the options for configuring failover monitoring after a job has been restored to a new source server.
Top
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions.ExtensionData Property

FailbackOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailbackOptions.NewMonitorOptions Property

FailbackOptionsNewMonitorOptions Property

This value represents the options for configuring failover monitoring after a job has been restored to a new source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions NewMonitorOptions { get; set; }
Public Property NewMonitorOptions As CoreMonitorOptions
    Get
    Set
public:
property CoreMonitorOptions^ NewMonitorOptions {
    CoreMonitorOptions^ get ();
    void set (CoreMonitorOptions^ value);
}
function get_NewMonitorOptions();
function set_NewMonitorOptions(value);

Property Value

Type: CoreMonitorOptions
The monitor options for the new source server.
Remarks
These options are only relevant if the job has been restored to a new source server.
See Also

Reference

FailbackOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverMode Enumeration

Indicates the style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverMode
Public Enumeration FailoverMode
public enum class FailoverMode
DoubleTake.Jobs.Contract.FailoverMode = function();
DoubleTake.Jobs.Contract.FailoverMode.createEnum('DoubleTake.Jobs.Contract.FailoverMode', false);
Members
Member name | Value | Description
Live | 0 | Failover is using live, current data and the target is started with network connectivity.
Test | 1 | Failover is using live current data, but is a test. The target is started without network connectivity.
Snapshot | 2 | Failover is using a data from a snapshot. The target is started with network connectivity.
SetRestoreRequiredOnly | 3 | Failover is not performed, but the restore required flag is set.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverOptions Class

Represents the options used when failing over a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverOptions : IExtensibleDataObject
Public Class FailoverOptions
    Implements IExtensibleDataObject
public ref class FailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailoverOptions',
    null,
    IExtensibleDataObject);

The FailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverDataAction | This value represents the action to take on the queued target data before failover.
Public property | FailoverMode | This value represents the live, test, or snapshot style of failover.
Public property | FailoverType | This value represents the automatic or manual style of failover.
Public property | PerformTestFailover | Gets or sets a value indicating whether to perform a test failover.
Public property | SnapshotId | This value is the snapshot ID that should be applied to the target during snapshot failover.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverOptions()
Public Sub New
public:
FailoverOptions()
DoubleTake.Jobs.Contract.FailoverOptions = function();
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions Properties

The FailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverDataAction | This value represents the action to take on the queued target data before failover.
Public property | FailoverMode | This value represents the live, test, or snapshot style of failover.
Public property | FailoverType | This value represents the automatic or manual style of failover.
Public property | PerformTestFailover | Gets or sets a value indicating whether to perform a test failover.
Public property | SnapshotId | This value is the snapshot ID that should be applied to the target during snapshot failover.
Top
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.ExtensionData Property

FailoverOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverDataAction Property

FailoverOptionsFailoverDataAction Property

This value represents the action to take on the queued target data before failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverDataAction FailoverDataAction { get; set; }
Public Property FailoverDataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction FailoverDataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
function get_FailoverDataAction();
function set_FailoverDataAction(value);

Property Value

Type: FailoverDataAction
The failover data action.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverMode Property

FailoverOptionsFailoverMode Property

This value represents the live, test, or snapshot style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverMode FailoverMode { get; set; }
Public Property FailoverMode As FailoverMode
    Get
    Set
public:
property FailoverMode FailoverMode {
    FailoverMode get ();
    void set (FailoverMode value);
}
function get_FailoverMode();
function set_FailoverMode(value);

Property Value

Type: FailoverMode
The failover mode.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.FailoverType Property

FailoverOptionsFailoverType Property

This value represents the automatic or manual style of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
function get_FailoverType();
function set_FailoverType(value);

Property Value

Type: FailoverType
The failover mode.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.PerformTestFailover Property

FailoverOptionsPerformTestFailover Property

Gets or sets a value indicating whether to perform a test failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool PerformTestFailover { get; set; }
Public Property PerformTestFailover As Boolean
    Get
    Set
public:
property bool PerformTestFailover {
    bool get ();
    void set (bool value);
}
function get_PerformTestFailover();
function set_PerformTestFailover(value);

Property Value

Type: Boolean
if performing a test failover; otherwise, .
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverOptions.SnapshotId Property

FailoverOptionsSnapshotId Property

This value is the snapshot ID that should be applied to the target during snapshot failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid SnapshotId { get; set; }
Public Property SnapshotId As Guid
    Get
    Set
public:
property Guid SnapshotId {
    Guid get ();
    void set (Guid value);
}
function get_SnapshotId();
function set_SnapshotId(value);

Property Value

Type: Guid
The snapshot id to apply to the target server during failover.
See Also

Reference

FailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FailoverReport Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFailoverReport

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FailoverReport
Public Class FailoverReport
public ref class FailoverReport
DoubleTake.Jobs.Contract.FailoverReport = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FailoverReport');

The FailoverReport type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReport |
Top
Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Top
Fields
 | Name | Description
Public field | targetedMachineInfo | Information about the target machine.
Public field | times | Times for this failover
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverReport Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverReport()
Public Sub New
public:
FailoverReport()
DoubleTake.Jobs.Contract.FailoverReport = function();
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport Properties

The FailoverReport type exposes the following members.

Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Top
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.failoverSuccess Property

FailoverReportfailoverSuccess Property

Whether the failover was a success

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool failoverSuccess { get; set; }
Public Property failoverSuccess As Boolean
    Get
    Set
public:
property bool failoverSuccess {
    bool get ();
    void set (bool value);
}
function get_failoverSuccess();
function set_failoverSuccess(value);

Property Value

Type: Boolean
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.failoverType Property

FailoverReportfailoverType Property

Type of failover being done.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverStyle failoverType { get; set; }
Public Property failoverType As FailoverStyle
    Get
    Set
public:
property FailoverStyle failoverType {
    FailoverStyle get ();
    void set (FailoverStyle value);
}
function get_failoverType();
function set_failoverType(value);

Property Value

Type: FailoverStyle
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.isReverse Property

FailoverReportisReverse Property

Whether this is the reverse of the source in an FFO job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool isReverse { get; set; }
Public Property isReverse As Boolean
    Get
    Set
public:
property bool isReverse {
    bool get ();
    void set (bool value);
}
function get_isReverse();
function set_isReverse(value);

Property Value

Type: Boolean
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.jobId Property

FailoverReportjobId Property

Job id being reported

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string jobId { get; set; }
Public Property jobId As String
    Get
    Set
public:
property String^ jobId {
    String^ get ();
    void set (String^ value);
}
function get_jobId();
function set_jobId(value);

Property Value

Type: String
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.jobName Property

FailoverReportjobName Property

Name of the job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string jobName { get; set; }
Public Property jobName As String
    Get
    Set
public:
property String^ jobName {
    String^ get ();
    void set (String^ value);
}
function get_jobName();
function set_jobName(value);

Property Value

Type: String
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.jobType Property

FailoverReportjobType Property

This is the job type as described within JobInfo.cs

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string jobType { get; set; }
Public Property jobType As String
    Get
    Set
public:
property String^ jobType {
    String^ get ();
    void set (String^ value);
}
function get_jobType();
function set_jobType(value);

Property Value

Type: String
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.snapshotLabel Property

FailoverReportsnapshotLabel Property

Label for the snapshot used. (Empty string for live data.)

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string snapshotLabel { get; set; }
Public Property snapshotLabel As String
    Get
    Set
public:
property String^ snapshotLabel {
    String^ get ();
    void set (String^ value);
}
function get_snapshotLabel();
function set_snapshotLabel(value);

Property Value

Type: String
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport Fields

The FailoverReport type exposes the following members.

Fields
 | Name | Description
Public field | targetedMachineInfo | Information about the target machine.
Public field | times | Times for this failover
Top
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.targetedMachineInfo Field

FailoverReporttargetedMachineInfo Field

Information about the target machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MachineInfoClass targetedMachineInfo
Public targetedMachineInfo As MachineInfoClass
public:
MachineInfoClass^ targetedMachineInfo
var targetedMachineInfo

Field Value

Type: MachineInfoClass
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverReport.times Field

FailoverReporttimes Field

Times for this failover

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimesClass times
Public times As TimesClass
public:
TimesClass^ times
var times

Field Value

Type: TimesClass
See Also

Reference

FailoverReport Class
DoubleTake.Jobs.Contract Namespace


FailoverStyle Enumeration

Type of failover being used.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverStyle
Public Enumeration FailoverStyle
public enum class FailoverStyle
DoubleTake.Jobs.Contract.FailoverStyle = function();
DoubleTake.Jobs.Contract.FailoverStyle.createEnum('DoubleTake.Jobs.Contract.FailoverStyle', false);
Members
Member name | Value | Description
Live | 0 | Live failover is being done.
Test | 1 | Test failover is being done.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FailoverType Enumeration

Indicates the type of failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum FailoverType
Public Enumeration FailoverType
public enum class FailoverType
DoubleTake.Jobs.Contract.FailoverType = function();
DoubleTake.Jobs.Contract.FailoverType.createEnum('DoubleTake.Jobs.Contract.FailoverType', false);
Members
Member name | Value | Description
Manual | 0 | Failover must be initiated by the user.
Automatic | 1 | Failover will occur automatically when a failover condition is met.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


Feature Class

Represents a services endpoint that provides additional features for a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFeature

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class Feature : IExtensibleDataObject
Public Class Feature
    Implements IExtensibleDataObject
public ref class Feature : IExtensibleDataObject
DoubleTake.Jobs.Contract.Feature = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Feature',
    null,
    IExtensibleDataObject);

The Feature type exposes the following members.

Constructors
 | Name | Description
Public method | Feature |
Top
Properties
 | Name | Description
Public property | Endpoint | This value is the endpoint that identifies the location of the service.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Tag | This value is the tag that identifies the role of the service.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


Feature Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Feature()
Public Sub New
public:
Feature()
DoubleTake.Jobs.Contract.Feature = function();
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature Properties

The Feature type exposes the following members.

Properties
 | Name | Description
Public property | Endpoint | This value is the endpoint that identifies the location of the service.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Tag | This value is the tag that identifies the role of the service.
Top
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.Endpoint Property

FeatureEndpoint Property

This value is the endpoint that identifies the location of the service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri Endpoint { get; set; }
Public Property Endpoint As Uri
    Get
    Set
public:
property Uri^ Endpoint {
    Uri^ get ();
    void set (Uri^ value);
}
function get_Endpoint();
function set_Endpoint(value);

Property Value

Type: Uri
The endpoint that identifies the location of this service.
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.ExtensionData Property

FeatureExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


Feature.Tag Property

FeatureTag Property

This value is the tag that identifies the role of the service.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}
function get_Tag();
function set_Tag(value);

Property Value

Type: String
The tag that identifies the role of this service.
See Also

Reference

Feature Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Class

Represents options for working with the full server failover feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFullServerFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerFailoverOptions : IExtensibleDataObject
Public Class FullServerFailoverOptions
    Implements IExtensibleDataObject
public ref class FullServerFailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.FullServerFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FullServerFailoverOptions',
    null,
    IExtensibleDataObject);

The FullServerFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerFailoverOptions |
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.
Public property | CreateBackupConnection | This value is true if reverse protection should be configured for this job; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RemoveOrphans | This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.
Public property | ReverseRoute | This value is the source IP address to be used for the reverse connection.
Public property | ReverseRouteEnginePort | This value is the port where the engine is listening.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | SourceChecksumAll | This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerFailoverOptions()
Public Sub New
public:
FullServerFailoverOptions()
DoubleTake.Jobs.Contract.FullServerFailoverOptions = function();
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions Properties

The FullServerFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.
Public property | CreateBackupConnection | This value is true if reverse protection should be configured for this job; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RemoveOrphans | This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.
Public property | ReverseRoute | This value is the source IP address to be used for the reverse connection.
Public property | ReverseRouteEnginePort | This value is the port where the engine is listening.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | SourceChecksumAll | This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.
Top
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.AdditionalStagingFolders Property

FullServerFailoverOptionsAdditionalStagingFolders Property

This value is the folders that should be staged on the target. They will be applied to their actual installation location during failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalStagingFolders();
function set_AdditionalStagingFolders(value);

Property Value

Type: String
The additional folders that should be staged on the target server.
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.CreateBackupConnection Property

FullServerFailoverOptionsCreateBackupConnection Property

This value is true if reverse protection should be configured for this job; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CreateBackupConnection { get; set; }
Public Property CreateBackupConnection As Boolean
    Get
    Set
public:
property bool CreateBackupConnection {
    bool get ();
    void set (bool value);
}
function get_CreateBackupConnection();
function set_CreateBackupConnection(value);

Property Value

Type: Boolean
if the job should create a backup connection; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ExtensionData Property

FullServerFailoverOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.RemoveOrphans Property

FullServerFailoverOptionsRemoveOrphans Property

This value is true if orphan files should be removed for the reverse connection; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool RemoveOrphans { get; set; }
Public Property RemoveOrphans As Boolean
    Get
    Set
public:
property bool RemoveOrphans {
    bool get ();
    void set (bool value);
}
function get_RemoveOrphans();
function set_RemoveOrphans(value);

Property Value

Type: Boolean
if orphans should be removed; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ReverseRoute Property

FullServerFailoverOptionsReverseRoute Property

This value is the source IP address to be used for the reverse connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
function get_ReverseRoute();
function set_ReverseRoute(value);

Property Value

Type: String
The reverse route.
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ReverseRouteEnginePort Property

FullServerFailoverOptionsReverseRouteEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ReverseRouteEnginePort { get; set; }
Public Property ReverseRouteEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ReverseRouteEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ReverseRouteEnginePort();
function set_ReverseRouteEnginePort(value);

Property Value

Type: Nullable Int32
The engine port for reverse routing.
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.ShutdownSourceServer Property

FullServerFailoverOptionsShutdownSourceServer Property

This value is true if the source server should be shut down during cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
function get_ShutdownSourceServer();
function set_ShutdownSourceServer(value);

Property Value

Type: Boolean
if the source server should be shut down during cutover; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerFailoverOptions.SourceChecksumAll Property

FullServerFailoverOptionsSourceChecksumAll Property

This value is true if a checksum should be used for all files when comparing them; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceChecksumAll { get; set; }
Public Property SourceChecksumAll As Boolean
    Get
    Set
public:
property bool SourceChecksumAll {
    bool get ();
    void set (bool value);
}
function get_SourceChecksumAll();
function set_SourceChecksumAll(value);

Property Value

Type: Boolean
if a checksum should be used for all files when comparing them; otherwise, .
See Also

Reference

FullServerFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions Class

FullServer TestFailover related options
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractFullServerTestFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerTestFailoverOptions
Public Class FullServerTestFailoverOptions
public ref class FullServerTestFailoverOptions
DoubleTake.Jobs.Contract.FullServerTestFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FullServerTestFailoverOptions');

The FullServerTestFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerTestFailoverOptions |
Top
Properties
 | Name | Description
Public property | DeleteSnapshots |
Public property | FailoverName | The server name to apply to the test failover server
Public property | NicMappings | This value represents the NIC mappings for full server testfailover.
Public property | TestFailoverServerAddress | The test failover server address to use for the replication service connection
Public property | TestFailoverServerCredential |
Public property | TestFailoverServerEnginePort | The test failover server engine port to use for the replication service connection
Public property | TestFailoverServerReservedAddress | IP address that will remain on the test failover server after a test failover
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerTestFailoverOptions()
Public Sub New
public:
FullServerTestFailoverOptions()
DoubleTake.Jobs.Contract.FullServerTestFailoverOptions = function();
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions Properties

The FullServerTestFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | DeleteSnapshots |
Public property | FailoverName | The server name to apply to the test failover server
Public property | NicMappings | This value represents the NIC mappings for full server testfailover.
Public property | TestFailoverServerAddress | The test failover server address to use for the replication service connection
Public property | TestFailoverServerCredential |
Public property | TestFailoverServerEnginePort | The test failover server engine port to use for the replication service connection
Public property | TestFailoverServerReservedAddress | IP address that will remain on the test failover server after a test failover
Top
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.DeleteSnapshots Property

FullServerTestFailoverOptionsDeleteSnapshots Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteSnapshots { get; set; }
Public Property DeleteSnapshots As Boolean
    Get
    Set
public:
property bool DeleteSnapshots {
    bool get ();
    void set (bool value);
}
function get_DeleteSnapshots();
function set_DeleteSnapshots(value);

Property Value

Type: Boolean
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.FailoverName Property

FullServerTestFailoverOptionsFailoverName Property

The server name to apply to the test failover server

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string FailoverName { get; set; }
Public Property FailoverName As String
    Get
    Set
public:
property String^ FailoverName {
    String^ get ();
    void set (String^ value);
}
function get_FailoverName();
function set_FailoverName(value);

Property Value

Type: String
Remarks
Typically this would be set to the source server name if failing over the name. If not set, the test failover server name will not be changed.
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.NicMappings Property

FullServerTestFailoverOptionsNicMappings Property

This value represents the NIC mappings for full server testfailover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerNicMappings[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappings()
    Get
    Set
public:
property array<FullServerNicMappings^>^ NicMappings {
    array<FullServerNicMappings^>^ get ();
    void set (array<FullServerNicMappings^>^ value);
}
function get_NicMappings();
function set_NicMappings(value);

Property Value

Type: FullServerNicMappings
The network interface mappings.
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.TestFailoverServerAddress Property

FullServerTestFailoverOptionsTestFailoverServerAddress Property

The test failover server address to use for the replication service connection

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestFailoverServerAddress { get; set; }
Public Property TestFailoverServerAddress As String
    Get
    Set
public:
property String^ TestFailoverServerAddress {
    String^ get ();
    void set (String^ value);
}
function get_TestFailoverServerAddress();
function set_TestFailoverServerAddress(value);

Property Value

Type: String
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.TestFailoverServerCredential Property

FullServerTestFailoverOptionsTestFailoverServerCredential Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TestFailoverServerCredential TestFailoverServerCredential { get; set; }
Public Property TestFailoverServerCredential As TestFailoverServerCredential
    Get
    Set
public:
property TestFailoverServerCredential^ TestFailoverServerCredential {
    TestFailoverServerCredential^ get ();
    void set (TestFailoverServerCredential^ value);
}
function get_TestFailoverServerCredential();
function set_TestFailoverServerCredential(value);

Property Value

Type: TestFailoverServerCredential
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.TestFailoverServerEnginePort Property

FullServerTestFailoverOptionsTestFailoverServerEnginePort Property

The test failover server engine port to use for the replication service connection

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> TestFailoverServerEnginePort { get; set; }
Public Property TestFailoverServerEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TestFailoverServerEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_TestFailoverServerEnginePort();
function set_TestFailoverServerEnginePort(value);

Property Value

Type: Nullable Int32
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


FullServerTestFailoverOptions.TestFailoverServerReservedAddress Property

FullServerTestFailoverOptionsTestFailoverServerReservedAddress Property

IP address that will remain on the test failover server after a test failover

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestFailoverServerReservedAddress { get; set; }
Public Property TestFailoverServerReservedAddress As String
    Get
    Set
public:
property String^ TestFailoverServerReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_TestFailoverServerReservedAddress();
function set_TestFailoverServerReservedAddress(value);

Property Value

Type: String
See Also

Reference

FullServerTestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


Health Enumeration

Indicates the health of a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum Health
Public Enumeration Health
public enum class Health
DoubleTake.Jobs.Contract.Health = function();
DoubleTake.Jobs.Contract.Health.createEnum('DoubleTake.Jobs.Contract.Health', false);
Members
Member name | Value | Description
Unknown | 0 | The health of the job is unknown or not yet determined.
Ok | 1 | The health of the job is good and data is protected.
Warning | 2 | The job is taking corrective action. Data may not be protected. You should closely monitor a job in a warning state.
Error | 3 | The job has encountered an error that requires user attention. Data is not protected.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


HighLevelState Enumeration

Defines the possible high-level states of a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum HighLevelState
Public Enumeration HighLevelState
public enum class HighLevelState
DoubleTake.Jobs.Contract.HighLevelState = function();
DoubleTake.Jobs.Contract.HighLevelState.createEnum('DoubleTake.Jobs.Contract.HighLevelState', false);
Members
Member name | Value | Description
Unknown | 0 | The job's state is unknown or not yet determined.
Created | 1 | The job is being created.
Deleting | 2 | The job is being deleted.
FailedBack | 3 | The job has failed back.
FailedOver | 4 | The job has failed over.
FailingBack | 5 | The job is failing back.
FailingOver | 6 | The job is failing over.
FailoverFailed | 7 | Failover has failed.
FailoverPending | 8 | The job has a failover condition met.
Mirroring | 9 | The job is mirroring.
MirrorRequired | 10 | The job requires a mirror to ensure data integrity.
Paused | 11 | The job is paused.
Pausing | 12 | The job is pausing.
Protecting | 13 | The job is started and protecting.
Provisioning | 14 | The job is provisioning resources required to start protection.
Restored | 15 | The job has completed restoring the data.
RestoreFailed | 16 | Restoration has failed.
RestorePaused | 17 | The job is restoring data but transmission is currently paused.
RestoreRequired | 18 | The job needs to restore data from the target to a new or the original source.
Restoring | 19 | The job is restoring data.
Resuming | 20 | The job is resuming.
Reversing | 21 | The job is reversing roles.
Reverting | 22 | The job is reverting.
Starting | 23 | The job is starting.
Stopped | 24 | The job is stopped.
Stopping | 25 | The job is stopping.
Undoing | 26 | The job is undoing a failover.
RevertingSnapshot | 27 | The job is reverting to a previous snapshot.
UpdatingTargetImage | 28 | The job is updating the target image on the source. This option is no longer needed.
CredentialsRequired | 29 | The job does not have sufficient credentials to operate properly.
ActivationCodeWarning | 30 | The Double-Take replication engine is reporting a licensing warning.
ActivationCodeError | 31 | The Double-Take replication engine is reporting a licensing error.
EngineConnectionWarning | 32 | The connection associated with the job is reporting an error, but the threshold for failed communication has not yet been met.
EngineConnectionError | 33 | The connection associated with the job is reporting an error, and the threshold for failed communication has been exceeded.
EngineServiceWarning | 34 | The Management Service on the target cannot communicate with the target replication engine or the Management Service on the source cannot communicate with the source replication engine, but the threshold for failed communication has not yet been met.
EngineServiceError | 35 | The Management Service on the target cannot communicate with the target replication engine or the Management Service on the source cannot communicate with the source replication engine, and the threshold for failed communication has been exceeded.
ServerCommunicationWarning | 36 | The Management Service on the target cannot contact the Management Service on the source, but the threshold for failed communication has not yet been met.
ServerCommunicationError | 37 | The Management Service on the target cannot contact the Management Service on the source, and the threshold for failed communication has not yet been met.
TargetInfoNotAvailable | 38 | The controller appliance for an agentless vSphere job cannot communicate with the target.
Editing | 39 | Job edit in progress
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Class

Represents options for working with the image protection feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractImageProtectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageProtectionOptions : IExtensibleDataObject
Public Class ImageProtectionOptions
    Implements IExtensibleDataObject
public ref class ImageProtectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageProtectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageProtectionOptions',
    null,
    IExtensibleDataObject);

The ImageProtectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that contains the protected data from the source.
Public property | ImageName | This value is the name of the image that contains the protected data from the source.
Public property | VhdInfo | This value represents information about a virtual hard disk used to store an image.
Public property | VhdsToDeleteOnRemove | This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionOptions()
Public Sub New
public:
ImageProtectionOptions()
DoubleTake.Jobs.Contract.ImageProtectionOptions = function();
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions Properties

The ImageProtectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that contains the protected data from the source.
Public property | ImageName | This value is the name of the image that contains the protected data from the source.
Public property | VhdInfo | This value represents information about a virtual hard disk used to store an image.
Public property | VhdsToDeleteOnRemove | This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.
Top
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ExtensionData Property

ImageProtectionOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ImageId Property

ImageProtectionOptionsImageId Property

This value is the unique ID of the image that contains the protected data from the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.ImageName Property

ImageProtectionOptionsImageName Property

This value is the name of the image that contains the protected data from the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
function get_ImageName();
function set_ImageName(value);

Property Value

Type: String
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.VhdInfo Property

ImageProtectionOptionsVhdInfo Property

This value represents information about a virtual hard disk used to store an image.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageVhdInfo[] VhdInfo { get; set; }
Public Property VhdInfo As ImageVhdInfo()
    Get
    Set
public:
property array<ImageVhdInfo^>^ VhdInfo {
    array<ImageVhdInfo^>^ get ();
    void set (array<ImageVhdInfo^>^ value);
}
function get_VhdInfo();
function set_VhdInfo(value);

Property Value

Type: ImageVhdInfo
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageProtectionOptions.VhdsToDeleteOnRemove Property

ImageProtectionOptionsVhdsToDeleteOnRemove Property

This value is a list of .vhd files to delete from disk when the corresponding protected volume is has been removed from the image. This value is specified by volume letter.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<string> VhdsToDeleteOnRemove { get; set; }
Public Property VhdsToDeleteOnRemove As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDeleteOnRemove {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
function get_VhdsToDeleteOnRemove();
function set_VhdsToDeleteOnRemove(value);

Property Value

Type: IEnumerable String
See Also

Reference

ImageProtectionOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Class

Represents options for working with the image recovery feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractImageRecoveryOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageRecoveryOptions : IExtensibleDataObject
Public Class ImageRecoveryOptions
    Implements IExtensibleDataObject
public ref class ImageRecoveryOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageRecoveryOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageRecoveryOptions',
    null,
    IExtensibleDataObject);

The ImageRecoveryOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryOptions |
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the additional folders that should be staged on the target server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that will be recovered.
Public property | ImageRecoveryDataLocation | This value is the location of the original source's protected data.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | UserInitiatedCutover | This value is true if the user is required to initiate cutover; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryOptions()
Public Sub New
public:
ImageRecoveryOptions()
DoubleTake.Jobs.Contract.ImageRecoveryOptions = function();
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions Properties

The ImageRecoveryOptions type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | This value is the additional folders that should be staged on the target server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ImageId | This value is the unique ID of the image that will be recovered.
Public property | ImageRecoveryDataLocation | This value is the location of the original source's protected data.
Public property | ShutdownSourceServer | This value is true if the source server should be shut down during cutover; otherwise, it is false.
Public property | UserInitiatedCutover | This value is true if the user is required to initiate cutover; otherwise, it is false.
Top
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.AdditionalStagingFolders Property

ImageRecoveryOptionsAdditionalStagingFolders Property

This value is the additional folders that should be staged on the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_AdditionalStagingFolders();
function set_AdditionalStagingFolders(value);

Property Value

Type: String
The additional folders that should be staged on the target server.
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ExtensionData Property

ImageRecoveryOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ImageId Property

ImageRecoveryOptionsImageId Property

This value is the unique ID of the image that will be recovered.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
function get_ImageId();
function set_ImageId(value);

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ImageRecoveryDataLocation Property

ImageRecoveryOptionsImageRecoveryDataLocation Property

This value is the location of the original source's protected data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ImageRecoveryDataLocation { get; set; }
Public Property ImageRecoveryDataLocation As String
    Get
    Set
public:
property String^ ImageRecoveryDataLocation {
    String^ get ();
    void set (String^ value);
}
function get_ImageRecoveryDataLocation();
function set_ImageRecoveryDataLocation(value);

Property Value

Type: String
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.ShutdownSourceServer Property

ImageRecoveryOptionsShutdownSourceServer Property

This value is true if the source server should be shut down during cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
function get_ShutdownSourceServer();
function set_ShutdownSourceServer(value);

Property Value

Type: Boolean
if the source server should be shut down during cutover; otherwise, .
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


ImageRecoveryOptions.UserInitiatedCutover Property

ImageRecoveryOptionsUserInitiatedCutover Property

This value is true if the user is required to initiate cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool UserInitiatedCutover { get; set; }
Public Property UserInitiatedCutover As Boolean
    Get
    Set
public:
property bool UserInitiatedCutover {
    bool get ();
    void set (bool value);
}
function get_UserInitiatedCutover();
function set_UserInitiatedCutover(value);

Property Value

Type: Boolean
if the user is required to initiate cutover; otherwise, .
See Also

Reference

ImageRecoveryOptions Class
DoubleTake.Jobs.Contract Namespace


JobAction Class

Represents an action recently reported by a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobAction

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobAction : IExtensibleDataObject
Public Class JobAction
    Implements IExtensibleDataObject
public ref class JobAction : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobAction = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobAction',
    null,
    IExtensibleDataObject);

The JobAction type exposes the following members.

Constructors
 | Name | Description
Public method | JobAction |
Top
Properties
 | Name | Description
Public property | Duration | This value is the duration of the action.
Public property | ErrorCode | This value is the error code associated with the action.
Public property | ExceptionMessage | This value is a message from the underlying exception. The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID of the action.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageId | This value is the message ID for the action. This value can be used to look up a message associated with this action.
Public property | RequestingUserName | This value is the name of the user that requested the action.
Public property | Status | This value represents the status of the action.
Public property | Timestamp | This value is the time when the action occurred.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleId | This value is the title ID for the action. This value can be used to look up a title associated with this action.
Top
Remarks
Naturally, error information is logged for a job in the Windows event log and other locations. This class represents an action or error in a format that is convenient for displaying in the user interface.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobAction Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobAction()
Public Sub New
public:
JobAction()
DoubleTake.Jobs.Contract.JobAction = function();
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction Properties

The JobAction type exposes the following members.

Properties
 | Name | Description
Public property | Duration | This value is the duration of the action.
Public property | ErrorCode | This value is the error code associated with the action.
Public property | ExceptionMessage | This value is a message from the underlying exception. The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the unique ID of the action.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageId | This value is the message ID for the action. This value can be used to look up a message associated with this action.
Public property | RequestingUserName | This value is the name of the user that requested the action.
Public property | Status | This value represents the status of the action.
Public property | Timestamp | This value is the time when the action occurred.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleId | This value is the title ID for the action. This value can be used to look up a title associated with this action.
Top
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Duration Property

JobActionDuration Property

This value is the duration of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
function get_Duration();
function set_Duration(value);

Property Value

Type: TimeSpan
The duration of action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ErrorCode Property

JobActionErrorCode Property

This value is the error code associated with the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
function get_ErrorCode();
function set_ErrorCode(value);

Property Value

Type: Int32
The error code.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ExceptionMessage Property

JobActionExceptionMessage Property

This value is a message from the underlying exception. The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the interface. This property should only be used for internal troubleshooting, and as a measure of last resort in the event of a completely unexpected error.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ExceptionMessage { get; set; }
Public Property ExceptionMessage As String
    Get
    Set
public:
property String^ ExceptionMessage {
    String^ get ();
    void set (String^ value);
}
function get_ExceptionMessage();
function set_ExceptionMessage(value);

Property Value

Type: String
The exception message.
Remarks
Job implementations should define specific messages for all known errors that can occur during the lifetime of a job. The message stored in this property should not be displayed in the user interface, as it may not be available in the language used by the console. This property should only be used for internal troubleshooting, and as measure of last resort in the event of an completely unexpected error.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.ExtensionData Property

JobActionExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Id Property

JobActionId Property

This value is the unique ID of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.MessageFormatParameters Property

JobActionMessageFormatParameters Property

This value is the message format parameters.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
The message format parameters for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.MessageId Property

JobActionMessageId Property

This value is the message ID for the action. This value can be used to look up a message associated with this action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
function get_MessageId();
function set_MessageId(value);

Property Value

Type: String
The message id for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.RequestingUserName Property

JobActionRequestingUserName Property

This value is the name of the user that requested the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string RequestingUserName { get; set; }
Public Property RequestingUserName As String
    Get
    Set
public:
property String^ RequestingUserName {
    String^ get ();
    void set (String^ value);
}
function get_RequestingUserName();
function set_RequestingUserName(value);

Property Value

Type: String
The name of the user that requested this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Status Property

JobActionStatus Property

This value represents the status of the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActionStatus Status { get; set; }
Public Property Status As ActionStatus
    Get
    Set
public:
property ActionStatus Status {
    ActionStatus get ();
    void set (ActionStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: ActionStatus
The status of this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.Timestamp Property

JobActionTimestamp Property

This value is the time when the action occurred.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
function get_Timestamp();
function set_Timestamp(value);

Property Value

Type: DateTimeOffset
The timestamp when this action occurred.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.TitleFormatParameters Property

JobActionTitleFormatParameters Property

This value is the title format parameters for the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TitleFormatParameters();
function set_TitleFormatParameters(value);

Property Value

Type: String
The title format parameters for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobAction.TitleId Property

JobActionTitleId Property

This value is the title ID for the action. This value can be used to look up a title associated with this action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TitleId { get; set; }
Public Property TitleId As String
    Get
    Set
public:
property String^ TitleId {
    String^ get ();
    void set (String^ value);
}
function get_TitleId();
function set_TitleId(value);

Property Value

Type: String
The title id for this action.
See Also

Reference

JobAction Class
DoubleTake.Jobs.Contract Namespace


JobInfo Class

Represents a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobInfo

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobInfo : IExtensibleDataObject
Public Class JobInfo
    Implements IExtensibleDataObject
public ref class JobInfo : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobInfo = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobInfo',
    null,
    IExtensibleDataObject);

The JobInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfo |
Top
Properties
 | Name | Description
Public property | CreatorUserName | This value is the name of the user who created the job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Features | This value represents a service endpoint that provides additional features for a job.
Public property | Id | This value is the unique ID for the job.
Public property | JobType | This value is the type of job. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property | LoadedFromDisk | This value is true if the job was loaded from persistence; otherwise, it is false.
Public property | Managed | This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.
Public property | Options | This value represents the current options for the job.
Public property | OtherHostUris | This value is the URIs for other servers involved in the job.
Public property | SourceHostUri | This value is the source URI.
Public property | SourceUniqueId | This value is the unique ID of the source server.
Public property | Statistics | This value represents the current statistics of the job
Public property | Status | This value represents the current state of the job.
Public property | TargetHostUri | This value is the target URI.
Public property | TargetUniqueId | This value is the unique ID of the target server.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobInfo Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobInfo()
Public Sub New
public:
JobInfo()
DoubleTake.Jobs.Contract.JobInfo = function();
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo Properties

The JobInfo type exposes the following members.

Properties
 | Name | Description
Public property | CreatorUserName | This value is the name of the user who created the job.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Features | This value represents a service endpoint that provides additional features for a job.
Public property | Id | This value is the unique ID for the job.
Public property | JobType | This value is the type of job. ClusterAwareFilesAndFolders—Cluster-aware files and folders job ClusterAwareSql—Cluster-aware SQL job Diagnostics—Throughput Diagnostic Utility job FilesAndFolders—Files and folders job FullServerFailover—Full server job FullServerImageProtection—DR full server protection job FullServerImageRecovery—DR full server recovery job LinuxFullServerFailover—Full server job LinuxMoveServerMigration—Full server migration job Lvra—Full server to ESX job MoveDataOnlyMigration—Data migration job MoveServerMigration—Full server migration job MoveLvra—Full server to ESX migration SQL—SQL job VRA—Full server to ESX or full server to Hyper-V job VraMove—Full server to ESX migration or full server to Hyper-V migration job
Public property | LoadedFromDisk | This value is true if the job was loaded from persistence; otherwise, it is false.
Public property | Managed | This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.
Public property | Options | This value represents the current options for the job.
Public property | OtherHostUris | This value is the URIs for other servers involved in the job.
Public property | SourceHostUri | This value is the source URI.
Public property | SourceUniqueId | This value is the unique ID of the source server.
Public property | Statistics | This value represents the current statistics of the job
Public property | Status | This value represents the current state of the job.
Public property | TargetHostUri | This value is the target URI.
Public property | TargetUniqueId | This value is the unique ID of the target server.
Top
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.CreatorUserName Property

JobInfoCreatorUserName Property

This value is the name of the user who created the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
function get_CreatorUserName();
function set_CreatorUserName(value);

Property Value

Type: String
The name of the user who created this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.ExtensionData Property

JobInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Features Property

JobInfoFeatures Property

This value represents a service endpoint that provides additional features for a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Feature[] Features { get; set; }
Public Property Features As Feature()
    Get
    Set
public:
property array<Feature^>^ Features {
    array<Feature^>^ get ();
    void set (array<Feature^>^ value);
}
function get_Features();
function set_Features(value);

Property Value

Type: Feature
An array of Feature that includes the additional features supported by this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Id Property

JobInfoId Property

This value is the unique ID for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
The unique identifier of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.JobType Property

JobInfoJobType Property

This value is the type of job.

ClusterAwareFilesAndFolders—Cluster-aware files and folders job

ClusterAwareSql—Cluster-aware SQL job

Diagnostics—Throughput Diagnostic Utility job

FilesAndFolders—Files and folders job

FullServerFailover—Full server job

FullServerImageProtection—DR full server protection job

FullServerImageRecovery—DR full server recovery job

LinuxFullServerFailover—Full server job

LinuxMoveServerMigration—Full server migration job

Lvra—Full server to ESX job

MoveDataOnlyMigration—Data migration job

MoveServerMigration—Full server migration job

MoveLvra—Full server to ESX migration

SQL—SQL job

VRA—Full server to ESX or full server to Hyper-V job

VraMove—Full server to ESX migration or full server to Hyper-V migration job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
function get_JobType();
function set_JobType(value);

Property Value

Type: String
The type of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.LoadedFromDisk Property

JobInfoLoadedFromDisk Property

This value is true if the job was loaded from persistence; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
function get_LoadedFromDisk();
function set_LoadedFromDisk(value);

Property Value

Type: Boolean
if this job was loaded from persistence; otherwise, .
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Managed Property

JobInfoManaged Property

This value is true if the job is managed; otherwise, it is false. This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
function get_Managed();
function set_Managed(value);

Property Value

Type: Boolean
if this job is managed; otherwise, .
Remarks
This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime. Typically, jobs who have this property set to will be added to the job manager using the [M:Add] method.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Options Property

JobInfoOptions Property

This value represents the current options for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions Options { get; set; }
Public Property Options As JobOptions
    Get
    Set
public:
property JobOptions^ Options {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_Options();
function set_Options(value);

Property Value

Type: JobOptions
A JobOptions that represents the current options for this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.OtherHostUris Property

JobInfoOtherHostUris Property

This value is the URIs for other servers involved in the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IDictionary<string, Uri> OtherHostUris { get; set; }
Public Property OtherHostUris As IDictionary(Of String, Uri)
    Get
    Set
public:
property IDictionary<String^, Uri^>^ OtherHostUris {
    IDictionary<String^, Uri^>^ get ();
    void set (IDictionary<String^, Uri^>^ value);
}
function get_OtherHostUris();
function set_OtherHostUris(value);

Property Value

Type: IDictionary String, Uri
The other server URIs.
Remarks
This property serves as a replacement for the OtherNetworkIds property. Please refrain from using the OtherNetworkIds property.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.SourceHostUri Property

JobInfoSourceHostUri Property

This value is the source URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source URI.
Remarks
This property serves as a replacement for the SourceNetworkId and SourceManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.SourceUniqueId Property

JobInfoSourceUniqueId Property

This value is the unique ID of the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_SourceUniqueId();
function set_SourceUniqueId(value);

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Statistics Property

JobInfoStatistics Property

This value represents the current statistics of the job

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatistics Statistics { get; set; }
Public Property Statistics As JobStatistics
    Get
    Set
public:
property JobStatistics^ Statistics {
    JobStatistics^ get ();
    void set (JobStatistics^ value);
}
function get_Statistics();
function set_Statistics(value);

Property Value

Type: JobStatistics
A JobStatistics that represents the current statistics of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.Status Property

JobInfoStatus Property

This value represents the current state of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatus Status { get; set; }
Public Property Status As JobStatus
    Get
    Set
public:
property JobStatus^ Status {
    JobStatus^ get ();
    void set (JobStatus^ value);
}
function get_Status();
function set_Status(value);

Property Value

Type: JobStatus
A JobStatus that represents the current status of this job.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.TargetHostUri Property

JobInfoTargetHostUri Property

This value is the target URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri TargetHostUri { get; set; }
Public Property TargetHostUri As Uri
    Get
    Set
public:
property Uri^ TargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_TargetHostUri();
function set_TargetHostUri(value);

Property Value

Type: Uri
The target URI.
Remarks
This property serves as a replacement for the TargetNetworkId and TargetManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.TargetUniqueId Property

JobInfoTargetUniqueId Property

This value is the unique ID of the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
function get_TargetUniqueId();
function set_TargetUniqueId(value);

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo Methods

The JobInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.GetDeserializedObject Method

JobInfoGetDeserializedObject Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobInfo.GetObjectToSerialize Method

JobInfoGetObjectToSerialize Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

JobInfo Class
DoubleTake.Jobs.Contract Namespace


JobOptions Class

Represents the user-configurable options of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobOptions : IExtensibleDataObject
Public Class JobOptions
    Implements IExtensibleDataObject
public ref class JobOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobOptions',
    null,
    IExtensibleDataObject);

The JobOptions type exposes the following members.

Constructors
 | Name | Description
Public method | JobOptions |
Top
Properties
 | Name | Description
Public property | ApplicationOptions | This value represents the options for Exchange and SQL jobs.
Public property | BandwidthOptions | This value represents bandwidth limiting configuration.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | This value represents cluster options.
Public property | CoreConnectionOptions | This value represents the options for the job connection.
Public property | CoreMonitorOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | DnsOptions | This value represents the options for jobs using DNS failover.
Public property | FailoverMonitoringEnabled | This value is true if failover monitoring is enabled; otherwise, it is false.
Public property | FullServerFailoverOptions | This value represents the options for full server jobs.
Public property | FullServerTestFailoverOptions | This value represents the testfailover options for full server jobs.
Public property | ImageProtectionOptions | This value represents the options for Double-Take DR protection jobs. This option is no longer needed.
Public property | ImageRecoveryOptions | This value represents the options for Double-Take DR recovery jobs. This option is no longer needed.
Public property | ManagementServiceTargetPort |
Public property | MonitoringOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | Name | This value is the name of the job.
Public property | SystemStateOptions | This value represents the system state options for full server jobs.
Public property | TargetServicesOptions | This value represents which target services will be stopped and started during failover and failback.
Public property | UnmanagedConnectionOptions | This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.
Public property | VRAOptions | This value represents the options for guest-level virtual jobs.
Public property | Workload | This value represents the workload being protected by the job.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions()
Public Sub New
public:
JobOptions()
DoubleTake.Jobs.Contract.JobOptions = function();
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions Properties

The JobOptions type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationOptions | This value represents the options for Exchange and SQL jobs.
Public property | BandwidthOptions | This value represents bandwidth limiting configuration.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | This value represents cluster options.
Public property | CoreConnectionOptions | This value represents the options for the job connection.
Public property | CoreMonitorOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | DnsOptions | This value represents the options for jobs using DNS failover.
Public property | FailoverMonitoringEnabled | This value is true if failover monitoring is enabled; otherwise, it is false.
Public property | FullServerFailoverOptions | This value represents the options for full server jobs.
Public property | FullServerTestFailoverOptions | This value represents the testfailover options for full server jobs.
Public property | ImageProtectionOptions | This value represents the options for Double-Take DR protection jobs. This option is no longer needed.
Public property | ImageRecoveryOptions | This value represents the options for Double-Take DR recovery jobs. This option is no longer needed.
Public property | ManagementServiceTargetPort |
Public property | MonitoringOptions | This value represents the options for configuring failover monitoring by using the service monitoring method.
Public property | Name | This value is the name of the job.
Public property | SystemStateOptions | This value represents the system state options for full server jobs.
Public property | TargetServicesOptions | This value represents which target services will be stopped and started during failover and failback.
Public property | UnmanagedConnectionOptions | This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.
Public property | VRAOptions | This value represents the options for guest-level virtual jobs.
Public property | Workload | This value represents the workload being protected by the job.
Top
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ApplicationOptions Property

JobOptionsApplicationOptions Property

This value represents the options for Exchange and SQL jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ApplicationOptions ApplicationOptions { get; set; }
Public Property ApplicationOptions As ApplicationOptions
    Get
    Set
public:
property ApplicationOptions^ ApplicationOptions {
    ApplicationOptions^ get ();
    void set (ApplicationOptions^ value);
}
function get_ApplicationOptions();
function set_ApplicationOptions(value);

Property Value

Type: ApplicationOptions
The options for application-specific protection jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.BandwidthOptions Property

JobOptionsBandwidthOptions Property

This value represents bandwidth limiting configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthOptions BandwidthOptions { get; set; }
Public Property BandwidthOptions As BandwidthOptions
    Get
    Set
public:
property BandwidthOptions^ BandwidthOptions {
    BandwidthOptions^ get ();
    void set (BandwidthOptions^ value);
}
function get_BandwidthOptions();
function set_BandwidthOptions(value);

Property Value

Type: BandwidthOptions
The options for bandwidth limiting.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CloudOptions Property

JobOptionsCloudOptions Property

Gets or sets the options for cloud jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CloudOptions CloudOptions { get; set; }
Public Property CloudOptions As CloudOptions
    Get
    Set
public:
property CloudOptions^ CloudOptions {
    CloudOptions^ get ();
    void set (CloudOptions^ value);
}
function get_CloudOptions();
function set_CloudOptions(value);

Property Value

Type: CloudOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ClusterOptions Property

JobOptionsClusterOptions Property

This value represents cluster options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterOptions ClusterOptions { get; set; }
Public Property ClusterOptions As ClusterOptions
    Get
    Set
public:
property ClusterOptions^ ClusterOptions {
    ClusterOptions^ get ();
    void set (ClusterOptions^ value);
}
function get_ClusterOptions();
function set_ClusterOptions(value);

Property Value

Type: ClusterOptions
The cluster options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CoreConnectionOptions Property

JobOptionsCoreConnectionOptions Property

This value represents the options for the job connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionOptions CoreConnectionOptions { get; set; }
Public Property CoreConnectionOptions As CoreConnectionOptions
    Get
    Set
public:
property CoreConnectionOptions^ CoreConnectionOptions {
    CoreConnectionOptions^ get ();
    void set (CoreConnectionOptions^ value);
}
function get_CoreConnectionOptions();
function set_CoreConnectionOptions(value);

Property Value

Type: CoreConnectionOptions
The core connection options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.CoreMonitorOptions Property

JobOptionsCoreMonitorOptions Property

This value represents the options for configuring failover monitoring by using the service monitoring method.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorOptions CoreMonitorOptions { get; set; }
Public Property CoreMonitorOptions As CoreMonitorOptions
    Get
    Set
public:
property CoreMonitorOptions^ CoreMonitorOptions {
    CoreMonitorOptions^ get ();
    void set (CoreMonitorOptions^ value);
}
function get_CoreMonitorOptions();
function set_CoreMonitorOptions(value);

Property Value

Type: CoreMonitorOptions
The core monitor options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.DnsOptions Property

JobOptionsDnsOptions Property

This value represents the options for jobs using DNS failover.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DNSOptions DnsOptions { get; set; }
Public Property DnsOptions As DNSOptions
    Get
    Set
public:
property DNSOptions^ DnsOptions {
    DNSOptions^ get ();
    void set (DNSOptions^ value);
}
function get_DnsOptions();
function set_DnsOptions(value);

Property Value

Type: DNSOptions
The DNS options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.FailoverMonitoringEnabled Property

JobOptionsFailoverMonitoringEnabled Property

This value is true if failover monitoring is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> FailoverMonitoringEnabled { get; set; }
Public Property FailoverMonitoringEnabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> FailoverMonitoringEnabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_FailoverMonitoringEnabled();
function set_FailoverMonitoringEnabled(value);

Property Value

Type: Nullable Boolean
True if failover monitoring is enabled. Set to false for DR only jobs
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.FullServerFailoverOptions Property

JobOptionsFullServerFailoverOptions Property

This value represents the options for full server jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerFailoverOptions FullServerFailoverOptions { get; set; }
Public Property FullServerFailoverOptions As FullServerFailoverOptions
    Get
    Set
public:
property FullServerFailoverOptions^ FullServerFailoverOptions {
    FullServerFailoverOptions^ get ();
    void set (FullServerFailoverOptions^ value);
}
function get_FullServerFailoverOptions();
function set_FullServerFailoverOptions(value);

Property Value

Type: FullServerFailoverOptions
The options for full server failover jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.FullServerTestFailoverOptions Property

JobOptionsFullServerTestFailoverOptions Property

This value represents the testfailover options for full server jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerTestFailoverOptions FullServerTestFailoverOptions { get; set; }
Public Property FullServerTestFailoverOptions As FullServerTestFailoverOptions
    Get
    Set
public:
property FullServerTestFailoverOptions^ FullServerTestFailoverOptions {
    FullServerTestFailoverOptions^ get ();
    void set (FullServerTestFailoverOptions^ value);
}
function get_FullServerTestFailoverOptions();
function set_FullServerTestFailoverOptions(value);

Property Value

Type: FullServerTestFailoverOptions
The testfailover options for full server failover jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ImageProtectionOptions Property

JobOptionsImageProtectionOptions Property

This value represents the options for Double-Take DR protection jobs. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionOptions ImageProtectionOptions { get; set; }
Public Property ImageProtectionOptions As ImageProtectionOptions
    Get
    Set
public:
property ImageProtectionOptions^ ImageProtectionOptions {
    ImageProtectionOptions^ get ();
    void set (ImageProtectionOptions^ value);
}
function get_ImageProtectionOptions();
function set_ImageProtectionOptions(value);

Property Value

Type: ImageProtectionOptions
The options for image protection jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ImageRecoveryOptions Property

JobOptionsImageRecoveryOptions Property

This value represents the options for Double-Take DR recovery jobs. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryOptions ImageRecoveryOptions { get; set; }
Public Property ImageRecoveryOptions As ImageRecoveryOptions
    Get
    Set
public:
property ImageRecoveryOptions^ ImageRecoveryOptions {
    ImageRecoveryOptions^ get ();
    void set (ImageRecoveryOptions^ value);
}
function get_ImageRecoveryOptions();
function set_ImageRecoveryOptions(value);

Property Value

Type: ImageRecoveryOptions
The options for image recovery jobs.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.ManagementServiceTargetPort Property

JobOptionsManagementServiceTargetPort Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> ManagementServiceTargetPort { get; set; }
Public Property ManagementServiceTargetPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ManagementServiceTargetPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_ManagementServiceTargetPort();
function set_ManagementServiceTargetPort(value);

Property Value

Type: Nullable Int32
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.MonitoringOptions Property

JobOptionsMonitoringOptions Property

This value represents the options for configuring failover monitoring by using the service monitoring method.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoringOptions MonitoringOptions { get; set; }
Public Property MonitoringOptions As MonitoringOptions
    Get
    Set
public:
property MonitoringOptions^ MonitoringOptions {
    MonitoringOptions^ get ();
    void set (MonitoringOptions^ value);
}
function get_MonitoringOptions();
function set_MonitoringOptions(value);

Property Value

Type: MonitoringOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.Name Property

JobOptionsName Property

This value is the name of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of this job.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.SystemStateOptions Property

JobOptionsSystemStateOptions Property

This value represents the system state options for full server jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateOptions SystemStateOptions { get; set; }
Public Property SystemStateOptions As SystemStateOptions
    Get
    Set
public:
property SystemStateOptions^ SystemStateOptions {
    SystemStateOptions^ get ();
    void set (SystemStateOptions^ value);
}
function get_SystemStateOptions();
function set_SystemStateOptions(value);

Property Value

Type: SystemStateOptions
The system state options.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.TargetServicesOptions Property

JobOptionsTargetServicesOptions Property

This value represents which target services will be stopped and started during failover and failback.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesOptions TargetServicesOptions { get; set; }
Public Property TargetServicesOptions As TargetServicesOptions
    Get
    Set
public:
property TargetServicesOptions^ TargetServicesOptions {
    TargetServicesOptions^ get ();
    void set (TargetServicesOptions^ value);
}
function get_TargetServicesOptions();
function set_TargetServicesOptions(value);

Property Value

Type: TargetServicesOptions
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.UnmanagedConnectionOptions Property

JobOptionsUnmanagedConnectionOptions Property

This value represents the options for unmanaged connections which are connections that are not associated with a known job. These connections were created in a client outside of the job manager.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnmanagedConnectionOptions UnmanagedConnectionOptions { get; set; }
Public Property UnmanagedConnectionOptions As UnmanagedConnectionOptions
    Get
    Set
public:
property UnmanagedConnectionOptions^ UnmanagedConnectionOptions {
    UnmanagedConnectionOptions^ get ();
    void set (UnmanagedConnectionOptions^ value);
}
function get_UnmanagedConnectionOptions();
function set_UnmanagedConnectionOptions(value);

Property Value

Type: UnmanagedConnectionOptions
The options for jobs that use an unmanaged connection.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.VRAOptions Property

JobOptionsVRAOptions Property

This value represents the options for guest-level virtual jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAOptions VRAOptions { get; set; }
Public Property VRAOptions As VRAOptions
    Get
    Set
public:
property VRAOptions^ VRAOptions {
    VRAOptions^ get ();
    void set (VRAOptions^ value);
}
function get_VRAOptions();
function set_VRAOptions(value);

Property Value

Type: VRAOptions
The options for jobs that use Virtual Recovery Assistant.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobOptions.Workload Property

JobOptionsWorkload Property

This value represents the workload being protected by the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Workload Workload { get; set; }
Public Property Workload As Workload
    Get
    Set
public:
property Workload^ Workload {
    Workload^ get ();
    void set (Workload^ value);
}
function get_Workload();
function set_Workload(value);

Property Value

Type: Workload
The workload to be protected by this job.
See Also

Reference

JobOptions Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults Class

Defines a set of values that represent the possible options when creating or editing a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobQualificationResults : IExtensibleDataObject
Public Class JobQualificationResults
    Implements IExtensibleDataObject
public ref class JobQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobQualificationResults',
    null,
    IExtensibleDataObject);

The JobQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | JobQualificationResults |
Top
Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | This value represents configuration information for clustered files and folders jobs.
Public property | CoreQualificationResults | This value represents the replication engine connection configuration.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceBehindNat | This value is true if the source is located behind a NAT router; otherwise, it is false.
Public property | SourceHostUri | This value is the source URI.
Public property | SupportsFrameworkMonitoring | This value is true if the server supports failover monitoring; otherwise, it is false.
Public property | SuppressFailoverMonitorOptions | This value is true if failover monitoring options are suppressed; otherwise, it is false.
Public property | VRAQualificationResults | This value represents configuration information for guest-level virtual jobs.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobQualificationResults Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobQualificationResults()
Public Sub New
public:
JobQualificationResults()
DoubleTake.Jobs.Contract.JobQualificationResults = function();
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults Properties

The JobQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | This value represents configuration information for clustered files and folders jobs.
Public property | CoreQualificationResults | This value represents the replication engine connection configuration.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceBehindNat | This value is true if the source is located behind a NAT router; otherwise, it is false.
Public property | SourceHostUri | This value is the source URI.
Public property | SupportsFrameworkMonitoring | This value is true if the server supports failover monitoring; otherwise, it is false.
Public property | SuppressFailoverMonitorOptions | This value is true if failover monitoring options are suppressed; otherwise, it is false.
Public property | VRAQualificationResults | This value represents configuration information for guest-level virtual jobs.
Top
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.ClusterFilesAndFoldersQualificationResults Property

JobQualificationResultsClusterFilesAndFoldersQualificationResults Property

This value represents configuration information for clustered files and folders jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ClusterFilesAndFoldersQualificationResults ClusterFilesAndFoldersQualificationResults { get; set; }
Public Property ClusterFilesAndFoldersQualificationResults As ClusterFilesAndFoldersQualificationResults
    Get
    Set
public:
property ClusterFilesAndFoldersQualificationResults^ ClusterFilesAndFoldersQualificationResults {
    ClusterFilesAndFoldersQualificationResults^ get ();
    void set (ClusterFilesAndFoldersQualificationResults^ value);
}
function get_ClusterFilesAndFoldersQualificationResults();
function set_ClusterFilesAndFoldersQualificationResults(value);

Property Value

Type: ClusterFilesAndFoldersQualificationResults
The cluster files and folders qualification results.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.CoreQualificationResults Property

JobQualificationResultsCoreQualificationResults Property

This value represents the replication engine connection configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreQualificationResults CoreQualificationResults { get; set; }
Public Property CoreQualificationResults As CoreQualificationResults
    Get
    Set
public:
property CoreQualificationResults^ CoreQualificationResults {
    CoreQualificationResults^ get ();
    void set (CoreQualificationResults^ value);
}
function get_CoreQualificationResults();
function set_CoreQualificationResults(value);

Property Value

Type: CoreQualificationResults
The possible options that apply to engine connection and monitor.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.ExtensionData Property

JobQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SourceBehindNat Property

JobQualificationResultsSourceBehindNat Property

This value is true if the source is located behind a NAT router; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SourceBehindNat { get; set; }
Public Property SourceBehindNat As Boolean
    Get
    Set
public:
property bool SourceBehindNat {
    bool get ();
    void set (bool value);
}
function get_SourceBehindNat();
function set_SourceBehindNat(value);

Property Value

Type: Boolean
if the source is behind a NAT firewall; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SourceHostUri Property

JobQualificationResultsSourceHostUri Property

This value is the source URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_SourceHostUri();
function set_SourceHostUri(value);

Property Value

Type: Uri
The source host URI.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SupportsFrameworkMonitoring Property

JobQualificationResultsSupportsFrameworkMonitoring Property

This value is true if the server supports failover monitoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SupportsFrameworkMonitoring { get; set; }
Public Property SupportsFrameworkMonitoring As Boolean
    Get
    Set
public:
property bool SupportsFrameworkMonitoring {
    bool get ();
    void set (bool value);
}
function get_SupportsFrameworkMonitoring();
function set_SupportsFrameworkMonitoring(value);

Property Value

Type: Boolean
if the machine supports framework monitoring; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.SuppressFailoverMonitorOptions Property

JobQualificationResultsSuppressFailoverMonitorOptions Property

This value is true if failover monitoring options are suppressed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SuppressFailoverMonitorOptions { get; set; }
Public Property SuppressFailoverMonitorOptions As Boolean
    Get
    Set
public:
property bool SuppressFailoverMonitorOptions {
    bool get ();
    void set (bool value);
}
function get_SuppressFailoverMonitorOptions();
function set_SuppressFailoverMonitorOptions(value);

Property Value

Type: Boolean
if failover monitor options are to be suppressed; otherwise, .
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobQualificationResults.VRAQualificationResults Property

JobQualificationResultsVRAQualificationResults Property

This value represents configuration information for guest-level virtual jobs.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAQualificationResults VRAQualificationResults { get; set; }
Public Property VRAQualificationResults As VRAQualificationResults
    Get
    Set
public:
property VRAQualificationResults^ VRAQualificationResults {
    VRAQualificationResults^ get ();
    void set (VRAQualificationResults^ value);
}
function get_VRAQualificationResults();
function set_VRAQualificationResults(value);

Property Value

Type: VRAQualificationResults
The possible options that apply to VRA job.
See Also

Reference

JobQualificationResults Class
DoubleTake.Jobs.Contract Namespace


JobStatistics Class

Represents the current statistics for a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobStatistics

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobStatistics : IExtensibleDataObject
Public Class JobStatistics
    Implements IExtensibleDataObject
public ref class JobStatistics : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobStatistics = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobStatistics',
    null,
    IExtensibleDataObject);

The JobStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatistics |
Top
Properties
 | Name | Description
Public property | CoreConnectionDetails | This value represents the details of the connection.
Public property | CoreMonitorDetails | This value represents the details of failover monitoring.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullServerJobDetails | This value represents the details of a full server job.
Public property | ImageProtectionJobDetails | This value represents the details of a Double-Take DR protection job. This option is no longer needed.
Public property | ImageRecoveryJobDetails | This value represents the details of a Double-Take DR recovery job. This option is no longer needed.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobStatistics Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatistics()
Public Sub New
public:
JobStatistics()
DoubleTake.Jobs.Contract.JobStatistics = function();
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics Properties

The JobStatistics type exposes the following members.

Properties
 | Name | Description
Public property | CoreConnectionDetails | This value represents the details of the connection.
Public property | CoreMonitorDetails | This value represents the details of failover monitoring.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FullServerJobDetails | This value represents the details of a full server job.
Public property | ImageProtectionJobDetails | This value represents the details of a Double-Take DR protection job. This option is no longer needed.
Public property | ImageRecoveryJobDetails | This value represents the details of a Double-Take DR recovery job. This option is no longer needed.
Top
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.CoreConnectionDetails Property

JobStatisticsCoreConnectionDetails Property

This value represents the details of the connection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails CoreConnectionDetails { get; set; }
Public Property CoreConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ CoreConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_CoreConnectionDetails();
function set_CoreConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The core connection details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.CoreMonitorDetails Property

JobStatisticsCoreMonitorDetails Property

This value represents the details of failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreMonitorDetails CoreMonitorDetails { get; set; }
Public Property CoreMonitorDetails As CoreMonitorDetails
    Get
    Set
public:
property CoreMonitorDetails^ CoreMonitorDetails {
    CoreMonitorDetails^ get ();
    void set (CoreMonitorDetails^ value);
}
function get_CoreMonitorDetails();
function set_CoreMonitorDetails(value);

Property Value

Type: CoreMonitorDetails
The core monitor details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ExtensionData Property

JobStatisticsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.FullServerJobDetails Property

JobStatisticsFullServerJobDetails Property

This value represents the details of a full server job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerJobDetails FullServerJobDetails { get; set; }
Public Property FullServerJobDetails As FullServerJobDetails
    Get
    Set
public:
property FullServerJobDetails^ FullServerJobDetails {
    FullServerJobDetails^ get ();
    void set (FullServerJobDetails^ value);
}
function get_FullServerJobDetails();
function set_FullServerJobDetails(value);

Property Value

Type: FullServerJobDetails
The full server job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ImageProtectionJobDetails Property

JobStatisticsImageProtectionJobDetails Property

This value represents the details of a Double-Take DR protection job. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionJobDetails ImageProtectionJobDetails { get; set; }
Public Property ImageProtectionJobDetails As ImageProtectionJobDetails
    Get
    Set
public:
property ImageProtectionJobDetails^ ImageProtectionJobDetails {
    ImageProtectionJobDetails^ get ();
    void set (ImageProtectionJobDetails^ value);
}
function get_ImageProtectionJobDetails();
function set_ImageProtectionJobDetails(value);

Property Value

Type: ImageProtectionJobDetails
The image protection job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatistics.ImageRecoveryJobDetails Property

JobStatisticsImageRecoveryJobDetails Property

This value represents the details of a Double-Take DR recovery job. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryJobDetails ImageRecoveryJobDetails { get; set; }
Public Property ImageRecoveryJobDetails As ImageRecoveryJobDetails
    Get
    Set
public:
property ImageRecoveryJobDetails^ ImageRecoveryJobDetails {
    ImageRecoveryJobDetails^ get ();
    void set (ImageRecoveryJobDetails^ value);
}
function get_ImageRecoveryJobDetails();
function set_ImageRecoveryJobDetails(value);

Property Value

Type: ImageRecoveryJobDetails
The image recovery job details.
See Also

Reference

JobStatistics Class
DoubleTake.Jobs.Contract Namespace


JobStatus Class

Represents the current status of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractJobStatus

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class JobStatus : IExtensibleDataObject
Public Class JobStatus
    Implements IExtensibleDataObject
public ref class JobStatus : IExtensibleDataObject
DoubleTake.Jobs.Contract.JobStatus = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.JobStatus',
    null,
    IExtensibleDataObject);

The JobStatus type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatus |
Top
Properties
 | Name | Description
Public property | Actions | This value represents an action recently reported by a job.
Public property | CanCreateImageRecovery | This value is true if the job can be used to create an image recovery; otherwise, it is false. This option is no longer needed.
Public property | CanDelete | This value is true if you can delete the job; otherwise, it is false.
Public property | CanEdit | This value is true if the job can be edited; otherwise, it is false.
Public property | CanFailback | This value is true if the job can be failed back; otherwise, it is false.
Public property | CanFailover | This value is true if the job can be failed over; otherwise, it is false.
Public property | CanPause | This value is true if the job can be can be paused; otherwise, it is false.
Public property | CanRestore | This value is true if the job can be restored; otherwise, it is false.
Public property | CanReverse | This value is true if the job can be reversed; otherwise, it is false.
Public property | CanStart | This value is true if the job can be started; otherwise, it is false.
Public property | CanStop | This value is true if the job can be stopped; otherwise, it is false.
Public property | CanUndoFailover | This value is true if the failover of the job can be undone; otherwise, it is false.
Public property | EngineControlStatuses | This value represents the status of the replication engine.
Public property | ExtendedLowLevelStates | This value represents additional information about the low level job state.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the high level health of the job.
Public property | HighLevelState | This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.
Public property | IsInError | This value is true if the job is in an error state; otherwise, it is false.
Public property | LowLevelState | This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.
Public property | PermillageComplete | This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.
Public property | TargetState | This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.
Top
Fields
Name | Description
EmptyPermillageComplete | Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


JobStatus Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobStatus()
Public Sub New
public:
JobStatus()
DoubleTake.Jobs.Contract.JobStatus = function();
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus Properties

The JobStatus type exposes the following members.

Properties
 | Name | Description
Public property | Actions | This value represents an action recently reported by a job.
Public property | CanCreateImageRecovery | This value is true if the job can be used to create an image recovery; otherwise, it is false. This option is no longer needed.
Public property | CanDelete | This value is true if you can delete the job; otherwise, it is false.
Public property | CanEdit | This value is true if the job can be edited; otherwise, it is false.
Public property | CanFailback | This value is true if the job can be failed back; otherwise, it is false.
Public property | CanFailover | This value is true if the job can be failed over; otherwise, it is false.
Public property | CanPause | This value is true if the job can be can be paused; otherwise, it is false.
Public property | CanRestore | This value is true if the job can be restored; otherwise, it is false.
Public property | CanReverse | This value is true if the job can be reversed; otherwise, it is false.
Public property | CanStart | This value is true if the job can be started; otherwise, it is false.
Public property | CanStop | This value is true if the job can be stopped; otherwise, it is false.
Public property | CanUndoFailover | This value is true if the failover of the job can be undone; otherwise, it is false.
Public property | EngineControlStatuses | This value represents the status of the replication engine.
Public property | ExtendedLowLevelStates | This value represents additional information about the low level job state.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Health | This value represents the high level health of the job.
Public property | HighLevelState | This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.
Public property | IsInError | This value is true if the job is in an error state; otherwise, it is false.
Public property | LowLevelState | This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.
Public property | PermillageComplete | This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.
Public property | TargetState | This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.
Top
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.Actions Property

JobStatusActions Property

This value represents an action recently reported by a job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobAction[] Actions { get; set; }
Public Property Actions As JobAction()
    Get
    Set
public:
property array<JobAction^>^ Actions {
    array<JobAction^>^ get ();
    void set (array<JobAction^>^ value);
}
function get_Actions();
function set_Actions(value);

Property Value

Type: JobAction
An array of JobAction that represents actions associated with this job.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanCreateImageRecovery Property

JobStatusCanCreateImageRecovery Property

This value is true if the job can be used to create an image recovery; otherwise, it is false. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanCreateImageRecovery { get; set; }
Public Property CanCreateImageRecovery As Boolean
    Get
    Set
public:
property bool CanCreateImageRecovery {
    bool get ();
    void set (bool value);
}
function get_CanCreateImageRecovery();
function set_CanCreateImageRecovery(value);

Property Value

Type: Boolean
if this job can currently be used to create an image recovery; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanDelete Property

JobStatusCanDelete Property

This value is true if you can delete the job; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanDelete { get; set; }
Public Property CanDelete As Boolean
    Get
    Set
public:
property bool CanDelete {
    bool get ();
    void set (bool value);
}
function get_CanDelete();
function set_CanDelete(value);

Property Value

Type: Boolean
if this job can currently be deleted; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanEdit Property

JobStatusCanEdit Property

This value is true if the job can be edited; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanEdit { get; set; }
Public Property CanEdit As Boolean
    Get
    Set
public:
property bool CanEdit {
    bool get ();
    void set (bool value);
}
function get_CanEdit();
function set_CanEdit(value);

Property Value

Type: Boolean
if this job can currently be edited; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanFailback Property

JobStatusCanFailback Property

This value is true if the job can be failed back; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFailback { get; set; }
Public Property CanFailback As Boolean
    Get
    Set
public:
property bool CanFailback {
    bool get ();
    void set (bool value);
}
function get_CanFailback();
function set_CanFailback(value);

Property Value

Type: Boolean
if this job can currently be failed back; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanFailover Property

JobStatusCanFailover Property

This value is true if the job can be failed over; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFailover { get; set; }
Public Property CanFailover As Boolean
    Get
    Set
public:
property bool CanFailover {
    bool get ();
    void set (bool value);
}
function get_CanFailover();
function set_CanFailover(value);

Property Value

Type: Boolean
if this job can currently be failed over; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanPause Property

JobStatusCanPause Property

This value is true if the job can be can be paused; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanPause { get; set; }
Public Property CanPause As Boolean
    Get
    Set
public:
property bool CanPause {
    bool get ();
    void set (bool value);
}
function get_CanPause();
function set_CanPause(value);

Property Value

Type: Boolean
if this job can currently be paused; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanRestore Property

JobStatusCanRestore Property

This value is true if the job can be restored; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanRestore { get; set; }
Public Property CanRestore As Boolean
    Get
    Set
public:
property bool CanRestore {
    bool get ();
    void set (bool value);
}
function get_CanRestore();
function set_CanRestore(value);

Property Value

Type: Boolean
if this job can currently be restored; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanReverse Property

JobStatusCanReverse Property

This value is true if the job can be reversed; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanReverse { get; set; }
Public Property CanReverse As Boolean
    Get
    Set
public:
property bool CanReverse {
    bool get ();
    void set (bool value);
}
function get_CanReverse();
function set_CanReverse(value);

Property Value

Type: Boolean
if this job can currently be reversed; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanStart Property

JobStatusCanStart Property

This value is true if the job can be started; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
function get_CanStart();
function set_CanStart(value);

Property Value

Type: Boolean
if this job can currently be started; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanStop Property

JobStatusCanStop Property

This value is true if the job can be stopped; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
function get_CanStop();
function set_CanStop(value);

Property Value

Type: Boolean
if this job can currently be stopped.; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.CanUndoFailover Property

JobStatusCanUndoFailover Property

This value is true if the failover of the job can be undone; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanUndoFailover { get; set; }
Public Property CanUndoFailover As Boolean
    Get
    Set
public:
property bool CanUndoFailover {
    bool get ();
    void set (bool value);
}
function get_CanUndoFailover();
function set_CanUndoFailover(value);

Property Value

Type: Boolean
if the failover of this job can be currently undone; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.EngineControlStatuses Property

JobStatusEngineControlStatuses Property

This value represents the status of the replication engine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public EngineControlStatus[] EngineControlStatuses { get; set; }
Public Property EngineControlStatuses As EngineControlStatus()
    Get
    Set
public:
property array<EngineControlStatus^>^ EngineControlStatuses {
    array<EngineControlStatus^>^ get ();
    void set (array<EngineControlStatus^>^ value);
}
function get_EngineControlStatuses();
function set_EngineControlStatuses(value);

Property Value

Type: EngineControlStatus
The engine control statuses.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.ExtendedLowLevelStates Property

JobStatusExtendedLowLevelStates Property

This value represents additional information about the low level job state.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState[] ExtendedLowLevelStates { get; set; }
Public Property ExtendedLowLevelStates As ExtendedLowLevelState()
    Get
    Set
public:
property array<ExtendedLowLevelState^>^ ExtendedLowLevelStates {
    array<ExtendedLowLevelState^>^ get ();
    void set (array<ExtendedLowLevelState^>^ value);
}
function get_ExtendedLowLevelStates();
function set_ExtendedLowLevelStates(value);

Property Value

Type: ExtendedLowLevelState
The low level states of this job.
Remarks
Additional information about the low level state.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.ExtensionData Property

JobStatusExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.Health Property

JobStatusHealth Property

This value represents the high level health of the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
function get_Health();
function set_Health(value);

Property Value

Type: Health
The health of this job.
Remarks
Job health is an at-a-glance indication of whether the job is working correctly. Users can be assured that a job whose health is [F:Ok] is working properly, while a job whose health is [F:Warning] should be more closely monitored, and a job whose health is [F:Error] requires immediate attention.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.HighLevelState Property

JobStatusHighLevelState Property

This value represents high level job states. High level states typically map to phases of the job's overall lifecycle, like mirroring or failing over. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of job type.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public HighLevelState HighLevelState { get; set; }
Public Property HighLevelState As HighLevelState
    Get
    Set
public:
property HighLevelState HighLevelState {
    HighLevelState get ();
    void set (HighLevelState value);
}
function get_HighLevelState();
function set_HighLevelState(value);

Property Value

Type: HighLevelState
The high level state of this job.
Remarks
High level states of a job typically map to phases of the job's overall lifecycle. Examples include "mirroring", "replicating", "failing over", etc. Jobs will pass through various high level states during their lifetime, and the types of high level states are usually shared between jobs, regardless of the job's purpose.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.IsInError Property

JobStatusIsInError Property

This value is true if the job is in an error state; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsInError { get; set; }
Public Property IsInError As Boolean
    Get
    Set
public:
property bool IsInError {
    bool get ();
    void set (bool value);
}
function get_IsInError();
function set_IsInError(value);

Property Value

Type: Boolean
if this job is in an error state; otherwise, .
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.LowLevelState Property

JobStatusLowLevelState Property

This value is a low level job state. Low level states typically map to individual steps the job is performing at any given time, like attaching virtual disks or updating DNS. Low level states provide detailed information about a job's current state or action and will vary between different job types.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string LowLevelState { get; set; }
Public Property LowLevelState As String
    Get
    Set
public:
property String^ LowLevelState {
    String^ get ();
    void set (String^ value);
}
function get_LowLevelState();
function set_LowLevelState(value);

Property Value

Type: String
The low level state of this job.
Remarks
Low level states of a job typically map to individual steps the job is performing at any given time. Examples include "attaching virtual disks", "system state processing", "updating DNS", etc. Low level state provides detailed information about what's going on with the job right now, and will widely vary between jobs with different purpose.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.PermillageComplete Property

JobStatusPermillageComplete Property

This value is the percentage of the current activity for that job that is complete. To display a percentage string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the client. To remove the display of the percentage, set this property to zero.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int PermillageComplete { get; set; }
Public Property PermillageComplete As Integer
    Get
    Set
public:
property int PermillageComplete {
    int get ();
    void set (int value);
}
function get_PermillageComplete();
function set_PermillageComplete(value);

Property Value

Type: Int32
The permillage complete of the current activity of this job.
Remarks
To display a "percent complete" string for an arbitrary activity, jobs can provide a value for this property, and that value will be formatted and displayed in the console. To remove the display of the percentage, set this property to zero.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.TargetState Property

JobStatusTargetState Property

This value is derived from TargetStates. Information from the connection is distilled into a string key which is sent to the client for display.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetState { get; set; }
Public Property TargetState As String
    Get
    Set
public:
property String^ TargetState {
    String^ get ();
    void set (String^ value);
}
function get_TargetState();
function set_TargetState(value);

Property Value

Type: String
The state of the data on the target server.
Remarks
Target state is derived from a number TargetStates values. Information from the connection is distilled into a string key which is sent to the client for display.
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus Fields

The JobStatus type exposes the following members.

Fields
Name | Description
EmptyPermillageComplete | Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.
Top
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


JobStatus.EmptyPermillageComplete Field

JobStatusEmptyPermillageComplete Field

Defines the value for [P:PermillageComplete] that will prevent the percentage from being displayed in the UI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public const int EmptyPermillageComplete = 0
Public Const EmptyPermillageComplete As Integer = 0
public:
literal int EmptyPermillageComplete = 0
var DoubleTake.Jobs.Contract.JobStatus.EmptyPermillageComplete

Field Value

Type: Int32
See Also

Reference

JobStatus Class
DoubleTake.Jobs.Contract Namespace


MachineInfoClass Class

Data about the target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractMachineInfoClass

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class MachineInfoClass
Public Class MachineInfoClass
public ref class MachineInfoClass
DoubleTake.Jobs.Contract.MachineInfoClass = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.MachineInfoClass');

The MachineInfoClass type exposes the following members.

Constructors
 | Name | Description
Public method | MachineInfoClass |
Top
Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


MachineInfoClass Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MachineInfoClass()
Public Sub New
public:
MachineInfoClass()
DoubleTake.Jobs.Contract.MachineInfoClass = function();
See Also

Reference

MachineInfoClass Class
DoubleTake.Jobs.Contract Namespace


MachineInfoClass Properties

The MachineInfoClass type exposes the following members.

Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
See Also

Reference

MachineInfoClass Class
DoubleTake.Jobs.Contract Namespace


MachineInfoClass.os Property

MachineInfoClassos Property

OS on the machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string os { get; set; }
Public Property os As String
    Get
    Set
public:
property String^ os {
    String^ get ();
    void set (String^ value);
}
function get_os();
function set_os(value);

Property Value

Type: String
See Also

Reference

MachineInfoClass Class
DoubleTake.Jobs.Contract Namespace


MachineInfoClass.osVersion Property

MachineInfoClassosVersion Property

OS version on the machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string osVersion { get; set; }
Public Property osVersion As String
    Get
    Set
public:
property String^ osVersion {
    String^ get ();
    void set (String^ value);
}
function get_osVersion();
function set_osVersion(value);

Property Value

Type: String
See Also

Reference

MachineInfoClass Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions Class

Represents the options for monitoring services.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractMonitoringOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class MonitoringOptions : IExtensibleDataObject
Public Class MonitoringOptions
    Implements IExtensibleDataObject
public ref class MonitoringOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.MonitoringOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.MonitoringOptions',
    null,
    IExtensibleDataObject);

The MonitoringOptions type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoringOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ServiceMonitoringEnabled | This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.
Public property | ServiceMonitoringOptions | This value represents the options used for the service monitoring method for failover monitoring.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


MonitoringOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public MonitoringOptions()
Public Sub New
public:
MonitoringOptions()
DoubleTake.Jobs.Contract.MonitoringOptions = function();
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions Properties

The MonitoringOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ServiceMonitoringEnabled | This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.
Public property | ServiceMonitoringOptions | This value represents the options used for the service monitoring method for failover monitoring.
Top
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ExtensionData Property

MonitoringOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ServiceMonitoringEnabled Property

MonitoringOptionsServiceMonitoringEnabled Property

This value is true if the service monitoring method for failover monitoring is enabled; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ServiceMonitoringEnabled { get; set; }
Public Property ServiceMonitoringEnabled As Boolean
    Get
    Set
public:
property bool ServiceMonitoringEnabled {
    bool get ();
    void set (bool value);
}
function get_ServiceMonitoringEnabled();
function set_ServiceMonitoringEnabled(value);

Property Value

Type: Boolean
if service monitoring is enabled; otherwise, .
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


MonitoringOptions.ServiceMonitoringOptions Property

MonitoringOptionsServiceMonitoringOptions Property

This value represents the options used for the service monitoring method for failover monitoring.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceMonitoringOptions ServiceMonitoringOptions { get; set; }
Public Property ServiceMonitoringOptions As ServiceMonitoringOptions
    Get
    Set
public:
property ServiceMonitoringOptions^ ServiceMonitoringOptions {
    ServiceMonitoringOptions^ get ();
    void set (ServiceMonitoringOptions^ value);
}
function get_ServiceMonitoringOptions();
function set_ServiceMonitoringOptions(value);

Property Value

Type: ServiceMonitoringOptions
The service monitoring options.
See Also

Reference

MonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Class

Includes the recommended options for failing back a job and additional information that can be used to customize failback options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedFailbackOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedFailbackOptions : IExtensibleDataObject
Public Class RecommendedFailbackOptions
    Implements IExtensibleDataObject
public ref class RecommendedFailbackOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedFailbackOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedFailbackOptions',
    null,
    IExtensibleDataObject);

The RecommendedFailbackOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailbackOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailbackOptions | This value represents the failback configuration.
Public property | IsSourceNew | This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.
Public property | RestoreStatus | This value represents the status of the restoration process.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedFailbackOptions()
Public Sub New
public:
RecommendedFailbackOptions()
DoubleTake.Jobs.Contract.RecommendedFailbackOptions = function();
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions Properties

The RecommendedFailbackOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailbackOptions | This value represents the failback configuration.
Public property | IsSourceNew | This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.
Public property | RestoreStatus | This value represents the status of the restoration process.
Top
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.ExtensionData Property

RecommendedFailbackOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.FailbackOptions Property

RecommendedFailbackOptionsFailbackOptions Property

This value represents the failback configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailbackOptions FailbackOptions { get; set; }
Public Property FailbackOptions As FailbackOptions
    Get
    Set
public:
property FailbackOptions^ FailbackOptions {
    FailbackOptions^ get ();
    void set (FailbackOptions^ value);
}
function get_FailbackOptions();
function set_FailbackOptions(value);

Property Value

Type: FailbackOptions
The failback options.
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.IsSourceNew Property

RecommendedFailbackOptionsIsSourceNew Property

This value is true if the data from the target was or is being restored to a new source server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSourceNew { get; set; }
Public Property IsSourceNew As Boolean
    Get
    Set
public:
property bool IsSourceNew {
    bool get ();
    void set (bool value);
}
function get_IsSourceNew();
function set_IsSourceNew(value);

Property Value

Type: Boolean
if the data was restored, or is being restored, to a new source; otherwise, .
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailbackOptions.RestoreStatus Property

RecommendedFailbackOptionsRestoreStatus Property

This value represents the status of the restoration process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreStatus RestoreStatus { get; set; }
Public Property RestoreStatus As RestoreStatus
    Get
    Set
public:
property RestoreStatus RestoreStatus {
    RestoreStatus get ();
    void set (RestoreStatus value);
}
function get_RestoreStatus();
function set_RestoreStatus(value);

Property Value

Type: RestoreStatus
The status of the restore operation.
See Also

Reference

RecommendedFailbackOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Class

Includes the recommended options for failing over a job and additional information that can be used to customize failover options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedFailoverOptions : IExtensibleDataObject
Public Class RecommendedFailoverOptions
    Implements IExtensibleDataObject
public ref class RecommendedFailoverOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedFailoverOptions',
    null,
    IExtensibleDataObject);

The RecommendedFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailoverOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverOptions | This value represents the failover configuration.
Public property | IsTestFailoverSupported | This value is true if test failover is supported for the job type; otherwise, it is false.
Public property | Snapshots | This value represents the available snapshots on the target.
Public property | WarningTextTestFailover | This value is true if optional warning text to display if test failover is selected; otherwise, it is false.
Public property | WarnUserOfInconsistentProtectionData | This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedFailoverOptions()
Public Sub New
public:
RecommendedFailoverOptions()
DoubleTake.Jobs.Contract.RecommendedFailoverOptions = function();
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions Properties

The RecommendedFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverOptions | This value represents the failover configuration.
Public property | IsTestFailoverSupported | This value is true if test failover is supported for the job type; otherwise, it is false.
Public property | Snapshots | This value represents the available snapshots on the target.
Public property | WarningTextTestFailover | This value is true if optional warning text to display if test failover is selected; otherwise, it is false.
Public property | WarnUserOfInconsistentProtectionData | This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.
Top
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.ExtensionData Property

RecommendedFailoverOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.FailoverOptions Property

RecommendedFailoverOptionsFailoverOptions Property

This value represents the failover configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FailoverOptions FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptions
    Get
    Set
public:
property FailoverOptions^ FailoverOptions {
    FailoverOptions^ get ();
    void set (FailoverOptions^ value);
}
function get_FailoverOptions();
function set_FailoverOptions(value);

Property Value

Type: FailoverOptions
The recommended failover options.
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.IsTestFailoverSupported Property

RecommendedFailoverOptionsIsTestFailoverSupported Property

This value is true if test failover is supported for the job type; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsTestFailoverSupported { get; set; }
Public Property IsTestFailoverSupported As Boolean
    Get
    Set
public:
property bool IsTestFailoverSupported {
    bool get ();
    void set (bool value);
}
function get_IsTestFailoverSupported();
function set_IsTestFailoverSupported(value);

Property Value

Type: Boolean
if this test failover is supported; otherwise, .
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.Snapshots Property

RecommendedFailoverOptionsSnapshots Property

This value represents the available snapshots on the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntry()
    Get
    Set
public:
property array<SnapshotEntry^>^ Snapshots {
    array<SnapshotEntry^>^ get ();
    void set (array<SnapshotEntry^>^ value);
}
function get_Snapshots();
function set_Snapshots(value);

Property Value

Type: SnapshotEntry
An array of SnapshotEntry that represents the snapshots on the target server.
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.WarningTextTestFailover Property

RecommendedFailoverOptionsWarningTextTestFailover Property

This value is true if optional warning text to display if test failover is selected; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarningTextTestFailover { get; set; }
Public Property WarningTextTestFailover As Boolean
    Get
    Set
public:
property bool WarningTextTestFailover {
    bool get ();
    void set (bool value);
}
function get_WarningTextTestFailover();
function set_WarningTextTestFailover(value);

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedFailoverOptions.WarnUserOfInconsistentProtectionData Property

RecommendedFailoverOptionsWarnUserOfInconsistentProtectionData Property

This value is true if the data on the target may be in an inconsistent state; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool WarnUserOfInconsistentProtectionData { get; set; }
Public Property WarnUserOfInconsistentProtectionData As Boolean
    Get
    Set
public:
property bool WarnUserOfInconsistentProtectionData {
    bool get ();
    void set (bool value);
}
function get_WarnUserOfInconsistentProtectionData();
function set_WarnUserOfInconsistentProtectionData(value);

Property Value

Type: Boolean
if the data on the target server may be in an inconsistent state; otherwise, .
See Also

Reference

RecommendedFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Class

Represents the recommended options for a job and potential values for those options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedJobOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedJobOptions : IExtensibleDataObject
Public Class RecommendedJobOptions
    Implements IExtensibleDataObject
public ref class RecommendedJobOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedJobOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedJobOptions',
    null,
    IExtensibleDataObject);

The RecommendedJobOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the current options for the job.
Public property | JobQualificationResults | This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedJobOptions()
Public Sub New
public:
RecommendedJobOptions()
DoubleTake.Jobs.Contract.RecommendedJobOptions = function();
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions Properties

The RecommendedJobOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | JobOptions | This value represents the current options for the job.
Public property | JobQualificationResults | This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.
Top
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.ExtensionData Property

RecommendedJobOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.JobOptions Property

RecommendedJobOptionsJobOptions Property

This value represents the current options for the job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobOptions JobOptions { get; set; }
Public Property JobOptions As JobOptions
    Get
    Set
public:
property JobOptions^ JobOptions {
    JobOptions^ get ();
    void set (JobOptions^ value);
}
function get_JobOptions();
function set_JobOptions(value);

Property Value

Type: JobOptions
The recommended job options.
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedJobOptions.JobQualificationResults Property

RecommendedJobOptionsJobQualificationResults Property

This value represents the job qualification results which are other possible job options, in addition to those that are strictly recommended. For example, JobOptions.CoreConnectionOptions. TargetAddress may be the recommended address, but JobQualificationResults.CoreQualificationResults.TargetIPAddresses may include other IP addresses on the server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public JobQualificationResults JobQualificationResults { get; set; }
Public Property JobQualificationResults As JobQualificationResults
    Get
    Set
public:
property JobQualificationResults^ JobQualificationResults {
    JobQualificationResults^ get ();
    void set (JobQualificationResults^ value);
}
function get_JobQualificationResults();
function set_JobQualificationResults(value);

Property Value

Type: JobQualificationResults
The job qualification results.
Remarks
The job qualification results are used to communicate other possible option for a job, outside of the options that are strictly recommended. For example, the [P:JobOptions] property may recommend a specific IP address as the target route, but the [P:JobQualificationResults] property may include the other IP addresses on the server.
See Also

Reference

RecommendedJobOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Class

Includes the recommended options for restoring job and additional information that can be used to customize restore options.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRecommendedRestoreOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RecommendedRestoreOptions : IExtensibleDataObject
Public Class RecommendedRestoreOptions
    Implements IExtensibleDataObject
public ref class RecommendedRestoreOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RecommendedRestoreOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RecommendedRestoreOptions',
    null,
    IExtensibleDataObject);

The RecommendedRestoreOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedRestoreOptions |
Top
Properties
 | Name | Description
Public property | CanClearRestoreRequired | This value is true if the restore required flag can be cleared; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNat | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | PossibleSourceAddresses | This value is the possible source IP addresses.
Public property | RestoreOptions | This value represents the restoration options.
Public property | SameSourceOnly | This value is true if the job can only be restored to the same source server; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RecommendedRestoreOptions()
Public Sub New
public:
RecommendedRestoreOptions()
DoubleTake.Jobs.Contract.RecommendedRestoreOptions = function();
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions Properties

The RecommendedRestoreOptions type exposes the following members.

Properties
 | Name | Description
Public property | CanClearRestoreRequired | This value is true if the restore required flag can be cleared; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsNat | This value is true if the IP address is a public NAT address; otherwise, it is false.
Public property | PossibleSourceAddresses | This value is the possible source IP addresses.
Public property | RestoreOptions | This value represents the restoration options.
Public property | SameSourceOnly | This value is true if the job can only be restored to the same source server; otherwise, it is false.
Top
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.CanClearRestoreRequired Property

RecommendedRestoreOptionsCanClearRestoreRequired Property

This value is true if the restore required flag can be cleared; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanClearRestoreRequired { get; set; }
Public Property CanClearRestoreRequired As Boolean
    Get
    Set
public:
property bool CanClearRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_CanClearRestoreRequired();
function set_CanClearRestoreRequired(value);

Property Value

Type: Boolean
if restore required can be cleared; otherwise, .
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.ExtensionData Property

RecommendedRestoreOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.IsNat Property

RecommendedRestoreOptionsIsNat Property

This value is true if the IP address is a public NAT address; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
function get_IsNat();
function set_IsNat(value);

Property Value

Type: Boolean
Boolean value indicating if IP address is a public NAT.
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.PossibleSourceAddresses Property

RecommendedRestoreOptionsPossibleSourceAddresses Property

This value is the possible source IP addresses.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PossibleSourceAddresses { get; set; }
Public Property PossibleSourceAddresses As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PossibleSourceAddresses();
function set_PossibleSourceAddresses(value);

Property Value

Type: String
The possible source addresses.
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.RestoreOptions Property

RecommendedRestoreOptionsRestoreOptions Property

This value represents the restoration options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptions
    Get
    Set
public:
property RestoreOptions^ RestoreOptions {
    RestoreOptions^ get ();
    void set (RestoreOptions^ value);
}
function get_RestoreOptions();
function set_RestoreOptions(value);

Property Value

Type: RestoreOptions
The restore options.
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RecommendedRestoreOptions.SameSourceOnly Property

RecommendedRestoreOptionsSameSourceOnly Property

This value is true if the job can only be restored to the same source server; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool SameSourceOnly { get; set; }
Public Property SameSourceOnly As Boolean
    Get
    Set
public:
property bool SameSourceOnly {
    bool get ();
    void set (bool value);
}
function get_SameSourceOnly();
function set_SameSourceOnly(value);

Property Value

Type: Boolean
if the job only allows restoring to the same source; otherwise, .
See Also

Reference

RecommendedRestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions Class

Represents the options used when restoring a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractRestoreOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class RestoreOptions : IExtensibleDataObject
Public Class RestoreOptions
    Implements IExtensibleDataObject
public ref class RestoreOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.RestoreOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.RestoreOptions',
    null,
    IExtensibleDataObject);

The RestoreOptions type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreOptions |
Top
Properties
 | Name | Description
Public property | ClearRestoreRequired | This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RestoreParameters | This value represents the restoration configuration.
Public property | RestoreTargetHostUri | This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


RestoreOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreOptions()
Public Sub New
public:
RestoreOptions()
DoubleTake.Jobs.Contract.RestoreOptions = function();
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions Properties

The RestoreOptions type exposes the following members.

Properties
 | Name | Description
Public property | ClearRestoreRequired | This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.
Public property | EnginePort | This value is the port where the engine is listening.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RestoreParameters | This value represents the restoration configuration.
Public property | RestoreTargetHostUri | This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)
Top
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.ClearRestoreRequired Property

RestoreOptionsClearRestoreRequired Property

This value is true if the restore required flag can be cleared without restoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ClearRestoreRequired { get; set; }
Public Property ClearRestoreRequired As Boolean
    Get
    Set
public:
property bool ClearRestoreRequired {
    bool get ();
    void set (bool value);
}
function get_ClearRestoreRequired();
function set_ClearRestoreRequired(value);

Property Value

Type: Boolean
to simply clear the "Restore required" state without restoring; otherwise, .
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.EnginePort Property

RestoreOptionsEnginePort Property

This value is the port where the engine is listening.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_EnginePort();
function set_EnginePort(value);

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.ExtensionData Property

RestoreOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.RestoreParameters Property

RestoreOptionsRestoreParameters Property

This value represents the restoration configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public RestoreParameters RestoreParameters { get; set; }
Public Property RestoreParameters As RestoreParameters
    Get
    Set
public:
property RestoreParameters^ RestoreParameters {
    RestoreParameters^ get ();
    void set (RestoreParameters^ value);
}
function get_RestoreParameters();
function set_RestoreParameters(value);

Property Value

Type: RestoreParameters
The parameters for the restore operation.
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreOptions.RestoreTargetHostUri Property

RestoreOptionsRestoreTargetHostUri Property

This value is the target URI. (The target is the target of the restoration connection, not the original protection connection.)

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_RestoreTargetHostUri();
function set_RestoreTargetHostUri(value);

Property Value

Type: Uri
The restore target host URI.
See Also

Reference

RestoreOptions Class
DoubleTake.Jobs.Contract Namespace


RestoreStatus Enumeration

Indicates the status of a restore operation.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum RestoreStatus
Public Enumeration RestoreStatus
public enum class RestoreStatus
DoubleTake.Jobs.Contract.RestoreStatus = function();
DoubleTake.Jobs.Contract.RestoreStatus.createEnum('DoubleTake.Jobs.Contract.RestoreStatus', false);
Members
Member name | Value | Description
NotStarted | 0 | The restoration has not started.
Restoring | 1 | The restoration process is in progress.
Restored | 2 | The restoration process is complete. It is now safe to perform failback.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ReverseOptions Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractReverseOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ReverseOptions
Public Class ReverseOptions
public ref class ReverseOptions
DoubleTake.Jobs.Contract.ReverseOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ReverseOptions');

The ReverseOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ReverseOptions |
Top
Properties
 | Name | Description
Public property | ReverseVMwareServer |
Public property | VmName |
Public property | VmPath |
Public property | Volumes |
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ReverseOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReverseOptions()
Public Sub New
public:
ReverseOptions()
DoubleTake.Jobs.Contract.ReverseOptions = function();
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions Properties

The ReverseOptions type exposes the following members.

Properties
 | Name | Description
Public property | ReverseVMwareServer |
Public property | VmName |
Public property | VmPath |
Public property | Volumes |
Top
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.ReverseVMwareServer Property

ReverseOptionsReverseVMwareServer Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri ReverseVMwareServer { get; set; }
Public Property ReverseVMwareServer As Uri
    Get
    Set
public:
property Uri^ ReverseVMwareServer {
    Uri^ get ();
    void set (Uri^ value);
}
function get_ReverseVMwareServer();
function set_ReverseVMwareServer(value);

Property Value

Type: Uri
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.VmName Property

ReverseOptionsVmName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VmName { get; set; }
Public Property VmName As String
    Get
    Set
public:
property String^ VmName {
    String^ get ();
    void set (String^ value);
}
function get_VmName();
function set_VmName(value);

Property Value

Type: String
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.VmPath Property

ReverseOptionsVmPath Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VmPath { get; set; }
Public Property VmPath As String
    Get
    Set
public:
property String^ VmPath {
    String^ get ();
    void set (String^ value);
}
function get_VmPath();
function set_VmPath(value);

Property Value

Type: String
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.Volumes Property

ReverseOptionsVolumes Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions[] Volumes { get; set; }
Public Property Volumes As VolumeOptions()
    Get
    Set
public:
property array<VolumeOptions^>^ Volumes {
    array<VolumeOptions^>^ get ();
    void set (array<VolumeOptions^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeOptions
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions Methods

The ReverseOptions type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.GetDeserializedObject Method

ReverseOptionsGetDeserializedObject Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ReverseOptions.GetObjectToSerialize Method

ReverseOptionsGetObjectToSerialize Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

ReverseOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation Class

Contains information about a service.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractServiceInformation

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceInformation
Public Class ServiceInformation
public ref class ServiceInformation
DoubleTake.Jobs.Contract.ServiceInformation = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ServiceInformation');

The ServiceInformation type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInformation |
Top
Fields
 | Name | Description
Public field | DisplayName | This value is the service display name.
Public field | Name | This value is the service name.
Public field | Selected | This value is true if the service is selected for service monitoring; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ServiceInformation Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation()
Public Sub New
public:
ServiceInformation()
DoubleTake.Jobs.Contract.ServiceInformation = function();
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation Fields

The ServiceInformation type exposes the following members.

Fields
 | Name | Description
Public field | DisplayName | This value is the service display name.
Public field | Name | This value is the service name.
Public field | Selected | This value is true if the service is selected for service monitoring; otherwise, it is false.
Top
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.DisplayName Field

ServiceInformationDisplayName Field

This value is the service display name.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName
Public DisplayName As String
public:
String^ DisplayName
var DisplayName

Field Value

Type: String
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.Name Field

ServiceInformationName Field

This value is the service name.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name
Public Name As String
public:
String^ Name
var Name

Field Value

Type: String
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceInformation.Selected Field

ServiceInformationSelected Field

This value is true if the service is selected for service monitoring; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Selected
Public Selected As Boolean
public:
bool Selected
var Selected

Field Value

Type: Boolean
See Also

Reference

ServiceInformation Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Class

A data contract representing the options for monitoring services on a source.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractServiceMonitoringOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ServiceMonitoringOptions : IExtensibleDataObject
Public Class ServiceMonitoringOptions
    Implements IExtensibleDataObject
public ref class ServiceMonitoringOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.ServiceMonitoringOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ServiceMonitoringOptions',
    null,
    IExtensibleDataObject);

The ServiceMonitoringOptions type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMonitoringOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RepeatCount | This value is the number of times to repeat the call to retrieve the service status.
Public property | Services | This value represents the services that should be monitored.
Public property | StartService | This value is true if the monitored service should be started if it is stopped; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceMonitoringOptions()
Public Sub New
public:
ServiceMonitoringOptions()
DoubleTake.Jobs.Contract.ServiceMonitoringOptions = function();
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions Properties

The ServiceMonitoringOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RepeatCount | This value is the number of times to repeat the call to retrieve the service status.
Public property | Services | This value represents the services that should be monitored.
Public property | StartService | This value is true if the monitored service should be started if it is stopped; otherwise, it is false.
Top
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.ExtensionData Property

ServiceMonitoringOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.RepeatCount Property

ServiceMonitoringOptionsRepeatCount Property

This value is the number of times to repeat the call to retrieve the service status.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int RepeatCount { get; set; }
Public Property RepeatCount As Integer
    Get
    Set
public:
property int RepeatCount {
    int get ();
    void set (int value);
}
function get_RepeatCount();
function set_RepeatCount(value);

Property Value

Type: Int32
The number of times to repeat the call to retrieve the service status.
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.Services Property

ServiceMonitoringOptionsServices Property

This value represents the services that should be monitored.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] Services { get; set; }
Public Property Services As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ Services {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_Services();
function set_Services(value);

Property Value

Type: ServiceInformation
The services to be monitored.
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


ServiceMonitoringOptions.StartService Property

ServiceMonitoringOptionsStartService Property

This value is true if the monitored service should be started if it is stopped; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool StartService { get; set; }
Public Property StartService As Boolean
    Get
    Set
public:
property bool StartService {
    bool get ();
    void set (bool value);
}
function get_StartService();
function set_StartService(value);

Property Value

Type: Boolean
if the monitored service is to be started when stopped; otherwise, .
See Also

Reference

ServiceMonitoringOptions Class
DoubleTake.Jobs.Contract Namespace


SnapshotDetails Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSnapshotDetails

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class SnapshotDetails
Public Class SnapshotDetails
public ref class SnapshotDetails
DoubleTake.Jobs.Contract.SnapshotDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SnapshotDetails');

The SnapshotDetails type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotDetails |
Top
Fields
 | Name | Description
Public field | Snapshot |
Public field | Volume |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SnapshotDetails Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotDetails()
Public Sub New
public:
SnapshotDetails()
DoubleTake.Jobs.Contract.SnapshotDetails = function();
See Also

Reference

SnapshotDetails Class
DoubleTake.Jobs.Contract Namespace


SnapshotDetails Fields

The SnapshotDetails type exposes the following members.

Fields
 | Name | Description
Public field | Snapshot |
Public field | Volume |
Top
See Also

Reference

SnapshotDetails Class
DoubleTake.Jobs.Contract Namespace


SnapshotDetails.Snapshot Field

SnapshotDetailsSnapshot Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Snapshot
Public Snapshot As Guid
public:
Guid Snapshot
var Snapshot

Field Value

Type: Guid
See Also

Reference

SnapshotDetails Class
DoubleTake.Jobs.Contract Namespace


SnapshotDetails.Volume Field

SnapshotDetailsVolume Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Volume
Public Volume As String
public:
String^ Volume
var Volume

Field Value

Type: String
See Also

Reference

SnapshotDetails Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSnapshotSetInfo

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class SnapshotSetInfo
Public Class SnapshotSetInfo
public ref class SnapshotSetInfo
DoubleTake.Jobs.Contract.SnapshotSetInfo = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SnapshotSetInfo');

The SnapshotSetInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotSetInfo |
Top
Methods
 | Name | Description
Public method | ToSnapshotEntry |
Top
Fields
 | Name | Description
Public field | Id |
Public field | Snapshots |
Public field | Timestamp |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSetInfo()
Public Sub New
public:
SnapshotSetInfo()
DoubleTake.Jobs.Contract.SnapshotSetInfo = function();
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo Methods

The SnapshotSetInfo type exposes the following members.

Methods
 | Name | Description
Public method | ToSnapshotEntry |
Top
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo.ToSnapshotEntry Method

SnapshotSetInfoToSnapshotEntry Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotEntry ToSnapshotEntry()
Public Function ToSnapshotEntry As SnapshotEntry
public:
SnapshotEntry^ ToSnapshotEntry()
function ToSnapshotEntry();

Return Value

Type: SnapshotEntry
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo Fields

The SnapshotSetInfo type exposes the following members.

Fields
 | Name | Description
Public field | Id |
Public field | Snapshots |
Public field | Timestamp |
Top
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo.Id Field

SnapshotSetInfoId Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id
Public Id As Guid
public:
Guid Id
var Id

Field Value

Type: Guid
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo.Snapshots Field

SnapshotSetInfoSnapshots Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<SnapshotDetails> Snapshots
Public Snapshots As IEnumerable(Of SnapshotDetails)
public:
IEnumerable<SnapshotDetails^>^ Snapshots
var Snapshots

Field Value

Type: IEnumerable SnapshotDetails
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SnapshotSetInfo.Timestamp Field

SnapshotSetInfoTimestamp Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime Timestamp
Public Timestamp As DateTime
public:
DateTime Timestamp
var Timestamp

Field Value

Type: DateTime
See Also

Reference

SnapshotSetInfo Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions Class

Represents options for using the system state feature of a job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractSystemStateOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class SystemStateOptions : IExtensibleDataObject
Public Class SystemStateOptions
    Implements IExtensibleDataObject
public ref class SystemStateOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.SystemStateOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.SystemStateOptions',
    null,
    IExtensibleDataObject);

The SystemStateOptions type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateOptions |
Top
Properties
 | Name | Description
Public property | AlternateVolumeMapping | This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.
Public property | AlternateVolumeStaging | This value is true if volumes will be staged to an alternate volume; otherwise it is false.
Public property | ApplyPorts | This value indicates if the source engine and management service ports should be copied to the target.
Public property | ClearMonitor | This value is true if the failover monitor should be removed at cutover; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | This value is true if the job uses WAN failover; otherwise, it is false.
Public property | KeepTargetActivationCode | This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).
Public property | NicMappings | This value represents the NIC mappings for a full server job.
Public property | ServerNameOverride |
Public property | ServicesToStopOptions | This value represents the services on the target to stop during protection.
Public property | ShouldApplyDiskSignatures | This value is true if disk signatures should be applied at cutover; otherwise, it is false.
Public property | SourceReservedAddress | This value is the reserved IP address on the source server.
Public property | StagingFolder | This value is the folder on the target where operating system files from the source will be staged.
Public property | TargetReservedAddress | This value is the reserved IP address on the target server.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


SystemStateOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SystemStateOptions()
Public Sub New
public:
SystemStateOptions()
DoubleTake.Jobs.Contract.SystemStateOptions = function();
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions Properties

The SystemStateOptions type exposes the following members.

Properties
 | Name | Description
Public property | AlternateVolumeMapping | This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.
Public property | AlternateVolumeStaging | This value is true if volumes will be staged to an alternate volume; otherwise it is false.
Public property | ApplyPorts | This value indicates if the source engine and management service ports should be copied to the target.
Public property | ClearMonitor | This value is true if the failover monitor should be removed at cutover; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsWanFailover | This value is true if the job uses WAN failover; otherwise, it is false.
Public property | KeepTargetActivationCode | This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).
Public property | NicMappings | This value represents the NIC mappings for a full server job.
Public property | ServerNameOverride |
Public property | ServicesToStopOptions | This value represents the services on the target to stop during protection.
Public property | ShouldApplyDiskSignatures | This value is true if disk signatures should be applied at cutover; otherwise, it is false.
Public property | SourceReservedAddress | This value is the reserved IP address on the source server.
Public property | StagingFolder | This value is the folder on the target where operating system files from the source will be staged.
Public property | TargetReservedAddress | This value is the reserved IP address on the target server.
Top
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.AlternateVolumeMapping Property

SystemStateOptionsAlternateVolumeMapping Property

This value is the mapping of source volumes to target volumes for alternate volume staging, for example, C:;N:.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string AlternateVolumeMapping { get; set; }
Public Property AlternateVolumeMapping As String
    Get
    Set
public:
property String^ AlternateVolumeMapping {
    String^ get ();
    void set (String^ value);
}
function get_AlternateVolumeMapping();
function set_AlternateVolumeMapping(value);

Property Value

Type: String
The source to target alternate staging volume map. ie. "C:;N:"
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.AlternateVolumeStaging Property

SystemStateOptionsAlternateVolumeStaging Property

This value is true if volumes will be staged to an alternate volume; otherwise it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool AlternateVolumeStaging { get; set; }
Public Property AlternateVolumeStaging As Boolean
    Get
    Set
public:
property bool AlternateVolumeStaging {
    bool get ();
    void set (bool value);
}
function get_AlternateVolumeStaging();
function set_AlternateVolumeStaging(value);

Property Value

Type: Boolean
if the system volume staging will be done on an alternate volume; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ApplyPorts Property

SystemStateOptionsApplyPorts Property

This value indicates if the source engine and management service ports should be copied to the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<bool> ApplyPorts { get; set; }
Public Property ApplyPorts As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ApplyPorts {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
function get_ApplyPorts();
function set_ApplyPorts(value);

Property Value

Type: Nullable Boolean
if the ports should be copied at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ClearMonitor Property

SystemStateOptionsClearMonitor Property

This value is true if the failover monitor should be removed at cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ClearMonitor { get; set; }
Public Property ClearMonitor As Boolean
    Get
    Set
public:
property bool ClearMonitor {
    bool get ();
    void set (bool value);
}
function get_ClearMonitor();
function set_ClearMonitor(value);

Property Value

Type: Boolean
if the failover monitor should be removed at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ExtensionData Property

SystemStateOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.IsWanFailover Property

SystemStateOptionsIsWanFailover Property

This value is true if the job uses WAN failover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
function get_IsWanFailover();
function set_IsWanFailover(value);

Property Value

Type: Boolean
if this job uses WAN failover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.KeepTargetActivationCode Property

SystemStateOptionsKeepTargetActivationCode Property

This value is true if the target license key should be kept after failover; otherwise, it is false (and the source's license key will be applied to the target after failover).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool KeepTargetActivationCode { get; set; }
Public Property KeepTargetActivationCode As Boolean
    Get
    Set
public:
property bool KeepTargetActivationCode {
    bool get ();
    void set (bool value);
}
function get_KeepTargetActivationCode();
function set_KeepTargetActivationCode(value);

Property Value

Type: Boolean
if the target activation code should be kept after failover. Otherwise the source's code will be applied
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.NicMappings Property

SystemStateOptionsNicMappings Property

This value represents the NIC mappings for a full server job.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerNicMappings[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappings()
    Get
    Set
public:
property array<FullServerNicMappings^>^ NicMappings {
    array<FullServerNicMappings^>^ get ();
    void set (array<FullServerNicMappings^>^ value);
}
function get_NicMappings();
function set_NicMappings(value);

Property Value

Type: FullServerNicMappings
The network interface mappings.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ServerNameOverride Property

SystemStateOptionsServerNameOverride Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ServerNameOverride { get; set; }
Public Property ServerNameOverride As String
    Get
    Set
public:
property String^ ServerNameOverride {
    String^ get ();
    void set (String^ value);
}
function get_ServerNameOverride();
function set_ServerNameOverride(value);

Property Value

Type: String
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ServicesToStopOptions Property

SystemStateOptionsServicesToStopOptions Property

This value represents the services on the target to stop during protection.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesToStop[] ServicesToStopOptions { get; set; }
Public Property ServicesToStopOptions As TargetServicesToStop()
    Get
    Set
public:
property array<TargetServicesToStop^>^ ServicesToStopOptions {
    array<TargetServicesToStop^>^ get ();
    void set (array<TargetServicesToStop^>^ value);
}
function get_ServicesToStopOptions();
function set_ServicesToStopOptions(value);

Property Value

Type: TargetServicesToStop
The services on the target server to stop during protection.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.ShouldApplyDiskSignatures Property

SystemStateOptionsShouldApplyDiskSignatures Property

This value is true if disk signatures should be applied at cutover; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldApplyDiskSignatures { get; set; }
Public Property ShouldApplyDiskSignatures As Boolean
    Get
    Set
public:
property bool ShouldApplyDiskSignatures {
    bool get ();
    void set (bool value);
}
function get_ShouldApplyDiskSignatures();
function set_ShouldApplyDiskSignatures(value);

Property Value

Type: Boolean
if disk signatures should be applied at cutover; otherwise, .
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.SourceReservedAddress Property

SystemStateOptionsSourceReservedAddress Property

This value is the reserved IP address on the source server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceReservedAddress { get; set; }
Public Property SourceReservedAddress As String
    Get
    Set
public:
property String^ SourceReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_SourceReservedAddress();
function set_SourceReservedAddress(value);

Property Value

Type: String
The reserved IP address on the source server.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.StagingFolder Property

SystemStateOptionsStagingFolder Property

This value is the folder on the target where operating system files from the source will be staged.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string StagingFolder { get; set; }
Public Property StagingFolder As String
    Get
    Set
public:
property String^ StagingFolder {
    String^ get ();
    void set (String^ value);
}
function get_StagingFolder();
function set_StagingFolder(value);

Property Value

Type: String
The folder where operating system files will be staged.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


SystemStateOptions.TargetReservedAddress Property

SystemStateOptionsTargetReservedAddress Property

This value is the reserved IP address on the target server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TargetReservedAddress { get; set; }
Public Property TargetReservedAddress As String
    Get
    Set
public:
property String^ TargetReservedAddress {
    String^ get ();
    void set (String^ value);
}
function get_TargetReservedAddress();
function set_TargetReservedAddress(value);

Property Value

Type: String
The reserved IP address on the target server.
See Also

Reference

SystemStateOptions Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Class

Represents target configuration information for clustered files and folders jobs.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTargetFileServerQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetFileServerQualificationResults : IExtensibleDataObject
Public Class TargetFileServerQualificationResults
    Implements IExtensibleDataObject
public ref class TargetFileServerQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.TargetFileServerQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TargetFileServerQualificationResults',
    null,
    IExtensibleDataObject);

The TargetFileServerQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | TargetFileServerQualificationResults |
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupIPAddresses | This value represents a unicast IP address.
Public property | ClusterResourceGroupName | This value is the name of the cluster group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is total disk size, in bytes, of the volume.
Public property | DriveLetter | This value is the volume drive letter.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the free space, in bytes, available on the volume.
Public property | IsVolumeCSV | This value is true if it is a cluster shared volume; otherwise, it is false.
Public property | RecommendedGroup | This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetFileServerQualificationResults()
Public Sub New
public:
TargetFileServerQualificationResults()
DoubleTake.Jobs.Contract.TargetFileServerQualificationResults = function();
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults Properties

The TargetFileServerQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupIPAddresses | This value represents a unicast IP address.
Public property | ClusterResourceGroupName | This value is the name of the cluster group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is total disk size, in bytes, of the volume.
Public property | DriveLetter | This value is the volume drive letter.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the free space, in bytes, available on the volume.
Public property | IsVolumeCSV | This value is true if it is a cluster shared volume; otherwise, it is false.
Public property | RecommendedGroup | This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress
Top
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ClusterResourceGroupIPAddresses Property

TargetFileServerQualificationResultsClusterResourceGroupIPAddresses Property

This value represents a unicast IP address.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnicastIPAddressInfo[] ClusterResourceGroupIPAddresses { get; set; }
Public Property ClusterResourceGroupIPAddresses As UnicastIPAddressInfo()
    Get
    Set
public:
property array<UnicastIPAddressInfo^>^ ClusterResourceGroupIPAddresses {
    array<UnicastIPAddressInfo^>^ get ();
    void set (array<UnicastIPAddressInfo^>^ value);
}
function get_ClusterResourceGroupIPAddresses();
function set_ClusterResourceGroupIPAddresses(value);

Property Value

Type: UnicastIPAddressInfo
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ClusterResourceGroupName Property

TargetFileServerQualificationResultsClusterResourceGroupName Property

This value is the name of the cluster group that contains the resource.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_ClusterResourceGroupName();
function set_ClusterResourceGroupName(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.CurrentOwnerNodeName Property

TargetFileServerQualificationResultsCurrentOwnerNodeName Property

This value is the name of the resource's current owning node.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
function get_CurrentOwnerNodeName();
function set_CurrentOwnerNodeName(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.DiskSize Property

TargetFileServerQualificationResultsDiskSize Property

This value is total disk size, in bytes, of the volume.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
function get_DiskSize();
function set_DiskSize(value);

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.DriveLetter Property

TargetFileServerQualificationResultsDriveLetter Property

This value is the volume drive letter.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
function get_DriveLetter();
function set_DriveLetter(value);

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.ExtensionData Property

TargetFileServerQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.FreeSpace Property

TargetFileServerQualificationResultsFreeSpace Property

This value is the free space, in bytes, available on the volume.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
function get_FreeSpace();
function set_FreeSpace(value);

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.IsVolumeCSV Property

TargetFileServerQualificationResultsIsVolumeCSV Property

This value is true if it is a cluster shared volume; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
function get_IsVolumeCSV();
function set_IsVolumeCSV(value);

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetFileServerQualificationResults.RecommendedGroup Property

TargetFileServerQualificationResultsRecommendedGroup Property

This value is true if there is a file server group on the target cluster that matches the protected file server group from the source; otherwise, it is false. When this value is true, an IP address from the group will be used as the route for CoreConnectionOptions.TargetAddress

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool RecommendedGroup { get; set; }
Public Property RecommendedGroup As Boolean
    Get
    Set
public:
property bool RecommendedGroup {
    bool get ();
    void set (bool value);
}
function get_RecommendedGroup();
function set_RecommendedGroup(value);

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResults Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Class

Represents options for configuring how target services function after failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTargetServicesOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TargetServicesOptions : IExtensibleDataObject
Public Class TargetServicesOptions
    Implements IExtensibleDataObject
public ref class TargetServicesOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.TargetServicesOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TargetServicesOptions',
    null,
    IExtensibleDataObject);

The TargetServicesOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverServices | This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.
Public property | StartAndStopServices | This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetServicesOptions()
Public Sub New
public:
TargetServicesOptions()
DoubleTake.Jobs.Contract.TargetServicesOptions = function();
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions Properties

The TargetServicesOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FailoverServices | This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.
Public property | StartAndStopServices | This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).
Top
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.ExtensionData Property

TargetServicesOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.FailoverServices Property

TargetServicesOptionsFailoverServices Property

This value represents services that will be stopped on the source and started on the target during failover and started on the source and stopped on the target during failback.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServiceInformation[] FailoverServices { get; set; }
Public Property FailoverServices As ServiceInformation()
    Get
    Set
public:
property array<ServiceInformation^>^ FailoverServices {
    array<ServiceInformation^>^ get ();
    void set (array<ServiceInformation^>^ value);
}
function get_FailoverServices();
function set_FailoverServices(value);

Property Value

Type: ServiceInformation
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TargetServicesOptions.StartAndStopServices Property

TargetServicesOptionsStartAndStopServices Property

This value is true if the services will be stopped and started; otherwise, it is false (and the services will be left running).

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool StartAndStopServices { get; set; }
Public Property StartAndStopServices As Boolean
    Get
    Set
public:
property bool StartAndStopServices {
    bool get ();
    void set (bool value);
}
function get_StartAndStopServices();
function set_StartAndStopServices(value);

Property Value

Type: Boolean
Remarks
The TargetServicesOptionsPresenter is overloaded to use the same widget for jobs that are starting and stopping the services and those that leave the services running. This value is used by the console to determine how the widget should look, feel and function.
See Also

Reference

TargetServicesOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTestFailoverOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TestFailoverOptions
Public Class TestFailoverOptions
public ref class TestFailoverOptions
DoubleTake.Jobs.Contract.TestFailoverOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TestFailoverOptions');

The TestFailoverOptions type exposes the following members.

Constructors
 | Name | Description
Public method | TestFailoverOptions |
Top
Properties
 | Name | Description
Public property | DeleteSnapshots |
Public property | DeleteVirtualDisks |
Public property | DiskOptions | This value represents the testfailover disk options for a Linux server.
Public property | LvmOptions | This value represents testfailover logical volume manager (LVM) options for a Linux server.
Public property | ReplicaDisplayName |
Public property | Volumes | This value represents a testfailover volume to protect and any changes to its base configuration.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TestFailoverOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TestFailoverOptions()
Public Sub New
public:
TestFailoverOptions()
DoubleTake.Jobs.Contract.TestFailoverOptions = function();
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions Properties

The TestFailoverOptions type exposes the following members.

Properties
 | Name | Description
Public property | DeleteSnapshots |
Public property | DeleteVirtualDisks |
Public property | DiskOptions | This value represents the testfailover disk options for a Linux server.
Public property | LvmOptions | This value represents testfailover logical volume manager (LVM) options for a Linux server.
Public property | ReplicaDisplayName |
Public property | Volumes | This value represents a testfailover volume to protect and any changes to its base configuration.
Top
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.DeleteSnapshots Property

TestFailoverOptionsDeleteSnapshots Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteSnapshots { get; set; }
Public Property DeleteSnapshots As Boolean
    Get
    Set
public:
property bool DeleteSnapshots {
    bool get ();
    void set (bool value);
}
function get_DeleteSnapshots();
function set_DeleteSnapshots(value);

Property Value

Type: Boolean
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.DeleteVirtualDisks Property

TestFailoverOptionsDeleteVirtualDisks Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool DeleteVirtualDisks { get; set; }
Public Property DeleteVirtualDisks As Boolean
    Get
    Set
public:
property bool DeleteVirtualDisks {
    bool get ();
    void set (bool value);
}
function get_DeleteVirtualDisks();
function set_DeleteVirtualDisks(value);

Property Value

Type: Boolean
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.DiskOptions Property

TestFailoverOptionsDiskOptions Property

This value represents the testfailover disk options for a Linux server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DiskOptions[] DiskOptions { get; set; }
Public Property DiskOptions As DiskOptions()
    Get
    Set
public:
property array<DiskOptions^>^ DiskOptions {
    array<DiskOptions^>^ get ();
    void set (array<DiskOptions^>^ value);
}
function get_DiskOptions();
function set_DiskOptions(value);

Property Value

Type: DiskOptions
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.LvmOptions Property

TestFailoverOptionsLvmOptions Property

This value represents testfailover logical volume manager (LVM) options for a Linux server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions LvmOptions { get; set; }
Public Property LvmOptions As LvmOptions
    Get
    Set
public:
property LvmOptions^ LvmOptions {
    LvmOptions^ get ();
    void set (LvmOptions^ value);
}
function get_LvmOptions();
function set_LvmOptions(value);

Property Value

Type: LvmOptions
The LVM Options
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.ReplicaDisplayName Property

TestFailoverOptionsReplicaDisplayName Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicaDisplayName { get; set; }
Public Property ReplicaDisplayName As String
    Get
    Set
public:
property String^ ReplicaDisplayName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicaDisplayName();
function set_ReplicaDisplayName(value);

Property Value

Type: String
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverOptions.Volumes Property

TestFailoverOptionsVolumes Property

This value represents a testfailover volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions[] Volumes { get; set; }
Public Property Volumes As VolumeOptions()
    Get
    Set
public:
property array<VolumeOptions^>^ Volumes {
    array<VolumeOptions^>^ get ();
    void set (array<VolumeOptions^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeOptions
The volumes.
See Also

Reference

TestFailoverOptions Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState Class

Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTestFailoverPersistedState

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TestFailoverPersistedState
Public Class TestFailoverPersistedState
public ref class TestFailoverPersistedState
DoubleTake.Jobs.Contract.TestFailoverPersistedState = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TestFailoverPersistedState');

The TestFailoverPersistedState type exposes the following members.

Constructors
 | Name | Description
Public method | TestFailoverPersistedState |
Top
Fields
 | Name | Description
Public field | ConnectionOptions |
Public field | CurrentSnapshotSet |
Public field | SnapshotSets |
Public field | State |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TestFailoverPersistedState()
Public Sub New
public:
TestFailoverPersistedState()
DoubleTake.Jobs.Contract.TestFailoverPersistedState = function();
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState Fields

The TestFailoverPersistedState type exposes the following members.

Fields
 | Name | Description
Public field | ConnectionOptions |
Public field | CurrentSnapshotSet |
Public field | SnapshotSets |
Public field | State |
Top
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState.ConnectionOptions Field

TestFailoverPersistedStateConnectionOptions Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionOptions ConnectionOptions
Public ConnectionOptions As CoreConnectionOptions
public:
CoreConnectionOptions^ ConnectionOptions
var ConnectionOptions

Field Value

Type: CoreConnectionOptions
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState.CurrentSnapshotSet Field

TestFailoverPersistedStateCurrentSnapshotSet Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public SnapshotSetInfo CurrentSnapshotSet
Public CurrentSnapshotSet As SnapshotSetInfo
public:
SnapshotSetInfo^ CurrentSnapshotSet
var CurrentSnapshotSet

Field Value

Type: SnapshotSetInfo
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState.SnapshotSets Field

TestFailoverPersistedStateSnapshotSets Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public IEnumerable<SnapshotSetInfo> SnapshotSets
Public SnapshotSets As IEnumerable(Of SnapshotSetInfo)
public:
IEnumerable<SnapshotSetInfo^>^ SnapshotSets
var SnapshotSets

Field Value

Type: IEnumerable SnapshotSetInfo
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverPersistedState.State Field

TestFailoverPersistedStateState Field

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtendedLowLevelState State
Public State As ExtendedLowLevelState
public:
ExtendedLowLevelState^ State
var State

Field Value

Type: ExtendedLowLevelState
See Also

Reference

TestFailoverPersistedState Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential Class

Represents the testfailover server (address, port, and credentials) required to work for fullserver testfailover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTestFailoverServerCredential

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TestFailoverServerCredential : IExtensibleDataObject
Public Class TestFailoverServerCredential
    Implements IExtensibleDataObject
public ref class TestFailoverServerCredential : IExtensibleDataObject
DoubleTake.Jobs.Contract.TestFailoverServerCredential = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TestFailoverServerCredential',
    null,
    IExtensibleDataObject);

The TestFailoverServerCredential type exposes the following members.

Constructors
 | Name | Description
Public method | TestFailoverServerCredential |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TestFailoverServerHardwareId | Gets or sets the testfailover server hardware id.
Public property | TestFailoverServerHostUri | Gets or sets the testfailover server host URI.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TestFailoverServerCredential()
Public Sub New
public:
TestFailoverServerCredential()
DoubleTake.Jobs.Contract.TestFailoverServerCredential = function();
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential Properties

The TestFailoverServerCredential type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TestFailoverServerHardwareId | Gets or sets the testfailover server hardware id.
Public property | TestFailoverServerHostUri | Gets or sets the testfailover server host URI.
Top
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential.ExtensionData Property

TestFailoverServerCredentialExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential.TestFailoverServerHardwareId Property

TestFailoverServerCredentialTestFailoverServerHardwareId Property

Gets or sets the testfailover server hardware id.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TestFailoverServerHardwareId { get; set; }
Public Property TestFailoverServerHardwareId As String
    Get
    Set
public:
property String^ TestFailoverServerHardwareId {
    String^ get ();
    void set (String^ value);
}
function get_TestFailoverServerHardwareId();
function set_TestFailoverServerHardwareId(value);

Property Value

Type: String
The testfailover server hardware id.
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential.TestFailoverServerHostUri Property

TestFailoverServerCredentialTestFailoverServerHostUri Property

Gets or sets the testfailover server host URI.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri TestFailoverServerHostUri { get; set; }
Public Property TestFailoverServerHostUri As Uri
    Get
    Set
public:
property Uri^ TestFailoverServerHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_TestFailoverServerHostUri();
function set_TestFailoverServerHostUri(value);

Property Value

Type: Uri
The testfailover server host URI.
Remarks
This property serves as a replacement for the deprecated SourceConnectionParameters property.
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential Methods

The TestFailoverServerCredential type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential.GetDeserializedObject Method

TestFailoverServerCredentialGetDeserializedObject Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TestFailoverServerCredential.GetObjectToSerialize Method

TestFailoverServerCredentialGetObjectToSerialize Method

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

TestFailoverServerCredential Class
DoubleTake.Jobs.Contract Namespace


TimesClass Class

Time at various points of the failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractTimesClass

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class TimesClass
Public Class TimesClass
public ref class TimesClass
DoubleTake.Jobs.Contract.TimesClass = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.TimesClass');

The TimesClass type exposes the following members.

Constructors
 | Name | Description
Public method | TimesClass |
Top
Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


TimesClass Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TimesClass()
Public Sub New
public:
TimesClass()
DoubleTake.Jobs.Contract.TimesClass = function();
See Also

Reference

TimesClass Class
DoubleTake.Jobs.Contract Namespace


TimesClass Properties

The TimesClass type exposes the following members.

Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
See Also

Reference

TimesClass Class
DoubleTake.Jobs.Contract Namespace


TimesClass.completed Property

TimesClasscompleted Property

Time that the failover is considered complete.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> completed { get; set; }
Public Property completed As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> completed {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_completed();
function set_completed(value);

Property Value

Type: Nullable DateTime
See Also

Reference

TimesClass Class
DoubleTake.Jobs.Contract Namespace


TimesClass.startProcessing Property

TimesClassstartProcessing Property

Time the failover processing started.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime startProcessing { get; set; }
Public Property startProcessing As DateTime
    Get
    Set
public:
property DateTime startProcessing {
    DateTime get ();
    void set (DateTime value);
}
function get_startProcessing();
function set_startProcessing(value);

Property Value

Type: DateTime
See Also

Reference

TimesClass Class
DoubleTake.Jobs.Contract Namespace


TimesClass.startReboot Property

TimesClassstartReboot Property

Time when the reboot started. NOTE: For data only jobs, this time will be null.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<DateTime> startReboot { get; set; }
Public Property startReboot As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> startReboot {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
function get_startReboot();
function set_startReboot(value);

Property Value

Type: Nullable DateTime
See Also

Reference

TimesClass Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Class

Represents options for configuring an unmanaged connection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractUnmanagedConnectionOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class UnmanagedConnectionOptions : IExtensibleDataObject
Public Class UnmanagedConnectionOptions
    Implements IExtensibleDataObject
public ref class UnmanagedConnectionOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.UnmanagedConnectionOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.UnmanagedConnectionOptions',
    null,
    IExtensibleDataObject);

The UnmanagedConnectionOptions type exposes the following members.

Constructors
 | Name | Description
Public method | UnmanagedConnectionOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetStateInfo | This value represents information on the state of the target.
Top
Remarks
An unmanaged connection job represents a connection that is not associated with a known job. This connection may have been created a client outside of the job manager.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public UnmanagedConnectionOptions()
Public Sub New
public:
UnmanagedConnectionOptions()
DoubleTake.Jobs.Contract.UnmanagedConnectionOptions = function();
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions Properties

The UnmanagedConnectionOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | TargetStateInfo | This value represents information on the state of the target.
Top
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions.ExtensionData Property

UnmanagedConnectionOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


UnmanagedConnectionOptions.TargetStateInfo Property

UnmanagedConnectionOptionsTargetStateInfo Property

This value represents information on the state of the target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TargetStateInfo TargetStateInfo { get; set; }
Public Property TargetStateInfo As TargetStateInfo
    Get
    Set
public:
property TargetStateInfo^ TargetStateInfo {
    TargetStateInfo^ get ();
    void set (TargetStateInfo^ value);
}
function get_TargetStateInfo();
function set_TargetStateInfo(value);

Property Value

Type: TargetStateInfo
The target state information for this connection.
See Also

Reference

UnmanagedConnectionOptions Class
DoubleTake.Jobs.Contract Namespace


VerificationStatus Enumeration

Indicates the status of a verification task or step.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum VerificationStatus
Public Enumeration VerificationStatus
public enum class VerificationStatus
DoubleTake.Jobs.Contract.VerificationStatus = function();
DoubleTake.Jobs.Contract.VerificationStatus.createEnum('DoubleTake.Jobs.Contract.VerificationStatus', false);
Members
Member name | Value | Description
InProgress | 0 | Indicates the verification task or step is still running.
Success | 1 | Indicates the verification task or step has completed successfully.
Warning | 2 | Indicates the verification task or step has completed with a warning.
Error | 3 | Indicates the verification task or step has completed with an error.
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VerificationStep Class

Represents a step in a verification task.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVerificationStep

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VerificationStep : IExtensibleDataObject
Public Class VerificationStep
    Implements IExtensibleDataObject
public ref class VerificationStep : IExtensibleDataObject
DoubleTake.Jobs.Contract.VerificationStep = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VerificationStep',
    null,
    IExtensibleDataObject);

The VerificationStep type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStep |
Top
Properties
 | Name | Description
Public property | CanFix | This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the ID for the validation item.
Public property | Index | This value is an index value used to impose an order to the validation items.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageKey | This value is a message key for the validation item. This value can be used to look up the message text.
Public property | Progress | This value is the completion progress of the validation item.
Public property | Status | This value represents the status of the validation item.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleKey | This value is a title key for the validation item. This value can be used to look up the title text.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VerificationStep Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationStep()
Public Sub New
public:
VerificationStep()
DoubleTake.Jobs.Contract.VerificationStep = function();
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep Properties

The VerificationStep type exposes the following members.

Properties
 | Name | Description
Public property | CanFix | This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Id | This value is the ID for the validation item.
Public property | Index | This value is an index value used to impose an order to the validation items.
Public property | MessageFormatParameters | This value is the message format parameters.
Public property | MessageKey | This value is a message key for the validation item. This value can be used to look up the message text.
Public property | Progress | This value is the completion progress of the validation item.
Public property | Status | This value represents the status of the validation item.
Public property | TitleFormatParameters | This value is the title format parameters for the action.
Public property | TitleKey | This value is a title key for the validation item. This value can be used to look up the title text.
Top
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.CanFix Property

VerificationStepCanFix Property

This value is true if Double-Take can automatically fix the validation item; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool CanFix { get; set; }
Public Property CanFix As Boolean
    Get
    Set
public:
property bool CanFix {
    bool get ();
    void set (bool value);
}
function get_CanFix();
function set_CanFix(value);

Property Value

Type: Boolean
if this step can be fixed; otherwise, .
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.ExtensionData Property

VerificationStepExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Id Property

VerificationStepId Property

This value is the ID for the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
function get_Id();
function set_Id(value);

Property Value

Type: String
The identifier of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Index Property

VerificationStepIndex Property

This value is an index value used to impose an order to the validation items.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
function get_Index();
function set_Index(value);

Property Value

Type: Int32
The index.
Remarks
This index can be used by job-level verifiers to impose an order to the steps being generated by the individual job aspect verifiers.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.MessageFormatParameters Property

VerificationStepMessageFormatParameters Property

This value is the message format parameters.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_MessageFormatParameters();
function set_MessageFormatParameters(value);

Property Value

Type: String
The message format parameters for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.MessageKey Property

VerificationStepMessageKey Property

This value is a message key for the validation item. This value can be used to look up the message text.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string MessageKey { get; set; }
Public Property MessageKey As String
    Get
    Set
public:
property String^ MessageKey {
    String^ get ();
    void set (String^ value);
}
function get_MessageKey();
function set_MessageKey(value);

Property Value

Type: String
The message key for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Progress Property

VerificationStepProgress Property

This value is the completion progress of the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set
public:
property int Progress {
    int get ();
    void set (int value);
}
function get_Progress();
function set_Progress(value);

Property Value

Type: Int32
The completion progress of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Status Property

VerificationStepStatus Property

This value represents the status of the validation item.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
function get_Status();
function set_Status(value);

Property Value

Type: VerificationStatus
The status of this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.TitleFormatParameters Property

VerificationStepTitleFormatParameters Property

This value is the title format parameters for the action.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_TitleFormatParameters();
function set_TitleFormatParameters(value);

Property Value

Type: String
The title format parameters for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.TitleKey Property

VerificationStepTitleKey Property

This value is a title key for the validation item. This value can be used to look up the title text.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string TitleKey { get; set; }
Public Property TitleKey As String
    Get
    Set
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}
function get_TitleKey();
function set_TitleKey(value);

Property Value

Type: String
The title key for this verification step.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep Methods

The VerificationStep type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Top
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VerificationStep.Clone Method

VerificationStepClone Method

Creates a new object that is a copy of the current instance.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
function Clone();

Return Value

Type: Object
A new object that is a copy of this instance.
See Also

Reference

VerificationStep Class
DoubleTake.Jobs.Contract Namespace


VRAOptions Class

Represents options for configuring the Virtual Recovery Assistant feature.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVRAOptions

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAOptions : IExtensibleDataObject
Public Class VRAOptions
    Implements IExtensibleDataObject
public ref class VRAOptions : IExtensibleDataObject
DoubleTake.Jobs.Contract.VRAOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VRAOptions',
    null,
    IExtensibleDataObject);

The VRAOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VRAOptions |
Top
Properties
 | Name | Description
Public property | DiskConfigStrategy | The value represents the disk layout strategy.
Public property | DiskOptions | This value represents the disk options for a Linux server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | This value is the name of the replica's hypervisor.
Public property | IsSourceHostCluster | This value is true if the source host is clustered; otherwise, it is false.
Public property | IsWANFailoverEnabled | This value is true if WAN failover is enabled; otherwise, it is false.
Public property | LvmOptions | This value represents logical volume manager (LVM) options for a Linux server.
Public property | ReplicaApplianceInfo | This value represents the helper appliance information.
Public property | ReplicaESXHostName | This value is the name of the ESX host where the replica will be located.
Public property | ReplicaNetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | ReplicaVMInfo | This value represents the desired configuration of the replica virtual machine.
Public property | ReverseCount | Do not use this property. Double-Take uses it internally.
Public property | ReverseOptions |
Public property | ReverseRoute | This value is the route used for the reverse process.
Public property | SourceApplianceInfo | This value represents the appliance used during reverse.
Public property | SourceESXHostName | This value is the name of the ESX host where the source is located.
Public property | SourceHypervisor | Gets or sets the source hypervisor.
Public property | SourceNetworkInterfaceInfo | This value represents the available NICs on the source.
Public property | SourceProductLicense | This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.
Public property | SourceVmInfo | This value represents the source information used during reverse.
Public property | TestFailover |
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VirtualSwitchMappingTestFailover | Gets or sets a value representing source and target virtual switch mappings for test failover
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Public property | WorkloadCustomizationOptions | This value represents workload customization options.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VRAOptions Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAOptions()
Public Sub New
public:
VRAOptions()
DoubleTake.Jobs.Contract.VRAOptions = function();
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions Properties

The VRAOptions type exposes the following members.

Properties
 | Name | Description
Public property | DiskConfigStrategy | The value represents the disk layout strategy.
Public property | DiskOptions | This value represents the disk options for a Linux server.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Hypervisor | This value is the name of the replica's hypervisor.
Public property | IsSourceHostCluster | This value is true if the source host is clustered; otherwise, it is false.
Public property | IsWANFailoverEnabled | This value is true if WAN failover is enabled; otherwise, it is false.
Public property | LvmOptions | This value represents logical volume manager (LVM) options for a Linux server.
Public property | ReplicaApplianceInfo | This value represents the helper appliance information.
Public property | ReplicaESXHostName | This value is the name of the ESX host where the replica will be located.
Public property | ReplicaNetworkInterfaceInfo | This value represents the desired NIC configuration on the replica virtual machine.
Public property | ReplicaVMInfo | This value represents the desired configuration of the replica virtual machine.
Public property | ReverseCount | Do not use this property. Double-Take uses it internally.
Public property | ReverseOptions |
Public property | ReverseRoute | This value is the route used for the reverse process.
Public property | SourceApplianceInfo | This value represents the appliance used during reverse.
Public property | SourceESXHostName | This value is the name of the ESX host where the source is located.
Public property | SourceHypervisor | Gets or sets the source hypervisor.
Public property | SourceNetworkInterfaceInfo | This value represents the available NICs on the source.
Public property | SourceProductLicense | This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.
Public property | SourceVmInfo | This value represents the source information used during reverse.
Public property | TestFailover |
Public property | VirtualSwitchMapping | This value represents the virtual switch mappings on the source and target.
Public property | VirtualSwitchMappingTestFailover | Gets or sets a value representing source and target virtual switch mappings for test failover
Public property | Volumes | This value represents a volume to protect and any changes to its base configuration.
Public property | WorkloadCustomizationOptions | This value represents workload customization options.
Top
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.DiskConfigStrategy Property

VRAOptionsDiskConfigStrategy Property

The value represents the disk layout strategy.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DiskConfigStrategy DiskConfigStrategy { get; set; }
Public Property DiskConfigStrategy As DiskConfigStrategy
    Get
    Set
public:
property DiskConfigStrategy DiskConfigStrategy {
    DiskConfigStrategy get ();
    void set (DiskConfigStrategy value);
}
function get_DiskConfigStrategy();
function set_DiskConfigStrategy(value);

Property Value

Type: DiskConfigStrategy
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.DiskOptions Property

VRAOptionsDiskOptions Property

This value represents the disk options for a Linux server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DiskOptions[] DiskOptions { get; set; }
Public Property DiskOptions As DiskOptions()
    Get
    Set
public:
property array<DiskOptions^>^ DiskOptions {
    array<DiskOptions^>^ get ();
    void set (array<DiskOptions^>^ value);
}
function get_DiskOptions();
function set_DiskOptions(value);

Property Value

Type: DiskOptions
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ExtensionData Property

VRAOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.Hypervisor Property

VRAOptionsHypervisor Property

This value is the name of the replica's hypervisor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Hypervisor { get; set; }
Public Property Hypervisor As String
    Get
    Set
public:
property String^ Hypervisor {
    String^ get ();
    void set (String^ value);
}
function get_Hypervisor();
function set_Hypervisor(value);

Property Value

Type: String
The hypervisor. This should be one of the values from HypervisorTypes.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.IsSourceHostCluster Property

VRAOptionsIsSourceHostCluster Property

This value is true if the source host is clustered; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSourceHostCluster { get; set; }
Public Property IsSourceHostCluster As Boolean
    Get
    Set
public:
property bool IsSourceHostCluster {
    bool get ();
    void set (bool value);
}
function get_IsSourceHostCluster();
function set_IsSourceHostCluster(value);

Property Value

Type: Boolean
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.IsWANFailoverEnabled Property

VRAOptionsIsWANFailoverEnabled Property

This value is true if WAN failover is enabled; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
function get_IsWANFailoverEnabled();
function set_IsWANFailoverEnabled(value);

Property Value

Type: Boolean
true if this instance is WAN failover enabled; otherwise, false.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.LvmOptions Property

VRAOptionsLvmOptions Property

This value represents logical volume manager (LVM) options for a Linux server.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public LvmOptions LvmOptions { get; set; }
Public Property LvmOptions As LvmOptions
    Get
    Set
public:
property LvmOptions^ LvmOptions {
    LvmOptions^ get ();
    void set (LvmOptions^ value);
}
function get_LvmOptions();
function set_LvmOptions(value);

Property Value

Type: LvmOptions
The LVM Options
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaApplianceInfo Property

VRAOptionsReplicaApplianceInfo Property

This value represents the helper appliance information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo ReplicaApplianceInfo { get; set; }
Public Property ReplicaApplianceInfo As VMInfo
    Get
    Set
public:
property VMInfo^ ReplicaApplianceInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_ReplicaApplianceInfo();
function set_ReplicaApplianceInfo(value);

Property Value

Type: VMInfo
The replica appliance information
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaESXHostName Property

VRAOptionsReplicaESXHostName Property

This value is the name of the ESX host where the replica will be located.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicaESXHostName { get; set; }
Public Property ReplicaESXHostName As String
    Get
    Set
public:
property String^ ReplicaESXHostName {
    String^ get ();
    void set (String^ value);
}
function get_ReplicaESXHostName();
function set_ReplicaESXHostName(value);

Property Value

Type: String
The target ESX host Info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaNetworkInterfaceInfo Property

VRAOptionsReplicaNetworkInterfaceInfo Property

This value represents the desired NIC configuration on the replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_ReplicaNetworkInterfaceInfo();
function set_ReplicaNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReplicaVMInfo Property

VRAOptionsReplicaVMInfo Property

This value represents the desired configuration of the replica virtual machine.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicaVMInfo ReplicaVMInfo { get; set; }
Public Property ReplicaVMInfo As ReplicaVMInfo
    Get
    Set
public:
property ReplicaVMInfo^ ReplicaVMInfo {
    ReplicaVMInfo^ get ();
    void set (ReplicaVMInfo^ value);
}
function get_ReplicaVMInfo();
function set_ReplicaVMInfo(value);

Property Value

Type: ReplicaVMInfo
The replica VM information
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReverseCount Property

VRAOptionsReverseCount Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int ReverseCount { get; set; }
Public Property ReverseCount As Integer
    Get
    Set
public:
property int ReverseCount {
    int get ();
    void set (int value);
}
function get_ReverseCount();
function set_ReverseCount(value);

Property Value

Type: Int32
The reverse count.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReverseOptions Property

VRAOptionsReverseOptions Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReverseOptions ReverseOptions { get; set; }
Public Property ReverseOptions As ReverseOptions
    Get
    Set
public:
property ReverseOptions^ ReverseOptions {
    ReverseOptions^ get ();
    void set (ReverseOptions^ value);
}
function get_ReverseOptions();
function set_ReverseOptions(value);

Property Value

Type: ReverseOptions
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.ReverseRoute Property

VRAOptionsReverseRoute Property

This value is the route used for the reverse process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
function get_ReverseRoute();
function set_ReverseRoute(value);

Property Value

Type: String
The reverse route.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceApplianceInfo Property

VRAOptionsSourceApplianceInfo Property

This value represents the appliance used during reverse.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo SourceApplianceInfo { get; set; }
Public Property SourceApplianceInfo As VMInfo
    Get
    Set
public:
property VMInfo^ SourceApplianceInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_SourceApplianceInfo();
function set_SourceApplianceInfo(value);

Property Value

Type: VMInfo
The source appliance information.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceESXHostName Property

VRAOptionsSourceESXHostName Property

This value is the name of the ESX host where the source is located.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceESXHostName { get; set; }
Public Property SourceESXHostName As String
    Get
    Set
public:
property String^ SourceESXHostName {
    String^ get ();
    void set (String^ value);
}
function get_SourceESXHostName();
function set_SourceESXHostName(value);

Property Value

Type: String
The source ESX host info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceHypervisor Property

VRAOptionsSourceHypervisor Property

Gets or sets the source hypervisor.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceHypervisor { get; set; }
Public Property SourceHypervisor As String
    Get
    Set
public:
property String^ SourceHypervisor {
    String^ get ();
    void set (String^ value);
}
function get_SourceHypervisor();
function set_SourceHypervisor(value);

Property Value

Type: String
The source hypervisor. This should be one of the values in HypervisorTypes
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceNetworkInterfaceInfo Property

VRAOptionsSourceNetworkInterfaceInfo Property

This value represents the available NICs on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo[] SourceNetworkInterfaceInfo { get; set; }
Public Property SourceNetworkInterfaceInfo As VirtualNetworkInterfaceInfo()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfo^>^ SourceNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfo^>^ get ();
    void set (array<VirtualNetworkInterfaceInfo^>^ value);
}
function get_SourceNetworkInterfaceInfo();
function set_SourceNetworkInterfaceInfo(value);

Property Value

Type: VirtualNetworkInterfaceInfo
The network interface info.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceProductLicense Property

VRAOptionsSourceProductLicense Property

This value is the license key used for automatic installations during the V to ESX and V to Hyper-V job creation process.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SourceProductLicense { get; set; }
Public Property SourceProductLicense As String
    Get
    Set
public:
property String^ SourceProductLicense {
    String^ get ();
    void set (String^ value);
}
function get_SourceProductLicense();
function set_SourceProductLicense(value);

Property Value

Type: String
The source product license.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.SourceVmInfo Property

VRAOptionsSourceVmInfo Property

This value represents the source information used during reverse.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo SourceVmInfo { get; set; }
Public Property SourceVmInfo As VMInfo
    Get
    Set
public:
property VMInfo^ SourceVmInfo {
    VMInfo^ get ();
    void set (VMInfo^ value);
}
function get_SourceVmInfo();
function set_SourceVmInfo(value);

Property Value

Type: VMInfo
The source vm VMInfo
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.TestFailover Property

VRAOptionsTestFailover Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TestFailoverOptions TestFailover { get; set; }
Public Property TestFailover As TestFailoverOptions
    Get
    Set
public:
property TestFailoverOptions^ TestFailover {
    TestFailoverOptions^ get ();
    void set (TestFailoverOptions^ value);
}
function get_TestFailover();
function set_TestFailover(value);

Property Value

Type: TestFailoverOptions
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.VirtualSwitchMapping Property

VRAOptionsVirtualSwitchMapping Property

This value represents the virtual switch mappings on the source and target.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMapping { get; set; }
Public Property VirtualSwitchMapping As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMapping {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMapping();
function set_VirtualSwitchMapping(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.VirtualSwitchMappingTestFailover Property

VRAOptionsVirtualSwitchMappingTestFailover Property

Gets or sets a value representing source and target virtual switch mappings for test failover

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping[] VirtualSwitchMappingTestFailover { get; set; }
Public Property VirtualSwitchMappingTestFailover As VirtualSwitchMapping()
    Get
    Set
public:
property array<VirtualSwitchMapping^>^ VirtualSwitchMappingTestFailover {
    array<VirtualSwitchMapping^>^ get ();
    void set (array<VirtualSwitchMapping^>^ value);
}
function get_VirtualSwitchMappingTestFailover();
function set_VirtualSwitchMappingTestFailover(value);

Property Value

Type: VirtualSwitchMapping
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.Volumes Property

VRAOptionsVolumes Property

This value represents a volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeOptions[] Volumes { get; set; }
Public Property Volumes As VolumeOptions()
    Get
    Set
public:
property array<VolumeOptions^>^ Volumes {
    array<VolumeOptions^>^ get ();
    void set (array<VolumeOptions^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeOptions
The volumes.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAOptions.WorkloadCustomizationOptions Property

VRAOptionsWorkloadCustomizationOptions Property

This value represents workload customization options.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAWorkloadCustomizationOptions WorkloadCustomizationOptions { get; set; }
Public Property WorkloadCustomizationOptions As VRAWorkloadCustomizationOptions
    Get
    Set
public:
property VRAWorkloadCustomizationOptions^ WorkloadCustomizationOptions {
    VRAWorkloadCustomizationOptions^ get ();
    void set (VRAWorkloadCustomizationOptions^ value);
}
function get_WorkloadCustomizationOptions();
function set_WorkloadCustomizationOptions(value);

Property Value

Type: VRAWorkloadCustomizationOptions
The workload customization options.
See Also

Reference

VRAOptions Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Class

Represents information that may be needed to configure a VRA job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.ContractVRAQualificationResults

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAQualificationResults : IExtensibleDataObject
Public Class VRAQualificationResults
    Implements IExtensibleDataObject
public ref class VRAQualificationResults : IExtensibleDataObject
DoubleTake.Jobs.Contract.VRAQualificationResults = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.VRAQualificationResults',
    null,
    IExtensibleDataObject);

The VRAQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | VRAQualificationResults |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreexistingDisksFileName | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | ReverseHost |
Public property | SourceServerCoresPerProcessorCount | This value is the number of cores per processor on the source.
Public property | SourceServerMemorySize | This value is the amount of memory, in bytes, on the source.
Public property | SourceServerProcessorCount | This value is the number of processors on the source.
Public property | TargetHost | This value represents the target server information.
Top
See Also

Reference

DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Constructor

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAQualificationResults()
Public Sub New
public:
VRAQualificationResults()
DoubleTake.Jobs.Contract.VRAQualificationResults = function();
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults Properties

The VRAQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | PreexistingDisksFileName | This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | ReverseHost |
Public property | SourceServerCoresPerProcessorCount | This value is the number of cores per processor on the source.
Public property | SourceServerMemorySize | This value is the amount of memory, in bytes, on the source.
Public property | SourceServerProcessorCount | This value is the number of processors on the source.
Public property | TargetHost | This value represents the target server information.
Top
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.ExtensionData Property

VRAQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.PreexistingDisksFileName Property

VRAQualificationResultsPreexistingDisksFileName Property

This value is the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] PreexistingDisksFileName { get; set; }
Public Property PreexistingDisksFileName As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksFileName {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_PreexistingDisksFileName();
function set_PreexistingDisksFileName(value);

Property Value

Type: String
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.ReverseHost Property

VRAQualificationResultsReverseHost Property

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults ReverseHost { get; set; }
Public Property ReverseHost As ServerQualificationResults
    Get
    Set
public:
property ServerQualificationResults^ ReverseHost {
    ServerQualificationResults^ get ();
    void set (ServerQualificationResults^ value);
}
function get_ReverseHost();
function set_ReverseHost(value);

Property Value

Type: ServerQualificationResults
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.SourceServerCoresPerProcessorCount Property

VRAQualificationResultsSourceServerCoresPerProcessorCount Property

This value is the number of cores per processor on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceServerCoresPerProcessorCount { get; set; }
Public Property SourceServerCoresPerProcessorCount As Integer
    Get
    Set
public:
property int SourceServerCoresPerProcessorCount {
    int get ();
    void set (int value);
}
function get_SourceServerCoresPerProcessorCount();
function set_SourceServerCoresPerProcessorCount(value);

Property Value

Type: Int32
The number of cores per processor on the server. Value of 0 used for unknown/unspecified.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.SourceServerMemorySize Property

VRAQualificationResultsSourceServerMemorySize Property

This value is the amount of memory, in bytes, on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long SourceServerMemorySize { get; set; }
Public Property SourceServerMemorySize As Long
    Get
    Set
public:
property long long SourceServerMemorySize {
    long long get ();
    void set (long long value);
}
function get_SourceServerMemorySize();
function set_SourceServerMemorySize(value);

Property Value

Type: Int64
The amount of memory on the server.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.SourceServerProcessorCount Property

VRAQualificationResultsSourceServerProcessorCount Property

This value is the number of processors on the source.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int SourceServerProcessorCount { get; set; }
Public Property SourceServerProcessorCount As Integer
    Get
    Set
public:
property int SourceServerProcessorCount {
    int get ();
    void set (int value);
}
function get_SourceServerProcessorCount();
function set_SourceServerProcessorCount(value);

Property Value

Type: Int32
The processor count of the server.
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


VRAQualificationResults.TargetHost Property

VRAQualificationResultsTargetHost Property

This value represents the target server information.

Namespace: DoubleTake.Jobs.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResults
    Get
    Set
public:
property ServerQualificationResults^ TargetHost {
    ServerQualificationResults^ get ();
    void set (ServerQualificationResults^ value);
}
function get_TargetHost();
function set_TargetHost(value);

Property Value

Type: ServerQualificationResults
See Also

Reference

VRAQualificationResults Class
DoubleTake.Jobs.Contract Namespace


DoubleTake.Jobs.Contract.FullServer Namespace

Classes
 | Class | Description
Public class | FullServerJobDetails | Represents the details of a full-server failover job.


FullServerJobDetails Class

Represents the details of a full-server failover job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.FullServerFullServerJobDetails

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class FullServerJobDetails : IExtensibleDataObject
Public Class FullServerJobDetails
    Implements IExtensibleDataObject
public ref class FullServerJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails',
    null,
    IExtensibleDataObject);

The FullServerJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerJobDetails |
Top
Properties
 | Name | Description
Public property | BackupConnectionDetails | This value represents the details of the Double-Take Availability reverse connection.
Public property | CutoverDetails | This value represents the Double-Take Move cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the protection connection.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection. This option is no longer needed.
Public property | SystemVolumeRevertConnectionDetails | This value represents the details of the system volume revert connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails Constructor

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public FullServerJobDetails()
Public Sub New
public:
FullServerJobDetails()
DoubleTake.Jobs.Contract.FullServer.FullServerJobDetails = function();
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails Properties

The FullServerJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionDetails | This value represents the details of the Double-Take Availability reverse connection.
Public property | CutoverDetails | This value represents the Double-Take Move cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the protection connection.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection. This option is no longer needed.
Public property | SystemVolumeRevertConnectionDetails | This value represents the details of the system volume revert connection.
Top
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.BackupConnectionDetails Property

FullServerJobDetailsBackupConnectionDetails Property

This value represents the details of the Double-Take Availability reverse connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails BackupConnectionDetails { get; set; }
Public Property BackupConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ BackupConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_BackupConnectionDetails();
function set_BackupConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The the details of the backup connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.CutoverDetails Property

FullServerJobDetailsCutoverDetails Property

This value represents the Double-Take Move cutover detail.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetails
    Get
    Set
public:
property CutoverDetails^ CutoverDetails {
    CutoverDetails^ get ();
    void set (CutoverDetails^ value);
}
function get_CutoverDetails();
function set_CutoverDetails(value);

Property Value

Type: CutoverDetails
The details of the cutover operation.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.ExtensionData Property

FullServerJobDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.ProtectionConnectionDetails Property

FullServerJobDetailsProtectionConnectionDetails Property

This value represents the details of the protection connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ ProtectionConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_ProtectionConnectionDetails();
function set_ProtectionConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the protection connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.RecoveryConnectionDetails Property

FullServerJobDetailsRecoveryConnectionDetails Property

This value represents the details of the Double-Take DR recovery connection. This option is no longer needed.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ RecoveryConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_RecoveryConnectionDetails();
function set_RecoveryConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the recovery connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


FullServerJobDetails.SystemVolumeRevertConnectionDetails Property

FullServerJobDetailsSystemVolumeRevertConnectionDetails Property

This value represents the details of the system volume revert connection.

Namespace: DoubleTake.Jobs.Contract.FullServer
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails SystemVolumeRevertConnectionDetails { get; set; }
Public Property SystemVolumeRevertConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ SystemVolumeRevertConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_SystemVolumeRevertConnectionDetails();
function set_SystemVolumeRevertConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the system volume revert connection.
See Also

Reference

FullServerJobDetails Class
DoubleTake.Jobs.Contract.FullServer Namespace


DoubleTake.Jobs.Contract.ImageBased Namespace

Classes
 | Class | Description
Public class | ImageProtectionJobDetails | Represents the details of an image protection job.
Public class | ImageRecoveryJobDetails | Represents the details of an image recovery job.


ImageProtectionJobDetails Class

Represents the details of an image protection job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.ImageBasedImageProtectionJobDetails

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageProtectionJobDetails : IExtensibleDataObject
Public Class ImageProtectionJobDetails
    Implements IExtensibleDataObject
public ref class ImageProtectionJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails',
    null,
    IExtensibleDataObject);

The ImageProtectionJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionJobDetails |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the Double-Take DR protection connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails Constructor

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageProtectionJobDetails()
Public Sub New
public:
ImageProtectionJobDetails()
DoubleTake.Jobs.Contract.ImageBased.ImageProtectionJobDetails = function();
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails Properties

The ImageProtectionJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | ProtectionConnectionDetails | This value represents the details of the Double-Take DR protection connection.
Top
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails.ExtensionData Property

ImageProtectionJobDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageProtectionJobDetails.ProtectionConnectionDetails Property

ImageProtectionJobDetailsProtectionConnectionDetails Property

This value represents the details of the Double-Take DR protection connection.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ ProtectionConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_ProtectionConnectionDetails();
function set_ProtectionConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the protection connection.
See Also

Reference

ImageProtectionJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Class

Represents the details of an image recovery job.
Inheritance Hierarchy
SystemObject
DoubleTake.Jobs.Contract.ImageBasedImageRecoveryJobDetails

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ImageRecoveryJobDetails : IExtensibleDataObject
Public Class ImageRecoveryJobDetails
    Implements IExtensibleDataObject
public ref class ImageRecoveryJobDetails : IExtensibleDataObject
DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails',
    null,
    IExtensibleDataObject);

The ImageRecoveryJobDetails type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryJobDetails |
Top
Properties
 | Name | Description
Public property | CutoverDetails | This value represents the Double-Take DR cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Top
See Also

Reference

DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Constructor

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ImageRecoveryJobDetails()
Public Sub New
public:
ImageRecoveryJobDetails()
DoubleTake.Jobs.Contract.ImageBased.ImageRecoveryJobDetails = function();
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails Properties

The ImageRecoveryJobDetails type exposes the following members.

Properties
 | Name | Description
Public property | CutoverDetails | This value represents the Double-Take DR cutover detail.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | RecoveryConnectionDetails | This value represents the details of the Double-Take DR recovery connection.
Top
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.CutoverDetails Property

ImageRecoveryJobDetailsCutoverDetails Property

This value represents the Double-Take DR cutover detail.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CutoverDetails CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetails
    Get
    Set
public:
property CutoverDetails^ CutoverDetails {
    CutoverDetails^ get ();
    void set (CutoverDetails^ value);
}
function get_CutoverDetails();
function set_CutoverDetails(value);

Property Value

Type: CutoverDetails
The details of the cutover operation.
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.ExtensionData Property

ImageRecoveryJobDetailsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


ImageRecoveryJobDetails.RecoveryConnectionDetails Property

ImageRecoveryJobDetailsRecoveryConnectionDetails Property

This value represents the details of the Double-Take DR recovery connection.

Namespace: DoubleTake.Jobs.Contract.ImageBased
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public CoreConnectionDetails RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetails
    Get
    Set
public:
property CoreConnectionDetails^ RecoveryConnectionDetails {
    CoreConnectionDetails^ get ();
    void set (CoreConnectionDetails^ value);
}
function get_RecoveryConnectionDetails();
function set_RecoveryConnectionDetails(value);

Property Value

Type: CoreConnectionDetails
The details of the recovery connection.
See Also

Reference

ImageRecoveryJobDetails Class
DoubleTake.Jobs.Contract.ImageBased Namespace


DoubleTake.Jobs.Contract.Scheduling Namespace

Classes
 | Class | Description
Public class | BandwidthEntry | Represents an entry in a bandwidth limiting schedule.
Public class | BandwidthOptions | Represents options for configuring a bandwidth limit and bandwidth limiting schedule.
Enumerations
 | Enumeration | Description
Public enumeration | BandwidthEntryType | Defines the type of a entry is a bandwidth schedule entry.


BandwidthEntry Class

Represents an entry in a bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Jobs.Contract.SchedulingBandwidthEntry

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthEntry : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthEntry
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthEntry sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthEntry type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthEntry |
Top
Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | EndTime | This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.
Public property | EntryType | This value represents a daytime or overnight schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
Methods
 | Name | Description
 | GetNextDay | Gets the next day of week, given a reference day.
Public method | Overlaps | Determines if this bandwidth entry overlaps with the provided entry.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Constructor

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntry()
Public Sub New
public:
BandwidthEntry()
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry = function();
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Properties

The BandwidthEntry type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | This values is the days of the week to which the entry applies.
Public property | EndTime | This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.
Public property | EntryType | This value represents a daytime or overnight schedule.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | IsUnlimited | This value is true if the entry allows unlimited bandwidth; otherwise, it is false.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Name | This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.
Public property | StartTime | This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).
Top
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.DaysOfWeek Property

BandwidthEntryDaysOfWeek Property

This values is the days of the week to which the entry applies.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
function get_DaysOfWeek();
function set_DaysOfWeek(value);

Property Value

Type: Weekdays
The days of the week to which the entry applies.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.EndTime Property

BandwidthEntryEndTime Property

This value is the end time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value is only applicable if the BandwidthOptions.BandwidthScheduleMode is Scheduled.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
function get_EndTime();
function set_EndTime(value);

Property Value

Type: DateTime
The end time of the entry.
Remarks
This value should be between 00:00:00 and 23:59:59 (hh:mm:ss). This value in only applicable to bandwidth schedules whose Mode is Scheduled.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.EntryType Property

BandwidthEntryEntryType Property

This value represents a daytime or overnight schedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntryType EntryType { get; }
Public ReadOnly Property EntryType As BandwidthEntryType
    Get
public:
property BandwidthEntryType EntryType {
    BandwidthEntryType get ();
}
function get_EntryType();

Property Value

Type: BandwidthEntryType
The type of the entry.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.ExtensionData Property

BandwidthEntryExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.IsUnlimited Property

BandwidthEntryIsUnlimited Property

This value is true if the entry allows unlimited bandwidth; otherwise, it is false.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
function get_IsUnlimited();
function set_IsUnlimited(value);

Property Value

Type: Boolean
if this entry allows unlimited bandwidth; otherwise, .
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Limit Property

BandwidthEntryLimit Property

This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The bandwidth limit for the entry, in bytes per second.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Name Property

BandwidthEntryName Property

This value is the name of the entry. It must be unique among all entries in the bandwidth schedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
function get_Name();
function set_Name(value);

Property Value

Type: String
The name of the bandwidth schedule entry.
Remarks
This name must be unique among all entries in the bandwidth schedule.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.StartTime Property

BandwidthEntryStartTime Property

This value is the start time of the entry. It should be between 00:00:00 and 23:59:59 (hh:mm:ss).

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
function get_StartTime();
function set_StartTime(value);

Property Value

Type: DateTime
The start time of the entry.
Remarks
This value should be between 00:00:00 and 23:59:59 (hh:mm:ss).
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry Methods

The BandwidthEntry type exposes the following members.

Methods
 | Name | Description
 | GetNextDay | Gets the next day of week, given a reference day.
Public method | Overlaps | Determines if this bandwidth entry overlaps with the provided entry.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.GetNextDay Method

BandwidthEntryGetNextDay Method

Gets the next day of week, given a reference day.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static Weekdays GetNextDay(
    Weekdays weekdays
)
Public Shared Function GetNextDay (
    weekdays As Weekdays
) As Weekdays
public:
static Weekdays GetNextDay(
    Weekdays weekdays
)
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntry.GetNextDay = function(weekdays);

Parameters

weekdays
Type: DoubleTake.Core.Contract.ConnectionWeekdays
The day from which the next day should be calculated.

Return Value

Type: Weekdays
The next day of the week.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.Overlaps Method

BandwidthEntryOverlaps Method

Determines if this bandwidth entry overlaps with the provided entry.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool Overlaps(
    BandwidthEntry other
)
Public Function Overlaps (
    other As BandwidthEntry
) As Boolean
public:
bool Overlaps(
    BandwidthEntry^ other
)
function Overlaps(other);

Parameters

other
Type: DoubleTake.Jobs.Contract.SchedulingBandwidthEntry
The other entry.

Return Value

Type: Boolean
if this entry overlaps with the provided entry; otherwise, .
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntry.ToString Method

BandwidthEntryToString Method

Returns a String that represents this instance.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
function ToString();

Return Value

Type: String
A String that represents this instance.
See Also

Reference

BandwidthEntry Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthEntryType Enumeration

Defines the type of a entry is a bandwidth schedule entry.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public enum BandwidthEntryType
Public Enumeration BandwidthEntryType
public enum class BandwidthEntryType
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType = function();
DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType.createEnum('DoubleTake.Jobs.Contract.Scheduling.BandwidthEntryType', false);
Members
Member name | Value | Description
Daytime | 0 | This value is an entry where the BandwidthEntry.StartTime and .EndTime are on the same day.
Overnight | 1 | This value is an entry where the BandwidthEntry.StartTime value is on one day and the .EndTime value is on the next day.
Remarks
[E:Overnight] indicates an entry that wraps around the end of the day and ends at the same or earlier time the following day or days than this entry begins. [E:Daytime] indicates that the entry begins and ends on the same day, in which case the end time occurs after the start time.
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Class

Represents options for configuring a bandwidth limit and bandwidth limiting schedule.
Inheritance Hierarchy
SystemObject
ObservableObject
DoubleTake.Jobs.Contract.SchedulingBandwidthOptions

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public sealed class BandwidthOptions : ObservableObject,
    IExtensibleDataObject
Public NotInheritable Class BandwidthOptions
    Inherits ObservableObject
    Implements IExtensibleDataObject
public ref class BandwidthOptions sealed : public ObservableObject,
    IExtensibleDataObject
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions = function();

Type.createClass(
    'DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions',
    DoubleTake.Common.ComponentModel.ObservableObject,
    IExtensibleDataObject);

The BandwidthOptions type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthOptions |
Top
Properties
 | Name | Description
Public property | Entries | This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.
Top
Methods
 | Name | Description
 | FromLegacy | Converts a legacy BandwithSchedule to an instance of BandwidthOptions.
Public method | ToLegacy | Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.
Top
See Also

Reference

DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Constructor

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthOptions()
Public Sub New
public:
BandwidthOptions()
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions = function();
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Properties

The BandwidthOptions type exposes the following members.

Properties
 | Name | Description
Public property | Entries | This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Limit | This value is the bandwidth limit in bytes per second.
Public property | Mode | This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.
Public property | Specifications | This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.
Top
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Entries Property

BandwidthOptionsEntries Property

This value represents the bandwidth schedule. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Entries.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthEntry[] Entries { get; set; }
Public Property Entries As BandwidthEntry()
    Get
    Set
public:
property array<BandwidthEntry^>^ Entries {
    array<BandwidthEntry^>^ get ();
    void set (array<BandwidthEntry^>^ value);
}
function get_Entries();
function set_Entries(value);

Property Value

Type: BandwidthEntry
An array of BandwidthEntry that represents the entries in the bandwidth limiting schedule.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.ExtensionData Property

BandwidthOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Limit Property

BandwidthOptionsLimit Property

This value is the bandwidth limit in bytes per second.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
function get_Limit();
function set_Limit(value);

Property Value

Type: Int64
The bandwidth limit, in bytes per second.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Mode Property

BandwidthOptionsMode Property

This value is the bandwidth limiting mode. This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Mode.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
function get_Mode();
function set_Mode(value);

Property Value

Type: BandwidthScheduleMode
The mode of the bandwidth schedule.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.Specifications Property

BandwidthOptionsSpecifications Property

This value represents a bandwidth specifications as identified by a common name (for example T1) and a numeric speed (for example, 193,000 bytes per second). This value is copied to CoreConnectionOptions.ConnectionStartParameters.Schedule.Bandwidth.Specification.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public BandwidthSpecification[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecification()
    Get
    Set
public:
property array<BandwidthSpecification^>^ Specifications {
    array<BandwidthSpecification^>^ get ();
    void set (array<BandwidthSpecification^>^ value);
}
function get_Specifications();
function set_Specifications(value);

Property Value

Type: BandwidthSpecification
An array of BandwidthSpecification that represents common bandwidth specifications.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions Methods

The BandwidthOptions type exposes the following members.

Methods
 | Name | Description
 | FromLegacy | Converts a legacy BandwithSchedule to an instance of BandwidthOptions.
Public method | ToLegacy | Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.
Top
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.FromLegacy Method

BandwidthOptionsFromLegacy Method

Converts a legacy BandwithSchedule to an instance of BandwidthOptions.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public static BandwidthOptions FromLegacy(
    BandwidthSchedule gatewayType
)
Public Shared Function FromLegacy (
    gatewayType As BandwidthSchedule
) As BandwidthOptions
public:
static BandwidthOptions^ FromLegacy(
    BandwidthSchedule^ gatewayType
)
DoubleTake.Jobs.Contract.Scheduling.BandwidthOptions.FromLegacy = function(gatewayType);

Parameters

gatewayType
Type: DoubleTake.Core.Contract.ConnectionBandwidthSchedule
The instance of BandwidthSchedule to be converted.

Return Value

Type: BandwidthOptions
An instance of BandwidthOptions that contains the converted data.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


BandwidthOptions.ToLegacy Method

BandwidthOptionsToLegacy Method

Converts this instance of BandwidthOptions to a legacy BandwidthSchedule.

Namespace: DoubleTake.Jobs.Contract.Scheduling
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public void ToLegacy(
    BandwidthSchedule legacyType
)
Public Sub ToLegacy (
    legacyType As BandwidthSchedule
)
public:
void ToLegacy(
    BandwidthSchedule^ legacyType
)
function ToLegacy(legacyType);

Parameters

legacyType
Type: DoubleTake.Core.Contract.ConnectionBandwidthSchedule
An instance of BandwidthSchedule that will receive the configuration of this instance.
See Also

Reference

BandwidthOptions Class
DoubleTake.Jobs.Contract.Scheduling Namespace


DoubleTake.PowerShell Namespace

Classes
 | Class | Description
Public class | Server |


Server Class

Inheritance Hierarchy
SystemObject
DoubleTake.PowerShellServer

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class Server
Public Class Server
public ref class Server
DoubleTake.PowerShell.Server = function();

Type.createClass(
    'DoubleTake.PowerShell.Server');

The Server type exposes the following members.

Constructors
 | Name | Description
Public method | Server |
Top
Properties
 | Name | Description
Public property | Credentials |
Public property | HostName |
Public property | Port |
Public property | Role |
Public property | Uri |
Top
Methods
 | Name | Description
Public method | GetProxyTClient |
Public method | RemoveAllAdapters |
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

DoubleTake.PowerShell Namespace


Server Constructor

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Server(
    string networkIdAndPort
)
Public Sub New (
    networkIdAndPort As String
)
public:
Server(
    String^ networkIdAndPort
)
DoubleTake.PowerShell.Server = function(networkIdAndPort);

Parameters

networkIdAndPort
Type: SystemString
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server Properties

The Server type exposes the following members.

Properties
 | Name | Description
Public property | Credentials |
Public property | HostName |
Public property | Port |
Public property | Role |
Public property | Uri |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Credentials Property

ServerCredentials Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PSCredential Credentials { get; set; }
Public Property Credentials As PSCredential
    Get
    Set
public:
property PSCredential^ Credentials {
    PSCredential^ get ();
    void set (PSCredential^ value);
}
function get_Credentials();
function set_Credentials(value);

Property Value

Type: PSCredential
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.HostName Property

ServerHostName Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string HostName { get; }
Public ReadOnly Property HostName As String
    Get
public:
property String^ HostName {
    String^ get ();
}
function get_HostName();

Property Value

Type: String
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Port Property

ServerPort Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Nullable<int> Port { get; set; }
Public Property Port As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
function get_Port();
function set_Port(value);

Property Value

Type: Nullable Int32
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Role Property

ServerRole Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
function get_Role();
function set_Role(value);

Property Value

Type: String
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.Uri Property

ServerUri Property

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri Uri { get; }
Public ReadOnly Property Uri As Uri
    Get
public:
property Uri^ Uri {
    Uri^ get ();
}
function get_Uri();

Property Value

Type: Uri
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server Methods

The Server type exposes the following members.

Methods
 | Name | Description
Public method | GetProxyTClient |
Public method | RemoveAllAdapters |
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.GetProxy(TClient) Method

ServerGetProxyTClient Method

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TClient GetProxy<TClient>()
where TClient : class

Public Function GetProxy(Of TClient As Class) As TClient
public:
generic<typename TClient>
where TClient : ref class
TClient GetProxy()
JavaScript does not support generic types or methods.

Type Parameters

TClient

Return Value

Type: TClient
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.RemoveAllAdapters Method

ServerRemoveAllAdapters Method

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public void RemoveAllAdapters()
Public Sub RemoveAllAdapters
public:
void RemoveAllAdapters()
function RemoveAllAdapters();
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.UsingProxy Method

ServerUsingProxy Method

Overload List
 | Name | Description
Public method | UsingProxyTChannel(ActionTChannel) |
Public method | UsingProxyTChannel, TResult(FuncTChannel, TResult) |
Top
See Also

Reference

Server Class
DoubleTake.PowerShell Namespace


Server.UsingProxy(TChannel) Method (Action(TChannel))

ServerUsingProxyTChannel Method (ActionTChannel)

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public void UsingProxy<TChannel>(
    Action<TChannel> action
)
where TChannel : class

Public Sub UsingProxy(Of TChannel As Class) (
    action As Action(Of TChannel)
)
public:
generic<typename TChannel>
where TChannel : ref class
void UsingProxy(
    Action<TChannel>^ action
)
JavaScript does not support generic types or methods.

Parameters

action
Type: SystemAction TChannel

Type Parameters

TChannel
See Also

Reference

Server Class
UsingProxy Overload
DoubleTake.PowerShell Namespace


Server.UsingProxy(TChannel, TResult) Method (Func(TChannel, TResult))

ServerUsingProxyTChannel, TResult Method (FuncTChannel, TResult)

Namespace: DoubleTake.PowerShell
Assembly: DoubleTake.PowerShell (in DoubleTake.PowerShell.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public TResult UsingProxy<TChannel, TResult>(
    Func<TChannel, TResult> func
)
where TChannel : class

Public Function UsingProxy(Of TChannel As Class, TResult) (
    func As Func(Of TChannel, TResult)
) As TResult
public:
generic<typename TChannel, typename TResult>
where TChannel : ref class
TResult UsingProxy(
    Func<TChannel, TResult>^ func
)
JavaScript does not support generic types or methods.

Parameters

func
Type: SystemFunc TChannel, TResult

Type Parameters

TChannel
TResult

Return Value

Type: TResult
See Also

Reference

Server Class
UsingProxy Overload
DoubleTake.PowerShell Namespace


DoubleTake.Virtualization Namespaces

Namespaces
Namespace | Description
DoubleTake.Virtualization.Contract |
DoubleTake.Virtualization.Contract.VRA |


DoubleTake.Virtualization.Contract Namespace

Classes
 | Class | Description
Public class | ServerQualificationResults | Represents server information to display on the Console
Public class | VHDInfo | Part of VM configuration. Describes VHD that is part of VM VM configuration contains an array of these types: all VHDs of that VM.
Public class | VirtualNetworkInterfaceInfo | This class adds the extra information we need for WAN Failover and host network mapping
Public class | VirtualSwitchInfo | Represents virtual switch of Hyper-V/ESX
Public class | VirtualSwitchMapping | Represents source and target virtual switch mappings
Public class | VMInfo | Represents properties of virtual machine.
Public class | VolumeQualificationResults | Represents information of volume for console display.


ServerQualificationResults Class

Represents server information to display on the Console
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractServerQualificationResults

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ServerQualificationResults : IExtensibleDataObject
Public Class ServerQualificationResults
    Implements IExtensibleDataObject
public ref class ServerQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.ServerQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.ServerQualificationResults',
    null,
    IExtensibleDataObject);

The ServerQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | ServerQualificationResults |
Top
Properties
 | Name | Description
Public property | CoresPerProcessor | This value is the number of cores per processor
Public property | Cpus | This value is the number of processors.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalProcessors | Gets or sets the total number of logical processors. This is the total number of logical processors including threads.
Public property | Memory | This value is the amount of memory in bytes.
Public property | Version | This value is the version of the target host hypervisor.
Public property | VirtualSwitches | This value represents the virtual switch information.
Public property | Volumes | This value represents the volume information.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ServerQualificationResults()
Public Sub New
public:
ServerQualificationResults()
DoubleTake.Virtualization.Contract.ServerQualificationResults = function();
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults Properties

The ServerQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | CoresPerProcessor | This value is the number of cores per processor
Public property | Cpus | This value is the number of processors.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | LogicalProcessors | Gets or sets the total number of logical processors. This is the total number of logical processors including threads.
Public property | Memory | This value is the amount of memory in bytes.
Public property | Version | This value is the version of the target host hypervisor.
Public property | VirtualSwitches | This value represents the virtual switch information.
Public property | Volumes | This value represents the volume information.
Top
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.CoresPerProcessor Property

ServerQualificationResultsCoresPerProcessor Property

This value is the number of cores per processor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int CoresPerProcessor { get; set; }
Public Property CoresPerProcessor As Integer
    Get
    Set
public:
property int CoresPerProcessor {
    int get ();
    void set (int value);
}
function get_CoresPerProcessor();
function set_CoresPerProcessor(value);

Property Value

Type: Int32
The number of cores per processor.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Cpus Property

ServerQualificationResultsCpus Property

This value is the number of processors.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
function get_Cpus();
function set_Cpus(value);

Property Value

Type: Int32
The number of cpus.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.ExtensionData Property

ServerQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.LogicalProcessors Property

ServerQualificationResultsLogicalProcessors Property

Gets or sets the total number of logical processors. This is the total number of logical processors including threads.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int LogicalProcessors { get; set; }
Public Property LogicalProcessors As Integer
    Get
    Set
public:
property int LogicalProcessors {
    int get ();
    void set (int value);
}
function get_LogicalProcessors();
function set_LogicalProcessors(value);

Property Value

Type: Int32
The total number of logical processors.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Memory Property

ServerQualificationResultsMemory Property

This value is the amount of memory in bytes.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
function get_Memory();
function set_Memory(value);

Property Value

Type: Int64
The number of bytes of memory.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Version Property

ServerQualificationResultsVersion Property

This value is the version of the target host hypervisor.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: String
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.VirtualSwitches Property

ServerQualificationResultsVirtualSwitches Property

This value represents the virtual switch information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo[] VirtualSwitches { get; set; }
Public Property VirtualSwitches As VirtualSwitchInfo()
    Get
    Set
public:
property array<VirtualSwitchInfo^>^ VirtualSwitches {
    array<VirtualSwitchInfo^>^ get ();
    void set (array<VirtualSwitchInfo^>^ value);
}
function get_VirtualSwitches();
function set_VirtualSwitches(value);

Property Value

Type: VirtualSwitchInfo
The array of number of virtual switches.
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


ServerQualificationResults.Volumes Property

ServerQualificationResultsVolumes Property

This value represents the volume information.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults[] Volumes { get; set; }
Public Property Volumes As VolumeQualificationResults()
    Get
    Set
public:
property array<VolumeQualificationResults^>^ Volumes {
    array<VolumeQualificationResults^>^ get ();
    void set (array<VolumeQualificationResults^>^ value);
}
function get_Volumes();
function set_Volumes(value);

Property Value

Type: VolumeQualificationResults
See Also

Reference

ServerQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Class

Part of VM configuration. Describes VHD that is part of VM VM configuration contains an array of these types: all VHDs of that VM.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVHDInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
[SerializableAttribute]
public class VHDInfo : IExtensibleDataObject
<SerializableAttribute>
Public Class VHDInfo
    Implements IExtensibleDataObject
[SerializableAttribute]
public ref class VHDInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VHDInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VHDInfo',
    null,
    IExtensibleDataObject);

The VHDInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VHDInfo |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
Fields
 | Name | Description
Public field | Drive | This value is the drive letter for the .vhd file.
Public field | FileSize | This value is the size, in bytes, of the .vhd file on the physical disk.
Public field | MaxInternalSize | This value is the maximum size, in bytes, of the .vhd file as viewable the virtual machine. It is used by CreateJob to check for free space.
Public field | ParentPath | This value is the full path to the parent location of the .vhd file.
Public field | Path | This value is the full path and file name to the .vhd file.
Public field | Type | This value is the disk type. 0-This value is an unknown disk type. 2-This value is a fixed disk. 3-This value is a dynamic disk. 4-This value is a differencing disk. 5-This value is a thick disk. 6-This value is a thin disk. 7-This value is a flat disk.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VHDInfo Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VHDInfo()
Public Sub New
public:
VHDInfo()
DoubleTake.Virtualization.Contract.VHDInfo = function();
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Properties

The VHDInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Top
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.ExtensionData Property

VHDInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo Fields

The VHDInfo type exposes the following members.

Fields
 | Name | Description
Public field | Drive | This value is the drive letter for the .vhd file.
Public field | FileSize | This value is the size, in bytes, of the .vhd file on the physical disk.
Public field | MaxInternalSize | This value is the maximum size, in bytes, of the .vhd file as viewable the virtual machine. It is used by CreateJob to check for free space.
Public field | ParentPath | This value is the full path to the parent location of the .vhd file.
Public field | Path | This value is the full path and file name to the .vhd file.
Public field | Type | This value is the disk type. 0-This value is an unknown disk type. 2-This value is a fixed disk. 3-This value is a dynamic disk. 4-This value is a differencing disk. 5-This value is a thick disk. 6-This value is a thin disk. 7-This value is a flat disk.
Top
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Drive Field

VHDInfoDrive Field

This value is the drive letter for the .vhd file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Drive
Public Drive As String
public:
String^ Drive
var Drive

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.FileSize Field

VHDInfoFileSize Field

This value is the size, in bytes, of the .vhd file on the physical disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long FileSize
Public FileSize As Long
public:
long long FileSize
var FileSize

Field Value

Type: Int64
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.MaxInternalSize Field

VHDInfoMaxInternalSize Field

This value is the maximum size, in bytes, of the .vhd file as viewable the virtual machine. It is used by CreateJob to check for free space.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxInternalSize
Public MaxInternalSize As Long
public:
long long MaxInternalSize
var MaxInternalSize

Field Value

Type: Int64
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.ParentPath Field

VHDInfoParentPath Field

This value is the full path to the parent location of the .vhd file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ParentPath
Public ParentPath As String
public:
String^ ParentPath
var ParentPath

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Path Field

VHDInfoPath Field

This value is the full path and file name to the .vhd file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path
Public Path As String
public:
String^ Path
var Path

Field Value

Type: String
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VHDInfo.Type Field

VHDInfoType Field

This value is the disk type.

0-This value is an unknown disk type.

2-This value is a fixed disk.

3-This value is a dynamic disk.

4-This value is a differencing disk.

5-This value is a thick disk.

6-This value is a thin disk.

7-This value is a flat disk.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Type
Public Type As Integer
public:
int Type
var Type

Field Value

Type: Int32
See Also

Reference

VHDInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Class

This class adds the extra information we need for WAN Failover and host network mapping
Inheritance Hierarchy
SystemObject
DoubleTake.Core.ContractNetworkInterfaceInfo
DoubleTake.Virtualization.ContractVirtualNetworkInterfaceInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualNetworkInterfaceInfo : NetworkInterfaceInfo
Public Class VirtualNetworkInterfaceInfo
    Inherits NetworkInterfaceInfo
public ref class VirtualNetworkInterfaceInfo : public NetworkInterfaceInfo
DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo',
    DoubleTake.Core.Contract.NetworkInterfaceInfo);

The VirtualNetworkInterfaceInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualNetworkInterfaceInfo |
Top
Properties
 | Name | Description
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network.
Public property | VirtualNicType | This value is the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualNetworkInterfaceInfo()
Public Sub New
public:
VirtualNetworkInterfaceInfo()
DoubleTake.Virtualization.Contract.VirtualNetworkInterfaceInfo = function();
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo Properties

The VirtualNetworkInterfaceInfo type exposes the following members.

Properties
 | Name | Description
Public property | Description | This value is the description of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsDomain | This value is the DNS domain assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | DnsServers | This value is the DNS server assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from NetworkInterfaceInfo.)
Public property | Gateways | This value is the gateway assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Guid | This value is the unique ID for the NIC. It is equivalent to the SettingID property of the Win32_NetworkAdapterConfiguration WMI class as well as the NetworkInterface.Id property in the Base Class Library (BCL). (Inherited from NetworkInterfaceInfo.)
Public property | Index | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | InterfaceIndex | Do not use this property. Double-Take uses it internally. (Inherited from NetworkInterfaceInfo.)
Public property | IPAddresses | This value represents the IP addresses assigned to the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | MacAddress | This value represents the MAC address of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | Name | This value is the friendly name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | PnpInstanceId | This value is the plug and play instance ID of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | ServiceName | This value is the service name of the NIC. (Inherited from NetworkInterfaceInfo.)
Public property | VirtualNetwork | This value is the virtual network.
Public property | VirtualNicType | This value is the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VirtualNetwork Property

VirtualNetworkInterfaceInfoVirtualNetwork Property

This value is the virtual network.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualNetwork { get; set; }
Public Property VirtualNetwork As String
    Get
    Set
public:
property String^ VirtualNetwork {
    String^ get ();
    void set (String^ value);
}
function get_VirtualNetwork();
function set_VirtualNetwork(value);

Property Value

Type: String
The virtual network.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VirtualNicType Property

VirtualNetworkInterfaceInfoVirtualNicType Property

This value is the virtual NIC.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string VirtualNicType { get; set; }
Public Property VirtualNicType As String
    Get
    Set
public:
property String^ VirtualNicType {
    String^ get ();
    void set (String^ value);
}
function get_VirtualNicType();
function set_VirtualNicType(value);

Property Value

Type: String
The type of the virtual nic.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VLAN_ID Property

VirtualNetworkInterfaceInfoVLAN_ID Property

Gets or sets the replica's VLan ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int VLAN_ID { get; set; }
Public Property VLAN_ID As Integer
    Get
    Set
public:
property int VLAN_ID {
    int get ();
    void set (int value);
}
function get_VLAN_ID();
function set_VLAN_ID(value);

Property Value

Type: Int32
The replica's VLan ID. Possible values: -1 - indicates that the vlan should not be set at failover time and the service supports setting it. 0 - indicates that the server does not support setting the vlan id at failover time. (1 - 4095) - indicates that the vlan for this nic should be set at failover time. all other values are not supported.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualNetworkInterfaceInfo.VLAN_ID_TestFailover Property

VirtualNetworkInterfaceInfoVLAN_ID_TestFailover Property

Gets or sets the replica's test failover VLan ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int VLAN_ID_TestFailover { get; set; }
Public Property VLAN_ID_TestFailover As Integer
    Get
    Set
public:
property int VLAN_ID_TestFailover {
    int get ();
    void set (int value);
}
function get_VLAN_ID_TestFailover();
function set_VLAN_ID_TestFailover(value);

Property Value

Type: Int32
The replica's VLan ID during test failover. Possible values: -1 - indicates that the vlan should not be set at failover time and the service supports setting it. 0 - indicates that the server does not support setting the vlan id at failover time. (1 - 4095) - indicates that the vlan for this nic should be set at failover time. all other values are not supported.
See Also

Reference

VirtualNetworkInterfaceInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Class

Represents virtual switch of Hyper-V/ESX
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVirtualSwitchInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchInfo : IExtensibleDataObject
Public Class VirtualSwitchInfo
    Implements IExtensibleDataObject
public ref class VirtualSwitchInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VirtualSwitchInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualSwitchInfo',
    null,
    IExtensibleDataObject);

The VirtualSwitchInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchInfo |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Label | This value is the virtual switch label.
Public property | SwitchUuid | This value is the virtual switch unique ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo()
Public Sub New
public:
VirtualSwitchInfo()
DoubleTake.Virtualization.Contract.VirtualSwitchInfo = function();
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo Properties

The VirtualSwitchInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | Label | This value is the virtual switch label.
Public property | SwitchUuid | This value is the virtual switch unique ID.
Top
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.ExtensionData Property

VirtualSwitchInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.Label Property

VirtualSwitchInfoLabel Property

This value is the virtual switch label.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
function get_Label();
function set_Label(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchInfo.SwitchUuid Property

VirtualSwitchInfoSwitchUuid Property

This value is the virtual switch unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SwitchUuid { get; set; }
Public Property SwitchUuid As String
    Get
    Set
public:
property String^ SwitchUuid {
    String^ get ();
    void set (String^ value);
}
function get_SwitchUuid();
function set_SwitchUuid(value);

Property Value

Type: String
See Also

Reference

VirtualSwitchInfo Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Class

Represents source and target virtual switch mappings
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVirtualSwitchMapping

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VirtualSwitchMapping : IExtensibleDataObject
Public Class VirtualSwitchMapping
    Implements IExtensibleDataObject
public ref class VirtualSwitchMapping : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VirtualSwitchMapping = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VirtualSwitchMapping',
    null,
    IExtensibleDataObject);

The VirtualSwitchMapping type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchMapping |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitch | This value represents the virtual switch on the source.
Public property | TargetVirtualSwitch | This value represents the virtual switch on the target.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchMapping()
Public Sub New
public:
VirtualSwitchMapping()
DoubleTake.Virtualization.Contract.VirtualSwitchMapping = function();
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping Properties

The VirtualSwitchMapping type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | SourceVirtualSwitch | This value represents the virtual switch on the source.
Public property | TargetVirtualSwitch | This value represents the virtual switch on the target.
Top
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.ExtensionData Property

VirtualSwitchMappingExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.SourceVirtualSwitch Property

VirtualSwitchMappingSourceVirtualSwitch Property

This value represents the virtual switch on the source.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo SourceVirtualSwitch { get; set; }
Public Property SourceVirtualSwitch As VirtualSwitchInfo
    Get
    Set
public:
property VirtualSwitchInfo^ SourceVirtualSwitch {
    VirtualSwitchInfo^ get ();
    void set (VirtualSwitchInfo^ value);
}
function get_SourceVirtualSwitch();
function set_SourceVirtualSwitch(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VirtualSwitchMapping.TargetVirtualSwitch Property

VirtualSwitchMappingTargetVirtualSwitch Property

This value represents the virtual switch on the target.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VirtualSwitchInfo TargetVirtualSwitch { get; set; }
Public Property TargetVirtualSwitch As VirtualSwitchInfo
    Get
    Set
public:
property VirtualSwitchInfo^ TargetVirtualSwitch {
    VirtualSwitchInfo^ get ();
    void set (VirtualSwitchInfo^ value);
}
function get_TargetVirtualSwitch();
function set_TargetVirtualSwitch(value);

Property Value

Type: VirtualSwitchInfo
See Also

Reference

VirtualSwitchMapping Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Class

Represents properties of virtual machine.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVMInfo
DoubleTake.Virtualization.Contract.VRAReplicaVMInfo

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VMInfo : IExtensibleDataObject
Public Class VMInfo
    Implements IExtensibleDataObject
public ref class VMInfo : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VMInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VMInfo',
    null,
    IExtensibleDataObject);

The VMInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VMInfo |
Top
Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.
Public property | DisplayName | This value is the virtual machine display name.
Public property | EsxHost |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GuestOS | This value is the virtual machine guest operating system.
Public property | GuestUri | This value is the guest URI.
Public property | Id | This value is the virtual machine unique ID.
Public property | Path | This value is the virtual machine configuration file location.
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location.
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names.
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location.
Top
Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VMInfo Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VMInfo()
Public Sub New
public:
VMInfo()
DoubleTake.Virtualization.Contract.VMInfo = function();
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Properties

The VMInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address.
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.
Public property | DisplayName | This value is the virtual machine display name.
Public property | EsxHost |
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | GuestOS | This value is the virtual machine guest operating system.
Public property | GuestUri | This value is the guest URI.
Public property | Id | This value is the virtual machine unique ID.
Public property | Path | This value is the virtual machine configuration file location.
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location.
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names.
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location.
Top
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Address Property

VMInfoAddress Property

This value is the virtual machine guest name or IP address.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
function get_Address();
function set_Address(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.BootVolumeSignature Property

VMInfoBootVolumeSignature Property

This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public byte[] BootVolumeSignature { get; set; }
Public Property BootVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ BootVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
function get_BootVolumeSignature();
function set_BootVolumeSignature(value);

Property Value

Type: Byte
Boot volume signature.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.DisplayName Property

VMInfoDisplayName Property

This value is the virtual machine display name.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
function get_DisplayName();
function set_DisplayName(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.EsxHost Property

VMInfoEsxHost Property

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string EsxHost { get; set; }
Public Property EsxHost As String
    Get
    Set
public:
property String^ EsxHost {
    String^ get ();
    void set (String^ value);
}
function get_EsxHost();
function set_EsxHost(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.ExtensionData Property

VMInfoExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GuestOS Property

VMInfoGuestOS Property

This value is the virtual machine guest operating system.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
function get_GuestOS();
function set_GuestOS(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GuestUri Property

VMInfoGuestUri Property

This value is the guest URI.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Uri GuestUri { get; set; }
Public Property GuestUri As Uri
    Get
    Set
public:
property Uri^ GuestUri {
    Uri^ get ();
    void set (Uri^ value);
}
function get_GuestUri();
function set_GuestUri(value);

Property Value

Type: Uri
The guest URI.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Id Property

VMInfoId Property

This value is the virtual machine unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
function get_Id();
function set_Id(value);

Property Value

Type: Guid
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.Path Property

VMInfoPath Property

This value is the virtual machine configuration file location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
function get_Path();
function set_Path(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.PathTransformations Property

VMInfoPathTransformations Property

This value represents where the protected source virtual machine will be located on the target.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public PathTransformation[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformation()
    Get
    Set
public:
property array<PathTransformation^>^ PathTransformations {
    array<PathTransformation^>^ get ();
    void set (array<PathTransformation^>^ value);
}
function get_PathTransformations();
function set_PathTransformations(value);

Property Value

Type: PathTransformation
The path transformations
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SnapshotDataPath Property

VMInfoSnapshotDataPath Property

This value is the virtual machine snapshot location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SnapshotDataPath { get; set; }
Public Property SnapshotDataPath As String
    Get
    Set
public:
property String^ SnapshotDataPath {
    String^ get ();
    void set (String^ value);
}
function get_SnapshotDataPath();
function set_SnapshotDataPath(value);

Property Value

Type: String
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SnapshotFileNames Property

VMInfoSnapshotFileNames Property

This value is the virtual machine snapshot file names.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] SnapshotFileNames { get; set; }
Public Property SnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ SnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_SnapshotFileNames();
function set_SnapshotFileNames(value);

Property Value

Type: String
System directory.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.SystemDirectory Property

VMInfoSystemDirectory Property

This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
function get_SystemDirectory();
function set_SystemDirectory(value);

Property Value

Type: String
System directory.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.VirtualHardDiskPath Property

VMInfoVirtualHardDiskPath Property

This value is the virtual machine hard disk location.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string[] VirtualHardDiskPath { get; set; }
Public Property VirtualHardDiskPath As String()
    Get
    Set
public:
property array<String^>^ VirtualHardDiskPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
function get_VirtualHardDiskPath();
function set_VirtualHardDiskPath(value);

Property Value

Type: String
The virtual hard disk path.
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Methods

The VMInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject |
Public method | GetObjectToSerialize |
Top
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GetDeserializedObject Method

VMInfoGetDeserializedObject Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetDeserializedObject(
    Type targetType
)
Public Function GetDeserializedObject (
    targetType As Type
) As Object
public:
virtual Object^ GetDeserializedObject(
    Type^ targetType
) sealed
function GetDeserializedObject(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.GetObjectToSerialize Method

VMInfoGetObjectToSerialize Method

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Object GetObjectToSerialize(
    Type targetType
)
Public Function GetObjectToSerialize (
    targetType As Type
) As Object
public:
virtual Object^ GetObjectToSerialize(
    Type^ targetType
) sealed
function GetObjectToSerialize(targetType);

Parameters

targetType
Type: SystemType

Return Value

Type: Object
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo Fields

The VMInfo type exposes the following members.

Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID.
Top
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VMInfo.BiosGuid Field

VMInfoBiosGuid Field

This value is the virtual machine BIOS unique ID.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public Guid BiosGuid
Public BiosGuid As Guid
public:
Guid BiosGuid
var BiosGuid

Field Value

Type: Guid
See Also

Reference

VMInfo Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Class

Represents information of volume for console display.
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVolumeQualificationResults

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VolumeQualificationResults : IExtensibleDataObject
Public Class VolumeQualificationResults
    Implements IExtensibleDataObject
public ref class VolumeQualificationResults : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VolumeQualificationResults = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VolumeQualificationResults',
    null,
    IExtensibleDataObject);

The VolumeQualificationResults type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeQualificationResults |
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupName | This value is the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is the total size, in bytes, of the volume.
Public property | DriveLetter | This value is the drive letter of the volume.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the available free space, in bytes, on the volume.
Public property | IsSystemVolume | This value is true if the volume is the system volume; otherwise, it is false.
Public property | IsVolumeCSV | This value is true if the volume is a cluster shared volume; otherwise, it is false.
Public property | MaxFileSize | This value is the maximum file size, in megabytes, of the virtual hard disk file.
Public property | ProvisionedSpace | This value is the amount of provisioned space, in bytes, on the volume.
Public property | Url | This value is the URL of an ESX datastore.
Top
See Also

Reference

DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Constructor

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VolumeQualificationResults()
Public Sub New
public:
VolumeQualificationResults()
DoubleTake.Virtualization.Contract.VolumeQualificationResults = function();
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults Properties

The VolumeQualificationResults type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupName | This value is the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | This value is the name of the resource's current owning node.
Public property | DiskSize | This value is the total size, in bytes, of the volume.
Public property | DriveLetter | This value is the drive letter of the volume.
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | FreeSpace | This value is the available free space, in bytes, on the volume.
Public property | IsSystemVolume | This value is true if the volume is the system volume; otherwise, it is false.
Public property | IsVolumeCSV | This value is true if the volume is a cluster shared volume; otherwise, it is false.
Public property | MaxFileSize | This value is the maximum file size, in megabytes, of the virtual hard disk file.
Public property | ProvisionedSpace | This value is the amount of provisioned space, in bytes, on the volume.
Public property | Url | This value is the URL of an ESX datastore.
Top
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ClusterResourceGroupName Property

VolumeQualificationResultsClusterResourceGroupName Property

This value is the name of the group that contains the resource.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
function get_ClusterResourceGroupName();
function set_ClusterResourceGroupName(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.CurrentOwnerNodeName Property

VolumeQualificationResultsCurrentOwnerNodeName Property

This value is the name of the resource's current owning node.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
function get_CurrentOwnerNodeName();
function set_CurrentOwnerNodeName(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.DiskSize Property

VolumeQualificationResultsDiskSize Property

This value is the total size, in bytes, of the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
function get_DiskSize();
function set_DiskSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.DriveLetter Property

VolumeQualificationResultsDriveLetter Property

This value is the drive letter of the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
function get_DriveLetter();
function set_DriveLetter(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ExtensionData Property

VolumeQualificationResultsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.FreeSpace Property

VolumeQualificationResultsFreeSpace Property

This value is the available free space, in bytes, on the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
function get_FreeSpace();
function set_FreeSpace(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.IsSystemVolume Property

VolumeQualificationResultsIsSystemVolume Property

This value is true if the volume is the system volume; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
function get_IsSystemVolume();
function set_IsSystemVolume(value);

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.IsVolumeCSV Property

VolumeQualificationResultsIsVolumeCSV Property

This value is true if the volume is a cluster shared volume; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
function get_IsVolumeCSV();
function set_IsVolumeCSV(value);

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.MaxFileSize Property

VolumeQualificationResultsMaxFileSize Property

This value is the maximum file size, in megabytes, of the virtual hard disk file.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long MaxFileSize { get; set; }
Public Property MaxFileSize As Long
    Get
    Set
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
function get_MaxFileSize();
function set_MaxFileSize(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.ProvisionedSpace Property

VolumeQualificationResultsProvisionedSpace Property

This value is the amount of provisioned space, in bytes, on the volume.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long ProvisionedSpace { get; set; }
Public Property ProvisionedSpace As Long
    Get
    Set
public:
property long long ProvisionedSpace {
    long long get ();
    void set (long long value);
}
function get_ProvisionedSpace();
function set_ProvisionedSpace(value);

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


VolumeQualificationResults.Url Property

VolumeQualificationResultsUrl Property

This value is the URL of an ESX datastore.

Namespace: DoubleTake.Virtualization.Contract
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
function get_Url();
function set_Url(value);

Property Value

Type: String
See Also

Reference

VolumeQualificationResults Class
DoubleTake.Virtualization.Contract Namespace


DoubleTake.Virtualization.Contract.VRA Namespace

Classes
 | Class | Description
Public class | ActivationCodeInfo | Activation code information on appliance for V2V push install
Public class | ESXInfo | This class represents the general information about an ESX server
Public class | ReplicaVMInfo | Represents replica virtual machine information
Public class | VRAWorkloadCustomizationOptions | This class contains options used to customize the workload


ActivationCodeInfo Class

Activation code information on appliance for V2V push install
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAActivationCodeInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ActivationCodeInfo
Public Class ActivationCodeInfo
public ref class ActivationCodeInfo
DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo');

The ActivationCodeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeInfo |
Top
Fields
 | Name | Description
Public field | ActivationCode | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public field | DaysToExpire | This value is the number of days until the license expires.
Public field | IsEval | This value is true if the license key is an evaluation license; otherwise, it is false.
Public field | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public field | IsTargetOnly |
Public field | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo Constructor

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ActivationCodeInfo()
Public Sub New
public:
ActivationCodeInfo()
DoubleTake.Virtualization.Contract.VRA.ActivationCodeInfo = function();
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo Fields

The ActivationCodeInfo type exposes the following members.

Fields
 | Name | Description
Public field | ActivationCode | This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public field | DaysToExpire | This value is the number of days until the license expires.
Public field | IsEval | This value is true if the license key is an evaluation license; otherwise, it is false.
Public field | IsNodeLocked | This value is true if the license key must be activated; otherwise, it is false.
Public field | IsTargetOnly |
Public field | IsValid | This value is true if the license key is valid; otherwise, it is false.
Top
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.ActivationCode Field

ActivationCodeInfoActivationCode Field

This value is a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ActivationCode
Public ActivationCode As String
public:
String^ ActivationCode
var ActivationCode

Field Value

Type: String
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.DaysToExpire Field

ActivationCodeInfoDaysToExpire Field

This value is the number of days until the license expires.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int DaysToExpire
Public DaysToExpire As Integer
public:
int DaysToExpire
var DaysToExpire

Field Value

Type: Int32
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsEval Field

ActivationCodeInfoIsEval Field

This value is true if the license key is an evaluation license; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsEval
Public IsEval As Boolean
public:
bool IsEval
var IsEval

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsNodeLocked Field

ActivationCodeInfoIsNodeLocked Field

This value is true if the license key must be activated; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsNodeLocked
Public IsNodeLocked As Boolean
public:
bool IsNodeLocked
var IsNodeLocked

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsTargetOnly Field

ActivationCodeInfoIsTargetOnly Field

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsTargetOnly
Public IsTargetOnly As Boolean
public:
bool IsTargetOnly
var IsTargetOnly

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ActivationCodeInfo.IsValid Field

ActivationCodeInfoIsValid Field

This value is true if the license key is valid; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool IsValid
Public IsValid As Boolean
public:
bool IsValid
var IsValid

Field Value

Type: Boolean
See Also

Reference

ActivationCodeInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo Class

This class represents the general information about an ESX server
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAESXInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ESXInfo
Public Class ESXInfo
public ref class ESXInfo
DoubleTake.Virtualization.Contract.VRA.ESXInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.ESXInfo');

The ESXInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ESXInfo |
Top
Properties
 | Name | Description
Public property | FullName | Full name including the build number of the ESX server
Public property | HasUserPermissions | Does the logged on user has the required permissions on ESX server
Public property | UserRoleID | Logged on user's role id
Public property | Version | Version of the ESX server
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo Constructor

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ESXInfo()
Public Sub New
public:
ESXInfo()
DoubleTake.Virtualization.Contract.VRA.ESXInfo = function();
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo Properties

The ESXInfo type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Full name including the build number of the ESX server
Public property | HasUserPermissions | Does the logged on user has the required permissions on ESX server
Public property | UserRoleID | Logged on user's role id
Public property | Version | Version of the ESX server
Top
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo.FullName Property

ESXInfoFullName Property

Full name including the build number of the ESX server

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
function get_FullName();
function set_FullName(value);

Property Value

Type: String
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo.HasUserPermissions Property

ESXInfoHasUserPermissions Property

Does the logged on user has the required permissions on ESX server

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool HasUserPermissions { get; set; }
Public Property HasUserPermissions As Boolean
    Get
    Set
public:
property bool HasUserPermissions {
    bool get ();
    void set (bool value);
}
function get_HasUserPermissions();
function set_HasUserPermissions(value);

Property Value

Type: Boolean
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo.UserRoleID Property

ESXInfoUserRoleID Property

Logged on user's role id

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int UserRoleID { get; set; }
Public Property UserRoleID As Integer
    Get
    Set
public:
property int UserRoleID {
    int get ();
    void set (int value);
}
function get_UserRoleID();
function set_UserRoleID(value);

Property Value

Type: Int32
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ESXInfo.Version Property

ESXInfoVersion Property

Version of the ESX server

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
function get_Version();
function set_Version(value);

Property Value

Type: String
See Also

Reference

ESXInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Class

Represents replica virtual machine information
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.ContractVMInfo
DoubleTake.Virtualization.Contract.VRAReplicaVMInfo

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class ReplicaVMInfo : VMInfo
Public Class ReplicaVMInfo
    Inherits VMInfo
public ref class ReplicaVMInfo : public VMInfo
DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo',
    DoubleTake.Virtualization.Contract.VMInfo);

The ReplicaVMInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaVMInfo |
Top
Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address. (Inherited from VMInfo.)
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | CoresPerProcessor | This value is the number of cores per processor.
Public property | Cpus | This value is the number of processors.
Public property | DisplayName | This value is the virtual machine display name. (Inherited from VMInfo.)
Public property | EsxHost | (Inherited from VMInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from VMInfo.)
Public property | GuestOS | This value is the virtual machine guest operating system. (Inherited from VMInfo.)
Public property | GuestUri | This value is the guest URI. (Inherited from VMInfo.)
Public property | Id | This value is the virtual machine unique ID. (Inherited from VMInfo.)
Public property | Memory | This value is the amount of memory in bytes.
Public property | OperatingSystem | This value is the ESX operating system.
Public property | Path | This value is the virtual machine configuration file location. (Inherited from VMInfo.)
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target. (Inherited from VMInfo.)
Public property | PrestageFolder | This value is the full path to a location that contains an existing virtual disk that you want to reuse.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | This value is a command to run when the replica virtual machine is first powered on.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location. (Inherited from VMInfo.)
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names. (Inherited from VMInfo.)
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location. (Inherited from VMInfo.)
Top
Methods
 | Name | Description
Public method | GetDeserializedObject | (Inherited from VMInfo.)
Public method | GetObjectToSerialize | (Inherited from VMInfo.)
Top
Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID. (Inherited from VMInfo.)
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Constructor

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ReplicaVMInfo()
Public Sub New
public:
ReplicaVMInfo()
DoubleTake.Virtualization.Contract.VRA.ReplicaVMInfo = function();
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Properties

The ReplicaVMInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | This value is the virtual machine guest name or IP address. (Inherited from VMInfo.)
Public property | BootVolumeSignature | This value is the virtual machine boot volume signature which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | CoresPerProcessor | This value is the number of cores per processor.
Public property | Cpus | This value is the number of processors.
Public property | DisplayName | This value is the virtual machine display name. (Inherited from VMInfo.)
Public property | EsxHost | (Inherited from VMInfo.)
Public property | ExtensionData | Gets or sets the structure that contains extra data. (Inherited from VMInfo.)
Public property | GuestOS | This value is the virtual machine guest operating system. (Inherited from VMInfo.)
Public property | GuestUri | This value is the guest URI. (Inherited from VMInfo.)
Public property | Id | This value is the virtual machine unique ID. (Inherited from VMInfo.)
Public property | Memory | This value is the amount of memory in bytes.
Public property | OperatingSystem | This value is the ESX operating system.
Public property | Path | This value is the virtual machine configuration file location. (Inherited from VMInfo.)
Public property | PathTransformations | This value represents where the protected source virtual machine will be located on the target. (Inherited from VMInfo.)
Public property | PrestageFolder | This value is the full path to a location that contains an existing virtual disk that you want to reuse.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | This value is a command to run when the replica virtual machine is first powered on.
Public property | SnapshotDataPath | This value is the virtual machine snapshot location. (Inherited from VMInfo.)
Public property | SnapshotFileNames | This value is the virtual machine snapshot file names. (Inherited from VMInfo.)
Public property | SystemDirectory | This value is the virtual machine system directory which is required for agentless Hyper-V WAN failover. (Inherited from VMInfo.)
Public property | VirtualHardDiskPath | This value is the virtual machine hard disk location. (Inherited from VMInfo.)
Top
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.CoresPerProcessor Property

ReplicaVMInfoCoresPerProcessor Property

This value is the number of cores per processor.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int CoresPerProcessor { get; set; }
Public Property CoresPerProcessor As Integer
    Get
    Set
public:
property int CoresPerProcessor {
    int get ();
    void set (int value);
}
function get_CoresPerProcessor();
function set_CoresPerProcessor(value);

Property Value

Type: Int32
The number of cores per processor. Value of 0 used for unknown/unspecified.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.Cpus Property

ReplicaVMInfoCpus Property

This value is the number of processors.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
function get_Cpus();
function set_Cpus(value);

Property Value

Type: Int32
The number of cpus.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.Memory Property

ReplicaVMInfoMemory Property

This value is the amount of memory in bytes.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
function get_Memory();
function set_Memory(value);

Property Value

Type: Int64
The number of bytes of memory.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.OperatingSystem Property

ReplicaVMInfoOperatingSystem Property

This value is the ESX operating system.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string OperatingSystem { get; set; }
Public Property OperatingSystem As String
    Get
    Set
public:
property String^ OperatingSystem {
    String^ get ();
    void set (String^ value);
}
function get_OperatingSystem();
function set_OperatingSystem(value);

Property Value

Type: String
The operating system name.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.PrestageFolder Property

ReplicaVMInfoPrestageFolder Property

This value is the full path to a location that contains an existing virtual disk that you want to reuse.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string PrestageFolder { get; set; }
Public Property PrestageFolder As String
    Get
    Set
public:
property String^ PrestageFolder {
    String^ get ();
    void set (String^ value);
}
function get_PrestageFolder();
function set_PrestageFolder(value);

Property Value

Type: String
The prestage folder.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.ReplicaVmVersion Property

ReplicaVMInfoReplicaVmVersion Property

Gets or sets the version of the Vm hardware.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string ReplicaVmVersion { get; set; }
Public Property ReplicaVmVersion As String
    Get
    Set
public:
property String^ ReplicaVmVersion {
    String^ get ();
    void set (String^ value);
}
function get_ReplicaVmVersion();
function set_ReplicaVmVersion(value);

Property Value

Type: String
The version of the Vm hardware.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo.RunOnceAtStartup Property

ReplicaVMInfoRunOnceAtStartup Property

This value is a command to run when the replica virtual machine is first powered on.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public string RunOnceAtStartup { get; set; }
Public Property RunOnceAtStartup As String
    Get
    Set
public:
property String^ RunOnceAtStartup {
    String^ get ();
    void set (String^ value);
}
function get_RunOnceAtStartup();
function set_RunOnceAtStartup(value);

Property Value

Type: String
The command to execute.
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Methods

The ReplicaVMInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetDeserializedObject | (Inherited from VMInfo.)
Public method | GetObjectToSerialize | (Inherited from VMInfo.)
Top
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


ReplicaVMInfo Fields

The ReplicaVMInfo type exposes the following members.

Fields
 | Name | Description
Public field | BiosGuid | This value is the virtual machine BIOS unique ID. (Inherited from VMInfo.)
Top
See Also

Reference

ReplicaVMInfo Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Class

This class contains options used to customize the workload
Inheritance Hierarchy
SystemObject
DoubleTake.Virtualization.Contract.VRAVRAWorkloadCustomizationOptions

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public class VRAWorkloadCustomizationOptions : IExtensibleDataObject
Public Class VRAWorkloadCustomizationOptions
    Implements IExtensibleDataObject
public ref class VRAWorkloadCustomizationOptions : IExtensibleDataObject
DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions = function();

Type.createClass(
    'DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions',
    null,
    IExtensibleDataObject);

The VRAWorkloadCustomizationOptions type exposes the following members.

Constructors
 | Name | Description
Public method | VRAWorkloadCustomizationOptions |
Top
Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NoReplication | Do not use this property. Double-Take uses it internally.
Public property | PowerupReplicaAfterFailover | This value is true if the replica should be powered on after failover; otherwise, it is false.
Public property | ShouldShutdownSource | This value is true if the source should be shut down during failover; otherwise, it is false.
Public property | UseWin32 | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Constructor

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public VRAWorkloadCustomizationOptions()
Public Sub New
public:
VRAWorkloadCustomizationOptions()
DoubleTake.Virtualization.Contract.VRA.VRAWorkloadCustomizationOptions = function();
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions Properties

The VRAWorkloadCustomizationOptions type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionData | Gets or sets the structure that contains extra data.
Public property | NoReplication | Do not use this property. Double-Take uses it internally.
Public property | PowerupReplicaAfterFailover | This value is true if the replica should be powered on after failover; otherwise, it is false.
Public property | ShouldShutdownSource | This value is true if the source should be shut down during failover; otherwise, it is false.
Public property | UseWin32 | Do not use this property. Double-Take uses it internally.
Top
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.ExtensionData Property

VRAWorkloadCustomizationOptionsExtensionData Property

Gets or sets the structure that contains extra data.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public ExtensionDataObject ExtensionData { get; set; }
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}
function get_ExtensionData();
function set_ExtensionData(value);

Property Value

Type: ExtensionDataObject
The extra data.

Return Value

Type: ExtensionDataObject
An ExtensionDataObject that contains data that is not recognized as belonging to the data contract.

Implements

IExtensibleDataObjectExtensionData
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.NoReplication Property

VRAWorkloadCustomizationOptionsNoReplication Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool NoReplication { get; set; }
Public Property NoReplication As Boolean
    Get
    Set
public:
property bool NoReplication {
    bool get ();
    void set (bool value);
}
function get_NoReplication();
function set_NoReplication(value);

Property Value

Type: Boolean
true if data replication desired; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.PowerupReplicaAfterFailover Property

VRAWorkloadCustomizationOptionsPowerupReplicaAfterFailover Property

This value is true if the replica should be powered on after failover; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool PowerupReplicaAfterFailover { get; set; }
Public Property PowerupReplicaAfterFailover As Boolean
    Get
    Set
public:
property bool PowerupReplicaAfterFailover {
    bool get ();
    void set (bool value);
}
function get_PowerupReplicaAfterFailover();
function set_PowerupReplicaAfterFailover(value);

Property Value

Type: Boolean
true if we should powerup the replica after failover; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.ShouldShutdownSource Property

VRAWorkloadCustomizationOptionsShouldShutdownSource Property

This value is true if the source should be shut down during failover; otherwise, it is false.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool ShouldShutdownSource { get; set; }
Public Property ShouldShutdownSource As Boolean
    Get
    Set
public:
property bool ShouldShutdownSource {
    bool get ();
    void set (bool value);
}
function get_ShouldShutdownSource();
function set_ShouldShutdownSource(value);

Property Value

Type: Boolean
true if the source should be shutdown; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


VRAWorkloadCustomizationOptions.UseWin32 Property

VRAWorkloadCustomizationOptionsUseWin32 Property

Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Virtualization.Contract.VRA
Assembly: DoubleTake.PowerShell.Contract.Data (in DoubleTake.PowerShell.Contract.Data.dll) Version: 8.2.0.814
Syntax
C#
VB
C++
JavaScript
Copy
public bool UseWin32 { get; set; }
Public Property UseWin32 As Boolean
    Get
    Set
public:
property bool UseWin32 {
    bool get ();
    void set (bool value);
}
function get_UseWin32();
function set_UseWin32(value);

Property Value

Type: Boolean
true if we should have a USEWIN32; otherwise, false.
See Also

Reference

VRAWorkloadCustomizationOptions Class
DoubleTake.Virtualization.Contract.VRA Namespace


Namespaces

Namespaces
Namespace | Description
DoubleTake.Common |
DoubleTake.Core |
DoubleTake.Diagnostics.Contract |
DoubleTake.Jobs |
DoubleTake.PowerShell |
DoubleTake.Virtualization |